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1.3  Statements of Functionality (SOF)



1.3.1 Programming Requirements



1.3.1.1 Program Language



The C/C++ language shall be used to implement  the JTIM application.



1.3.1.2 Compilers/Assemblers



TAMPS shall utilize the Solaris 2.5.1 operating system for Software Release Version 6.2.�

TAMPS installation shall include all COTS, Solaris patches, executables and libraries necessary to provide complete TAMPS Core and MPM required functionality. �

1.3.1.3 Programming Standards



The JTIM application shall be implemented in accordance with the TAMPS 6.2 Software Development Plan.



The JTIM application shall use the TAMPS 6.2 HMI style guide as a programming standard.



1.3.2 Design Requirements



1.3.2.1 Timing



JTIM performance goals shall depend on aircrew and Precision Guided Munition (PGM) imagery related mission planning requirements, which are currently TBD.  �

1.3.2.2 Design Standards



The JTIM application shall be developed in accordance with the TAMPS 6.2 Software Development Plan.



1.3.2.3 Design Constraints



a. JTIM shall be hosted on TAMPS hardware as a TAMPS Core Extension.



b. JTIM shall not require new TAMPS hardware.



c. Basic TAMPS functionality shall not be impacted if JTIM is not installed as a TAMPS Core Extension, or JTIM functions are deactivated. 



d. The JTIM shall provide the capability for the TAMPS operator to perform  JTIM or TAMPS MPM functions while imagery is being retrieved.



1.3.3 Interface Requirements



a. The  Joint Service Imagery Processing System-Navy (JSIPS-N) shall provide NITF 2.0 imagery and imagery derived products to the JTIM upon request.



b. The  Joint Maritime Command Information System (JMCIS)  shall provide NITF 2.0 imagery and imagery derived products to the JTIM upon request.�

c. A public/private  interface design document shall define the interface between the JTIM Core Extension and MPM’s (public), and the JTIM Core Extension and the TAMPS Core (private).



1.3.4 Detailed Functional and Performance Requirements



a. JTIM shall provide the application software necessary to perform the Query & Retrieval, JTIM Imagery Toolkit, and JTIM Data Management functions.



b. TAMPS shall provide the capability to initiate  a query using the TAMPS browser without the MPM being initiated.



1.3.4.1 JTIM Control Function



1.3.4.1.1 JTIM Initiation Subfunction



a. The JTIM application shall be initiated from a TAMPS Mission Planning Module (MPM) pulldown menu



b. The JTIM query function application shall be initiated from a TAMPS Mission Planning Module (MPM) toolbar icon.



c. The JTIM imagery toolkit function application shall be initiated from a TAMPS Mission Planning Module (MPM) toolbar icon.



1.3.4.1.2 Query/Imagery Toolkit Initiation Subfunction



a. The JTIM shall provide the TAMPS operator with the capability to perform the query and retrieval  functions



b. The JTIM shall provide the TAMPS operator with the capability  to perform the Imagery Toolkit functions



1.3.4.2 Query  and Retrieval Function



a. JTIM functions shall allow the Query & Retrieval of available imagery and imagery derived products.



1.3.4.2.1 Query  Subfunction



a. Upon initiation of the JTIM application, the TAMPS operator shall be able to 



	1. Initiate a target icon query



	2. Initiate  a rubber band box query



	3. Initiate  a browser query



1.3.4.2.1.1 Query Types



	A.	Target Icon Query



	1. The operator  shall be able to initiate a request for product information for a 	designated target by selecting the target’s icon on the TAMPS display



	2. The TAMPS shall receive the JTIM request and provide the JTIM with	available information for the selected target  icon



	3. The JTIM shall extract  query related information and display this information  to 	the TAMPS operator



	4. JTIM shall provide the TAMPS operator with the capability to send or cancel the 	query



	5. The JTIM shall forward the query request to the selected image server(s)



	B.	Rubber Band Box Query

	

	1. The operator  shall be able to initiate a request for product 	information  by using 	a rubber band box to define an area of interest



	2. The TAMPS shall determine the latitude/longitude values for the four corners of 	the rubber band box



	3. The TAMPS shall provide the latitude/longitude values for the four corners of 	the rubber band box to JTIM



	4. The JTIM shall display the four corner latitude/longitude information to the 	TAMPS operator



	5. JTIM shall provide the TAMPS operator with the capability to send or cancel the 	query



	6. The JTIM shall forward the query request to the selected image server(s)



	C.	Browser Query

	

	1. The operator  shall be able to initiate a request for product 	information  by using 	a browser



	2. The JTIM shall be able to query the JSIPS-N, TAMPS, and JMCIS imagery 	servers on the 	MP LAN using a browser



	3. The TAMPS operator shall be able to fill in and make selections in the browser 	window



	4. JTIM shall provide the TAMPS operator with the capability to send or cancel the 	query



	5. The JTIM shall forward the query request to the selected image server(s)



1.3.4.2.1.2 Query Actions



a. JTIM shall provide the TAMPS operator with the capability to



	1. Select all products in the query request



	2. Select images



	3. Select target folder data



	4. Select perspective scene products



	5. Select a combination of  images, target folder data, and perspective scene 		products.



	6. Select the system to query



	7. Request the generation of products from JSIPS-N to be used in support of 	mission planning by the MPM



b. JTIM shall provide the TAMPS operator with the capability to select image query constraints regarding the number of images to be requested



c. JTIM shall provide the TAMPS operator with the capability to select image query constraints regarding the size of images to be requested



d. JTIM shall provide the TAMPS operator with the capability to view the details of the query request prior to the request being sent



e. JTIM shall provide the TAMPS operator with the capability to modify the details of the query request prior to the request being sent



f. JTIM shall provide the TAMPS operator with the capability to check on the current  status of a query request



1.3.4.2.2 Retrieval Subfunction



1.3.4.2.2.1 Display Query Response On TAMPS Display



a. For queries initiated by a MPM, query responses shall be graphically displayed on the TAMPS display.



b. JTIM shall display the footprints of available images onto TAMPS display, providing the footprint is viewable on the TAMPS display



	1. For footprints that are not of sufficient size to be viewed on the TAMPS display, 	the JTIM shall display an image icon using the returned image's center 	latitude/longitude coordinates



	2. Image footprints and image icons shall visually identify the sensor type (tactical, 	national) used in collecting the image on the TAMPS display 



	3. Image footprints and image icons shall visually identify the sensor technology 	(EO, IR, SAR) used in collecting the image on the TAMPS display



	4. Image footprints and image icons which include an associated target folder shall 	be identified on the TAMPS display



	5. The JTIM shall provide a legend for footprints onto the TAMPS display



c. JTIM shall provide the TAMPS operator with a product  identification number for each image footprint and image icon 



d. The TAMPS operator shall be able to select an image footprint , image icon or product identification number from the TAMPS display



e. For the selected image footprint, image icon or product identification number, the TAMPS operator shall be provided with the information obtained from the query response on the TAMPS display



1.3.4.2.2.2 Retrieve Data



a. The TAMPS operator shall be provided with the capability to 



	1. Individually select an image footprint or image icon for retrieval to JTIM

	2. Select all products for retrieval to JTIM



b. The TAMPS operator shall be provided with the capability to initiate or cancel a product retrieval request



c. The TAMPS operator  shall be provided with the capability to prioritize a product retrieval request



d. An estimate of the time required for the product’s generation and/or transfer shall be provided to the TAMPS operator.



e. The TAMPS operator shall be able to check on the current  status of a product retrieval



1.3.4.2.2.3 Transfer Target Folder Data To The MPM



a. For the retrieved target folder product, the TAMPS operator  shall be able to view the Target Folder (TF) by selecting the JTIM graphic target folder icon on the active TAMPS window 



b. The TAMPS operator shall be able to transfer Target Folder data to the MPM



1.3.4.3 Imagery Toolkit Function



a. The JTIM Imagery Toolkit  shall provide the capability to 



	1. Display and manipulate retrieved imagery

	2. Annotate images

	3. Create image products

	4. Generate perspective scenes.�

b. The JTIM Imagery Toolkit shall include function menus and toolbar icons.



1.3.4.3.1 Image Display  and Manipulation Subfunction



1.3.4.3.1.1 Image Load and Display



a. Selecting the footprint for a retrieved image will automatically start the Imagery Toolkit (if not already active) and display the NITF 2.0 image to the TAMPS operator.



b. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to display an available NITF 2.0 image.



c. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to selectively display onto the displayed image the threats, generated routes, and target locations from the mission being planned.



1.3.4.3.1.2 Image  Manipulation



a. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to rotate a displayed image



b. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to zoom in/out for a displayed image



c. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to select the Reduced Resolution Data Set (RRDS) levels for a displayed image, if available.



d. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to roam a displayed image.



e. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to adjust the contrast of a displayed image.



f. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to adjust the brightness of a displayed image.



1.3.4.3.1.3 Cursor Latitude/Longitude Determination



The JTIM Imagery Toolkit shall provide the capability to display the cursor's latitude/longitude when roaming the displayed image



1.3.4.3.1.4 Display  of Target Folder Data



a. The JTIM Imagery Toolkit shall display graphics associated with target folder aimpoints



b. The JTIM Imagery Toolkit shall display to the TAMPS operator the target folder data associated with a selected aimpoint graphic



c. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to transfer the target folder data associated with a selected aimpoint graphic to the mission being planned by the MPM



1.3.4.3.2 Image Annotation Subfunction



a. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to overlay graphics and text on a displayed image.



1.3.4.3.3 Image Product  Creation Subfunction



a. The JTIM Imagery Toolkit shall provide the capability for the TAMPS operator to create image chips 



b. The JTIM Imagery Toolkit  shall provide the capability to paste JTIM image chips onto an active TAMPS display



1.3.4.3.4 Perspective Scene Generation Subfunction



a. The JTIM Imagery Toolkit shall provide a perspective scene capability



b. The perspective scene application shall be initiated from the Imagery Toolkit's menu.



c. The perspective scene application shall provide the capability for the TAMPS operator to enter eyepoint and aimpoint parameters

	

d. The perspective scene application shall provide the capability for the TAMPS operator to render a single perspective scene



e. The perspective scene application shall provide the capability for the TAMPS operator to select rendering  modes



f. The perspective scene application shall display to the TAMPS operator the range from the aimpoint to the eyepoint, and the azimuth of the viewed perspective scene



1.3.4.4 Data Manager  Function



a. The data manager shall provide the capability  for JTIM database updates.



b. The data manager shall provide the capability for  tracking  JTIM requests and retrievals.



c. The data manager shall provide the capability for managing and updating JTIM windows and displays



d. The data manager shall provide the capability for transferring Target Folder (TF) data to the MPM being planned



e. The data manager shall provide the capability for accessing the TAMPS database to retrieve threat, routes, and target  data when requested by the TAMPS operator



f. The data manager shall provide the capability for transferring  imagery and products to TAMPS



Statements of Test



 JTIM (# 97-11B) Test Cases



Test Case Number:

97-11B.1��Test Case Name:

JTIM Initialization�FRD:

97-11B JTIM��Requirements:  



SOF ¶:  

        4.1.1a, b, c��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

None.��Assumptions:

None.��Constraints

None.��Description:



•	Open an MPM.

•	Select Threat/Intel -> JSIPS-N -> QR and verify query/retrieve function is displayed.

•	Exit the function.

•	Select Threat/Intel -> JSIPS-N -> Imagery Toolkit and verify the tookit function is displayed.

•	Exit the function.

•	Select the QR icon from the toolbar and verify that the query/retrieve function is displayed.

•	Exit the function.

•	Select the BAK/GND icon from the toolbar

•	Select Imagery, Edit and select the JSIPS-N option.

•	Verify that the imagery toolkit is displayed.

•	Exit the function.



��Output:  

None.��Evaluation Criteria:   

Must be able to initiate JTIM application and imagery toolkit from an MPM.  Must be able to initiate the JTIM query function from the toolbar.  Must be able to initiate the Query and imagery toolkit functions from a JSIPS-N menu.  Must be able to access the imagery toolkit through the standard TAMPS background imagery display tool.

��

�

Test Case Number:

97-11B.2��Test Case Name:

Target Icon Query�FRD:

97-11B JTIM��Requirements:  

CE0100, CE0300, CE0400

SOF ¶:  

         4.2.a, 4.2.1.a.1,

         4.2.1.1.A.1-5, 4.2.1.2

4.2.2.1.a-c��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products data from JSIPS-N and JMCIS.��Assumptions:

Target icon specific data available on JSIPS-N and JMCIS.��Constraints

None.��Description:



•	Open an MPM.

•	Select the QR icon from the toolbar.

•	Select the Target Icon button from the Query Details HMI.

•	Verify cursor changes to pointing hand.

•	Click on a target icon from the map display.

•	Verify target information is displayed in the Map Query Data section of the Query Details HMI.

•	Select JSIPS-N and various Data Categories and Image Query Constraints.

•	Select OK and verify the results of the query based on evaluation criteria.

•	Select JMCIS and various Data Categories and Image Query Constraints.

•	Select OK and verify the results of the query based on evaluation criteria.

•	Select More Details and verify that additional request parameters are displayed.

•	Perform queries using some of the paramters provided in the More Details section.

•	Verify the results of each query based on evaluation criteria.

•	Enter some request parameters, select Cancel, and verify that query is not sent.



��Output:  

Imagery footprints, imagery icons and target folder icons displayed on map.��Evaluation Criteria:   

Must be able to initiate a JTIM query by selecting a target icon.  TAMPS must provide the JTIM with available information for the selected target icon.  JTIM must extract query related information and display the information to the user.  Must be able to select All products, images only, target folders, perspective scene products and system to query.  Must be able to select number and size of images.  The user must be able to send or cancel the query.  JTIM must query the user-selected image servers.  Query results must display image footprints or icons for each image, indicating sensor type, technology (EO, IR, SAR),  associated target folder and product identification number.

��

�

Test Case Number:

97-11B.3��Test Case Name:

Rubber Band Box Query�FRD:

97-11B JTIM��Requirements:  

CE0100, CE0300, CE0400

SOF ¶:  

         4.2.a, 4.2.1.a.2, 

         4.2.1.1.B.1-6, 4.2.1.2

4.2.2.1.a-c��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products data from JSIPS-N and JMCIS.��Assumptions:

Data available on JSIPS-N and JMCIS for the desired area.��Constraints

None.��Description:



•	Open an MPM.

•	Select the QR icon from the toolbar.

•	Select the Rubberband button from the Query Details HMI.

•	Verify cursor changes to pencil.

•	Select a boxed area from the map.

•	Verify correct lat/lons are displayed in the Query Details HMI.

•	Perform JSIPS-N and JMCIS queries, by selecting various Data Categories, Image Query Constraints and More Details parameters.

•	Verify the results of each query based on the evaluation criteria.

•	Enter some request parameters, select Cancel, and verify that query is not sent.



��Output:  

Imagery footprints, imagery icons and target folder icons displayed on map.��Evaluation Criteria:   

Must be able to initiate a JTIM query by selecting a rubber band box to define an area of interest.  TAMPS must provide the JTIM with the lat/lons of the fours corners of the box.  JTIM must extract query related information and display the information to the user. Must be able to select All products, images only, target folders, perspective scene products and system to query.  Must be able to select number and size of images.  The user must be able to send or cancel the query.  JTIM must query the user-selected image servers.  Query results must display image footprints or icons for each image, indicating sensor type, technology (EO, IR, SAR),  associated target folder and product identification number.

��

�

Test Case Number:

97-11B.4��Test Case Name:

Browser Query�FRD:

97-11B JTIM��Requirements:  

CE0100, CE0300, CE0400

SOF ¶:  

         4.2.a, 4.2.1.a.3, 

         4.2.1.1.C.1-5, 4.2.1.2

4.2.2.1.a-c��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products data from JSIPS-N and JMCIS.��Assumptions:

Data available on JSIPS-N and JMCIS for the desired area.��Constraints

None.��Description:



•	Open an MPM.

•	Select the QR icon from the toolbar.

•	Deselect both the Target Icon and Rubber band buttons in the Query Details HMI.

•	Select the More Details button.

•	Perform JSIPS-N and JMCIS queries, by selecting various Data Categories, Image Query Constraints and More Details parameters.

•	Verify the results of each query based on the evaluation criteria.

•	Enter some request parameters, select Cancel, and verify that query is not sent.



��Output:  

Imagery footprints, imagery icons and target folder icons displayed on map.��Evaluation Criteria:   

Must be able to initiate a JTIM query using a browser.  JTIM must extract query related information and display the information to the user. Must be able to select All products, images only, target folders, perspective scene products and system to query.  Must be able to select number and size of images.  The user must be able to send or cancel the query.  JTIM must query the user-selected image servers.  Query results must display image footprints or icons for each image, indicating sensor type, technology (EO, IR, SAR),  associated target folder and product identification number.

��

�

Test Case Number:

97-11B.5��Test Case Name:

Product Data Display�FRD:

97-11B JTIM��Requirements:  



SOF ¶:  

        4.2.2.1.d, e��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products data from JSIPS-N and JMCIS.��Assumptions:

Various imagery types are available for the current area.��Constraints

None.��Description:



•	Perform a new query or use query from previous test case.

•	Select an imagery footprint.

•	Verify that the Product Data HMI with correct information is displayed.

•	Select an imagery icon.

•	Verify that the Product Data HMI with correct information is displayed.

•	Select a target folder icon.

•	Verify that the target folder data HMI with correct information is displayed.



��Output:  

Product data displayed.��Evaluation Criteria:   

The user must be able to view the information obtained from the query when an image footprint, image icon, product identification number or target folder is selected.

��

Test Case Number:

97-11B.6��Test Case Name:

Redisplaying Query Footprints�FRD:

97-11B JSIPS-N��Requirements:  



SOF ¶:  

��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products from JSIPS-N and JMCIS.��Assumptions:

Various queries have been performed during the current session.��Constraints

None.��Description:



•	Select QR from the toolbar.

•	Select View Query Request List in the Query Details HMI.

•	View various queries by selecting a query and selecting View and verify results.

•	View all queries by selecting the View All button and verify.

•	Delete a couple of queries.

•	Use the Delete All button to delete all queries.

•	Close the HMI.



��Output:  

Imagery footprints, imagery icons and target folder icons displayed on map.��Evaluation Criteria:   



��

�

Test Case Number:

97-11B.7��Test Case Name:

Retrieving Data�FRD:

97-11B JTIM��Requirements:  

CE0200, CE0900

SOF ¶:  

       2.3.d, 3.a-b,  4.2.2.2��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Imagery and imagery derived products from JSIPS-N and JMCIS.��Assumptions:

None.��Constraints

None.��Description:



•	Perform a query.

•	Select various products and select Retrieve.

•	Verify that retrieval status is provided for each product selected, including time remaining.

•	Verify that an indication is provided when the retrieval is complete.

•	Display the images to verify successful retrieval.

•	Use the Retrieve All button to retrieve all products in a query.

•	Verify successful retrieval.

•	While performing a retrieval, attempt to perform JTIMS or MPM functions.

•	Verify functions are not affected.



��Output:  

Imagery and imagery derived products transferred to TAMPS database.��Evaluation Criteria:   

Must be able to select individual or all products for retrieval.  Must be able to initiate, cancel and prioritize retrieval requests.  User must be provided a status, including time required for the each products retrieval.  The user must be able to perform JTIM or MPM functions while imagery is being retrieved.

��

�

Test Case Number:

97-11B.8��Test Case Name:

Target Folder Data�FRD:

97-11B JTIM��Requirements:  



SOF ¶:  

        4.2.2.3��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Targets folder data.��Assumptions:

None.��Constraints

None.��Description:



•	Select a target folder from the product retrieved in the previous test case.

•	Verify textual contents of the target folder are dislayed in the Target Folder Data HMI.

•	Select OK in the Target Folder Data HMI.

•	Verify that the data is transferred to the MPM.



��Output:  

Displayed target folder data.  Data transferred to the MPM..��Evaluation Criteria:   

Must be able to view the contents of a target folder after retrieval.  Must be able to transfer target folder data to the MPM. 

��

�

Test Case Number:

97-11B.9��Test Case Name:

Imagery Toolkit Tools�FRD:

97-11B JTIM��Requirements:  

CE0500, CE0800

SOF ¶:  

         4.3.a.1-3, 4.3.b, 

         4.3.1.1.a-b, 4.3.1.2.b-f

4.3.1.3, 4.3.2.a, 

         4.3.3.a-b��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

NITF 2.0 image.��Assumptions:

None.��Constraints

None.��Description:



•	Select the footprint for a retrieved image.

•	Verify the JTIM Imagery Toolkit with the selected image loaded is displayed.

•	Select the Pick Tool and verify that the cursor changes to an arrow, allowing selection of menu items and other general selection operations.

•	Select the Roam Tool and verify that the cursor changes to “crossed arrows”, allowing the user to grab and Roam the image.

•	Use the Magnifying Glass to zoom in to an area.

•	Use the Icon Annotation Tool to add some icons to the image.

•	Use the Text Annotation Tool to add some text to the image.

•	Use the Text Menu to modify some text.

•	Use each of the Graphics Annotation Tools (Line, Rectangle, Ellipse, polygon) to add some graphics to the image.

•	Use the Edit Menu to duplicate, delete and move front/back some graphics.

•	Use the Graphics Menu to change the color and styles of graphics.

•	Select the Scissor Tool.

•	Use the right mouse button to cut out a portion of the image as an image chip.

•	Press the right mouse button again to move the chip to TAMPS.

•	Verify the image chip was moved to theTAMPS display.

•	Use the Contrast Control to adjust the image contrast.

•	Use the Brightness Control to adjust the image brightness.

•	Use the RRDS zoom control to adjust the image scale and visible detail.

•	Verify that the cursor lat/lon is displayed in the status box when it is not active.



��Output:  

Display changes according to editing changes.��Evaluation Criteria:   

Selecting the footpint of a retrieved image must start the toolkit and display the image.  The imagery toolkit must provide the capability to zoom in/out, set RRDS levels, roam the image, adjust contrast, adjust brightness, display cursor lat/lon, overlay graphics and text, create image chips and transfer image chips to the TAMPS display.

��

�

Test Case Number:

97-11B.10��Test Case Name:

Imagery Toolkit Image Manipulation�FRD:

97-11B JTIM��Requirements:  

CE0500, CE0600, CE0700

SOF ¶:  

        4.3.a.4, 4.3.1.2.a��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

NITF 2.0 images.��Assumptions:

None.��Constraints

None.��Description:



•	Select View -> Rotate and attempt to rotate the image right, left and free rotate.

•	Select View -> Center Image and verify that center  of image is centered on the screen.

•	Select View -> Geolocate and verify that a specific location can be obtained.

•	Select View -> Zoom and zoom to various scales.

•	Select View -> Perspective Scene -> Generate Perspective Scene.

•	Enter Eye Point and Aim Point information.

•	Select Calculate and verify depression angle, range and azimuth are updated.

•	Select Render Scene and verify scene is displayed.

•	Select View -> Perspective Scene -> Products Request.

•	Select products type and Send.

•	Verify products are created.



��Output:  

Display changes according to editing changes.��Evaluation Criteria:   

Must be able to generate perspective scenes by entering eyepoint and aimpoint data.  Must display the range and azimuth of the entered data for the scene.  The user must be able to select rendering modes.  The toolkit must allow the user to rotate the image. 

��

�

Test Case Number:

97-11B.11��Test Case Name:

Imagery Toolkit Object Display�FRD:

97-11B JTIM��Requirements:  



SOF ¶:  

        4.3.1.1.c��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

TAMPS objects.��Assumptions:

None.��Constraints

None.��Description:



•	Select File -> Load and load an image with a target folder in the imagery toolkit.

•	Select Graphics -> Display Routes to display current routes on the image and verify.

•	Select Graphics -> Display Targets to display current targets on the image and verify.

•	Select Graphics -> Display Threats to display current threats on the image and verify.

•	Select Graphics -> North Arrow to display the north arrow graphic.

•	Select Graphics -> Clear all graphics to clear the graphics from the display.

•	Select Graphics -> Display Target Folder Data and verfiy data displayed.

•	Select Graphics -> Display all MPM Data and verify.



��Output:  

Objects displayed on image.��Evaluation Criteria:   

The user must be able to display threats, generated routes and target locations from the mission being planned.

��

�

Test Case Number:

97-11B.12��Test Case Name:

Imagery Toolkit Target Folders�FRD:

97-11B JTIM��Requirements:  



SOF ¶:  

        4.3.1.4��Initial State:

TAMPS system installed with MPLAN connected to JSIPS-N, and JMCIS using the JTIMS interface.  �Inputs:

Target folder data.��Assumptions:

None.��Constraints

None.��Description:



•	Select File -> Load and load an image with a target folder in the imagery toolkit.

•	Select a target icon graphic.

•	Verify that the taret folder data is displayed in the Target Folder Data HMI.

•	Select OK or Apply in the Target Folder Data HMI to transfer the data to the MPM.

•	Verify that the data was transferred.



��Output:  

Displayed target folder data.  Data transferred to the MPM..��Evaluation Criteria:   

The JTIM imagery toolkit must display graphics associated with target folder aimpoints.  The user must be able to display target folder data associated with a selected aimpoint graphic and transfer that data to the mission being planned by the MPM.

��
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