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Statements of Functionality (SOF)

Overview

	The automatic recognition and storage of GPS crypto key type (weekly, yearly) will be provided.  The key type will not be editable.  This SOR will not have any impact on the TAMPS system performance criteria as specified in the TAMPS TEMP.

Manually Entered Keys (CS0625.0010)

	a)  TAMPS shall provide recognition of the key type based on the key value for manually entered weekly keys.

	b)  TAMPS shall provide storage of the key type in the GPS crypto key database for manually entered weekly keys.

	c)  TAMPS shall display the key type as “CVw” in the GPS Crypto Key DBA HMI for manually entered weekly keys.

	d)  TAMPS shall update the Manual Entry HMI for manually entered weekly keys to display the key type as weekly.  The HMI will be updated after the key value has been entered twice and the “Key Value (repeat)” text field no longer has input focus.

	e)  TAMPS shall provide recognition of the key type based on the key value for manually entered yearly keys.

	f)  TAMPS shall provide storage of the key type in the GPS crypto key database for manually entered yearly keys.

	g)  TAMPS shall display the key type as “GUV” in the GPS Crypto Key DBA HMI for manually entered yearly keys.

	h)  TAMPS shall update the Manual Entry HMI for manually entered yearly keys to display the key type as yearly.  The HMI will be updated after the key value has been entered twice and the “Key Value (repeat)” text field no longer has input focus.

 	i)  TAMPS shall display the key type as “Weekly” in the Modify Keys HMI for manually entered weekly keys.

	j)  TAMPS shall display the key type as “Yearly” in the Modify Keys HMI for manually entered yearly keys.

Transfer of Keys from AN/CYZ-10 (CS0625.0020)

	a)  TAMPS shall provide recognition of the key type based on the key value for weekly keys electronically transferred from the AN/CYZ-10.

	b)  TAMPS shall provide storage of the key type in the GPS crypto key database for weekly keys electronically transferred from the AN/CYZ-10.

	c)  TAMPS shall display the key type as “CVw” in the GPS Crypto Key DBA HMI for weekly keys electronically transferred from the AN/CYZ-10.

	d)  TAMPS shall provide recognition of the key type based on the key value for yearly keys electronically transferred from the AN/CYZ-10.

	e)  TAMPS shall provide storage of the key type in the GPS crypto key database for yearly keys electronically transferred from the AN/CYZ-10.

	f)  TAMPS shall display the key type as “GUV” in the GPS Crypto Key DBA HMI for yearly keys electronically transferred from the AN/CYZ-10.

 	g)  TAMPS shall display the key type as “Weekly” in the Modify Keys HMI for weekly keys electronically transferred from the AN/CYZ-10.

	h)  TAMPS shall display the key type as “Yearly” in the Modify Keys HMI for yearly keys electronically transferred from the AN/CYZ-10.



Unknown Key Types (CS0625.0030)

	a)  TAMPS shall provide a warning when the key type cannot be automatically  determined (unknown) based on the key value for manually entered keys.  The warning shall indicate that unknown key types cannot be used by TAMPS and that the key will not be stored in the GPS crypto key database.

	b)  TAMPS shall provide a warning when the key type cannot be automatically determined (unknown) based on the key value for keys electronically transferred from the AN/CYZ-10.  The warning shall indicate that unknown key types cannot be used by TAMPS and that the key will not be stored in the GPS crypto key database.

	c)  TAMPS shall not store manually entered unknown keys in the GPS crypto key database.

	d) TAMPS shall not store unknown keys electronically transferred from the AN/CYZ-10 in the GPS crypto key database.



Statement of Test



GPS Crypto Key (FRD # 97-12) Test Cases



Test Case Number:

97-12.1��Test Case Name:

Manual Entry - Weekly Keys�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0010

SOF ¶:  

         1.4.2a, b, c, d, ��Initial State:  

TAMPS system installed.  Crypto key storage space available on system.�Inputs:

Manual key data.��Assumptions:

None��Constraints

Must use “real” crypto keys, since software uses data to determine key type.��Description:



Open DBA Crypto Key function.

Select Edit -> Manual Entry.

Enter Short Title, Edition, Reg Num, Seg Num, Description, Key Value and Key Value (repeat) for a weekly crypto key.

Verify that the “weekly” toggle button is highlighted after Key Value (repeat) loses focus.

Enter start date.

Verify end date is automatically filled in.

Select Apply.

Verify correct data is displayed in GPS Crypto Key window, including “CVw” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Enter a portion of the information for another key and select OK.

Verify that an error message is displayed.

��Output:  

None.��Evaluation Criteria:  

System must recognize the key type of manually entered weekly crypto keys.��



Test Case Number:

97-12.2��Test Case Name:

Manual Entry - Yearly Keys�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0010

SOF ¶:  

         1.4.2e, f, g, h ��Initial State:  

TAMPS system installed.  Crypto key storage space available on system.�Inputs:

GPS crypto key data.��Assumptions:

None��Constraints

Must use “real” crypto keys, since software uses data to determine key type.��Description:



Open DBA Crypto Key function.

Select Edit -> Manual Entry.

Enter Short Title, Edition, Reg Num, Seg Num, Description, Key Value and Key Value (repeat) for a yearly crypto key.

Verify that the “yearly” toggle button is highlighted after Key Value (repeat) loses focus.

Enter start date.

Verify end date is automatically filled in.

Select Apply.

Verify correct data is displayed in GPS Crypto Key window, including “GUV” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Enter info for another yearly key, select OK and verify.

��Output:  

None.��Evaluation Criteria:  

System must recognize the key type of manually entered yearly crypto keys.��



Test Case Number:

97-12.3��Test Case Name:

Manual Entry - Unknown Key Types�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0030

SOF ¶:  

         1.4.4a, b, c, d, e��Initial State:  

TAMPS system installed.  Crypto key storage space available on system.�Inputs:

Data not recognized as a weekly or yearly key.��Assumptions:

None.��Constraints

None��Description:



Open DBA Crypto Key function.

Select Edit -> Manual Entry.

Enter Short Title, Edition, Reg Num, Seg Num, Description, Key Value and Key Value (repeat) for a dummy crypto key.

Verify that the “unknown” toggle button is highlighted and date field is grayed out after Key Value (repeat) loses focus.

Verify that a warning is provided which says that unknown key types cannot be used by TAMPS.

Select Apply.

Verify correct data is displayed in GPS Crypto Key window, including “UNK” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Enter info for another dummy key and select OK.

��Output:  

None.��Evaluation Criteria:  

System must assign an “unknown” key type to manually entered keys which are not weekly or yearly keys.��



Test Case Number:

97-12.4��Test Case Name:

Manual Entry Modify�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0010, CS0625.0030

SOF ¶:  

         1.4.2i, 1.4.2j, 1.4.4f��Initial State:  

TAMPS system installed.  Manually entered crypto keys loaded on system.�Inputs:

None��Assumptions:

None.��Constraints

None.��Description:



Open DBA Crypto Key function.

Select Edit -> Modify and select a weekly key that was manually entered from the list.

Verify that it is correctly labelled as “weekly” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information is correctly updated in the GPS Crypto Key window.

Select Edit -> Modify and select a yearly key that was manually entered from the list.

Verify that it is correctly labelled as “yearly” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information is correctly updated in the GPS Crypto Key window.

Select Edit -> Modify and select an unknown key that was manually entered from the list.

Verify that it is correctly labelled as “unknown” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information is correctly updated in the GPS Crypto Key window.

��Output:  

None��Evaluation Criteria:  

Modify Keys HMI must display correct key types for all crypto keys.  Must be able to modify manually entered weekly, yearly and unknown keys.��



Test Case Number:

97-12.5��Test Case Name:

CYZ-10 Load - Weekly Keys�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0020

SOF ¶:  

         1.4.3a, b, c��Initial State:  

TAMPS system installed.  Crypto key storage space  available on system.  CYZ-10 hooked up to serial port 2.  Weekly keys have been loaded on CYZ-10.�Inputs:

GPS crypto key data.��Assumptions:

None.��Constraints

Must use “real” crypto keys, since software uses data to determine key type.��Description:



Open DBA Crypto Key function.

Select File -> Load DTD Keys.

Select a weekly key on the CYZ-10 and execute download.

Verify correct data is displayed in GPS Crypto Key window, including “CVw” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Download other weekly keys from the CYZ-10 and verify.

��Output:  

None.��Evaluation Criteria:  

System must recognize and load weekly crypto keys downloaded from the CYZ-10.��



Test Case Number:

97-12.6��Test Case Name:

CYZ-10 Load - Yearly Keys�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0020

SOF ¶:  

         1.4.3d, e, f ��Initial State:  

TAMPS system installed.  Crypto key storage space  available on system.  CYZ-10 hooked up to serial port 2.   Yearly keys have been loaded on CYZ-10.�Inputs:

GPS crypto key data.��Assumptions:

None��Constraints

Must use “real” crypto keys, since software uses data to determine key type.��Description:



Open DBA Crypto Key function.

Select File -> Load DTD Keys.

Select a yearly key on the CYZ-10 and execute download.

Verify correct data is displayed in GPS Crypto Key window, including “GUV” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Download other yearly keys from the CYZ-10 and verify.

��Output:  

None.��Evaluation Criteria:  

System must recognize and load yearly crypto keys downloaded from the CYZ-10.��



Test Case Number:

97-12.7��Test Case Name:

CYZ-10 Load - Unknown Key Types�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0030

SOF ¶:  

         1.4.4g, h, i, j��Initial State:  

TAMPS system installed.  Crypto key storage space available on system.  CYZ-10 hooked up to serial port 2. Keys of unknown type have been loaded on CYZ-10.�Inputs:

Data not recognized as a weekly or yearly key.��Assumptions:

None.��Constraints

None.��Description:



Open DBA Crypto Key function.

Select File -> Load DTD Keys.

Select a key not recognized as weekly or yearly on the CYZ-10 and execute download.

Verify warning is displayed.

Verify correct data is displayed in GPS Crypto Key window, including “UNK” key type.

Using the od tool, verify that the key was correctly stored in TAMPS.

Download other unkown keys from the CYZ-10 and verify.

��Output:  

None.��Evaluation Criteria:  

System must assign an “unknown” key type to keys loaded from the CYZ-10 which are not weekly or yearly keys.��



Test Case Number:

97-12.8��Test Case Name:

CYZ-10 Load Modify�FRD:

97-12 GPS Crypto Key��Requirements:  

CS0625.0020

SOF ¶:  

         1.4.3g, h��Initial State:  

TAMPS system installed.  Crypto keys from CYZ-10 loaded on system.�Inputs:

GPS crypto key data��Assumptions:

None.��Constraints

None.��Description:



Open DBA Crypto Key function.

Select Edit -> Modify and select a weekly key that was loaded from the CYZ-10 from the list.

Verify that it is correctly labelled as “weekly” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information is correctly updated in the GPS Crypto Key window.

Select Edit -> Modify and select a yearly key that was loaded from the CYZ-10 from the list.

Verify that it is correctly labelled as “yearly” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information  is correctly updated in the GPS Crypto Key window.

Select Edit -> Modify and select an unknown key that was loaded from the CYZ-10 from the list.

Verify that it is correctly labelled as “unknown” in the Modify Keys HMI.

Modify some information and select OK.

Verify that the key information is correctly updated in the GPS Crypto Key window.

��Output:  

None��Evaluation Criteria:  

Modify Keys HMI must display correct key types for all crypto keys.  Must be able to modify weekly, yearly and unknown keys that were loaded from the CYZ-10.��
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