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�

�HIGH-LEVEL DESIGN

CONOPS

Scope

Requirement Number: 97-12



Title:  GPS Cryptographic Key Type Identification



The GPS crypto key identification capability shall provide automated recognition of the key type (weekly, yearly) based on the GPS key only.  The key type shall be determined independent of user defined input and of the short title.  The key type shall be written to the GPS database and shall not be manually changeable by the user.  Automated key type recognition shall be provided for keys transferred via AN/CYZ-10 or manually entered via keyboard.  Key types other than weekly or yearly shall not be stored in the database as an “unknown” type and a warning message shall be displayed that the key is not a known type and will not be stored in the database can not be used by TAMPS.

Applicable Documents

Government Documents

Specifications

SLAM OAG 4 Dec. 1996.

SCP II-5 - “Provide method for TAMPS to independently check the crypto key type and date.”

Standards

None

Other Publications

None

Non-Government Documents

None

Impact Analysis

Users



The user impact will be to database administrators only.

�

Mission Planners

It is not envisioned that there will be any impact on the mission planners.

System Administrators

It is not envisioned that there will be any impact on the system administrator.

Database Administrators

The database administrators will be impacted when executing the GPS crypto key applications.   The HMI will be changed to reflect the addition of the unknown key type.  Previously, the HMI only reflected weekly and yearly key types.  An error message will be displayed for key types other than weekly or yearly, and those key types will not be stored as an “unknown” type in the database.

Performance and Sizing

The key type determination algorithm will have minimal impact on the time required to load GPS crypto keys.

Operating Locations

The GPS crypto key type identification capabilities will be required at all TAMPS locations: afloat, ashore, training, marine corps expeditionary, DTE/OTE sites, and coast guard bases.

Hardware and Software Configuration

System Hardware

No changes to the currently supported TAMPS configurations are required.

Operating System

No changes to the currently supported TAMPS configurations are required.

Commercial-Off-The-Shelf (COTS) Application Software

No changes to the currently supported TAMPS configurations are required.

Installation

No changes to the currently supported TAMPS configurations are required.

Description of Processing

After the GPS crypto key is transferred via the AN/CYZ-10 or manually entered via the keyboard, the key type will be determined by running a GFI algorithm on the key.  If the key type is determined to be weekly or yearly, tThe GPS crypto key will then be stored in the database along with the key type and other crypto key data fields.  Key types other than weekly or yearly will not be stored in the databaseas “unknown”.  TAMPS modules which need to access and utilize GPS receivers will request the appropriate key data from the GPS crypto key server.  The key data (if available) will be provided in response to this request and the module will format the information as required, and include the key in the appropriate BDF.  The BDF will then be transferred to an avionics interface device, such as the memory unit (MU).  The MU will then be used to transfer the BDF, along with the embedded key information into the associated weapon system.

Performance Criteria

This SOR will not have any impact on the TAMPS system performance criteria as specified in the TAMPS TEMP.

System Architecture

Software Architecture

No changes to the current TAMPS software architecture are required.

Hardware Architecture

No changes to the current TAMPS hardware architecture are required.

�Draft User Interface



�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC \r 1 �1� GPS Crypto Key DBA HMI





	Keys for which the key type cannot be automatically determined will be stored with a key type of “unknown” in the database.  Unknown keys will be listed as ìUNKî in the Type column in the GPS Crypto Key DBA HMI.  Weekly keys will be listed as “CVw” and yearly keys will be listed as “GUV” as in the existing HMI.  There are no other changes to the existing HMI.	� REF _Ref391561468 \* MERGEFORMAT �Figure 1.2-1� shows the GPS Crypto Key DBA HMI.  There are no changes to this HMI.

�



�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC �2� Manual Entry HMI



	The manual entry HMI will include “Unknown” as a new key type.  The Manual Entry HMI will be modified to update the Key Type radio box based on the Key Value instead of the short title as in TAMPS 6.1.  After the key value is entered twice and the input focus is changed to another field or the Help button is pressed, the key type will be automatically determined based on the key value.  At that point the key type in the HMI will be updated in the Key Type radio box and will not be editable (read only).  For unknown keys, both the weekly and yearly selections will be grayed out.

	When the key type cannot be automatically determined, the key will be not be stored in the GPS crypto key database with a key type of unknown and the error message in � REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4� � REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4� will appear.  The start and end date text entry fields will be grayed out if the key type is unknown.  The “Key Value” and “Key Value (repeat)” text fields will be cleared.

	The label “Zulu” will be added after the start and end date text fields to clarify that the key will be effective at the start of the day Zulu time on the start date until the end of the day Zulu time on the end date.  There are no other changes to the existing HMI.



�



�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC �3� Load Keys from DTD HMI



	There are no changes to the existing HMI to load keys from the AN/CYZ-10.  After the OK or Apply button is pressed, the key will be loaded from the AN/CYZ-10.  If the key type cannot be automatically recognized based on the key value the error in � REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4� will appear.

�

�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC �4� Error Message for Unrecognized Key Types



	Upon transfer of a key from the AN/CYZ-10 or manual entry of a key, the key type (weekly, yearly) will be automatically determined and stored.  When the key type cannot be automatically determined, the user will be notified by the message in � REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4�.  To remove the message the user may either press the “Acknowledge” button or close the dialog box.

�



�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC �5� Modify Keys HMI



	The modify keys HMI will include “Unknown” as a new key type.  The key type will be retrieved from the GPS crypto key database and will be indicated in the Key Type radio box.  The key type will not be editable (read only).  For unknown key types, the start and end date text entry fields will be grayed out.

	The label “Zulu” will be added after the start and end date text fields to clarify that the key will be effective at the start of the day Zulu time on the start date until the end of the day Zulu time on the end date.  There are no other changes to the existing HMI.



�



�

Figure � STYLEREF 2 \n �1.2�-� SEQ Figure \* ARABIC �6� User Interface Hierarchy





�Requirements Trace

RTDB



CS0625.0010�3.4.1.9.1.7.1¶2S1�GPS Crypto Key processing shall support automatic recognition and storage of crypto key type (weekly, yearly) based on manually entered data.��CS0625.0020�3.4.1.9.1.7.1¶2S1�GPS Crypto Key processing shall support automatic recognition and storage of crypto key type (weekly, yearly) based on data transferred via AN/CYZ-10.��CS0625.0030�3.4.1.9.1.7.1¶2S2�Key types other than weekly and yearly shall not be stored in the GPS crypto key databases.��CS0625.0040�3.4.1.9.1.7.1¶2S2�A warning message shall be displayed indicating that the key is not a known type and will not be stored in the database.��





�

Administrative Actions



Spec Para�RTDB�Action��3.4.1.9.1.7.1¶2S1�CS0625.0010

CS0625.0020�None.��3.4.1.9.1.7.1¶2S2�CS0625.0030

CS0625.0040�None.��

Allocation



Spec Para�RTDB�SOF�Functional Unit�User Interface��3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�a�GST_ManualEntry

GKT_GpsMasterKey���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�b�GST_ClientDBA

GST_RequestMgr���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�c�GST_DbaGui

GST_ClientDBA

GST_RequestMgr�� REF _Ref391561468 \* MERGEFORMAT �Figure 1.2-1���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�d�GST_ManualEntry�� REF _Ref391561526 \* MERGEFORMAT �Figure 1.2-2���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�e�GST_ManualEntry

GKT_GpsMasterKey���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�f�GST_ClientDBA

GST_RequestMgr���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�g�GST_DbaGui

GST_ClientDBA

GST_RequestMgr�� REF _Ref391561468 \* MERGEFORMAT �Figure 1.2-1���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�h�GST_ManualEntry�� REF _Ref391561526 \* MERGEFORMAT �Figure 1.2-2���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�i�GST_ModifyDialog�� REF _Ref391562700 \* MERGEFORMAT �Figure 1.2-5���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�� REF _Ref387804502 \n �1.4.2�j�GST_ModifyDialog�� REF _Ref391562700 \* MERGEFORMAT �Figure 1.2-5���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�a�GKT_GpsMasterKey���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�b�GST_GpsKeyMgr

GST_RequestMgr���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�c�GST_DbaGui

GST_ClientDBA

GST_RequestMgr�� REF _Ref391561468 \* MERGEFORMAT �Figure 1.2-1���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�d�GKT_GpsMasterKey���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�e�GST_GpsKeyMgr

GST_RequestMgr���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�f�GST_DbaGui

GST_ClientDBA

GST_RequestMgr

gpskey/gut�� REF _Ref391561468 \* MERGEFORMAT �Figure 1.2-1���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�g�GST_ModifyDialog�� REF _Ref391562700 \* MERGEFORMAT �Figure 1.2-5���3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�� REF _Ref387804671 \n �1.4.3�h�GST_ModifyDialog�� REF _Ref391562700 \* MERGEFORMAT �Figure 1.2-5���3.4.1.9.1.7.1¶2S23.4.1.5.2.2¶1�CS0625.0030�� REF _Ref387804741 \n �1.4.4�a�GST_ManualEntry

GST_ErrorDialog�� REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4���3.4.1.9.1.7.1¶2S23.4.1.5.2.2¶1�CS0625.0030�� REF _Ref387804741 \n �1.4.4�b�GST_GpsKeyMgr

GST_ErrorDialog�� REF _Ref391561216 \* MERGEFORMAT �Figure 1.2-4���3.4.1.9.1.7.1¶2S2�CS0625.0040�1.4.4c�GST_ManualEntry���3.4.1.9.1.7.1¶2S2�CS0625.0040�1.4.4d�GST_GpsKeyMgr���

Assumptions



Spec Para�RTDB�Assumption��3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0010�The GFI algorithm to automatically recognize the key type will be provided.  The algorithm will be accurate as well as require minimal computational time.  Test keys (weekly, yearly) will be provided which will be recognized by the GFI algorithm.��3.4.1.9.1.7.1¶2S13.4.1.5.2.2¶1�CS0625.0020�The GFI algorithm to automatically recognize the key type will be provided.  The algorithm will be accurate as well as require minimal computational time.  Test keys (weekly, yearly) will be provided which will be recognized by the GFI algorithm.��3.4.1.9.1.7.1¶2S23.4.1.5.2.2¶1�CS0625.0030�None��3.4.1.9.1.7.1¶2S2�CS0625.0040�None���Statements of Functionality (SOF)

Overview

	The automatic recognition and storage of GPS crypto key type (weekly, yearly) will be provided.  The key type will not be editable.  This SOR will not have any impact on the TAMPS system performance criteria as specified in the TAMPS TEMP.

Manually Entered Keys (CS0625.0010)

	a)  TAMPS shall provide recognition of the key type based on the key value for manually entered weekly keys.

	b)  TAMPS shall provide storage of the key type in the GPS crypto key database for manually entered weekly keys.

	c)  TAMPS shall display the key type as “CVw” in the GPS Crypto Key DBA HMI for manually entered weekly keys.

	d)  TAMPS shall update the Manual Entry HMI for manually entered weekly keys to display the key type as weekly.  The HMI will be updated after the key value has been entered twice and the “Key Value (repeat)” text field no longer has input focus.

	e)  TAMPS shall provide recognition of the key type based on the key value for manually entered yearly keys.

	f)  TAMPS shall provide storage of the key type in the GPS crypto key database for manually entered yearly keys.

	g)  TAMPS shall display the key type as “GUV” in the GPS Crypto Key DBA HMI for manually entered yearly keys.

	h)  TAMPS shall update the Manual Entry HMI for manually entered yearly keys to display the key type as yearly.  The HMI will be updated after the key value has been entered twice and the “Key Value (repeat)” text field no longer has input focus.

 	i)  TAMPS shall display the key type as “Weekly” in the Modify Keys HMI for manually entered weekly keys.

	j)  TAMPS shall display the key type as “Yearly” in the Modify Keys HMI for manually entered yearly keys.

Transfer of Keys from AN/CYZ-10 (CS0625.0020)

	a)  TAMPS shall provide recognition of the key type based on the key value for weekly keys electronically transferred from the AN/CYZ-10.

	b)  TAMPS shall provide storage of the key type in the GPS crypto key database for weekly keys electronically transferred from the AN/CYZ-10.

	c)  TAMPS shall display the key type as “CVw” in the GPS Crypto Key DBA HMI for weekly keys electronically transferred from the AN/CYZ-10.

	d)  TAMPS shall provide recognition of the key type based on the key value for yearly keys electronically transferred from the AN/CYZ-10.

	e)  TAMPS shall provide storage of the key type in the GPS crypto key database for yearly keys electronically transferred from the AN/CYZ-10.

	f)  TAMPS shall display the key type as “GUV” in the GPS Crypto Key DBA HMI for yearly keys electronically transferred from the AN/CYZ-10.

 	g)  TAMPS shall display the key type as “Weekly” in the Modify Keys HMI for weekly keys electronically transferred from the AN/CYZ-10.

	h)  TAMPS shall display the key type as “Yearly” in the Modify Keys HMI for yearly keys electronically transferred from the AN/CYZ-10.



Unknown Key Types (CS0625.0030)

	a)  TAMPS shall provide a warning when the key type cannot be automatically  determined (unknown) based on the key value for manually entered keys.  The warning shall indicate that unknown key types cannot be used by TAMPS and that the key will not be stored in the GPS crypto key database.

	b)  TAMPS shall provide storage in the GPS crypto key database of manually entered keys for which the key type cannot be automatically determined based on the key value.

	c)  TAMPS shall provide storage of the key type as unknown in the GPS crypto key database for manually entered keys for which the key type cannot be automatically determined based on the key value.

	d)  TAMPS shall display the key type as “UNK” in the GPS Crypto Key DBA HMI for manually entered unknown keys.

	e)  TAMPS shall update the Manual Entry HMI to display the key type as unknown and to gray out the start and end date text fields for manually entered keys for which the key type cannot be automatically determined based on the key value.  The HMI will be updated after the key value has been entered twice and the “Key Value (repeat)” text field no longer has input focus.

	f)  TAMPS shall display the key type as “Unknown” and gray out the start and end date text fields in the Modify Keys HMI for manually entered unknown keys.

	bg)  TAMPS shall provide a warning when the key type cannot be automatically determined (unknown) based on the key value for keys electronically transferred from the AN/CYZ-10.  The warning shall indicate that unknown key types cannot be used by TAMPS and that the key will not be stored in the GPS crypto key database.

	c)  TAMPS shall not store manually entered unknown keys in the GPS crypto key database.

	d) TAMPS shall not store unknown keys electronically transferred from the AN/CYZ-10 in the GPS crypto key database.

	h)  TAMPS shall provide storage in the GPS crypto key database of keys electronically transferred from the AN/CYZ-10 for which the key type cannot be automatically determined based on the key value.

	i)  TAMPS shall provide storage of the key type as unknown in the GPS crypto key database for keys electronically transferred from the AN/CYZ-10 for which the key type cannot be automatically determined based on the key value.

	j)  TAMPS shall display the key type as “UNK” in the GPS Crypto Key DBA HMI for unknown keys electronically transferred from the AN/CYZ-10.

	k)  TAMPS shall display the key type as “Unknown” and gray out the start and end date text fields in the Modify Keys HMI for unknown keys electronically transferred from the AN/CYZ-10. �

Data Flow Diagram





�

Figure � STYLEREF 2 \n �1.5�-� SEQ Figure \* ARABIC \r 1 �1� Context Diagram



	A context diagram of how this SOR relates to TAMPS is shown in � REF _Ref387720656 \* MERGEFORMAT �Figure 1.5-1�.  This SOR requires the addition of the GPS Crypto Key Type algorithm to automatically determine the key type based on the key value.  The key type algorithm is called by both the GPS Crypto Key Server (for keys transferred from the AN/CYZ-10) and the GPS Crypto Key DBA (for manually entered keys).  This SOR also requires storage in the GPS Crypto Key Database of keys with an unknown key type.  Both the GPS Crypto Key DBA and the GPS Crypto Key Server will be modified to satisfy the requirements of this SOR.



��

Figure � STYLEREF 2 \n �1.5�-� SEQ Figure \* ARABIC �2� Data Flow Diagram for the GPS Crypto Key DBA Application



	The data flow diagram for the GPS Crypto Key DBA application is shown in � REF _Ref387720722 \* MERGEFORMAT �Figure 1.5-2�.  The GPS Crypto Key DBA application is provided for the DBA to manage the GPS crypto key database.  “Key info” refers to information associated with each key including the short title, register number, segment number, instance number, description, start and end effectivity dates, and key type.

	The GPS DBA Manager will send requests to the GPS Crypto Key Server according to what functions the DBA wishes to perform.  The GPS Crypto Key Server returns an error status to the GPS DBA Manager for each request.

	GPS DBA GUI represents the main HMI window for the application.  This window displays the key info retrieved from the server for each key stored in the GPS crypto key database.  The key info displayed in the main HMI for each key in the database is retrieved through a request sent by the GPS DBA Manager to the GPS Crypto Key Server.  The GPS Crypto Key Server will return the key info along with the error status to the GPS DBA Manager, which will send the key info on to the GPS DBA GUI.

	The Modify Keys HMI is displayed when “Modify Keys” is selected from the Edit pulldown menu in the main HMI.  The Modify Keys HMI displays key info received from the GPS DBA GUI for the selected key.  That information may be modified and saved in the GPS crypto key database through the GPS Crypto Key Server.  The key info is sent to the GPS DBA GUI and on to the GPS DBA Manager which sends it along with a request to update a key to the GPS Crypto Key Server.

	The Manual Entry HMI is displayed when “Manual Entry” is selected from the Edit pulldown menu in the main HMI.  The key value entered is sent to the key type algorithm which returns the key type based on the key value.  The key value and key info are sent to the GPS DBA Manager.  The request to store the key along with the key and key info (including the key type) is sent from the GPS DBA Manager to the GPS Crypto Key Server.

	Other requests in response to DBA commands in the GPS DBA GUI which may be sent by the GPS DBA Manager to the GPS Crypto Key Server include key purges, key deletion, and key loads from the AN/CYZ-10.

�

�

Figure � STYLEREF 2 \n �1.5�-� SEQ Figure \* ARABIC �3� Data Flow Diagram for the GPS Crypto Key Server

�	In � REF _Ref387720771 \* MERGEFORMAT �Figure 1.5-3� “key info” refers to the information stored along with the key value which includes the short title, register number, segment number, instance number, description, start and end effectivity dates, and key type.

	The purpose of the GPS Crypto Key Server is to process requests from the GPS Crypto Key DBA application and the MPMs, to store and retrieve GPS crypto keys/key info from the database, and to load keys/key info from the AN/CYZ-10.  The server is started by the operating system during the system boot and should always be running on the TAMPS system.  It consists of a request manager, key manager, AN/CYZ-10 interface, and the key type algorithm.

	The server request manager receives requests from the GPS Crypto Key DBA application.  Requests include updating existing key info in the database (through the Modify Keys HMI in the DBA application), purging all keys/key info from the database, loading keys/key info from the AN/CYZ-10, deleting a key/key info, requesting the key info for each key stored in the GPS crypto key database, and storing keys/key info in the GPS crypto key database (for manually entered keys).  The request manager calls the key manager, which performs the appropriate action.

	For requests to load keys/key info from the AN/CYZ-10, the request manager calls the key manager.  The key manager loads the key values and key info through the AN/CYZ-10 interface from the AN/CYZ-10 using the RS-232/DS-101 standards.  After the key values and key info are loaded, the key values are sent to the key type algorithm which returns the key type.  The key values and key info are then sent to the GPS Crypto Key Server key manager and stored in the GPS crypto key database.  An error status is returned from the key manager to the request manager which sends it to the GPS Crypto Key DBA application.

	For storage of manually entered keys, the request manager receives the key value and key info from the GPS Crypto Key DBA application and sends it to the key manager, which stores it in the GPS crypto key database.  An error status is returned by the key manager to the request manager which sends it to the GPS Crypto Key DBA application.

	For updates to existing keys, the request manager receives the updated key info from the GPS Crypto Key DBA application and sends it to the key manager, which performs the update to the GPS crypto key database.  An error status is returned by the key manager to the request manager which sends it to the GPS Crypto Key DBA application.

	For requests for the key info for each key stored in the database, the server returns the key info associated with each key to the GPS Crypto Key DBA application.  The actual key value is not sent to the GPS Crypto Key DBA application.  The request is received by the request manager which calls the key manager.  The key manager retrieves the key info for each key from the GPS crypto key database and sends it and the error status to the request manager, from where it is sent to the GPS Crypto Key DBA application.

	For key purge and key deletion requests, the request manager receives the request from the GPS Crypto Key DBA application and calls the key manager.  The key manager will perform the necessary action (purging key values/key info or deleting a key value/key info) on the GPS crypto key database and return an error status to the request manager.  The error status is then returned to the GPS Crypto Key DBA application.

	The server request manager receives requests for key values/key info from MPMs.  The MPMs make the requests by key type and date.  The request manager calls the key manager which retrieves the key value and key info from the GPS crypto key database.  The key value, key info, and error status are returned to the request manager and then to the MPM.

�Control Flow Diagram

�

Figure � STYLEREF 2 \n �1.6�-� SEQ Figure \* ARABIC \r 1 �1� Control Flow for Keys Transferred Via AN/CYZ-10

�	The control flow for keys transferred via the AN/CYZ-10 is shown in � REF _Ref391620427 \* MERGEFORMAT �Figure 1.6-1�.  The control flows relevant to this SOR for both the GPS Crypto Key DBA and the GPS Crypto Key Server are shown.

	In summary, during normal operation the GPS Crypto Key Server is always executing and waiting for requests.  To load GPS crypto keys from the AN/CYZ-10, it is necessary to invoke the GPS Crypto Key DBA application and to select “Load DTD Keys” from the File pulldown menu.  The “Load Keys from DTD” HMI will be displayed.  When the AN/CYZ-10 is ready to transfer keys, the OK or Apply button in the “Load Keys from DTD” HMI should be pressed.

	At that point the GPS Crypto Key DBA will send a request to the GPS Crypto Key Server request manager to load keys from the AN/CYZ-10.  The server request manager will then call the key manager, which will load the key value and key info from the AN/CYZ-10 using the RS-232/DS-101 interface protocols.

	After the key value and key info have been loaded, the GPS crypto key type algorithm will be executed on the key value to determine the key type.  If the key type is determined to be weekly or yearly, tThe key value and key type will then be stored in the GPS crypto key database.  Unknown keys will not be stored in the database.

	If the key type was recognized by the key type algorithm, the server will return a status of “no error” to the GPS Crypto Key DBA application.  If the key type was not recognized and therefore classified as unknown, a “key type unknown” error will be returned to the GPS Crypto Key DBA application, at which point the GPS Crypto Key DBA will display a warning indicating that the key type is unknown and that the key will not be stored in the GPS crypto key database.

�



�

Figure � STYLEREF 2 \n �1.6�-� SEQ Figure \* ARABIC �2� Control Flow for Manually Entered Keys

�

�

Figure � STYLEREF 2 \n �1.6�-� SEQ Figure \* ARABIC �3� Control Flow for Manually Entered Keys (continued)

�	The control flow for manually entered keys is shown in � REF _Ref388412584 \* MERGEFORMAT �Figure 1.6-2� and � REF _Ref391620849 \* MERGEFORMAT �Figure 1.6-3�.  The control flows relevant to this SOR for both the GPS Crypto Key DBA and the GPS Crypto Key Server are shown.

	In summary, during normal operation the GPS Crypto Key Server is always executing and waiting for requests.  To manually enter GPS crypto keys, it is necessary to invoke the GPS Crypto Key DBA application and to select “Manual Entry” from the Edit pulldown menu.  The “Manual Entry” HMI will be displayed.

	It is necessary to enter the GPS crypto key value in both the “Key Value” and “Key Value (repeat)” fields.  When the input focus is removed (by moving the cursor to another text field or pressing the “Help” buttona button other than “Cancel”) from the “Key Value (repeat)” field, the values entered in the two fields will be compared.  If they are not equivalent an error message will be displayed and the “Key Value” and “Key Value (repeat)” fields cleared so that the values may be entered again.

	If the key values in the two fields are equivalent, the GPS crypto key type algorithm will be executed on the key value to determine the key type.  The “Manual Entry” HMI will be updated to indicate the key type.

	If the key type is unknown the “Key Value” and “Key Value (repeat)” text fields will be cleared and, a warning will be displayed indicating that the key type is unknown.  For unknown keys, the start date and end date text fields will be grayed out, as the keys will be stored without effectivity dates.

	After the OK or Apply button has been pressed in the “Manual Entry” HMI, the keys in the “Key Value” and the “Key Value (repeat)” fields will once again be compared to make sure they are equivalent, and the GPS crypto key type algorithm executed again on the key value to determine the key type.

	Comparing the key values after the OK or Apply button has been pressed will generate a warning to the user if the first key value (in the “Key Value” field) is changed after the key has already been entered twice.  If the key values are equivalent, the key type algorithm will be executed.  Executing the key type algorithm after the OK or Apply button is pressed increases the reliability of storing the correct key type as the key type is obtained directly from the key type algorithm (instead of from the X/Motif toggle buttons).

	If the key type is not unknown, tThe key value and key type will be sent to the GPS Crypto Key Server along with a request to store the key.  The server will store the key value and key type in the GPS crypto key database and return an error status to the GPS Crypto Key DBA application.  If the key type is unknown the “Key Value” and “Key Value (repeat)” text fields will be cleared and a warning will be displayed indicating that the key type is unknown.

	There are no other changes to the control flow of the GPS Crypto Key Server and the GPS Crypto Key DBA application.









	� REF _Ref387721008 \* MERGEFORMAT �Figure 1.6-4� shows the control flow when “Edit->Modify Keys” is selected.  The change in this flow is that when the key type is unknown, the start and end date text fields are grayed out.

�Preliminary IDD Information



	There will be no changes to the IDD as a result of this SOR.

�Detailed Design

PDR Action Item Review

GPS Crypto Key Type Algorithm

Description:  Find and/or obtain algorithm sent by Joint GPS Program Office to PMA-233

Suspense Date: 15 Jun 97

Actionee(s):  LCDR Dober

Status:  The algorithm has been received by PMA-233 and received by TRW.  Recommend action be closed.



GPS Crypto Keys Expiration Gap

Description:  Find out what is the GPS keys expiration gap (2359-0001?)

Suspense Date:  15 Jun 97

Actionee(s):  SLAM

Status:  According to D. Martin, this is an operational issue that can not be resolved by TAMPS.  Recommend action be closed.



HMI for Unknown Keys

Description:  A HMI should instruct the planner than an unknown key has been identified and it should be deleted immediately

Suspense Date:  30 Jun 97

Actionee(s):  TRW

Status:  The requirement to store unknown keys in the GPS crypto key database has been removed.  The HMI warning will indicate that the key type is unknown and that the key will not be stored in the database.  Recommend action be closed.



TAMPS 6.2 GPS Crypto Re-certification

Description:  Obtain from NSA if TAMPS 6.2 will need to be GPS Crypto recertified

Suspense Date:  30 Jul 97

Actionee(s):  LCDR Dober, D. Pearson

Status:  TAMPS 6.2 will not need to be GPS Crypto recertified according to Lt. Loomis (NSA).  Recommend action be closed.



Test Keys

Description:  Obtain letter from NSA stating the usage of keys in respect to test

Suspense Date:  15 Jul 97

Actionee(s):  D. Pearson, D. Martin

Status:  According to D. Martin, testing of keys is being worked with local CMS managers.  Recommend action be closed.



�Database Design

Database Schema

	There are no changes to the database file “/dynamic/data/gpsKey/gpsKeys” as a result of this SOR.  The GPS crypto key database schema is unchanged as follows:



Data type�Length�Description��char�24�short title��char�16�edition��long��register number��int��segment number��int��instance number��char�16�description��char�16�key value��GST_KEY_T (enumerated type)��key type (weekly, yearly)��tm (time struct)��start date��tm (time struct)��end date��

Data Flows



�

Figure � STYLEREF 2 \n �2.2�-� SEQ Figure \* ARABIC \r 1 �1� Context Diagram





�

�

Figure � STYLEREF 2 \n �2.2�-� SEQ Figure \* ARABIC �2� Detailed Data Flow for Keys Transferred from AN/CYZ-10

�	� REF _Ref391533243 \* MERGEFORMAT �Figure 2.2-2� shows the detailed data flow for keys transferred from the AN/CYZ-10.  There are no changes to the data flow of the DBA application as a result of this SOR.  The GPS Crypto Key DBA application sends a request to load keys to the request manager of the GPS crypto key server.

	The AN/CYZ-10 interface in the server receives the key value and key info from the AN/CYZ-10 DTD through the RS-232 and DS-101 protocols.  The AN/CYZ-10 interface sends the key value to the GPS crypto key type algorithm which returns the key type.  The key value and key info (including the key type) are sent to the key manager, which stores it in the GPS crypto key database.  A completion status is returned to the request manager and to the GPS Crypto Key DBA application indicating the success or failure of the key transfer operation.��

Figure � STYLEREF 2 \n �2.2�-� SEQ Figure \* ARABIC �3� Detailed Data Flow for Manually Entered Keys

	� REF _Ref391532744 \* MERGEFORMAT �Figure 2.2-3� shows the detailed data flow for manually entered keys.  Only the modified and new data flows are shown.  The user enters the key value into the Manual Entry HMI, which calls the GPS crypto key type algorithm with the key value as the parameter.  The key type is returned by the algorithm to the Manual Entry HMI.

�Control Flows

�

Figure � STYLEREF 2 \n �2.3�-� SEQ Figure \* ARABIC \r 1 �1� GPS Crypto Key DBA Detailed Control Flow for Keys Transferred from AN/CYZ-10 (CF1 in test plans)

�	� REF _Ref391537259 \* MERGEFORMAT �Figure 2.3-1� shows the detailed control flow for the GPS Crypto Key DBA application for keys transferred from the AN/CYZ-10.  The user invokes the GPS Crypto Key DBA application and selects “File->Load DTD Keys”.  The “Load Keys from DTD” HMI will be displayed, and the user should select OK or Apply and also select “Send” on the AN/CYZ-10.  The OK/Apply callback will be activated and a request to load keys sent to the GPS Crypto Key Server request manager.

	After the error status is returned from the GPS Crypto Key Server, the key list will be refreshed in the GPS Crypto Key DBA HMI and the error status checked.  If an error was returned, the appropriate error message will be displayed.

��

Figure � STYLEREF 2 \n �2.3�-� SEQ Figure \* ARABIC �2� GPS Crypto Key Server Detailed Control Flow for Keys Transferred from AN/CYZ-10 (CF2 in test plans)

�	� REF _Ref391537131 \* MERGEFORMAT �Figure 2.3-2� shows the detailed control flow for the GPS Crypto Key Server for keys transferred from the AN/CYZ-10.  The server is invoked at system startup and should always be running.  When the user wishes to load keys from the AN/CYZ-10, a request will be received from the GPS Crypto Key DBA application.

	The key will be transferred from the AN/CYZ-10, and the key value and associated key information extracted from the data.  The key type algorithm will be executed on the key value to determine the key type as weekly, yearly, or unknown.  The key and associated information including the key type will be added to the key list.  This process will continue until there are no more keys to be transferred.

	A key will then be retrieved from the key list and the key type will be checked for an unknown type.  If the key type is unknown, an error status will be set and the next key retrieved from the key list.  If the key type is not unknown, checks will be made to see if the key already exists in the database and if the maximum number of keys will be exceeded.  If an error is detected, the error status will be set, and the next key retrieved from the key list

	If no errors are detected the key will be stored in the GPS crypto key database.  The next key will be retrieved from the key list.

	This process continues until there are no more keys in the key list.

��

Figure � STYLEREF 2 \n �2.3�-� SEQ Figure \* ARABIC �3� GPS Crypto Key DBA Detailed Control Flow for Manually Entered Keys (CF3 in test plans)

��

Figure � STYLEREF 2 \n �2.3�-� SEQ Figure \* ARABIC �4� GPS Crypto Key DBA Detailed Control Flow for Manually Entered Keys (continued) (CF3 in test plans)

�	� REF _Ref391543884 \* MERGEFORMAT �Figure 2.3-3� and � REF _Ref391544650 \* MERGEFORMAT �Figure 2.3-4� show the detailed control flow of the GPS Crypto Key DBA application for manually entered keys.  The user invokes the GPS Crypto Key DBA application and selects “Edit->Manual Entry” which will bring up the “Manual Entry” HMI.  

	The user enters the key value in the “Key Value” text field and enters the key value a second time in the “Key Value (repeat)” text field.  When the user moves the input focus from the “Key Value (repeat)” text field to any other text field or to the “Help” button, error checking will be performed on the key values and the HMI updated.

	The key values will be checked to see if they are equivalent and of length 32 characters.  If they are not, an error message will be displayed.  The user may change the key value at that point.

	If the key values are equivalent and of the correct length, the GPS crypto key type algorithm will be executed on the key value, and the key type determined to be weekly, yearly, or unknown.  If the key type is unknown, an error message will be displayed and the “Key Value” and “Key Value (repeat)” text fields cleared.  The user may change the key value at that point.

	If the key type is weekly or yearly, the “Key Type” radio box will be updated in the HMI.  After the user finishes entering information and selects “OK” or “Apply”, the OK/Apply callback will be activated.

	Error checking will be done on the key information entered, any errors will result in an error message at which point the user can update the information and select “OK” or “Apply” again.    Error checking on the key information consists of checking for non-NULL short title, edition, register number, segment number, and start/end dates.  The register and segment numbers are checked to verify that only digits were entered.  The start/end dates are checked to verify that the end date is later than the start date, and that the key would not already be expired.  If no errors are detected, error checking will be done on the key values to ensure that they are the same and that the length of the keys are correct.  If an error in the key value is detected, an error message will be displayed.  The user may change the key values at that point.

	If no errors are detected in the key values, the GPS crypto key type algorithm will be executed again on the key value.  Executing the algorithm a second time will increase the reliability of storing the correct key type, as the Motif toggle buttons will not be relied upon for the key type.

	If the key type is unknown, an error message will be displayed and the “Key Value” and “Key Value (repeat)” text fields cleared, at which point the user may re-enter the key values.  If the key type is not unknown, a request along with the key value and key information (including key type) will be sent to the GPS crypto key server.  There are no modifications to the GPS crypto key server for manually entered keys.

�Algorithms

	The classified GPS crypto key type algorithm to determine the key type based on the key value will be implemented and integrated into the baseline.  There are no other algorithms introduced by this SOR.

�Code Description

PDL

	The GKT_GpsMasterKey::fduKeyToKey function will be modified to call “getKeyType” with the key value as the parameter.  Previously, getKeyType was called with the short title as the parameter.  The fduKeyToKey function is called after a key has been received from the AN/CYZ-10.  The function extracts the key value and key information.



GKT_GpsMasterKey::fduKeyToKey(GDT_FduKey& fdu)

{

	extract short title, edition, register number, segment number

	extract key value

	keyType=getKeyType(keyValue);	// call key type algorithm

}





	The GKT_GpsMasterKey::getKeyType function will be modified to change the input parameter from the short title to the key value.  This function will contain the GPS crypto key type algorithm and is called by the fduKeyToKey function for key loads from the AN/CYZ-10 and by the Manual Entry class for manually entered keys.  The key type (weekly, yearly, or unknown) will be returned.



KeyType GKT_GpsMasterKey::getKeyType(const RWCString& fdu.data)

{

	GPS crypto key type algorithm executed on key value

	return key type

}





	The GST_ManualEntry::GST_ManualEntry function is the constructor for the GST_ManualEntry class.  It will be modified to add the “Zulu” label to the Manual Entry HMI after the text fields for the start date and end date.

GST_ManualEntry::GST_ManualEntry( ... )

{

		.

		.

		.

	add Zulu label after text field for “Start (mm/dd/yyyy)”

		.

	add Zulu label after text field for “End (mm/dd/yyyy)”

		.

		.

		.

}





	The following callback will be deleted, as the short title will no longer be used to determine the key type.  This callback was called to determine the key type based on the short title when the short title text field lost focus.



ENTRY_CL_ONLY(GST_ManualEntry::titleLoseFocus, ... )

{

		.

		.

		keyType=getKeyType(char * short title)	// old version of getKeyType

		.

		.

}





	The GST_ManualEntry::checkKeyValues() function will be added to error check the key values entered and to determine if the “Key Type” radio box in the Manual Entry HMI needs to be updated.  If the radio box needs to be updated, the getKeyType function containing the algorithm will be called and the radio box set according to the returned key type.  For unknown keys, neither of the selections in the radio box (weekly, yearly) will be set.



GST_ManualEntry::checkKeyValues()

{

	if previous focus was in “Key Value (repeat)” field then

	{

		if (key values in “Key Value” and “Key Value (repeat)” fields are not

			equivalent)

			return(error);

		if (length of key value != 32 chars)

			return(error);

		keyType=getKeyType(key value);	// call key type algorithm function

		if key type is unknown then

		{

			display warning

			clear out “Key Value” and “Key Value (repeat)” text fields

			update “Key Type” radio box by graying out both the weekly and 					yearly selections

		}

		else

			update “Key Type” radio box with key type

	}

}





The following callback will be added to all text fields in the Manual Entry HMI window except  the “Key Value” and “Key Value (repeat)” fields.  This callback will call the checkKeyValues() function.



ENTRY_CL_ONLY(GST_ManualEntry::entryArmCB,...)

{

	checkKeyValues();

}





The following callback for the Help button in the Manual Entry HMI will be modified to call the checkKeyValues() function.



GST_ManualEntry::helpCB()

{

	checkKeyValues();

		.

		.

		.

}





PDL for OK/Apply callback in the Manual Entry screen:



GST_ManualEntry::applyCB(void)

{

	check if adding a key would exceed the maximum number of keys that may be stored

	make sure that the key value is non-null

	make sure that the key values are the same in the “Key Value” and “Key Value (repeat)” fields

	make sure the key value is of the correct length

	call GPS crypto key algorithm, execute algorithm on key value

	if the key type is unknown, display error message, clear “Key Value” and “Key Value (repeat)” fields, and return

	.

	.

	.

	send a request to store the key to the GPS crypto key server

	refresh the list of keys in the GPS Crypto Key DBA HMI

}





The section of code listed below will be removed in the getFields function in the Manual Entry class, as the key type will not be based on the short title:



GST_ManualEntry::getFields(....)

{

	.

	.

	.

	determine key type based on the short title

	if key type is unknown, display error message, return error

	.

	.

	.

}





API Test Tool and Other Test Software

	Since there are no new or modified public interfaces as a result of this SOR, no API test tool is necessary.



Updated SLOC

Description�New�Mod�Other��Implement GFI GPS crypto key type algorithm�50�20���Add warning for unknown keys�20����Additional processing in manual entry HMI to determine key type based on key value�50�20���Total SLOC�120�40���

�Interface Description

	There are no changes to the interface description as a result of this SOR.

�Unit Test Plan and Procedures

Introduction

	This section contains the unit test plan and procedures for SOR 97-12, GPS Cryptographic Key Type Identification.  The critical units tested are the GPS crypto key type algorithm, processing for keys transferred from the AN/CYZ-10, and processing for manually entered keys.  Since there are no new or modified public interfaces, no API testing is necessary.

	Note that in the control flow(s) column in the test plan, CF1-1..3 refers to control flow 1, flow paths 1 through 3.  CF1 refers to � REF _Ref391537259 \* MERGEFORMAT �Figure 2.3-1�, CF2 refers to � REF _Ref391537131 \* MERGEFORMAT �Figure 2.3-2�, and CF3 refers to � REF _Ref391543884 \* MERGEFORMAT �Figure 2.3-3� and � REF _Ref391544650 \* MERGEFORMAT �Figure 2.3-4�.

Test Environment

	The equipment required for the unit test plan include an AN/CYZ-10 data transfer device loaded with weekly, yearly, and unknown keys and connected to the serial port of a TAMPS workstation.  The GPS crypto key server application should be running.  The TAMPS workstation should be configured to run the GPS Crypto Key DBA application from a shell window.  Test key values with known key types (weekly, yearly, or unknown) will be required for manual entry.  The unit test requires a TAMPS development environment with access to a debugger.  Only one tester is required to perform the unit test plan.  The tester should be familiar with the GPS Crypto Key DBA application and a debugger.

	There are no additional disk space, RAM, or database requirements beyond the normal TAMPS development environment.

Coverage

	100% of all new and modified code will be tested.  Pure Coverage will be used, and the Pure Coverage output will be attached to the Unit Test Report.  The exit criteria for the unit test plan are that 100% of all new and modified code have been tested and have satisfied the pass/fail criteria.

Critical Unit and API Testing

GPS Crypto Key Type Algorithm

	While this test case tests the GPS crypto key type algorithm through manually entered keys, it also covers the GPS crypto key type algorithm for keys transferred from the AN/CYZ-10 as the same algorithm function is linked into both the GPS Crypto Key DBA application and the GPS Crypto Key Server.



Test Step�Control Flow(s)�Inputs�Expected Results�Pass/Fail Criteria��1��Using the debugger, bring up GPS Crypto Key DBA application�Debugger started and executable loaded�Debugger window brought up without errors��2��Set a breakpoint in the function containing the GPS crypto key type algorithm�Breakpoint set�Message in debugger window indicating breakpoint set without errors��3�CF3-1�Run the GPS Crypto Key DBA application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�application brought up��4�CF3-2..3�Select “Edit->Manual entry...”�manual entry callback activated�“Manual Entry” HMI displayed��5�CF3-4�Enter a weekly key value in the “Key Value” text field�key value is shown in “Key Value” text field as a “*” for each hex digit�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��6�CF3-5�Enter the same key value in the “Key Value (repeat)” text field�key value is shown in “Key Value” text field as a “*” for each hex digit�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��7�CF3-6..9�Click on any other text field besides “Key Value (repeat)”�callback activated, key type algorithm called with key value as parameter�debugger stops at breakpoint in the function containing the GPS crypto key type algorithm��8��Print the key value in the debugger window�key value printed�key value the same as entered in the Manual Entry HMI��9�CF3-10..11, CF2-5..6�Step through the algorithm, after key type is determined print out the key type�key type determined to be weekly�flow of control through algorithm correct, key type determined to be weekly��10�CF3-12..13�Enter “continue” in the debugger command window�application continues�“Key Type” radio box updated to indicate a weekly key��11�CF3-14..15 (for unk. keys)�Repeat steps 5-10 for other weekly keys, yearly keys, and unknown keys��output should correspond to key type entered, an error message dialog should appear for unknown keys��12��Enter a key value of 32 characters in the “Key Value” field�key value is shown as astericks�a string of astericks is shown with one asterick for each character entered��13�CF3-8�Enter a different key value in the “Key Value” repeat field�key value is shown as astericks�When the cursor is moved from the “repeat” box to the next data entry field, an error message is issued stating that the key values are not the same.��14��Enter a key value of less than 32 characters in the “Key Value” field�key value is shown as astericks�a string of astericks is shown with one asterick for each character entered��15�CF3-9�Enter a key value of less than or equal to 32 characters in the “Key Value” repeat field.�key value is shown as astericks�When the cursor is moved from the “repeat” box to the next data entry field, an error message is issued stating that the key values are an incorrect length.��

Processing for Keys Transferred From AN/CYZ-10



Note:  The GPS Crypto Key Server functionality is not tested in detail as there no additional modifications beyond the algorithm tested in the previous test case.



Preparation: Re-compile the GPS Crypto Key Server  with the debug flag and make sure the server application is owned by “root” and that the sticky bit is set.  Start the server as root under debugger control.  The debugger will be used to print key values and key types.



Test Step�Control Flow(s)�Inputs�Expected Results�Pass/Fail Criteria��1�CF1-1�From a shell window, start the GPS Crypto Key DBA application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�application brought up��2�CF1-2..3�Select “File->Load DTD keys...”�load keys callback activated�“Load Keys from DTD” HMI appears��3��Prepare AN/CYZ-10 for transmit of a weekly key�key selected for transmit�AN/CYZ-10 ready to transmit key, “Send” selection appears on LCD display��4�CF1-4�Press the OK or Apply button in the “Load Keys from DTD” HMI�OK/Apply callback activated�“Loading Keys from DTD...” message appears in HMI��5�CF1-4..8, CF2-1..13, CF2-15..16�Select “Send” on the AN/CYZ-10�key transmitted to server, key type algorithm determines key to be a weekly key, key stored in database�Use the debugger to view key type and key value.  Key is listed in GPS Crypto Key DBA HMI key list.��6�CF1-9, CF2-14 for unk. keys�Repeat steps 2-5 for other weekly keys, yearly keys, and unknown keys��shell window output and GPS Crypto Key DBA HMI should correspond to key value and key type entered, an error message dialog should appear for unknown keys and the key should not be listed in the GPS Crypto Key DBA HMI��

Manual Entry Processing

	Preparation:  Modify the GPS crypto key type algorithm to print the key value and key type to the shell window.  Re-compile the GPS Crypto Key Server and make sure the server application is owned by “root” and that the sticky bit is set.  Start the server.



Test Step�Control Flow(s)�Inputs�Expected Results�Pass/Fail Criteria��1��Using the debugger, bring up GPS Crypto Key DBA application�Debugger started and executable loaded�Debugger window brought up without errors��2��Set breakpoints in function containing GPS crypto key type algorithm, in entryFocusCB callback, and in the helpCB callback�Breakpoint set�Message in debugger window indicating breakpoint set without errors��3�CF3-1�Run the GPS Crypto Key DBA application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�application brought up��4�CF3-2..3�Select “Edit->Manual entry...”�manual entry callback activated�“Manual Entry” HMI displayed��5�CF3-4�Enter a weekly key value in the “Key Value” text field�key value is shown in “Key Value” text field as a “*” for each hex digit�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��6�CF3-5�Enter the same key value in the “Key Value (repeat)” text field�key value is shown in “Key Value” text field as a “*” for each hex digit�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��7�CF3-6..7�Click on any other text field besides “Key Value (repeat)”�callback activated, key type algorithm called with key value as parameter�debugger stops at breakpoint in the entryFocusCB callback��8�CF3-8..10�Step through code until key algorithm is called�correct flow of control through functions�flow of control through functions occurs as expected��9�CF3-11..13�Enter “continue” in debugger input window�GPS Crypto Key DBA continues execution�application continues��10��Click in “Key Value (repeat)” text field�input focus is in “Key Value (repeat)” text field�input focus is in “Key Value (repeat)” text field��11�CF3-7..10�Select “Help” button�helpCB activated, key type algorithm called with key value as parameter�debugger stops at breakpoint in the helpCB callback��12�CF3-8..10�Step through code until key algorithm is called�correct flow of control through functions�flow of control through functions occurs as expected��13��Enter valid information in all other text fields in Manual Entry HMI except the “Key Value” and “Key Value (repeat)” text fields (already filled in)�information entered displayed in HMI�information entered displayed in HMI��14�CF3-16..25�Press OK in Manual Entry HMI�OK/Apply callback activated, error checking performed on information entered, GPS crypto key type algorithm executed on key value, key sent to server to be stored in the database�key appears in GPS Crypto Key DBA HMI key list without errors, use the debugger to view key type and key value in server��15�CF3-14..15, CF3-26 for unk. keys�Repeat steps 4-14 for other weekly keys, yearly keys, and unknown keys; for unknown keys re-enter key values at step 10��output should correspond to key type entered, an error message dialog should appear for unknown keys and the key should not be listed in the GPS Crypto Key DBA HMI��

�Function Test Plan and Procedures

Introduction

	This section contains the function test plan and procedures for SOR 97-12, GPS Cryptographic Key Type Identification.  The first section in the function test plan is for testing of the transfer of GPS crypto keys from the AN/CYZ-10, while the second section is for test of manually entered GPS crypto keys.

	Since there are no new or modified public interfaces, no API software or MPM modification is necessary.

	Note that in the control flow(s) column in the test plan, CF1-1..3 refers to control flow 1, flow paths 1 through 3.  CF1 refers to � REF _Ref391537259 \* MERGEFORMAT �Figure 2.3-1�, CF2 refers to � REF _Ref391537131 \* MERGEFORMAT �Figure 2.3-2�, and CF3 refers to � REF _Ref391543884 \* MERGEFORMAT �Figure 2.3-3� and � REF _Ref391544650 \* MERGEFORMAT �Figure 2.3-4�.

Test Environment

	The equipment required for the function test plan include an AN/CYZ-10 data transfer device loaded with weekly, yearly, and unknown keys and connected to the serial port of a TAMPS workstation.  The GPS crypto key server application should be running.  The TAMPS workstation should be configured to run the GPS Crypto Key DBA application.  Test key values with known key types (weekly, yearly, or unknown) will be required for manual entry.  The function test may be done in either a TAMPS development environment or a test environment.  Only one person is required to perform the function test plan.

	There are no additional disk space, RAM, or database requirements beyond the operational TAMPS environment.

	The problem tracking process will involve recording the result of each step of each test case according to the pass/fail criteria listed for each step.  Any failures will require the code to be fixed and the test case performed again.

	The exit criteria for the function test plan are that 100% of all new and modified code have been tested and have satisfied the pass/fail criteria, and that there are no run-time errors detected by Purify.

Function Test Plan

Transferring Keys from the AN/CYZ-10

Weekly Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF1-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF1-2, CF1-3�Select “File->Load DTD keys...”�“Load Keys from DTD” HMI displayed�100�dialog is created��3���Prepare AN/CYZ-10 for transmit of a weekly key�����4��CF1-4, CF2-2�Select OK or Apply�“Loading keys from DTD...” message displayed�100�message dialog is created��5�1.4.3a-c�CF1-4..8, CF2-3..13, CF2-15..16�Select send from AN/CYZ-10�Key transferred from AN/CYZ-10, stored in GPS crypto key database with a key type of weekly�90�keys are listed in GPS Crypto Key DBA HMI as “CVw” type��Yearly Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF1-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF1-2, CF1-3�Select “File->Load DTD keys...”�“Load Keys from DTD” HMI displayed�100�dialog is created��3���Prepare AN/CYZ-10 for transmit of 2 yearly keys�����4��CF1-4, CF2-2�Select OK or Apply�“Loading keys from DTD...” message displayed�100�message dialog is created��5�1.4.3d-f�CF1-4..8, CF2-3..13, CF2-15..16�Select send from AN/CYZ-10�Key transferred from AN/CYZ-10, stored in GPS crypto key database with a key type of yearly�90�keys are listed in GPS Crypto Key DBA HMI as “GUV” type��Unknown Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF1-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF1-2, CF1-3�Select “File->Load DTD keys...”�“Load Keys from DTD” HMI displayed�100�dialog is created��3���Prepare AN/CYZ-10 for transmit of an unknown key�����4��CF1-4, CF2-2�Select OK or Apply�“Loading keys from DTD...” message displayed�100�message dialog is created��5�1.4.4b, 1.4.4d�CF1-4..9, CF2-3..10, CF14-16�Select send from AN/CYZ-10�Key transferred from AN/CYZ-10, determined to be an unknown key, not saved in database�90�error message indicating that the key type is unknown and that the key will not be stored in the database displayed, key not listed in key list in GPS Crypto Key DBA HMI��Manually Entered Keys

Weekly Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF3-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF3-2..3�Select “Edit->Manual entry...”�“Manual Entry” HMI displayed�100�dialog is created, “Zulu” label exists after “Start Date” and “End Date” text fields, “Key Type” radio box is not editable��3��CF3-4�Enter weekly key value of length 32 hex digits in the “Key Value” text field�Key value is shown in “Key Value” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��4��CF3-5�Enter the same key value in the “Key Value (repeat)” text field�Key value is shown in “Key Value (repeat)” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value (repeat)” text field with one “*” for each entered hex digit��5�1.4.2d�CF3-6..13�Move input focus from “Key Value (repeat)” text field to any other text field or to the “Help” button�Key type of entered key determined to be weekly�90�“Key type” radio box updated to indicate a weekly key��6�1.4.2a-c�CF3-16..20, CF3-23..25�Select OK or Apply�Key type determined to be weekly, key stored in database�75�key is listed in GPS Crypto Key DBA HMI as “CVw” type��Yearly Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF3-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF3-2..3�Select “Edit->Manual entry...”�“Manual Entry” HMI displayed�100�dialog is created��3��CF3-4�Enter yearly key value of length 32 hex digits into “Key Value” text field�Key value is shown in “Key Value” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��4��CF3-5�Enter the same key value into the “Key Value (repeat)” text field�Key value is shown in “Key Value (repeat)” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value (repeat)” text field with one “*” for each entered hex digit��5�1.4.2h�CF3-6..13�Move input focus from “Key Value (repeat)” text field to any other text field or to the “Help” button�Key type of entered key determined to be yearly�90�“Key type” radio box updated to indicate a yearly key��6�1.4.2e-g�CF3-16..20, CF3-23..25�Select OK or Apply�Key type determined to be yearly, key stored in database�75�key is listed in GPS Crypto Key DBA HMI as “GUV” type��

Unknown Keys

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF3-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF3-2..3�Select “Edit->Manual entry...”�“Manual Entry” HMI displayed�100�dialog is created��3��CF3-4�Enter unknown key value of length 32 hex digits into “Key Value” text field�Key value is shown in “Key Value” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��4��CF3-5�Enter the same key value into the “Key Value (repeat)” text field�Key value is shown in “Key Value (repeat)” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value (repeat)” text field with one “*” for each entered hex digit��5�1.4.4a, 1.4.4c�CF3-6..15, CF3-3�Move input focus from “Key Value (repeat)” text field to any other text field or to the “Help” button�Key type of entered key determined to be unknown�90�Error message displayed indicating the key type is unknown, “Key Value” and “Key Value (repeat)” fields cleared, key not listed in key list in GPS Crypto Key DBA HMI��

Keys of Incorrect Length

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF3-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF3-2..3�Select “Edit->Manual entry...”�“Manual Entry” HMI displayed�100�dialog is created��3��CF3-4�Enter key value of length 2 hex digits into “Key Value” text field�Key value is shown in “Key Value” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��4��CF3-5�Enter the same key value into the “Key Value (repeat)” text field�Key value is shown in “Key Value (repeat)” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value (repeat)” text field with one “*” for each entered hex digit��5��CF3-6..9, CF3-15, CF3-3�Move input focus from “Key Value (repeat)” text field to any other text field or to the “Help” button�Key value determined to be of incorrect length�67�Error message displayed indicating the key value length is incorrect��



Different Keys Entered in “Key Value” and “Key Value (repeat)” text fields

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1��CF3-1�Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.�100�application brought up��2��CF3-2..3�Select “Edit->Manual entry...”�“Manual Entry” HMI displayed�100�dialog is created��3��CF3-4�Enter unknown key value of length 32 hex digits into “Key Value” text field�Key value is shown in “Key Value” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value” text field with one “*” for each entered hex digit��4��CF3-5�Enter a different key value of length 32 hex digits into the “Key Value (repeat)” text field�Key value is shown in “Key Value (repeat)” text field as a “*” for each hex digit�100�a string of “*” is shown in the “Key Value (repeat)” text field with one “*” for each entered hex digit��5��CF3-6..8, CF3-15, CF3-3�Move input focus from “Key Value (repeat)” text field to any other text field or to the “Help” button�Key values determined to be different�67�Error message displayed indicating the key values entered are different��Modify HMI

Test Step�SOR SOF(s)�Control Flow(s)�Inputs�Expected Results�% of flowpath tested�Pass/Fail Criteria��1���Bring up GPS Crypto Key DBA Application�GPS Crypto Key DBA is instantiated.  Keys in the database are displayed.��application brought up��2�1.4.2ij, 1.4.3gh��Double-click on a key in the key list�Modify HMI callback activated��Modify Keys HMI is brought up, “Zulu” label created after “Start Date” and “End Date” text fields, “Key Type” radio box is set to correct key type and not editable��

Sections of the Control Flow Diagrams Not Covered by the Function Test Plan

	Some sections of the control flow diagrams are not covered by this function test plan, the reasons they have not been included will be explained here.  All control flow paths not described in this section are 100% covered in the test plan.

	The following portions of the control flow diagram are not included in the function test plan as they already exist in the TAMPS system and will not be modified:  CF2-1, the “yes” branch coming out of CF2-11, the “yes” branch coming out of CF2-12, the “yes” branch coming out of CF3-6, the “no” branch coming out of CF3-18, and the “no” branch coming out of CF3-19.

	The SOFs relating to the Modify Keys (1.4.2ij, 1.4.3gh) are also existing functionality.  A test case has been created for the Modify Keys HMI to test the addition of the “Zulu” label after the “Start Date” and “End Date” text fields.

Additional Tools

	Additional tools which will be used in the test process include Purify and Pure Coverage.  Purify will detect run-time errors and Pure Coverage will determine the test coverage.

� Unit Test Report

Unit Test Results



The unit test for SOR 96-71 took approximately 4 hours to complete 32 out of 32 steps (100%). There were no problems found during unit test.





SOR/STR Name:�SOR 97-12 GPS Crypto Key��Limitations to testing (Environment, test data, etc.):�N/A��Percent of Code Executed during Unit Test:�100%��Major Logic Paths not tested (List the numbered step of the control flow or PDL that corresponds to untested path):�N/A��Major Logic Paths failing test (List the numbered step of the control flow or PDL that failed unit test is traced to):�N/A��Number of DTRs found during testing:�0��Number of DTRs corrected:�0��Number of Outstanding DTRs:�0��Summary of Unit Test Results

Unit Test Corrected DTR Results



Number of Corrected DTRs tested:�N/A��Number of Corrected DTRs passing test:�N/A��Results from retest of corrected DTRs





�

Functional Test Report



Formal functional testing has not been performed on SOR 96-71 due to an issue that came up during preliminary testing.  The issue involves the identification of maintenance vs. 

operational keys.  Functional testing will be completed once this issue has been resolved.







SOR/STR Name:���Limitations to testing (Environment, test data, etc.):���Number of Function tests Performed:���Number of Function Tests Failed:���Number of DTRs recorded:���Number of DTRs outstanding:���Summary of Function Tests

Failed Function Test�Description of the Problem�Correction Approach������Summary of Outstanding DTRs







Failed API/MPM Test�Description of the Problem�Correction Approach������Summary of Outstanding DTRs found during API Testing

Individual function test results and a list of all DTRs found during function test are attached.
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