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�

�Functional Tests

Entry Criteria:

	 Succesful completion of all MPLAN unit tests



Results of all test will be noted in Functional Test Log.  Unccessful test will be repeated after correction of deficiency causing failure.



Exit Criteria:

	Successful completion of all MPLAN functional tests, and completion of Functional Test Log.

Connect to TAMPS LAN

Entry Criteria:

Successful completion of Unit Testing.



Environment:

Platform:	A Low Side machine, pre-configured to standalone mode.

A High Side machine, pre-configured to standalone mode.

A server machine which is also configured as an NIS+ root master.

Physical network connection between clients and server.



Software:	TAMPS 6.2

Populated Database



Personnel:	The System Administrators for the Client and the Server.



Exit Criteria:

Successful completion of all functional tests annotated in the Functional Test Log

Preconnection Warning HMI

Test:�Display the Pre Connection Warning HMI.��Input:�From WSE menu, selects System Admin->MPLAN Client Administrator-> Connect to MPLAN.��Expected Results:�The Pre Connection Warning HMI is displayed at the center of the screen.��

Test:�Test the Pre Connection Warning HMIís Cancel Button��Input:�Push the Cancel button.��Expected Results:�The Pre Connection Warning HMI is removed from the screen.��

Test:�Test the Pre Connection Warning HMIís Help Button��Input:�Repeat test 1 to bring up the Pre Connection Warning HMI again, then press the Help button.��Expected Results:�The Help window is displayed.��

Test:�Test the Pre Connection Warning HMIís OK Button��Input:�Press Close on the Help window, then press the OK button.��Expected Results:�The Pre Connection Warning HMI is removed from the screen.

The Connect to MPLAN HMI is displayed at the center of the screen.��Connect to MPLAN HMI

Test:�Test mandatory fields checking on the Connect to MPLAN HMI.��Input:�Observe the OK button, without any information entered, this button is desensitized.

Enter the following items and observe the OK button everytime an item is entered

Enter the Workstationís Hostname.

Enter the Workstationís IP Address

Enter the Serverís Hostname

Enter the Serverís IP Address��Expected Results:�The OK button remains desensitized until the last mandatory item (the Serverís IP Address) is entered.  When all of the above items are entered, the OK button is then sensitized.��

Test:�Test error checking on the Connect to MPLAN HMI.��Input:�Enter 0.0.0.1 (or any bogus IP Address) on the IP Address field for local machine.

Fills out the rest of the mandatory information including:  Local Hostname, Server Hostname and IP Address.  Press OK.��Expected Results:�An error message is displayed, stating that the clientís IP Address is invalid.��

Test:�Test High Side Configuration.��Input:�Select High Side Configuration toggle button��Expected Results:�The Additional Information frame become desensitized.��

Test:�Test High Side Connection.  This test is to be performed on a standalone High Side machine. Part I, before reboot��Input:�Bring up the Connect to MPLAN HMI by selecting Sys Admin->MPLAN Client Administrator->Connect to MPLAN.  

Press OK on the Pre Connection Warning HMI.  

Fill out the Connect to MPLAN HMI.  

Enter the Local Workstationís IP Address and Hostname.  

Enter the Serverís IP Address and Hostname.  

Select the High Side Configuration toggle button.

Press OK on the Connect to MPLAN HMI.��Expected Results:�The system reboots.��

Test:�Test High Side Connection.  Part II, after reboot��Input:�Log back into the local machine.

Issue queries for serverís specific data (TBD by Chuck) for MIDB, NID, DAFIF, and TAMPS

Bring up the LAN Admin tool on the server by selecting Sys Admin->MPLAN Server Administration.

Select View->Connected Client.��Expected Results:�Receive serverís specific data as the results of queries.

An entry containing the IP Address and Hostname of the local machine should be displayed on the LAN Admin window.��

Test:�Test Low Side Connection.  This test is to be performed on a standalone Low Side machine. The client machine should be setup to have about five local users.  Set up the local machine so that at least two users will conflict with the users on the server.  Part I, before reboot��Input:�Bring up the Connect to MPLAN HMI by selecting Sys Admin->MPLAN Client Administrator->Connect to MPLAN.  

Press OK on the Pre Connection Warning HMI.  

Fill out the Connect to MPLAN HMI.  

Enter the Local Workstationís IP Address and Hostname.  

Enter the Serverís IP Address and Hostname.  

Select the High Side Configuration toggle button.

Press OK on the Connect to MPLAN HMI.��Expected Results:�The system reboots.��

Test:�Test Low Side Connection.  Part II, after reboot��Input:�Log back into the local machine.��Expected Results:�Conflicting User Accounts HMI is displayed��Conflicting User Accounts HMI

Test:�Test the Conflicting User Accounts HMIís Help Button.��Input:�The Conflicting User Accounts should displayed the conflicting users.  

The Valid User Accounts window should consist of the list of existing users on the server.

Press the Help button��Expected Results:�The help window is displayed.��

Test:�Test the Conflicting User Accounts HMIís Cancel button��Input:�Press Close on the Help window, then press the Cancel button��Expected Results:�The Conflicting User Accounts Warning window is displayed, warning the user that all user names remaining on the Conflicting Users List will be removed.��

Test:�Test Rename User��Input:�Select a user name from the Conflicting User Accounts list and observe the user name appears on the Change text field.

Highlight the username on the change text field, and overwrite the text with another user name on the Conflicting User Account list.  Observe the new user name on the Conflicting User Accounts list gets highlighted.

Type a new user name that does not currently exist on the Conflicting User Account List��Expected Results:�The highlighted user name on the Conflicting User Accounts (or the user name on the Change text field) is removed from this list.

The user name on the To text field is added to the list of Valid User Accounts.��

Test:�Test the Conflicting User Accounts HMIís OK button��Input:�Press OK on the Conflicting User Accounts window.��Expected Results:�The Conflicting User Accounts Warning window is displayed, warning the user that all user names remaining on the Conflicting Users List will be removed.��Conflicting User Accounts Warning HMI

Test:�Test the Conflicting User Accounts Warning HMIís Help Button.��Input:�Press the Help button��Expected Results:�The help window is displayed.��

Test:�Test the Conflicting User Accounts Warning HMIís OK Button.��Input:�Press the OK button��Expected Results:�The Conflicting User Accounts Warning HMI is removed and the Conflicting User Accounts HMI is removed as well.��User login from the low side

Test:�Test to see if a user on a connected Low Side client can log in for the first time.��Input:�Log out of TAMPS.

Log back in as a user��Expected Results:�A User NIS+ Initialization HMI is displayed prompting for the login passwd.��

Test:�Test the User NIS+ Initialization HMI��Input:�Type in the login password, then press OK.  The user should be authenticated.��Expected Results:�The User NIS+ Initialization window is removed.

The user should be able to see all of the cross mounted /home directory, /maps directory, and /tamps/dynamics/mpm directory on the server.��Test:�Test user access to the server��Input:�None��Expected Results:�The user should be able to see all of the cross mounted /home directory, /maps directory, and /tamps/dynamics/mpm directory on the server.

The user should be able to query serverís specific data (TBD by Chuck)��Disconnect from LAN

Test:�Display the Disconnect fom MPLAN HMI.��Input:�From WSE menu, selects System Admin->MPLAN Client Administrator-> Disconnect from MPLAN.��Expected Results:�The Disconnect from MPLAN HMI is displayed at the center of the screen.��

Test:�Test the Disconnect from MPLAN HMIís Cancel Button��Input:�Push the Cancel button.��Expected Results:�The Disconnect from MPLAN HMI is removed from the screen.��

Test:�Test the Disconnect from MPLAN HMIís Help Button��Input:�Repeat test 1 to bring up the Disconnect from MPLAN HMI again, then press the Help button.��Expected Results:�The Help window is displayed.��

Test:�Test the Disconnect from MPLAN HMIís OK Button and the Update Local Database option.��Input:�Select the Update Local Databases toggle button, then press OK on the Disconnect from MPLAN window.

Once the Update Database from MPLAN Server HMI is displayed, press Cancel on this window.  This window has its own functional test.��Expected Results:�The Disconnect from MPLAN HMI is removed from the screen.

The Update Database from MPLAN Server HMI is displayed at the center of the screen.��

Test:�Test the High Side Disconnection, Part I before Rebooting��Input:�On the connected High Side Client, do Test 1 to Display Disconnect from MPLAN.

Press  the OK button on the Disconnect from MPLAN window.��Expected Results:�The system will reboot.  ��

Test:�Test the High Side Disconnection, Part II after Rebooting��Input:�Log back into the High Side local machine.

Do query of serverís specific data (TBD by Chuck).

Log into the server as the server SA, bring up the LAN Admin tool window and select View->Connected Client.��Expected Results:�Data will not be found for these queries for serverís specific data.  

The local IP Address and Hostname is removed from the list of Connected Client on the LAN Admin tool window.��

Test:�Test the Low Side Disconnection, Part I before Rebooting��Input:�On the connected Low Side Client, do Test 1 to Display Disconnect from MPLAN.

Press  the OK button on the Disconnect from MPLAN window.��Expected Results:�The system will reboot.  ��

Test:�Test the Low Side Disconnection, Part II after Rebooting��Input:�Log back into the Low Side local machine as a user.

Do query of serverís specific data (TBD by Chuck).

Log into the server as the server SA, bring up the LAN Admin tool window and select View->Connected Client.

Log out of the local machine.  Log back in as a renamed user.

Check the server to see if the home directories of those users on the disconnected hosts have been removed and the /clients/<local hostname> directory has been removed.��Expected Results:�Data will not be found for these queries for serverís specific data.  

The local IP Address and Hostname is removed from the list of Connected Client on the LAN Admin tool window. 

The renamed user should be able to log into the local machine.

The /clients/<local hostname> directory does not exist.��Set Default Printer HMI

Entry Criteria:

	Successful completion of Unit Testing



Environment:

Platform:	Two print servers.



Software:	TAMPS 6.2



Personnel:	The System Administrators for the Client and the Server.



Exit Criteria:

Successful completion of all functional tests annotated in the Functional Test Log



Test:�Display the Set Default Printer HMI.��Input:�From WSE menu, selects System Admin->MPLAN Client Administrator-> Configure MPLAN Printer->Set Default Printer.��Expected Results:�The Set Default Printer HMI is displayed at the center of the screen.��

Test:�Test the Set Default Printer Warning HMI.��Input:�Without selecting any printer name on the list, press Set Default.��Expected Results:�A Select Printer Warning HMI is display on the screen.��

Test:�Test the Set Default Printer HMIís Selection list��Input:�Select a printer from the list��Expected Results:�The selected printer name appears on the Default Printer text fields.��

Test:�Test the Set Default Printer HMIís Selection list and Set Default Button��Input:�Select a printer from the list, then press the Set Default Button.��Expected Results:�The selected printer name appears on the Default Printer text fields.��

Test:�Test printing to the default printer.��Input:�Open an xterm and issue an lp command to print any ASCII file.��Expected Results:�The file is printing at the default printer.��

Test:�Test deleting the printer queue from the Set Default Printer HMI��Input:�Select the printer queue to be deleted, press Delete.��Expected Results:�An message notifying the user that the printer queue to the selected printer has been deleted.��

Test:�Test deleted printer queue.��Input:�Open an xterm and issue an lp command to print any ASCII file to the deleted printer queue.��Expected Results:�Warning message that the printer is unavailable, and thereís no print out.��Network Printer Designation HMI

Test:�Display Network Printer Designation HMI.��Input:�From the WSE menu, select System Admin->MPLAN Client Administration->Configure MPLAN Printer->Designate Network Printer.��Expected Results:�The Network Printer Designation HMI is displayed.��

Test:�Unset a network printer.��Input:�From the Client machine that was set as the print server, deselect the network printing toggle button, press OK.

To check if the client machine is still the print server, bring up the Set Default Printer HMI by selecting System Admin->MPLAN Client Administration->Configure MPLAN Printer->Set Default Printer.��Expected Results:�The Client machine is no longer a print server.  The Available Network Printers list on the Set Default Printer HMI does not show the local host as a print server.��

Test:�Set a network printer.��Input:�From the same client machine, bring up  the Network Printer Designation HMI, select the Allow Network Printing option, then press OK.

To check if the client machine is now the print server, bring up the Set Default Printer HMI by selecting System Admin->MPLAN Client Administration->Configure MPLAN Printer->Set Default Printer.��Expected Results:�The Client machine is now a print server.  The Available Network Printers list on the Set Default Printer HMI show the local host as a print server.���LAN Administration Test

Entry Criteria:

Successful completion of Unit Testing.

The MPLAN Administration HMI operational environment requirements to perform functional testing shall consist of:

Environment

Platform:     	MPLAN Server suite with workstation connected

Software:      	TAMPS 6.2 Core 

	Populated Database

Personnel:     	TAMPS Tester

The MPLAN Administration HMI will provide the tools necessary for the Server Administrator to maintain the MPLAN.  The following are the functional tests necessary to ensure proper operation of the MPLAN Administration HMI.

Results of all testing will be annotated in a Functional Test Log.  Failed test will be repeated after the deficiency has been corrected.



Exit Criteria:

Successful completion of all functional tests annotated in the Functional Test Log.

MPLAN Administration HMI Activation

Test:�Display MPLAN Administration HMI.��Input:�Select System Admin -> MPLAN Server Administration ��Expected Results:�Verify:

MPLAN Administration HMI is displayed

Connected Client Information is displayed in the HMI listing

View->Client Amplification option grayed

Edit->Add option grayed

Edit-> Modify option grayed��File Selection Options

Test:�File->Print option selection  ��Input:�Select File Pulldown from menu bar

Select Print option

	Verify TAMPS Core Output Data Window HMI is displayed

Select Portrait Orientation

Select desired Fonts

Select desired Destination

Select Classification

Select OK�� Expected Results:�Verify:

Listing of Connected Client information generated.��Test:�File->Exit option selection  ��Input:�Select File Pulldown from menu bar

Select Exit option�� Expected Results:�Verify:

MPLAN Administration HMI is unmanaged and is no longer displayed���View Selection Options

Test:�View->Client Amplification option selection  ��Input:�Select item from Connected Client listing

Select View pulldown from menu bar

Select Client Amplification�� Expected Results:�Verify:

Amplify Information HMI is displayed.

Hostname matches item selected

IP Address matches item selected

Location matches item selected

Status matches item selected

Squadron/Unit has valid entry (optional) 

Point of Contact has valid entry (optional)

Phone/Extension has valid entry (optional)

Idle Time if status is shutdown or unknown

Select Close

	Verify:

	HMI is unmanaged and is no longer displayed

	Control returned to MPLAN Administration HMI

View->Client Amplification option grayed��

Test:�View->Available IP Addresses option selection  ��Input:�Select View Pulldown from menu bar

Select Available IP Addresses option�� Expected Results:�Verify:

HMI list updates with Available IP Addresses

	Note: HMI list may contain blank display if no IP Addresses were entered

Location column blank

Hostname column blank

Status column blank

IP Address column contains entered IP Addresses

View->Client Amplification option grayed 

Edit->Modify option grayed

Edit->Delete option grayed

Select an Available IP Address

	Verify:

	Edit->Modify option ungrayed

	Edit->Delete option ungrayed

Select Edit->Add

	Verify:

	IP Address Editor is displayed

Enter 111 . 111 . 111 . 111 in the corresponding octets of the IP Address: textfield 

Hostname textfield grayed

Select OK

 	Verify:

	111 . 111 . 111 . 111 is displayed in IP Address column 

Select 111 . 111 . 111 . 111 list option

Select Edit->Modify

	Verify:

	IP Address Editor is displayed

111 . 111 . 111 . 111 is displayed in the corresponding octets of the IP Address: textfield 

Enter TEST in Hostname textfield

Select OK

 	Verify:

	111 . 111 . 111 . 111 in IP Address has been removed

Select View->NIS+ Host Table Entries 

	Verify:

TEST 111 . 111 . 111 . 111 is displayed in HMI list

Select TEST 111 . 111 . 111 . 111 list option

Select Edit->Delete

	Verify:

	TEST 111 . 111 . 111 . 111 removed from the HMI list

Select View->Available IP Addresses option

Select Edit->Add

	Verify:

	IP Address Editor is displayed

Enter 111 . 111 . 111 . 111 in the corresponding octets of the IP Address: textfield 

Hostname textfield grayed

Select OK

 	Verify:

		111 . 111 . 111 . 111 is displayed in IP Address column

Select TEST 111 . 111 . 111 . 111 list option

Select Edit->Delete

	Verify:

	TEST 111 . 111 . 111 . 111 removed from the HMI list��

Test:�View->Connected Clients option selection  ��Input:�Select View Pulldown from menu bar

Select Connected Clients option�� Expected Results:�Verify:

HMI list updates with Connected Clients information

	Note: HMI list may contain blank display if no Clients are connected

Location column contains connected clients location

Hostname column contains connected clients Hostname

IP Address column contains connected clients IP Addresses

Status column contains connected clients operational status 

Edit->Add option grayed

Edit->Modify option grayed

Select a connected client with status = Active

Select Edit->Remove option

	Verify:

	Warning HMI displayed

Selected Item has a status = Active.  The Client machine cannot be removed.

Select OK

Select a connected client with status = Shutdown (if applicable)

Select Edit->Remove option

	Verify:

	Warning HMI displayed

Selected Item has a status = Shutdown.  The Client machine is still registered with the LAN Daemon and may only be powered down.  Please investigate before removing this entry from the LAN Daemon database.  Proceed with deletion ?

Select Cancel

Select a connected client with status = Unknown (if applicable)

Select Edit->Remove option

	Verify:

	Warning HMI displayed

Selected Item has a status = Unknown.  The Client machine is not registered with the LAN Daemon but may still be connected. Please investigate before removing this entry from the LAN Daemon database.  Proceed with deletion ?

Select Cancel��

Test:�View->NIS+ Host Table Entries option selection  ��Input:�Select View Pulldown from menu bar

Select NIS+ Host Table Entries option�� Expected Results:�Verify:

HMI list updates with NIS+ Host Table Entries

Location column blank

Status column blank

View->Client Amplification option grayed

Select Edit->Add

	Verify:

	IP Address Editor is displayed

Enter 111 . 111 . 111 . 111 in the corresponding octets of the IP Address: textfield 

Enter TEST in Hostname textfield

Select Ok

 	Verify:

	TEST is displayed in Hostname column 

	111 . 111 . 111 . 111 is displayed in IP Address column next to 	Hostname

Select TEST 111 . 111 . 111 . 111 list option

Select Edit->Modify

	Verify:

	IP Address Editor is displayed

111 . 111 . 111 . 111 in the corresponding octets of the IP Address: textfield 

TEST in Hostname textfield

Enter 222 . 222 . 222 . 222 in the corresponding octets of the IP Address: textfield 

Enter TSET in Hostname textfield

Select Ok

 	Verify:

	TSET replaced TEST in Hostname column 

	222 . 222 . 222 . 222 replaced 111 . 111 . 111 . 111 in IP Address 	column next to 	Hostname

Select TSET 222 . 222 . 222 . 222 list option

Select Edit->Delete

	Verify:

	TSET 222 . 222 . 222 . 222 removed from the HMI list���Environmental Update

Test:�Display Weather timeout value��Input:�Select Weather Admin pulldown from LAN Administration��Expected Results:�The Weather Admin HMI will be displayed with current timeout value��

Test:�Display AOI’s with  Weather designator value��Input:�Select Weather Admin pulldown from LAN Administration��Expected Results:�The Weather Admin HMI will be displayed with current AOI’s and the appropriate Weather designator��

Test:�Change Weather timeout value and leave HMI up.��Input:�Select Weather Admin pulldown from LAN Administration

	Enter valid new timeout value ( 0 > Value < 2400)

	Select Apply��Expected Results:�Timeout value will be updated in the HMI and in the TAMPS_CATALOG datatable.

	(Use TAMPS_CATALOG report to verify an entry for Weather where expiration date = new timeout value)

	HMI will remain up.��

Test:�Change Weather timeout value and remove HMI.��Input:�Select Weather Admin pulldown from LAN Administration

	Enter valid new timeout value ( 0 > Value < 2400)

	Select OK��Expected Results:�Timeout value will be updated in the HMI and in the TAMPS_CATALOG datatable.

	(Use TAMPS_CATALOG report to verify an entry for Weather where expiration date = new timeout value)

		HMI will be removed.��

Test:�Attempt to Change Weather timeout to an invalid time��Input:�Select Weather Admin pulldown from LAN Administration

	Enter invalid new timeout value (value < 0 or blank or value > 2400 or non-numeric value)

	Select OK/Apply��Expected Results:�A warning will be posted “Invalid timeout value”.  Control returned to HMI with invalid value removed.��

Test:�Add a designator flag to a Weather AOI and leave HMI up.��Input:�Select Weather Admin pulldown from LAN Administration

	Select an AOI without designator flag

	Select Set/Clear��Expected Results:�Designator flag will be removed in the HMI and in the TAMPS_OPAREA datatable.

	HMI will remain up��

Test:�Clear a designator flag to a Weather AOI and leave HMI up.��Input:�Select Weather Admin pulldown from LAN Administration

	Select an AOI with designator flag

	Select Set/Clear��Expected Results:�Designator flag will be set in the HMI and in the TAMPS_OPAREA datatable.

	HMI will remain up.��

Test:�Close the Weather Admin HMI.��Input:�Select Weather Admin pulldown from LAN Administration

	Select Cancel��Expected Results:�HMI will be removed.��

Test:�Display Weather Admin Help window.��Input:�Select Weather Admin pulldown from LAN Administration

Select Help��Expected Results:�Metacard Help window will be displayed��Mission Transfer

Mission Data Transfer HMI Functional Test Plan

Entry Criteria:

Successful completion of Unit Testing.

The Mission Data Transfer HMI will operate differently based upon the platform initiating the transfer of Mission Data.  There are three types of platform currently configured for the MPLAN:

Low Side Workstation

MPLAN Server

High Side Workstation

This unit test will cover all mission data transfer scenarios using a Low Side Client, the MPLAN Server and a High Side Client configuration.  Results of all testing will be annotated in a Functional Test Log.  Failed test will be repeated after the deficiency has been corrected.



Exit Criteria:

Successful completion of all functional tests annotated in the Functional Test Log.

Low Side Workstation

Environment

Platform:     	Low side client connected to MPLAN

Software:      	TAMPS 6.2 MPM environment

	Populated Database

Personnel:     	TAMPS User

Test Material:	3.5 Inch Floppy Disk

	8 mm Tape

	Functional Test Log

	MPM User created Test Mission

Mission Data Transfer HMI Activation

Test:�Display Mission Data Transfer HMI.��Input:�Activate an MPM with planned Missions

Select File ->Import/Export Mission . . . from MPM menu bar��Expected Results:�Verify:

Mission Data Transfer HMI is displayed 

Source Option Menu displays None 

Destination Option Menu displays None

Open Destination Option Menu

	Verify all remaining options grayed

All External Media Options are grayed��Workstation To Media Transfer 8mm

Test:�Export Mission data from Workstation to 8mm Media��Input:�Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select Ok�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI���Workstation To Media Transfer 3.5 Inch FD

Test:�Export Mission data from Workstation to 3.5 Inch Floppy Media��Input:�Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select Ok�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��8mm Media to Workstation Transfer

Test:�Import Mission data from 8mm Media to Workstation��Input:�Select File-> Delete Missions . . .

Select Test Mission

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation and Server option ungrayed

Select Workstation from Destination Option Menu

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select Ok�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select workstation from Source Option Menu

Verify mission transferred is displayed in HMI list��3.5 Inch FD Media to Workstation Transfer

Test:�Import Mission data from 8mm Media to Workstation��Input:�Select File-> Delete Missions . . .

Select Test Mission

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation and Server option ungrayed

Select Workstation from Destination Option Menu

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI

Select workstation from Source Option Menu

Verify mission transferred is displayed in HMI list���Workstation to Server Transfer

Test:�Export Mission data from Workstation to Server��Input:�Select File-> Import/Export Missions . . .

Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Server from Destination Option Menu

Select User created Test Mission from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Server.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list��Server To 8 mm Media Transfer

Test:�Export Mission data from the MPLAN Server to Media��Input:�Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media, Workstation and Other options are ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI���Server To 3.5 FD Media Transfer

Test:�Export Mission data from the MPLAN Server to Media��Input:�Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media, Workstation and  Other options are ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��8 mm Media to Server Transfer

Test:�Import Mission data from Media to MPLAN Server ��Input:�On MPLAN Server:

Select File-> Delete Missions . . .

Select Test Mission (If applicable)

Delete Test Mission

On Low Side Workstation 

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation and Server option ungrayed

Select Server from Destination Option Menu

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list��3.5 Inch FD Media to Server Transfer

Test:�Import Mission data from Media to MPLAN Server ��Input:�On MPLAN Server:

Select File-> Delete Missions . . .

Select Test Mission (If applicable)

Delete Test Mission

On Low Side Workstation 

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation and Server option ungrayed

Select Server from Destination Option Menu

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list���Server to Workstation Transfer

Test:�Export Mission data from Server to Workstation��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media, Workstation and Other options are ungrayed

Select Workstation from Destination Option Menu

Select User created Test Mission from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Workstation.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI 

Select Workstation  from the Source Option Menu

Verify mission transferred is displayed in HMI list��Server to Other Transfer

Test:�Export Mission data from Server to Other (High Side)��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media, Workstation and Other options are ungrayed

Select Other from Destination Option Menu

Select User created Test Mission from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Other.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Open shell script on High Side Client

cd to /tamps/dynamic/data/mpm_tmp

Verify directory exists with /mpmName_pid

Open Mission.dat file

Search for filename with the following format 

	MissionNameMissionId.mpmName��Other to Server Transfer

The following test must have had a Workstation to Server transfer of a mission initiated from a High Side Client.

Test:�Import Mission data from Other (High Side) to the MPLAN Server��Input:�Select File-> Import/Export Missions . . .

Select Other from Source Option Menu

	Verify listing of transfer directories is displayed in MHI list

Open destination Option Menu

	Verify Server option ungrayed

Select Server from Destination Option Menu

Select transfer directory from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Server.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list���MPLAN Server 

Environment

Platform:     	MPLAN Server with Low/High Side Workstation connections

Software:      	TAMPS 6.2 MPM environment

	Populated Database

Personnel:     	TAMPS User

Test Material:	3.5 Inch Floppy Disk

	8 mm Tape

	Functional Test Log

	MPM User created Test Mission

Server To 8 mm Media Transfer

Test:�Export Mission data from the MPLAN Server to 8 mm Media��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Other option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��Server To 3.5 FD Media Transfer

Test:�Export Mission data from the MPLAN Server to 3.5 Inch Floppy Disk Media��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Other option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��8 mm Media to Server Transfer

Test:�Import Mission data from 8 mm Media to MPLAN Server ��Input:�Select File-> Delete Missions . . .

Select Test Mission (If applicable)

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Server option ungrayed

Select Server from Destination Option Menu

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list���3.5 Inch FD Media to Server Transfer

Test:�Import Mission data from 3.5 Inch Floppy Disk Media to MPLAN Server ��Input:�Select File-> Delete Missions . . .

Select Test Mission (If applicable)

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Server option ungrayed

Select Server from Destination Option Menu

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list��Server to Other Transfer

Test:�Export Mission data from Server to Other (High Side)��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify MPLAN Server Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Other options ungrayed

Select Other from Destination Option Menu

Select User created Test Mission from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Other.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Open shell script on High Side Client

Cd to /tamps/dynamic/data/mpm_tmp

Verify directory exists with /mpmName_pid

Open Mission.dat file

Search for filename with the following format 

	MissionNameMissionId.mpmName��Other to Server Transfer

The following test must have had a Workstation to Server transfer of a mission initiated from a High Side Client.

Test:�Import Mission data from Other (High Side) to the MPLAN Server��Input:�Select File-> Import/Export Missions . . .

Select Other from Source Option Menu

	Verify listing of transfer directories is displayed in MHI list

Open destination Option Menu

	Verify Server option ungrayed

Select Server from Destination Option Menu

Select transfer directory from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Server.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Select Server from the Source Option Menu

Verify mission transferred is displayed in HMI list���High Side Workstation

Environment

Platform:     	High Side Workstation connected to MPLAN Server

Software:      	TAMPS 6.2 MPM environment

	Populated Database

Personnel:     	TAMPS User

Test Material:	3.5 Inch Floppy Disk

	8 mm Tape

	Functional Test Log

	MPM User created Test Mission

Workstation To Media Transfer 8mm

Test:�Export Mission data from Workstation to 8mm Media��Input:�Select File-> Import/Export Missions . . .

Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select Ok�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��Workstation To Media Transfer 3.5 Inch FD

Test:�Export Mission data from Workstation to 3.5 Inch Floppy Media��Input:�Select File-> Import/Export Missions . . .

Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Media from Destination Option Menu

 	Verify External Device Option ungrayed

Select User created Test Mission from HMI list

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to tape device.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI��8mm Media to Workstation Transfer

Test:�Import Mission data from 8mm Media to Workstation��Input:�Select File-> Delete Missions . . .

Select Test Mission

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation option ungrayed

Select Workstation from Destination Option Menu

Insert 8 mm Tape into External 8 mm Tape Device

Select 8 mm Tape option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI 

Select workstation from Source Option Menu

Verify mission transferred is displayed in HMI list��3.5 Inch FD Media to Workstation Transfer

Test:�Import Mission data from 8mm Media to Workstation��Input:�Select File-> Delete Missions . . .

Select Test Mission

Delete Test Mission

Select File-> Import/Export Missions . . .

Select Media from Source Option Menu

	Verify External Device Options ungrayed 

Open destination Option Menu

	Verify Workstation option ungrayed

Select Workstation from Destination Option Menu

Insert 3.5 Inch floppy diskette into 3.5 Inch floppy drive

Select 3 Ω Inch Disk option

Select OK�� Expected Results:�Verify completion by posting of message box:

	Mission Import: MSN_Name mission imported.

Verify control returns to Mission Data Transfer HMI

Select workstation from Source Option Menu

Verify mission transferred is displayed in HMI list���Workstation to Server Transfer

Test:�Export Mission data from Workstation to Server��Input:�Select File-> Import/Export Missions . . .

Select Workstation from Source Option Menu

	Verify Workstation Missions displayed in MHI list

Open destination Option Menu

	Verify Media and Server option ungrayed

Select Server from Destination Option Menu

Select User created Test Mission from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Other.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI

Open shell script on Server

Cd to /tamps/dynamic/data/mpm_tmp

Verify directory exists with /mpmName_pid

Open Mission.dat file

Search for filename with the following format 

	MissionNameMissionId.mpmName��Server to Workstation Transfer

Test:�Import Mission data from Server to Workstation��Input:�Select File-> Import/Export Missions . . .

Select Server from Source Option Menu

	Verify listing of transfer directories is displayed in HMI list

Open destination Option Menu

	Verify Workstation option ungrayed

Select Workstation from Destination Option Menu

Select transfer directory from HMI list

Select OK�� Expected Results:�Verify Message Box displayed:

	Writing data to Workstation.  Please Wait . . .

Verify completion of transfer by control returning back to the Mission Data Transfer HMI 

Open shell script on High Side Client 

Cd to /tamps/dynamic/data/mpm_tmp

Verify directory exists with /mpmName_pid

Open Mission.dat file

Search for filename with the following format 

	MissionNameMissionId.mpmName��Database Update

Database Maintenance Functional Test

Sections 2.8.6 through 2.8.X.x test the components of MPLAN software concerned with the Database Maintenance function to be developed by Lockheed (Refer to SOF 1.3.7, CS0630.0200  and CT2755).  These components provide the network client DBA with the capability to Update the perishable databases from the MPLAN Server dump files.  It also provides the MPLAN Server DBA with the capability to backup the Server perishable databases.  TRW, the developer/modifier of the Dump/Restore  --8 mm. tape function is responsible for the functional testing of this Database Maintenance component.



Assumption: the tester is familiarized with the use of the DATABASE ADMINISTRATION main HMI.

Test:�Display  Database Maintenance Tear-off Menu for a user on the server.��Input:�Select Database Maintenance from the DBA Main Utilities Pulldown menu.��Expected Results:�Displaying of the Database Maintenance Tear-off Menu. The menu has three options: Dump/Restore - 8 mm Tape, Update Database from Server and Update Database Dumps.  This last option is sensitized (enabled) .��

Test:�Display  Database Maintenance Tear-off Menu for a standalone user.��Input:�Select Database Maintenance from the DBA Main Utilities Pulldown menu.��Expected Results:�Displaying of the Database Maintenance Tear-off Menu. The menu has three options: Dump/Restore - 8 mm Tape, Update Database from Server and Update Database Dumps.  This last option is desensitized (disabled).��

Test:�Displaying the Update Database from TAMPS Server HMI for the first time.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.��Expected Results:�Displaying of the Update Database from TAMPS Server HMI with the following settings:

	Update Now:  off

	Update Later:  off

	MIDB:  off  and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  000 minutes

	OK, Apply, Cancel, Help buttons enabled��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select MIDB .

Select Update Now .

Select Cancel.

Select Update Database from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Now Warning window. ��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  on and  estimated MIDB dump time displayed

	NID:  off and  estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated MIDB dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

The client machine gets rebooted to single user mode.

The MIDB database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select NID .

Select Update Now .

Select Cancel.

Select Update Database from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Now Warning window. ��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and  estimated MIDB dump time displayed

	NID:  on and  estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated NID dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

The client machine gets rebooted to single user mode.

The NID database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Update Now .

Select Cancel.

Select Update Database from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Now Warning window. ��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and  estimated MIDB dump time displayed

	NID:  off and  estimated NID dump time displayed

	DAFIF/GPS:  on  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated DAFIF/GPS dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

The client machine gets rebooted to single user mode.

The DAFIF/GPS database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select Mission Related .

Select Update Now .

Select Cancel.

Select Update Database from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Now Warning window. ��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and  estimated MIDB dump time displayed

	NID:  off and  estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  on

	Estimated Download Time:  estimated Mission Related dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

The client machine gets rebooted to single user mode.

The Mission Related data gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Update Later .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK.

Select NID.

Select OK from the Database Update Later Warning window.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off   and estimated MIDB dump time displayed

	NID:  on  and estimated NID dump time displayed

	DAFIF/GPS:  on  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated DAFIF/GPS dump time + estimated NID dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select MIDB.

Select Update Later .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK.

Select OK from the Database Update Later Warning window.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  on   and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated MIDB dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select NID.

Select Update Later .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK.

Select OK from the Database Update Later Warning window.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off   and estimated MIDB dump time displayed

	NID:  on  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated NID dump time dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Update Later .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK.

Select OK from the Database Update Later Warning window.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off   and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  on  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated DAFIF/GPS dump time dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìlow sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select Mission Related Data

Select Update Later .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK.

Select OK from the Database Update Later Warning window.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off   and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  on

	Estimated Download Time:  estimated Mission Related dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select MIDB .

Select Update Now .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Warning window��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  on and estimated MIDB dump time displayed

	NID:  off and estimated NID dump time displayed

	DAFIF/GPS:  off and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated MIDB dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

MIDB server dump is FTPíd to client.  (Verify it).

The client machine gets rebooted to single user mode.

The MIDB database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).

MIDB dump file on the client is deleted.

(Verify that MIDB dump file is deleted.).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select NID .

Select Update Now .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Warning window��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and estimated MIDB dump time displayed

	NID:  on and estimated NID dump time displayed

	DAFIF/GPS:  off and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated NID dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

NID server dump is FTPíd to client.  (Verify it).

The client machine gets rebooted to single user mode.

The NID database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).

NID dump file on the client is deleted.

(Verify that NID dump file is deleted.).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Update Now .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Warning window��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and estimated MIDB dump time displayed

	NID:  off and estimated NID dump time displayed

	DAFIF/GPS:  on and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time:  estimated DAFIF/GPS dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

DAFIF server dump is FTPíd to client.  (Verify it).

The client machine gets rebooted to single user mode.

The DAFIF/GPS database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).

DAFIF/GPS dump file on the client is deleted.

(Verify that DAFIF/GPS dump file is deleted.).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating now case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select Mission Related Data .

Select Update Now .

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select OK/Apply.

Select OK from the Database Update Warning window��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  on

	Update Later:  off

	MIDB:  off and estimated MIDB dump time displayed

	NID:  off and estimated NID dump time displayed

	DAFIF/GPS:  off and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  on

	Estimated Download Time:  estimated Mission Related dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Now Warning window is displayed warning user about required reboot.

Mission Related Data server dump is FTPíd to client.  (Verify it).

The client machine gets rebooted to single user mode.

The Mission Related Data database gets updated.

The database catalog gets updated with the date of the new update.

The client machine gets rebooted to multi-user mode.

(Verify that the database catalog gets updated).

Mission Related Data dump file on the client is deleted.

(Verify that Mission Related Data dump file is deleted.).��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select MIDB .

Select Update Later.

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select Apply.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  on  and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time: estimated MIDB dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select NID .

Select Update Later.

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select Apply.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off  and estimated MIDB dump time displayed

	NID:  on  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time: estimated NID dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Update Later.

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select Apply.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off  and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  on  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  off

	Estimated Download Time: estimated DAFIF/GPS dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server HMI after the first time for a ìhigh sideî user and updating later case.��Input:�Select Update Database  from Server from the Database Maintenance Tear-off menu.

Select Mission Related Data .

Select Update Later.

Select Cancel.

Select Update Database  from Server from the Database Maintenance Tear-off menu 

Select Apply.��Expected Results:�The Update Database from TAMPS Server HMI is displayed with the following settings:

	Update Now:  off

	Update Later:  on

	MIDB:  off  and estimated MIDB dump time displayed

	NID:  off  and estimated NID dump time displayed

	DAFIF/GPS:  off  and estimated DAFIF/GPS dump time displayed

	Mission Related Data:  on

	Estimated Download Time: estimated Mission Related dump time minutes

	OK, Apply, Cancel, Help buttons enabled

The Database Update Later Warning window is displayed telling user how to restore the database later.

The Database Update Later Warning window is removed.

The Update Database from TAMPS Server HMI is removed.��

Test:�Displaying the Update Database from TAMPS Server Help window.��Input:�Select Update Database from TAMPS Server  from the Database Maintenance Tear-off menu.

Select Help.��Expected Results:�Displaying of the metacard Help window informing the user on the Update Database from TAMPS Server function.

The Update Database from TAMPS Server HMI remains up.��

Test:�Closing the Update Database from TAMPS Server HMI. Help window��Input:�Select Update Database from TAMPS Server from the Database Maintenance Tear-off menu.

Select Help.

Select Cancel from Help window.��Expected Results:�Removing of the metacard Help window.

The Update Database from TAMPS Server HMI remains up.��

Test:�Displaying the Update Database Dumps HMI for the first time.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.��Expected Results:�Displaying of the Update Database Dumps HMI with the following settings:

	MIDB:  off 

	NID:  off 

	DAFIF/GPS:  

	OK, Apply, Cancel, Help buttons enabled��

Test:�Displaying the Update Database Dumps HMI after the first time but removing HMI.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select MIDB .

Select Cancel.

Select Update Database Dumps from Server from the Database Maintenance Tear-off menu 

Select OK.��Expected Results:�The Update Database Dumps HMI is displayed with the following settings:

	MIDB:  on

	NID:  off

	DAFIF/GPS:  off  and desensitized

	OK, Apply, Cancel, Help buttons enabled

The MIDB database gets updated.

Removing of the Update Database Dumps HMI.

 (Go to an X-Terminal and verify that the MIDB database dump has been updated with the Server MIDB database  version, i.e., a new MIDB database backup file should have been created ).��

Test:�Displaying the Update Database Dumps HMI after the first time but removing HMI.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select NID .

Select Cancel.

Select Update Database Dumps from Server from the Database Maintenance Tear-off menu 

Select OK.��Expected Results:�The Update Database Dumps HMI is displayed with the following settings:

	MIDB:  off

	NID:  on

	DAFIF/GPS:  off  and desensitized

	OK, Apply, Cancel, Help buttons enabled

The NID database gets updated.

Removing of the Update Database Dumps HMI.

 (Go to an X-Terminal and verify that the NID database dump has been updated with the Server NID database  version, i.e., a new NID database backup file should have been created ).��

Test:�Displaying the Update Database Dumps HMI after the first time but removing HMI.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select DAFIF/GPS .

Select Cancel.

Select Update Database Dumps from Server from the Database Maintenance Tear-off menu 

Select OK.��Expected Results:�The Update Database Dumps HMI is displayed with the following settings:

	MIDB:  off

	NID:  off

	DAFIF/GPS:  on  and desensitized

	OK, Apply, Cancel, Help buttons enabled

The DAFIF/GPS database gets updated.

Removing of the Update Database Dumps HMI.

 (Go to an X-Terminal and verify that the DAFIF/GPS database dump has been updated with the Server DAFIF/GPS database  version, i.e., a new DAFIF/GPS database backup file should have been created ).��

Test:�Displaying the Update Database Dumps HMI after the first time but leave HMI up.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select NID.

Select DAFIF/GPS.

Select Cancel.

Select Update Database Dumps from Server from the Database Maintenance Tear-off menu 

Select Apply.��Expected Results:�The Update Database Dumps HMI is displayed with the following settings:

	MIDB:  off

	NID:  on

	DAFIF/GPS:  on  and desensitized

	OK, Apply, Cancel, Help buttons enabled

The NID database gets updated.

The DAFIF/GPS database gets updated.

The Update Database Dumps HMI remains up.

 (Go to an X-Terminal and verify that the NID and DAFIF/GPS databases dumps have been updated with the Server NID and DAFIF/GPS databases versions, i.e., new  NID and DAFIF/GPS databases backup files should have been created ).��

Test:�Displaying Update Database Dumps Help window.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select Help.��Expected Results:�Displaying of the metacard Help window informing the user on the Update database Dumps function.

The Update Database Dumps HMI remains up.��

�Closing the Update Database Dumps HMI.��Input:�Select Update Database Dumps from the Database Maintenance Tear-off menu.

Select Help.

Select Cancel from Help window.��Expected Results:�Removing of the metacard Help window.

The Update Database Dumps HMI remains up.��JMCIS Interface

Test:�Verify that the Server Startup checks for JMCIS Rep Server Active and displays a warning if it is not.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured but NOT running)

Shutdown the Server

Re-start the Server��Expected Results:�After system has completed startup, a warning will be posted “JMCIS Rep Server Not running”.��

Test:�Verify that the Server Startup checks for JMCIS Rep Server Active.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

(This test should be run after the previous test once JMCIS Rep Server is started)

Shutdown the Server

Re-start the Server��Expected Results:�Server startup will proceed with NO warning concerning JMCIS Rep Server.��

Test:�Verify that modifications to the JMCIS MIDB_GMI database are replicated to the TAMPS Master and Subset MIDB_GMI databases when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, modify an existing MIDB_GMI record in one of the tables listed in Table X.X in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The TAMPS Master MIDB_GMI record should reflect the modifications made to the JMCIS MIDB_GMI record.��

Test:�Verify that additions to the JMCIS MIDB_GMI database are replicated to the TAMPS Master and Subset MIDB_GMI databases when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, add a new record to the MIDB_GMI in one of the tables listed in Table X.X in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The TAMPS Master and Subset MIDB_GMI databases should contain the new record added to the JMCIS MIDB_GMI record.��

Test:�Verify that deletions to the JMCIS MIDB_GMI database are replicated to the TAMPS Master and Subset MIDB_GMI databases when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, delete an existing MIDB_GMI record in one of the tables listed in Table X.X in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The record should not be in either the TAMPS Master or Subset MIDB_GMI databases.��

Test:�Verify that modifications to JMCIS MIDB_GMI datatables that are maintained in the TAMPS Master MIDB_GMI database ONLY (Not the Subset) are replicated to the TAMPS Master when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, modify an existing MIDB_GMI record in one of the tables listed in Table TBD in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The TAMPS Master MIDB_GMI record should reflect the modifications made to the JMCIS MIDB_GMI record.

The TAMPS Subset MIDB_GMI record should NOT reflect the modifications made to the JMCIS MIDB_GMI record.��

Test:�Verify that additions to JMCIS MIDB_GMI datatables that are maintained in the TAMPS Master MIDB_GMI database ONLY (Not the Subset) are replicated to the TAMPS Master when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, add a new record to the MIDB_GMI in one of the tables listed in Table TBD in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The TAMPS Master MIDB_GMI should contain the new record added to the JMCIS MIDB_GMI database.

The TAMPS Subset MIDB_GMI should NOT contain the new record added to the JMCIS MIDB_GMI database.��

Test:�Verify that deletions to JMCIS MIDB_GMI datatables that are maintained in the TAMPS Master MIDB_GMI database ONLY (Not the Subset) are replicated to the TAMPS Master when in a TAMPS/JMCIS configuration.��Input:�(Requres a fully configured TAMPS Server connected to a JMCIS 3.0 system with Rep Server configured and running)

On the JMCIS 3.0 system, delete an existing MIDB_GMI record in one of the tables listed in Table TBD in the MPLAN Design Notebook.

On the TAMPS server, Query the Master and Subset MIDB_GMI databases for the selected record.��Expected Results:�The TAMPS Master MIDB_GMI should reflect the deletion made to the JMCIS MIDB_GMI record.

The TAMPS Subset MIDB_GMI record should NOT reflect the deletion made to the JMCIS MIDB_GMI record.��

Test:�Reconfigure MPLAN Server to not interface with JMCIS Replication��Input:�Select Disconnect from JMCIS from LAN Admin pulldown

	Select OK from warning widget.��Expected Results:�The JMCIS_STAT will be changed to UNAVAIL.

Rep Subscriptions against JMCIS Rep Server will be dropped.

Rep Defs against TAMPS Master MIDB will be loaded.

Rep Subscriptions against TAMPS Master Rep Defs loaded.��Data Products

Test:�Display CIB data available on the Server.��Input:�Select Load from DBA menu

Select CIB

Select Network

Select OK��Expected Results:�The coverage tool will be displayed with CIB data available on server.��

Test:�Display ADRG data available on the Server.��Input:�Select Load from DBA menu

Select ADRG

	Select Network

Select OK��Expected Results:�The coverage tool will be displayed with ADRG data available on server.��

Test:�Display DTED data available on the Server��Input:�Select Load from DBA menu

	Select DTED

	Select Network

	Select OK��Expected Results:�The coverage tool will be displayed with DTED data available on server.��

Test:�Load CIB data from server to client��Input:�Select Load from DBA menu

Select CIB

	Select Network

	Select OK

	Hook a displayed CIB item

	Select OK��Expected Results:�The selected CIB imagery will be transferred from the server to the client and loaded into the designated map directory and the catalogupdated��

Test:�Load ADRG data from server to client��Input:�Select Load from DBA menu

	Select ADRG

	Select Network

	Select OK

	Hook a displayed ADRG item

	Select OK��Expected Results:�The selected ADRG imagery will be transferred from the server to the client and loaded into the designated map directory and the catalog updated.��

Test:�Load DTED data from server to client��Input:�Select Load from DBA menu

Select DTED

Select Network

Select OK

Hook a displayed DTED item

Select OK��Expected Results:�The selected DTED imagery will be transferred from the server to the client and loaded into the designated map directory and the catalog updated��System Interface

Test:�View new Modify_MIDB and Network_DBA privileges are available for assignment.��Input:�Select User Administration

Select Assign Privileges��Expected Results:�Modify_MIDB and Network_DBA privileges should be available for assignment��

Test:�Verify selected options are not available to a user who does not have Modify_MIDB privileges��Input:�(Workstation must have been previously “Connected to the LAN”)

Select Update from the DBA menu Bar

Select Archive/Restore from DBA menu Bar��Expected Results:�MIDB should be greyed out.��

Test:�Verify selected options are not available to a user who does not have Network DBA privileges��Input:�(Workstation must have been previously “Connected to the LAN”)

1) Select System Admin from the WSE menu Bar

2)  Select Utilities from DBA menu Bar

3)  Select Utilities->Database Maintenance from the DBA menu Bar��Expected Results:�1)  LAN Admin will be greyed out.

     LAN Printer will be greyed out

2) Archive Restore will be greyed out.

     Data Removal will be greyed out

3)  Update Database from Server will be greyed out

     Update Database Dumps will be greyed out

��

Test:�Verify that selected options are available once Modify_MIDB privilege is assigned.��Input:�(Workstation must have been previously “Connected to the LAN”)

Select Update from the DBA menu Bar

Select Archive/Restore from DBA menu Bar��Expected Results:�MIDB should be available.��

Test:�Verify that selected options are available once Modify_MIDB privilege is assigned.��Input:�(Workstation must have been previously “Connected to the LAN”)

1) Select System Admin from the WSE menu Bar

2)  Select Utilities from DBA menu Bar

3)  Select Utilities->Database Maintenance from the DBA menu Bar��Expected Results:�1)  LAN Admin will be available.

     LAN Printer will be available

2) Archive Restore will be available.

     Data Removal will be available

3)  Update Database from Server will be available

     Update Database Dumps will be available

��

Test:�Verify that when a new user is added, an account is created in the tamps database.��Input:�Select User Administration from WSE menu Bar

Add User��Expected Results:�An account for the new user will be added to the “tamps” database.

(To verify, via an xterm, isql -Utamps -Ptamps60

????

��

Test:�Verify that when a new user is added, an account is created in the NID database.��Input:�Select User Administration from WSE menu Bar

Add User��Expected Results:�An account for the new user will be added to the “NID” database.

(To verify, via an xterm, isql -Utamps -Ptamps60

????

��

Test:�Verify that when a new user is added, an account is created in the DAFIF_GPS database.��Input:�Select User Administration from WSE menu Bar

Add User��Expected Results:�An account for the new user will be added to the “DAFIF_GPS” database.

(To verify, via an xterm, isql -Utamps -Ptamps60

????

��

Test:�Verify that when a new user is added, an account is created in the TAMPS_SPROCS database.��Input:�Select User Administration from WSE menu Bar

Add User��Expected Results:�An account for the new user will be added to the “TAMPS_SPROCS” database.

(To verify, via an xterm, isql -Utamps -Ptamps60

????

��
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