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1 Introduction 
 
The Joint Mission Planning System will be capable of both stand-alone and client / server 
operation.  When deployed in the client / server application, a server must be utilized to 
provide the functionality required by the Mission Planners.  Some of the duties that the 
JMPS Server will be perform will be to maintain user accounts, store mission data, and 
provide links to key mission parameters.  In order to allow the JMPS server to perform 
these tasks, it must be configured properly.  This document will outline the required steps 
to configure the JMPS Server. 
 

2 Purpose 
 
The sole purpose of this document is to establish a set of governing procedures that will 
be followed to load the JMPS Servers.  By the establishment of these procedures the 
intent is to eliminate undocumented installations.  In this manner all sites will have a 
“known” configuration and the guesswork, frustration and waste of time trying to debug 
problems on differently configured setups will be eliminated. 

3 Quick Review of JMPS Server Configuration 
 
There are three possible JMPS server configurations.  The one that is delivered to a 
particular site is determined by the Program Office and upon the requirements of site.  
There are 3 configurations for the JMPS Server suite, they include JMPS Enterprise, 
JMPS Enterprise Lite and JMPS PICO Server.  Below are diagrams that show each of 
these configurations for reference. 
 
 

 
 

Figure 1 - JMPS Enterprise Server Configuration 
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Figure 2 - JMPS Enterprise Lite Server Configuration 

 
 

 
 
 

Figure 3 - JMPS PICO Server 
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4 Necessary Items 
 
The following hardware and software items are necessary to accomplish the JMPS server 
configuration. 

4.1 Hardware 
 

4.1.1 JMPS Enterprise Server Hardware 
 
The following list of hardware will be required for the JMPS Enterprise Server suite: 
 

1. 2 - Compaq DL380 Servers, configured for JMPS Enterprise operations. 
2. 2 - Ciprico NetArray 1100 Units 
3. 2- Brocade SilkWorm 3200 Fibre Switches 
4. 4 - SCSI hard drives, 2 for each server. Size should be 73 GB. 
5. 2 - TAC 4 racks 
6. 2 - Flat Panel displays 
7. 2 - Rack Mount Key Boards 
8. 2 - UPS Units 
9. IOMGEA NAS 
10. Fibre Channel Cables (specifics TBD) 
11. Ethernet Cables (specifics TBD) 
12. OTHERS TBD 

 
 

4.1.2 JMPS Enterprise Lite Server Hardware 
 
The following list of hardware will be required for the JMPS Enterprise Lite Server suite: 
 

1. 1 - Compaq DL380 Server, configured for JMPS Enterprise Lite operations. 
2. 1 - Ciprico NetArray 1100 Unit 
3. 2- Brocade SilkWorm 3200 Fibre Switches 
4. 4 - SCSI hard drives, 2 for the single server, Size should be 73 GB. 
5. 1 - Rack TBD 
6. 1 - Flat Panel display 
7. 1 - Rack Mount Key Board 
8. 1 - UPS Unit 
9. IOMEGA NAS 
10. Fibre Channel Cables (specifics TBD) 
11. Ethernet Cables (specifics TBD) 
12. OTHERS TBD 
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4.1.3 JMPS PICO Server Hardware 
 
The following list of hardware will be required for the JMPS PICO Server suite: 
 

1. 1 - Compaq DL380 Server, configured for JMPS PICO operations. 
2. 5 - SCSI hard drives, Size should be 73 GB. 
3. 1 - Rack, Deployment Case, TBD 
4. 1 - Display TBD 
5. 1 - Key Board TBD 
6. 1 - UPS Unit TBD 
7. IOMEGA NAS 
8. Ethernet Cables (specifics TBD) 
9. OTHERS TBD 

 
 

4.2 Software and Licenses 
 
The following software and licenses will be required for each of the server 
configurations. 
 

4.2.1 Software 
 
1. Microsoft Windows 2000 Advanced Server 
2. Microsoft SQL 2000 Server 
3. Microsoft Office 2000 (non SP or SP1, or SP2) 
4. COE 4205 Kernel Software and JMPS required COE Segments 
5. Veritas Cluster Server 2.0 (only for JMPS Enterprise) 
6. Veritas Volume Manager 3.1 (only for JMPS Enterprise and JMPS Enterprise 

Lite) 
7. Veritas Cluster Server 2.0 Enterprise Agent for SQL 2000 (only for JMPS 

Enterprise) 
8. Veritas Backup Exec 9.0 
9. JAVA SDK (freeware, see www.sun.TBD) 
10. WinZip 8.1 (or later version) 
11. OTHERS TBD… 
 

4.2.2 Licenses 
 
The System Administrator responsible for the setup, configuration and maintenance of 
the JMPS Server must ensure that the following valid licenses are in place for the site and 
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that the number of licenses is never exceeded. The individual sites will be held 
responsible for license violations. 
 

1. Microsoft Windows 2000 Advanced Server Client Licenses 
2. Microsoft Office 2000 Licenses 
3. Microsoft SQL 2000 Server Client Licenses 
4. Veritas Cluster Node Licenses 
5. Veritas Cluster Server 2.0 Enterprise Agent for SQL 2000 Licenses 
6. Veritas Volume Manager Licenses 
7. Veritas Backup Exec Licenses 
8. WinZip License 
9. OTHERS TBD 

 
 

5 JMPS Server Wiring Diagrams 
 
The basic interconnection diagram for each of the JMPS Server Configurations is 
presented in the below. 
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Internal 10/100 Ethernet Port 1 (RJ-45)

COMPAQ DL380 SERVER

Internal 10/100 Ethernet Port 2 (RJ-45)

Compaq NC7131 PCI Gigabyte Ethernet Card (Bottom PCI Slot, RJ-45)

Compaq FCA - 2101 PCI Fibre Channel Host Bus Adapter # 1 (Top PCI Slot, LC)

Compaq FCA - 2101 PCI Fibre Channel Host Bus Adapter # 2 (Middle PCI Slot, LC)

Monitor (Standard 15 pin)

Keyboard (PS2)

Mouse (PS2)

Power Supply Input # 1 (120 Volt AC)

Power Supply Input # 2 (120 Volt AC)

CIPRICO NETARRAY 1100
RAID

Controller A, SC

Controller B, SC

Ethernet Port Controller A, RJ-45

Ethernet Port Controller B, RJ-45

Serial Port Controller A, 9 Pin

Serial Port Controller B, 9 Pin

Power Supply Input # 1 (120 Volt AC)

Power Supply Input # 2 (120 Volt AC)

All Network Adapters are
available for connection to  the

External Network

NOTE
DO NOT CONNECT SECOND FIBRE

CHANNEL PATH TO RAID UNTIL
FURTHER NOTICE. ONLY CONNECT

FIBRE CHANNEL DATA PATH
BETWEEN FIRST FIBRE CHANNEL
CARD IN SERVER TO CONROLLER

A ON THE SINGLE CIPRICO
NETARRAY 1100.

Rack Flat Panel Display or Standard Table Top Display

Rack Intergrated Track Ball or Standard Tabletop Mouse

Rack Pullout Keyboard or Standard Tabletop Keyboard

Rack or Standard UPS Power

N/C

N/C

N/C

N/C

UPS Data
Connection

Serial Port 1
(9 Pin)

Figure 5 - JMPS Enterprise Lite Server Wiring Diagram 
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Internal 10/100 Ethernet Port 1 (RJ-45)
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Internal 10/100 Ethernet Port 2 (RJ-45)

Compaq NC7131 PCI Gigabyte Ethernet Card (Bottom PCI Slot, RJ-45)
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Compaq FCA - 2101 PCI Fibre Channel Host Bus Adapter # 2 (Middle PCI Slot, LC)

Monitor (Standard 15 pin)

Keyboard (PS2)

Mouse (PS2)
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Power Supply Input # 2 (120 Volt AC)

All Network Adapters are
available for connection to  the
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Rack Flat Panel Display or Standard Tabletop Display

Rack Intergrated Track Ball or Standard Tabletop Mouse

Rack Pullout Keyboard or Standard Tabletop Keyboard

Rack or Standard UPS Power

N/C

N/C

Serial Port  1
9 Pin

UPS Data
Connection

Figure 6 - JMPS PICO Server Wiring Diagram 
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6 Loading Procedures for JMPS Servers 
 
The following sub-sections outline the various steps to configure the JMPS Server no 
matter which configuration is being setup. Some sections will not have to be executed for 
some of the configurations. It is essential that all instructions and notes be carefully 
reviewed before being executed. 

6.1 Procedure: Basic Load of the Windows 2000 Advanced Operating System 
 

NOTE 
 

The Microsoft Windows 2000 Advanced Server media 
and the Compaq Smart Array5i driver will be required 
to execute this procedure. The Windows 2000 Advanced 
server software disk will ship with the server. However 
it will be necessary to build a Smart Array 5i driver 
diskette, a floppy disk will be required for this 
procedure. 
 

NOTE 
 
Instructions below assume possession of Compaq 
media. HP bought Compaq and has since updated the 
SmartStart for Servers CD. New HP media is very 
different from the Compaq media. In order to follow 
the procedure described below, the same driver for 
Compaq SmartArray 5i controller has to be 
downloaded from the following HP website and 
manually extracted to a floppy. If using the downloaded 
driver, follow these steps and skip steps 3-14. 
 

a. Download the driver file from the website shown below. 
b. Double-click on it.  
c. In Compaq Package Setup window that comes up, click on Extract. 
d. A window will come up asking for directory to extract files to. 
e. Place a clean floppy into drive A, select the A: drive from the file browser window, 

and click OK. 
f. Files will be extracted to the floppy. 
g. Click Close to exit out of Compaq Package Setup Window. 
 
http://h18004.www1.hp.com/support/files/server/us/download/13437.html 

 
 
 

http://h18004.www1.hp.com/support/files/server/us/download/13437.html
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NOTE 
 
Instructions in sections 6.1 – 6.9 can be executed 
concurrently on both servers to save time. 

 
Step 1. Verify the power and network connections to the DL380 server(s). 
Step 2. Power on the Compaq DL380 server 
Step 3. As the server starts insert the Compaq SmartStart for Servers CD found in the 

Compaq ProLiant Essentials Foundation Pack. 
Step 4. The SmartStart for Servers screen will appear several times and then the System 

Utilities screen will open. Double click on the “Create Support Software” icon. 
Step 5. The Compaq SmartStart - Diskette Builder screen will then open. Double click on 

the “Compaq” icon to expand the list of available diskette sets. 
Step 6. Use the scroll bar to locate the “Compaq Support Paq for Microsoft Windows 

2000 Supplemental Diskettes version 5.40A” and select this choice by clicking the 
check box next to it. 

Step 7. Click the “Next” button. 
Step 8. The Diskette Destination Selection screen will then appear, make sure to select 

the “Create software diskettes to floppy only” choice. 
Step 9. Click the “Next” button. 
Step 10. The Diskette Builder dialog box will open requesting that a diskette be 

inserted into the floppy drive. Insert a blank diskette into the floppy drive and then 
click the “OK” button.  

Step 11. The Diskette Builder Information dialog will then open with the status of 
the build process. When completed click the “Finish” button on the Compaq 
SmartStart - Diskette Builder screen that appears. 

Step 12. Back on the System Utilities screen, click the “Exit” button. 
Step 13. Click the “OK” button on the exiting SmartStart warning dilaog. 
Step 14. Remove the SmartStart CD from the CD-ROM and the floppy disk created 

from the floppy drive. Label this disk “Compaq DL380 SmartArray 5I Driver”. Press 
any key to reboot the server. 

Step 15. Pay close attention to the boot sequence happening, at the Press <F8> to 
run the Option ROM Configuration for Arrays Utility prompt that appears during the 
boot sequence press “F8” to enter the configuration utility. 

Step 16. The main Option ROM Configuration for Arrays (ORCA) screen will 
appear. On the Main Menu that appears use the down-arrow key to select the “View 
Logical Drive” selection (it will be highlighted in dark blue when selected) and press 
“Enter”. 

Step 17. If the system has been pre-configured or previously loaded, Logical 
Drives will appear in the list, in this case and if required follow the sub-steps 
below to wipe all the existing logical drives. This option would be the case for a 
totally clean installation, however, if the server was shipped pre-configured to the 
site (in special cases this may happen) skip to Step 19. If the system has no logical 
drives defined, the There are no available logical drives Press <ESC> to return to 
the main menu dialog will appear, press “ESC” and continue at Step 6 in this 
procedure to create the new logical drives. 
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a) Press “ESC” to return the main ORCA screen. 
b) On the Main Menu use the down-arrow key to select the “Delete Logical Drive” 

selection, press “Enter”. 
c) The Available Logical Drive list will appear. Select the first logical drive in list 

(the selected drive will be highlighted in dark blue) and press “F8” to delete it. 
d) A red warning dialog box will open with the following message: 
 

“Warning 
 
This will result in complete data loss for this logical drive. 
 
You have selected to delete logical drive # X, RAID X, XXX GB with X physical 
drive(s). 
 
Press <F3> to delete the logical drive 
Press <ESC> to cancel” 

 
Press “F3” to delete the logical drive. 
 
e) The Saving Configuration… message will flash and then the Configuration 

saved Press <Enter> to continue dialog will open. Press “Enter”. 
f) Repeat sub-steps (b) to (d) above for each additional logical drive in the 

Available Logical Drive list. When the There are no available logical drives. 
Press <ESC> to return to the main menu message appears in response to the 
View Logical Drive command; the delete operation has been completed. 

g) When there are no more drives, press “ESC” to go back to the main ORCA 
screen. 

h) Proceed to Step 18 to build the new logical drives. 
 
Step 18. The logical drive creation procedure will differ between the JMPS 

Enterprise, JMPS Enterprise Lite and the JMPS PICO server configurations. Sub-
procedures are presented below to handle each case: 

 
JMPS Enterprise and JMPS Enterprise Lite Configurations 

 
a) In the JMPS Enterprise and JMPS Enterprise Lite configurations the server 

may only contain 2 drives but could also have the full compliment of 5 drives. 
In either case the first two drives will have to be configured into a RAID 0+1 
(mirrored) configuration to provide the mirrored system boot disk. On the 
ORCA Main Menu start by selecting the “Create Logical Drive” selection, 
press “Enter”. 

b) The Available Physical Drives, Raid Configurations and the Spare boxes will 
open on the ORCA screen. In the Available Physical Drives box make sure 
both drive ID 0 and drive ID 1 are selected. (If the drives are not selected, use 
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the down-arrow key to select each one and then click the Space Bar to select 
them. An “X” will be present in the brackets next to the drive when selected). 

 
NOTE 

 
If for there are more than 2 hard drives present in the 
system the extra drives must be de-selected for the 
Enterprise and Enterprise Lite configurations. De-select 
them by using the arrow key to select each drive and 
then clicking the Space Bar, the “X” should not be 
present on any other drives at this point except for drive 
ID 0 and ID 1. 

 
c) With drive ID 0 and ID 1 selected, press the “Tab” key to move to the Raid 

Configurations box. 
d) In the Raid Configurations box select the RAID 1 (1+0) choice by using the 

arrow key, and then press “Enter” to create the logical drive. 
e) The following message will appear: 

 
“You have selected a logical drive with a total data size of xxx.x GB and 
RAID 1 fault tolerance. 
 
Press <F8> to save the configuration 
Press <ESC> to cancel” 
 
Press “F8” to save the configuration. 

 
f) The Saving Configuration… message will flash and then the 

Configuration saved Press <Enter> to continue dialog will open. Press 
“Enter”. 

g) Using the arrow key select the “View Logical Drive” selection on the 
ORCA Main Menu, press “Enter”. 

h) The Available Logical Drives list will open. Verify that the new Logical 
Drive defined appears in the list as Logical Drive # 1 and that it is a RAID 
1 configuration. 

i) Press “ESC” to go back to the ORCA main screen. 
j) Press “ESC” to exit the ORCA utility and continue the server boot 

sequence. Continue the setup at configuration at Step 19. 
 

JMPS PICO Configuration 
 
 

a) In the case of the JMPS PICO Configuration a total of 5 hard drives will 
be present in the DL380 server. Two of the five drives will have to be 
configured into a RAID 0+1 (mirrored) configuration to provide the 
mirrored system boot disk. The remaining three drives will be configured 
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into a RAID 5 storage area for the JMPS data. On the ORCA Main Menu 
start by selecting the “Create Logical Drive” selection, press “Enter”. 

b) The Available Physical Drives, Raid Configurations and the Spare boxes 
will open on the ORCA screen. In the Available Physical Drives box make 
sure both drive ID 0 and drive ID 1 are selected. (If the drives are not 
selected, use the down-arrow key to select each one and then click the 
Space Bar to select them. An “X” will be present in the brackets next to 
the drive when selected. Unselect all other drives except 0 and 1.). 

c) With drive ID 0 and ID 1 selected, press the “Tab” key to move to the 
Raid Configurations box. 

d) In the Raid Configurations box select the RAID 1 (1+0) choice by using 
the arrow key, and then press “Enter” to create the logical drive. 

e) The following message will appear: 
 

“You have selected a logical drive with a total data size of xxx.x GB and 
RAID 1 fault tolerance. 
 
Press <F8> to save the configuration 
Press <ESC> to cancel” 
 
Press “F8” to save the configuration. 

 
f) The Saving Configuration… message will flash and then the 

Configuration saved Press <Enter> to continue dialog will open. Press 
“Enter”. 

g) Using the arrow key select the “View Logical Drive” selection on the 
ORCA Main Menu, press “Enter”. 

h) The Available Logical Drives list will open. Verify that the new Logical 
Drive defined appears in the list and is a RAID 1 configuration. 

i) Press “ESC” to exit the Logical Drive display. 
j) Back on the ORCA Main Menu select the “Create Logical Drive” 

selection, press “Enter”. 
k) The Available Physical Drives, Raid Configurations and the Spare boxes 

will open on the ORCA screen. In the Available Physical Drives box 
select the remaining three drives, drive ID 2, drive ID 3 and drive ID 4. 
(These should be selected by default, if the drives are not selected, use the 
down-arrow key to select each one and then click the Space Bar to select 
them. An “X” will be present in the brackets next to the drive when it is 
selected). 

l) With drive ID 2, 3 and 4 selected, press the “Tab” key to move to the Raid 
Configurations box. 

m) In the Raid Configurations box select the RAID 5 choice by using the 
arrow key, and then press “Enter” to create the logical drive. 

n) The following message will appear: 
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“You have selected a logical drive with a total data size of xxx.x GB and 
RAID 5 fault tolerance. 
 
Press <F8> to save the configuration 
Press <ESC> to cancel” 
 
Press “F8” to save the configuration. 

 
o) The Saving Configuration… message will flash and then the 

Configuration saved Press <Enter> to continue dialog will open. Press 
“Enter”. 

p) Using the arrow key select the “View Logical Drive” selection on the 
ORCA Main Menu, press “Enter”. 

q) The Available Logical Drives list will open. Verify that the new Logical 
Drive # 2 defined appears in the list and is a RAID 5 configuration. 

r) Press “ESC” to go back to the ORCA main screen. 
s) Press “ESC” to exit the ORCA utility and continue the server 

configuration at Step 19. 
 

 
Step 19. After Step 18 is completed the boot sequence will continue. Carefully 

watch as the boot sequence executes, when the Press F9 key for ROM-Based Setup 
Utility prompt appears during the boot sequence press “F9” to enter the ROM-Based 
Setup Utility. 

Step 20. Once in the ROM-Based Setup Utility use the down-arrow key to select 
the “Standard Boot Order (IPL)” selection in the left-hand box (it should be 
highlighted in dark blue) and then press “Enter”. 

Step 21. The boot order list will appear, if the CD-ROM is set as IPL:1 press 
“ESC” and continue at Step 22. If the CD-ROM is not set to IPL:1 then execute 
the following sub-steps: 

 
a) Using the up/down arrow keys select the CD-ROM (the IPL: number will 

be highlighted in black on the selected item) and then press “Enter”. 
b) From the list that appears, using the up/down arrows keys, select the “Set 

the IPL Device Boot Order to 1” selection and press “Enter”. This will 
move the CD-ROM to the top of the boot list (IPL:1 CD-ROM). 

c) Press “ESC” on the boot list to return to the main ROM-Based Setup 
Utility screen 

 
Step 22. Once the boot order has been verified / changed on the main ROM-Based Setup 

Utility screen press “ESC” to exit the utility. 
Step 23. Place the Microsoft Windows 2000 Advanced Server CD into the CD-ROM 

drive. 
Step 24. Press “F10” to confirm the exit from the ROM-Based Setup Utility and save the  
Step 25. The system will reboot. 
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Step 26. The blue “Windows 2000 Setup” screen will appear with the message “Setup is 

loading files…” Allow the file loading process to continue. 
Step 27. At the Press <F6> if you need to install third party SCSI or RAID driver… 

prompt press “F6”. (Note: This prompt appears only for a few seconds, attention 
and quick action are required to catch it, if it is missed press CTRL - ALT - DEL to 
reboot and restart the Windows 2000 Advanced Server installation.) 

Step 28. Once the files have been loaded the blue Windows 2000 Setup screen will 
appear with the mass storage specification screen. Press “s” to load the Compaq 
Smart Array5I SCSI controller driver. 

Step 29. The blue Windows 2000 Setup screen will appear with the instruction: 
 

“Please insert the disk labeled Manufacturer-supplied hardware support disk into 
Drive A:  
 
Press ENTER when ready.” 

 
Insert the floppy disk containing the Compaq Smart Array5i SCSI controller driver, 
(the one built from the SmartStart CD at the beginning of these procedures or 
downloaded from the HP website), into the floppy drive and then press “Enter”. 
Leave this disk in the floppy drive until instructed to remove it. 

Step 30. The blue Windows 2000 Setup screen will appear with the array type selection 
screen. Use the arrow keys to select the “Compaq Smart Array 5i, 532, 5312 
Controllers” choice (the selection will be highlighted in white) and then press 
“Enter”. 

Step 31. The dialog Setup is loading files.. will appear briefly on the bottom of the 
screen and then the mass storage specification screen will reappear. Press “Enter” to 
continue since no further drivers are required to be loaded. Setup will then to 
continue to load files. 

Step 32. The Windows 2000 Server Setup blue screen will appear. Press “Enter” to begin 
the setup of Windows 2000. 

Step 33. The next blue Windows 2000 Server Setup blue screen will appear with the 
following messages: 

 
“Setup has determined that your computer’s start up hard disk is new or has been 
erased, or that your computer is running an operating system that is incompatible 
with Windows 2000. 
 
If the hard disk is new or has been erased, or if you want to discard its current 
contents, you can choose to continue setup. 
 
If your computer is running an operating system that is incompatible with 
Windows 2000, continuing Setup may damage or destroy the existing operating 
system. 
 

• To Continue Setup press C. 
• To Quit Setup press F3. 
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CAUTION: Any data currently on your computer’s startup hard disk will be lost.” 
 
Press “C” to continue with Setup. 

Step 34. The Microsoft® Windows 2000 Licensing Agreement will appear on the next 
blue Setup screen. Press “F8 = I agree” to accept the license. 

 
INFORMATION 

 
According to the general DII-COE installation 
guidelines it suggests that the disk be partitioned into 
three separate partitions. These include a C: partition 
for the system files named “System”, a D: partition for 
the COE segments named “Segments” and an E: 
partition for the user data named “Data”. The general 
rule of thumb used to calculate the sizes of these 
partitions was to break the drive into 30%, 30%, and 
40% slices. The Data partition shall always be the 
largest since it will hold the user data. 
 
In the JMPS Enterprise and JMPS Enterprise Lite 
configurations the Data E: partition will be placed on 
the external Ciprico NetArray 1100 RAID. Therefore, 
the internal mirrored boot disk should be split into two 
equal partitions for the System C: and the Segments D: 
partitions. 
 
In the JMPS PICO server configuration the Data E: 
partition will be an internal (inside the DL380 server) 
RAID 5 storage area. The Compaq Smart Array5I 
controller will control this internal RAID 5 array which 
was configured in Step 18 above. In the JMPS PICO 
Server case the internal mirrored boot disk should also 
be split into two equal partitions for the System C: and 
the Segments D: partitions. However, for the PICO 
server the Data E: partition will be placed on the 
internal RAID 5. The following procedures will detail 
how this operation is completed. 
 

 
Step 35. The next Windows 2000 Server Setup blue screen to appear will be the 

partition information screen. The following messages will appear on the partition 
screen: 

 
“The following list shows the existing partitions and unpartitioned space on this 
computer. 
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Use the UP and DOWN ARROW keys to select an item in the list: 
 

• To setup Windows 2000 on the selected item, press Enter. 
• To create a partition in the unpartitioned space, press C. 
• To delete the selected partition, press D.” 

 
The following disk summary will be displayed: 

 

34728 MB Disk0 at Id4 on bus on cpqcissm 
 Unpartitioned space   34728MB 
 
(Note: The total drive size may be different, this is the expected size with 36.4 GB 
hard drives. If larger drives are used in the server, this size will be different. Also 
note that in the PICO Server there will two drives present, work only with the first 
at this point.) 

 
Make sure that the Unpartitioned space is selected (highlighted in white). Press 
“C” to create a new C: partition. 

 
Step 36. The next blue Windows 2000 Server Setup screen will appear with the 

following message: 
 
“You asked Setup to create a new partition on DDDDD MB Disk 0 at Id3 on Bus 0 on 
adpu160m (where DDDDD  is the actual size of the drive). 
 

• To create the new partition, enter a size below and press Enter 
• To go back to the previous screen without creating the partition, press ESC. 

 
The minimum size for the new partition is:   4 megabytes (MB) 
The maximum size for the new partition is:   32724 megabytes (MB) 
Create a partition of size (in MB):   XXXX MB” 
 

 
Calculate the necessary size for the C: partition using the actual size of the hard drive 
(an example using a 36.4GB drive, it will roughly be 34724 * .5 = 17364 MB). Enter 
this partition size in the white highlighted block and then press “Enter” to create it. 

Step 37. The blue Windows 2000 Server Setup screen will reappear with the partition 
information. The partition display should look similar to the following: 

 
34728 MB Disk0 at I4 on bus 0 on cpqcissm 
C: New(Unformattted)   17364 MB 
Unpartitoned space    17364 MB 
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(Note: The above drive size may be different, these are the expected size with 36.4 
GB hard drives. If larger drives are used in the server, the sizes will differ.) 

 
Press “ENTER” to install the partition. At this time do not worry about creating any 
other partitions; this task will be addressed later after the basic system installation is 
accomplished via the Windows 2000 Disk Manager. 

Step 38. The blue Windows 2000 Server Setup Format Type screen will then appear 
with the following statements: 

 
“The partition you selected is not formatted. Setup will now format the partition. 
 
Use the UP and DOWN ARROW keys to select the file system you want, and then 
press ENTER. 
 
If you want to select a different partition for Windows 2000, press ESC” 

 
Select the “Format the partition using the NTFS file system” option by using the 
arrow keys, this choice should be the default. Press “Enter” to accept the NTFS 
format type and to start the formatting process. 

Step 39. The blue “Windows 2000 Server Setup” screen will appear with the following 
message: 

 
“Please wait while Setup formats the partition 

 
 C: New(Unformatted)   xxxxMB 
 On DDDDD MB Disk0 at Id0 on bus 0 on adpu160m.” 
 

The progress bar will also be displayed: 
 

Setup is formatting… 
 
    XX % 
 
 

 
Wait until the formatting operation is completed. 

Step 40. The next blue Windows 2000 Server Setup screen will flash by with the 
“Checking System” notification. No action is required. 

Step 41. The Windows 2000 Server Setup screen will reappear at this time displaying 
the following message: 

“Please wait while Setup copies files to the Windows 2000 installation folders. This 
may take several minutes to complete.” 

 
The progress bar will also be displayed: 

25 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 26 
 
 

Setup is copying files… 
 
    XX % 
 

 
Wait until the copy operation finishes. 

Step 42. The next blue Windows 2000 Server Setup screen to appear will display the 
following: 

 
“Setup has completed copying files, the system will now reboot” 

 
Allow the system to reboot, do not remove the Windows 2000 Advanced Server CD 
from the CD-ROM drive. 

Step 43. Once the server reboots the Window 2000 Server Setup dialog box will appear 
over the Windows 2000 Advanced Server screen. Wait for the next dialog box to 
open. 

Step 44. The next Windows 2000 Server Setup screen with the “Welcome to the 
Windows 2000 Setup Wizard” dialog box will appear. Click the “Next” button. 

Step 45. The next Windows 2000 Server Screen will appear with the “Installing 
Devices…” dialog (at this time setup is detecting and installing devices on the 
server, the screen may flicker during this period). Wait until this process is finished. 

Step 46. The Windows 2000 Server Setup screen will appear with the “Regional 
Settings” dialog box. Accept the default (English, US Keyboard) settings by clicking 
the “Next” button. 

Step 47. The next Windows 2000 Server Setup screen will appear with the 
“Personalize Your Software” dialog box. On this dialog enter the name of the 
administrator in the Name box and the name of the organization into the 
Organization box. When finished click the “Next” button. 

Step 48. The next Windows 2000 Server Setup screen will appear with the “Your 
Product Key” dialog box. In the Product Key boxes enter the 25 alphanumeric 
license key for the Windows 2000 Advanced Server software package that was 
shipped with the server. Press the “Next” button to continue. 

Step 49. The next Windows 2000 Server Setup screen will appear with the “Licensing 
Modes” dialog box. Select the “Per Seat - Each computer must have its own Client 
Access License” choice. Note the statement that appears on this screen: 

 
“To avoid violation of the License Agreement, use Licensing (which is located in 
Administrative Tools) to record the number of Client Access Licenses purchased.” 

 
Click the “Next” button to continue the installation. 

Step 50. The next Windows 2000 Server Setup screen will appear with the “Computer 
Name and Administrator Password” dialog box. Enter in the desired computer name 
in the Computer Name box. Also enter in the desired administrator password in the 
Administrator password and the Confirm Password boxes. Press the “Next” button to 
continue with the installation. (Note: If this is the second server in a JMPS Enterprise 
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configuration, be sure to select a unique name, different than the one selected for the 
first server.) 

Step 51. The next Windows 2000 Server Setup screen will appear with the “Window 
2000 Components” dialog box. Double click on the Accessories and Utilities 
component listed in the Components box to open the subcomponent list. The 
Accessories and Utilities dialog box will open with the Subcomponents of 
Accessories and Utilities list. Perform the following operations on the subcomponent 
list: 

 
a) Leave the Accessibility Wizard box checked. 
b) Double click the Accessories subcomponent. The Subcomponents of 

Accessories list will appear. Verify that all components are checked. Click the 
“OK” button. 

c) Double click the Communications subcomponent. The Subcomponents of 
Communications list will appear. Uncheck the Chat and Phone Dialer 
subcomponents. Only the HyperTerminal subcomponent should be installed. 
Click the “OK” button. The Communications check box will now be gray, this 
is due to the custom settings that were applied. 

d) Uncheck the Games subcomponent on the Subcomponents of Accessories and 
Utilities list to exclude it from the load. 

e) Double click the Multimedia subcomponent. The Subcomponents of 
Multimedia list will appear. Verify that all the subcomponents are checked. 
Click the “OK” button. 

f) With all the subcomponents now selected, on the Accessories and Utilities 
dialog box, click the “OK” button. 

 
Step 52. Continuing on the “Windows 2000 Components” dialog box, leave the 

Certificate Services component unchecked. 
Step 53. Continuing on the “Windows 2000 Components” dialog box, leave the 

Cluster Services component unchecked. 
Step 54. Continuing on the “Windows 2000 Components” dialog box, leave the 

Indexing Services component checked. 
Step 55. Continuing on the “Windows 2000 Components” double click on the Internet 

Information Services (IIS) to open its subcomponent list. The Internet Information 
Services (IIS) dialog box will open with the Subcomponents of Internet Information 
Services (IIS) list. Perform the following operations on the subcomponent list: 

 
a) Leave the Common Files subcomponent checked. 
b) Uncheck the Documentation subcomponent. 
c) Check the File Transfer Protocol (FTP) Server subcomponent selection box to 

select it. 
d) Uncheck the FrontPage 2000 Server Extensions subcomponent. 
e) Leave the Internet Information Services Snap-In subcomponent checked. 
f) Uncheck the Internet Services Manager (HTML) subcomponent. 
g) Leave the NNTP Service subcomponent unchecked. 
h) Uncheck the SMTP Service subcomponent. 
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i) Leave the Visual InterDev RAD Remote Deployment Support subcomponent 
unchecked. 

j) Uncheck the World Wide Web Server subcomponent. 
g) With all the subcomponents now selected, on the Subcomponents of Internet 

Information Services (IIS) dialog box, click the “OK” button. On the 
Windows 2000 Components the Internet Information Services (IIS) check 
box will show as gray now due to the custom settings selected. 

 
Step 56. Continuing on the “Windows 2000 Components” select the Management and 

Monitoring Tools component by checking the selection box. 
Step 57. Double click on the Management and Monitoring Tools component to open its 

subcomponent list. The Management and Monitoring Tools dialog box will open 
with the Subcomponents of Management and Monitoring Tools list. Perform the 
following operations on the subcomponent list: 

 
a) Uncheck the Connection Manager Components subcomponent. 
b) Leave the Network Monitor Tools subcomponent checked. 
c) Leave the Single Network Management Protocol subcomponent checked. 
d) With all the subcomponents now selected, on the Subcomponents of Management 

and Monitoring Tools dialog box, click the “OK” button. On the Windows 2000 
Components the Management and Monitoring Tools check box will show as gray 
now due to the custom settings selected. 

 
Step 58. Continuing on the Windows 2000 Components dialog box leave the Message 

Queuing Services component unchecked. The Message Queuing Services will need 
to be added for JC1 but this step will be performed later in the installation procedure 
after Active Directory has been configured. 

Step 59. Continuing on the “Windows 2000 Components” select the Networking 
Services component by checking the selection box. 

Step 60. Double click on the Networking Services component to open its 
subcomponent list. The Subcomponents of Networking Services dialog box will 
open with the Subcomponents of Networking Services list. Perform the following 
operations on the subcomponent list: 

 
a) Leave the COM Internet Services Proxy subcomponent checked. 
b) Uncheck the Domain Name Server (DNS) subcomponent. 
c) Uncheck the Dynamic Host Configuration Protocol (DHCP) subcomponent. 
d) Leave the Internet Authentication Service subcomponent selected. 
e) Uncheck the QoS Admission Control Service subcomponent. 
f) Leave the Simple TCP/IP Services subcomponent selected. 
g) Leave the Site Server ILS Services subcomponent unselected. 
h) Uncheck the Windows Internet Name Services (WINS) subcomponent. 
h) With all the subcomponents now selected, on the Subcomponents of 

Networking Services dialog box, click the “OK” button. On the Windows 
2000 Components list the Networking Services check box will show as gray 
now due to the custom settings selected. 
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Step 61. Continuing on the “Windows 2000 Components” dialog box, leave the Other 

Network File and Print Services component unselected. 
Step 62. Continuing on the “Windows 2000 Components” dialog box, leave the 

Remote Installation Services component unselected. 
Step 63. Continuing on the “Windows 2000 Components” dialog box, leave the 

Remote Storage component unselected. 
Step 64. Continuing on the “Windows 2000 Components” dialog box, leave the Script 

Debugger component selected. 
Step 65. Continuing on the “Windows 2000 Components” dialog box, leave the 

Terminal Services component unselected. 
Step 66. Continuing on the “Windows 2000 Components” dialog box, leave the 

Terminal Services Licensing component unselected. 
Step 67. Continuing on the “Windows 2000 Components” dialog box, leave the 

Windows Media Services component unselected. 
Step 68. Now that all the Windows 2000 components have been selected on the 

Windows 2000 Components dialog box, click the “Next” button. 
Step 69. The next Windows 2000 Server Setup screen with the “Date and Time 

Settings” dialog box will appear. In the Date and Time boxes enter the correct date 
and the GMT time. In the Time Zone box use the down arrow key and the scroll bar 
to select the “{GMT} Greenwich Mean Time: Dublin, Edinburgh, Lisbon, London” 
time zone. Leave the “Automatically adjust clock for daylight saving changes” box 
checked. Click the “Next” button on the Date and Time Settings dialog box. 

Step 70. After the Network Settings installation runs, the Windows 2000 Server Setup 
screen with the “Network Settings” dialog box will appear. Select “Custom Settings” 
and then click the “Next” button. 

Step 71. The next Windows 2000 Server Setup screen with the Networking 
Components dialog box will appear. The For Device line will display the network 
card that the settings will apply to, for the Compaq DL380 system it should be the 
second onboard NIC “Compaq NC3163 Fast Ethernet NIC #2”. The components for 
this NIC are shown in the Components checked are used by this connection box. 
Perform the following operations on the component list: 

 
a) Leave the Client for Microsoft Networks component checked. Double click on the 

Client for Microsoft Networks component to open the component properties. The 
Client for Microsoft Networks Properties dialog box will open, verify that the 
Name service provider is set to Windows Locator. Click the “OK” button. 

b) Continuing on the Networking Components list leave the Network Load 
Balancing component unchecked. 

c) Leave the File and Printer Sharing for Microsoft Networks component checked. 
Double click on the File and Printer Sharing for Microsoft Networks component 
to open the component properties. The File and Printer Sharing for Microsoft 
Networks Properties dialog box will open, verify that the “Maximize data 
throughput for file sharing” choice is selected, if it is not, select it. Click the “OK” 
button. 
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d) Leave the Internet Protocol (TCP/IP) component checked. Double click on the 
Internet Protocol (TCP/IP) component to open the component properties. The 
Internet Protocol (TCP/IP) Properties dialog box will open. Click the “Use the 
following IP address” button. Proceed to enter the IP address, Subnet mask and 
Default gateway. Also enter the Preferred DNS server and the Alternate DNS 
server IP addresses if available.  Once the addresses are entered click the “OK” 
button. 

e) With all the necessary components loaded / configured for the second network 
card, on the Networking Components dialog box click the “Next” button. 

 
Step 72. The second “Networking Components” dialog box will appear. The For 

Device line will display the network card that the settings will apply to, in the case of 
the Compaq DL380 system it should be the first onboard NIC “Compaq NC3163 
Fast Ethernet NIC”. The components for the network card are shown in the 
Components checked are used by this connection box. Perform the following 
operations on the component list: 

 
a) Leave the Client for Microsoft Networks component checked. Double click on the 

Client for Microsoft Networks component to open the component properties. The 
Client for Microsoft Networks Properties dialog box will open, verify that the 
Name service provider is set to Windows Locator. Click the “OK” button. 

b) Continuing on the Networking Components list leave the Network Load 
Balancing component unchecked. 

c) Leave the File and Printer Sharing for Microsoft Networks component checked. 
Double click on the File and Printer Sharing for Microsoft Networks component 
to open the component properties. The File and Printer Sharing for Microsoft 
Networks Properties dialog box will open, verify that the “Maximize data 
throughput for file sharing” choice is selected, if it is not select it. Click the “OK” 
button. 

d) Leave the Internet Protocol (TCP/IP) component checked. Double click on the 
Internet Protocol (TCP/IP) component to open the component properties. The 
Internet Protocol (TCP/IP) Properties dialog box will open. Click the “Use the 
following IP address” button. Proceed to enter the IP address, Subnet mask and 
Default gateway. Also enter the Preferred DNS server and the Alternate DNS 
server IP addresses if available.  Once the addresses are entered click the “OK” 
button. 

e) With all the necessary components loaded / configured for the first network card, 
on the Networking Components dialog box click the “Next” button. 

 
Step 73. The next Windows 2000 Server Setup screen will open with the “Workgroup 

or Computer Domain” dialog box. Accept the default “No, this computer is not on a 
network, or is on a network without a domain” choice for now, the actual workgroup 
/ domain configurations will be done later in the procedure. Click the “Next” button. 

Step 74. The next Windows 2000 Server Setup screen with the Installing Components 
dialog box will appear with the message: 
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“Please wait while Setup installs the components. This may take several minutes”. 
 

The Status bar will show the progress of the installation. The “Performing Final 
Tasks” dialog will appear during the final steps. Wait until the setup completes. 

Step 75. The next Windows 2000 Server Setup screen with the “Completing the 
Windows 2000 Setup Wizard” dialog box will appear with the following message: 

 
“You have successfully completed Windows 2000 Setup. 

 
If there is a CD in your drive, remove it. Then to restart your computer, click 
Finish” 

 
Remove the Windows 2000 Advanced Server CD from the CD-ROM drive and 
remove the floppy containing the Compaq Smart Array5i driver if it is still in the 
floppy drive. Click the “Finish” button. The server will restart. 
 

NOTES 
 

PRIOR TO RESTARTING THE SERVER ENSURE 
THAT THE NETWORK CARDS ARE CONNECTED 
TO THE NETWORK AND THAT THE PORTS THEY 
ARE CONNECTED TO ARE ACTIVE. IF THE 
NETWORK CARDS ARE NOT CONNECTED, 
SEVERAL SERVICE CONTROL MANAGER 
ERRORS RELATED TO NETWORKING SERVICES 
WILL OCCURR AT BOOT. THIS IS NOT A MJOR 
ISSUE BUT CAN BE ADVOIDED IF THE 
NETWORK IS AVAILABLE. 
 
IN THE ENTERPRISE LITE OR PICO 
CONFIGRATIONS, THE INTERNAL 10/100 NICS 
WILL NOT BE USED. HOWEVER, FOLLOW THE 
INSTRUCTIONS ABOVE AND BE SURE TO 
ASSIGN VALID IP ADDRESSES TO BOTH CARDS. 
DO NOT ALLOW THE DCHP OPTION TO 
DEFAULT ON ANY NIC CARD, DHCP SHALL NOT 
BE INSTALLED ON ANY JMPS SERVER 
CONFIGURATIONS. FAILURE TO SET VALID IP 
ADDRESSES ON THE CARDS AT THIS POINT 
WILL RESULT IN THE AUTOMATIC 
INSTALLATION OF THE DHCP SERVICE, WHICH 
IS THE INCORRECT CONFIGURATION. 

 
Step 76. When the system boots, the “Welcome to Windows - Press Ctrl-Alt-Delete to 

begin” dialog box will appear. Logon to the system via the following steps: 
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a) Press “Ctrl-Alt-Delete” at the logon prompt. 
b) The “Log On to Windows” dialog box will appear. By default at this time the 

User Name will be “Administrator”. 
c) Enter the administrator password. 
d) Press “Enter” or click the “OK” button. 

 
Step 77. Upon boot the Windows 2000 Configure Your Server window will appear. 

Close this dialog. 
 

NOTE 
 
Monitor resolution can be changed at this point from 
640x480 to 800x600 or 1024x768 for convenience.   
 
(E.S. Add directions for changing resolution) 

 
Step 78. Start->Settings->Network and Dial-up Connections. 
Step 79. The Network and Dial-up Connections dialog box will open.  Click on the 

“Local Area Connection”.  Verify that the description displayed is “Compaq 
NC3163 Fast Ethernet NIC”, to confirm that it is the first 10/100 internal network 
interface card.  If the description does not show this, click on the other connection(s) 
shown in the dialog box until this card is located. 

Step 80. Right click on this Local Area Connection and select “Disable” from the pop-
up menu. 

Step 81. Right click again on this Local Area Connection and select “Properties” from 
the pop-up menu. 

Step 82. The Local Area Connection Properties dialog box will open.  In the 
Components checked are used by this connection: box use the scroll bar to access the 
Internet Protocol (TCP/IP) component.  Double click on the component. 

Step 83. The Internet Protocol (TCP/IP) Properties dialog box will open.  On this 
dialog click the “Advanced…” button. 

Step 84. The Advanced TCP/IP Settings dialog box will then open.  Click the “DNS” 
TAB to bring it forward. 

Step 85. On the DNS TAB uncheck the “Register this connection’s address in DNS” 
box.  Click the “OK” button. 

Step 86. On the Internet Protocol (TCP/IP) Properties dialog box, click the “OK” 
button. 

Step 87. On the Local Area Connection Properties dialog box, click the “OK” button. 
Step 88. The Local Network dialog box will appear with the following message: 
 

“You must shut down and restart your computer before the new settings will take 
effect.  Do you want to restart your computer now?” 
 
Click the “NO” button.  The system will be restarted later in this procedure. 
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Step 89. Repeat Steps 80 to 89 above for the second 10/100 internal network interface 

card, the description for this card will be “Local Area Connection 2”.  On the second 
card respond “Yes” to the restart question that appears in Step 89 so that the changes 
will be applied.  These steps will disable the 10/100 cards and unregister them from 
DNS to prevent them from being used by the system until needed. 

Step 90. Upon boot the Windows 2000 Configure Your Server window will appear. 
Close this dialog and proceed with Section 6.2. 

 
 

6.2 Procedure: Configure the Server Hard Drive Partitions 
 
 With the basic operating system installed the task of formatting the hard drives 
can be accomplished. The procedures between the JMPS Enterprise, JMPS Enterprise 
Lite and the JMPS PICO configurations will differ due to the different server hard drive 
capacities and the presence or lack of an external Ciprico NetArray 1100 RAID. This 
section has been broken into sub-sections to handle each case. Select the appropriate one 
based on the configuration being deployed. 

6.2.1 JMPS Enterprise and JMPS Enterprise Lite Configurations 
 

NOTE 
 
IF THE JMPS ENTERPRISE CONFIGURATION IS 
BEING SETUP PROCEDURES 6.1 – 6.9 WILL HAVE 
TO BE EXECUTED TWICE, ONE ON THE FIRST 
SERVER AND THEN REPEATED ON THE SECOND 
SERVER IN THE JMPS ENTERPRISE SUITE. 
 
IF THE JMPS ENTERPRISE LITE 
CONFIGURATION IS BEING SETUP, EXECUTE 
PROCEDURES 6.1 – 6.9 ONCE ON THE SINGLE 
SERVER. 

 
Step 1. In the JMPS Enterprise and JMPS Enterprise Lite configurations the server will 

contain two hard drives that have been setup in a hardware RAID 0+1 configuration 
via the above procedures. The first partition C: was defined for the basic operating 
system space. Labeling and formatting operations must now be completed to define 
the second partition. Select Start->Programs->Administrative Tools->Computer 
Management. 

Step 2. The Computer Management window will open. In the left-hand box double click 
on the “Disk Management” folder. 

Step 3. In the right-hand pane of the Computer Management window the volume 
information will appear for the disk drives in the system. Click on the CDRom 0 drive 
label box and then right-click. 

Step 4. Select “Change Drive Letter and Path…” from the pop-up menu. 
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Step 5. The Change Drive Letter and Paths for (D:) will appear. Click the “Edit” button. 
Step 6. The Edit Drive Letter or Path dialog box will open, on the Assign a drive letter 

line click the down-arrow key and select the “G:” drive letter from the drop down list. 
Click the “OK” button to set it. 

Step 7. The Confirm dialog box will then open with the following message: 
 

“Changing the drive letter of a volume may cause programs to no longer run. Are 
you sure you want to change this drive letter?” 

 
Click the “Yes” button. The drive letter for the CDRom0 will change to “G:” on the 
Computer Management window. 

Step 8. On the Start Menu Bar click Start->Shut Down. On the Shut Down Windows 
dialog that appears click the down-arrow button and select “Restart” from the 
presented list. Click the “OK” button. The server will restart. 

Step 9. After the server restarts logon as the administrator as previously outlined. 
Step 10. Upon boot, the Windows 2000 Configure Your Server window will appear. 

For now just close this dialog and proceed with Step 11. 
Step 11. Select Start->Programs->Administrative Tools->Computer Management. 
Step 12. The Computer Management window will open. In the left-hand box double 

click on the “Disk Management” folder. 
Step 13. In the right-hand pane of the Computer Management window the volume 

information will appear for the disk drives in the system. Verify that the CDRom 0 
drive label is now “G:” 

Step 14. On the Disk 0 display click on the C: partition which was built during the 
basic operating system load and then right-click on it. From the pop-up menu select 
“Properties”. 

Step 15. The Local Disk (C:) Properties dialog box will open. On the General TAB, in 
the Label box enter “System” and click the “OK” button. The Local Disk (C:) 
Properties box will close and the partition display on the Computer Management 
window will update to show the name of the C: partition, “System”. 

Step 16. Select and then right-click on the Unallocated space on Disk 0. Select “Create 
Partition” from the pop-up menu. 

Step 17. The Create Partition Wizard dialog box will open with the Welcome to the 
Create Partition Wizard message. Click the “Next” button. 

Step 18. The Select Partition Type dialog will then appear, select the “Primary 
partition” choice and click the “Next” button. 

Step 19. The Specify Partition Size dialog will then appear, accept the total amount of 
disk space for the “Segment” partition. (For the JMPS Enterprise and Enterprise Lite 
configuration the size will be approximately 1/2 of the RAID 1 area.) Click the 
“Next” button. 

Step 20. The Assign Drive Letter or Path dialog will then open. On the Assign a drive 
letter line click the down-arrow button and select “D:” from the drive letter list 
presented if it is not already the default choice. Click the “Next” button. 

Step 21. The Format Partition dialog box will open. Set the File system to “NTFS”, 
leave the Allocation unit size at “Default” and enter “Segments” for the Volume 
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label. Leave the Perform a Quick Format and the Enable file and folder compression 
boxes unchecked. Click the “Next” button. 

Step 22. The Completing the Create Partition Wizard dialog will then appear, click the 
“Finish” button to start the format process. 

Step 23. The status of the Segments D: partition will be “Formatting: (xx%)” with the 
format status percentage updating. Wait until the format operation is completed, the 
drive status will change to “Healthy” when its is completed. 

Step 24. Close the Computer Management window. 
Step 25. Proceed onto Section 6.3. 
 
 

6.2.2 JMPS PICO Configuration 
 
Step 1. Logon to the server into the administrator account. 
Step 2. Upon startup the Windows 2000 Configure Your Server window will open. Close 

this window for now. 
Step 3. In the JMPS PICO Server configuration the server will contain two hard drives 

that have been setup in a hardware RAID 1 configuration and three drives configured 
in a RAID 5 configuration via the above procedures. The first partition C: was 
defined for the basic operating system space. Labeling and formatting operations 
must now be completed to define the second and third partitions for the JMPS PICO 
Server. Select Start->Programs->Administrative Tools->Computer Management. 

Step 4. The Computer Management window will open. In the left-hand box double click 
on the “Disk Management” folder along with a Write Signature and Upgrade Disk 
Wizard dialog box. On the signature dialog click the “Next” button. 

Step 5. The Select Disk to Write Signature dialog will then open, select Disk 1 by 
clicking the check box next to it and then click “Next”. 

Step 6. The Select Disks to Upgrade dialog will then open, de-select Disk 1 and click the 
“Next” button. 

Step 7. The Completing the Write Signature and Upgrade Disk Wizard dialog will open, 
click the “Finish” button. 

Step 8. In the right-hand pane of the Computer Management window the volume 
information will appear for the disk drives in the system. Click on the CDRom 0 drive 
label box and then right-click. 

Step 9. Select “Change Drive Letter and Path…” from the pop-up menu. 
Step 10. The Change Drive Letter and Paths for (D:) will appear. Click the “Edit” 

button. 
Step 11. The Edit Drive Letter or Path dialog box will open, on the Assign a drive 

letter line click the down-arrow key and select the “G:” drive letter from the drop 
down list. Click the “OK” button to set it. 

Step 12. The Confirm dialog box will then open with the following message: 
 

“Changing the drive letter of a volume may cause programs to no longer run. Are 
you sure you want to change this drive letter?” 
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Click the “Yes” button. The drive letter for the CDRom0 will change to “G:” on the 
Computer Management window. 

Step 13. On the Start Menu Bar click Start->Shut Down. On the Shut Down Windows 
dialog that appears click the down-arrow button and select “Restart” from the 
presented list. Click the “OK” button. The server will restart. 

Step 14. After the server restarts logon as the administrator as previously outlined. 
Step 15. Upon boot the Windows 2000 Configure Your Server window will appear. For 

now just close this dialog and proceed with Step 16. 
Step 16. Select Start->Programs->Administrative Tools->Computer Management. 
Step 17. Click the “Cancel” button on the Write Signature and Upgrade Disk Wizard 

dialog box. 
Step 18. The Computer Management window will open. In the left-hand box double 

click on the “Disk Management” folder. 
Step 19. In the right-hand pane of the Computer Management window the volume 

information will appear for the disk drives in the system. Verify that the CDRom 0 
drive label is now “G:” 

Step 20. On the Disk 0 display click on the C: partition, which was built during the 
basic operating system load, and then right-click on it. From the pop-up menu select 
“Properties”. 

Step 21. The Local Disk (C:) Properties dialog box will open. On the General TAB, in 
the Label box enter “System” and click the “OK” button. The Local Disk (C:) 
Properties box will close and the partition display on the Computer Management 
window will update to show the name of the C: partition, “System”. 

Step 22. Select and then right-click on the Unallocated space on Disk 0. Select “Create 
Partition” from the pop-up menu. 

Step 23. The Create Partition Wizard dialog box will open with the Welcome to the 
Create Partition Wizard message. Click the “Next” button. 

Step 24. The Select Partition Type dialog will then appear, select the “Primary 
partition” choice and click the “Next” button. 

Step 25. The Specify Partition Size dialog will then appear, accept the total amount of 
disk space for the “Segment” partition. (For the JMPS PICO Server configuration the 
size of the D: partition will be approximately 1/2 of the RAID 1 area.) Click the 
“Next” button. 

Step 26. The Assign Drive Letter or Path dialog will then open. On the Assign a drive 
letter line click the down-arrow button and select “D:” from the drive letter list 
presented if it is not already the default choice. Click the “Next” button. 

Step 27. The Format Partition dialog box will open. Set the File system to “NTFS”, 
leave the Allocation unit size at “Default” and enter “Segments” for the Volume 
label. Leave the Perform a Quick Format and the Enable file and folder compression 
boxes unchecked. Click the “Next” button. 

Step 28. The Completing the Create Partition Wizard dialog will then appear, click the 
“Finish” button to start the format process. 

Step 29. The status of the Segments D: partition will be “Formatting: (xx%)” with the 
format status percentage updating. Wait until the format operation is completed, the 
drive status will change to “Healthy” when its is completed. 
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Step 30. When the formatting operation for D: finishes, select and then right-click on 

the Unallocated space on Disk 1. Select “Create Partition” from the pop-up menu. 
Step 31. The Create Partition Wizard dialog box will open with the Welcome to the 

Create Partition Wizard message. Click the “Next” button. 
Step 32. The Select Partition Type dialog will then appear, select the “Primary 

partition” choice and click the “Next” button. 
Step 33. The Specify Partition Size dialog will then appear, accept the total amount of 

disk space available on the RAID 5 disk for the “Data” partition. Click the “Next” 
button. 

Step 34. The Assign Drive Letter or Path dialog will then open. On the Assign a drive 
letter line click the down-arrow button and select “E:” from the drive letter list 
presented if it is not already the default choice. Click the “Next” button. 

Step 35. The Format Partition dialog box will open. Set the File system to “NTFS”, 
leave the Allocation unit size at “Default” and enter “Data” for the Volume label. 
Leave the Perform a Quick Format and the Enable file and folder compression boxes 
unchecked. Click the “Next” button. 

Step 36. The Completing the Create Partition Wizard dialog will then appear, click the 
“Finish” button to start the format process. 

Step 37. The status of the Data E: partition will be “Formatting: (xx%)” with the 
format status percentage updating. Wait until the format operation is completed, the 
drive status will change to “Healthy” when its is completed. 

Step 38. Close the Computer Management window. 
Step 39. Proceed onto Section 6.3. 
 
 

6.3 Procedure: Installation of WinZip 
 

NOTE 
 

THE DEMO WINZIP INSTALLATION FILE CAN 
BE DOWNLOADED FROM THE INTERNET, IT 
MAY BE NECESSARY TO DOWNLOAD IT AND 
CREATE A CD CONTAINING THIS FILE FOR THIS 
PROCEDURE. BE SURE TO OBTAIN AN 
OFFICIALLY LICENSED VERSION OF THIS 
PRODUCT. 

 
DURING THE WRITING OF THESE PROCEDURES 
OFFICIAL VERSIONS OF THE WINZIP 8.1 
PROGRAM WERE PURCHASED AND USED TO 
DEFINE THE PROCEDURES BELOW. IF THE 
DEMO VERSION OF THE PROGRAM IS USED THE 
INSTALLATION PROCEDURE MAY DIFFER 
SLIGHTY HOWEVER THE STEPS BELOW 
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SHOULD DEFINE THE BASIC REQUIRED 
PROCEDURE. 
 
DURING THE WRITING OF THIS PROCEDURE 
WINZIP WAS NOT YET A COE SEGMENT. THIS 
HOWEVER WILL CHANGE. WHEN THE COE 
WINZIP SEGMENT IS RELEASED THEN THIS 
PROCEDURE WILL NOT BE FOLLWED. WINZIP 
WILL BE ADDED VIA THE COE INSTALLER. 

 
Step 1. Logon to the server into the administrator account. Close the Windows 2000 

Configure Your Server dialog. 
Step 2. Place the WinZip Version 8.1 CD into the CD-ROM drive. 
Step 3. The installation program should auto-start, if it does not execute the following 

sub-steps: 
 

a) Select Start->Run. 
b) On the Run dialog box click the “Browse” button. 
c) On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the WinZip application installation executable 
“SETUP.exe”, Double click on it to set the path to it in the Run dialog box. 

d) On the Run dialog box click the “OK” button to execute the WinZip setup file. 
 
Step 4. The WinZip 8.1 CD Setup dialog will appear. Click the “Install WinZip” button. 
Step 5. The WinZip Setup dialog box will appear with the following message: 
 

“Setup will install WinZip into the following folder, which it will create if necessary. 
 
If you want to install WinZip in a different folder and/or drive, type the name of the 
folder below: 
 
C:\Program Files\WinZip” 
 
Accept the default location and click the “OK” button. 

 
Step 6. The Thank you for installing WinZip! dialog box will appear next, click the 

“Next” button. 
Step 7. The License Agreement and Warranty Disclaimer dialog box will then open, click 

the “Yes” button to accept the license. 
Step 8. The WinZip Quick Start dialog will open next, click the “Next” button to skip 

viewing / printing the Quick Start Guide. 
Step 9. The Select “Wizard” or “Classic” dialog will then appear, select the “Start with 

WinZip Classic” choice and then click the “Next” button. 
Step 10. The Click “Next” to proceed dialog box will then open, leave the default 

“Express setup (recommended)” choice selected and click the “Next” button. 

38 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 39 
 
Step 11. The WinZip needs to associate itself with your archives dialog box will open. 

By default all supported archive types will be associated with WinZip, click the 
“Next” button. 

Step 12. The Installation is complete dialog box will then open, click the “Finish” 
button. 

Step 13. The WinZip window will open with the WinZip Tip of the Day dialog. On the 
WinZip Tip of the Day dialog box click the down arrow button and select the “Never 
show tips at startup” choice from the list and then click the “Close” button on the 
WinZip Tip of the Day dialog box. 

Step 14. Close the WinZip window and the WinZip 8.1 CD Setup dialog. Notice that 
the WinZip application symbol will now appear in the right-hand corner of the Start 
Bar and a WinZip icon will appear on the desktop. 

Step 15. Remove the WinZip CD from the CD-ROM drive. 
Step 16. Continue the loading procedures in Section 6.4. 
 
 

6.4 Procedure: Load the NC7131 Gigabit Server Adapter Driver 
 

NOTE 
 

ENSURE THAT THE NC7131 NIC IS CONNECTED 
TO THE NETWORK PRIOR TO EXECUTING THE 
PROCEDURES IN THIS SECTION. 

 
Step 1. Logon to the server into the administrator account. Close the Windows 2000 

Configure Your Server dialog. 
Step 2. Select Start->Programs->Administrative Tools->Computer Management. 
Step 3. The Computer Management window will open, in the left-hand list double click 

on the “Device Manager”. 
Step 4. The list of devices will appear in the right-hand side of the Computer 

Management window. Under the “Other devices” item locate the “Ethernet 
Controller” device and double click on it (the device will have a yellow question 
mark on it at this point). 

Step 5. The Ethernet Controller Properties dialog box will open, on the General TAB 
click the “Reinstall Driver” button. 

Step 6. The Upgrade Device Driver Wizard Welcome dialog box will appear, click the 
“Next” button. 

Step 7. The Install Hardware Device Drivers dialog box will open. Accept the default 
“Search for a suitable driver for my device (recommended)” choice and click the 
“Next” button. 

Step 8. The Locate Driver Files dialog box will open, uncheck the “Floppy disk drives” 
location and keep the “CD-ROM drives” search location checked. Insert the Compaq 
Network Server Adapters and Upgrade Modules CD into the CD-ROM drive. (This 
CD should be in the Compaq DL380 package, in the bag, which contains the NC7131 
documentation.) Click the “Next” button. 
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Step 9. The Driver Files Search Results dialog box will open, a search will be executed 

and the NC7131 driver will be found on the CD (g:\win2000\netcpqg.inf). A message 
will be displayed on the dialog box: 

 
“Windows found a driver that is a closer match for this device than your current 
driver. To install the driver Windows found, click Next.” 
 
Click the Next button to load the driver. 
 

Step 10. The Completing the Upgrade Device Driver Wizard dialog will open with the 
following information: 

 
“ Compaq NC7131 Gigabit Server Adapter  
 
Window has finished installing the software for this device.” 
 
Click the “Finish” button. 

 
Step 11. The Ethernet Controller Properties dialog box title will update to “Compaq 

NC7131 Gigabit Server Adapter Properties” and the device status will update to “This 
device is working properly.” Click the “Close” button on the properties dialog box. 

Step 12. The Computer Management window will update. The “Other devices” list will 
no longer have the Ethernet Controller. Now that the driver has been loaded the 
NC7131 will move to the “Network Adapters” list. 

Step 13. In the right-hand list on the Computer Management window double click the 
Network adapters device if necessary to expand the tree. Verify that the NC7131 now 
appears in the list. The list should look like: 

 
“Compaq NC3163 Fast Ethernet NIC 
  Compaq NC3163 Fast Ethernet NIC #2 
  Compaq NC7131 Gigabit Server Adapter” 

 
Step 14. Close the Computer Manager. 
Step 15. Select Start-Settings->Network and Dial-up Connections. 
Step 16. The Network and Dial-up Connections dialog box will open. A new, 

Connection 3, will now be present.  This is the NC7131 adapter. Double click on this 
connection to access the properties. 

Step 17. The Local Area Connection 3 Properties dialog box will open with the 
General TAB open. Click the “Properties” button and perform the following 
operations on the Local Area Connection 3 Properties dialog box: 

 
a) Leave the Client for Microsoft Networks component checked. Double click on the 

Client for Microsoft Networks component to open the component properties. The 
Client for Microsoft Networks Properties dialog box will open, verify that the 
Name service provider is set to Windows Locator. Click the “OK” button. 
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b) Continuing on the Networking Components list leave the Network Load 
Balancing component unchecked. 

c) Leave the File and Printer Sharing for Microsoft Networks component checked. 
Double click on the File and Printer Sharing for Microsoft Networks component 
to open the component properties. The File and Printer Sharing for Microsoft 
Networks Properties dialog box will open, verify that the “Maximize data 
throughput for file sharing” choice is selected, if it is not select it. Click the “OK” 
button. 

d) Leave the Network Monitor Driver component checked. 
e) Leave the Internet Protocol (TCP/IP) component checked. Double click on the 

Internet Protocol (TCP/IP) component to open the component properties. The 
Internet Protocol (TCP/IP) Properties dialog box will open. Click the “Use the 
following IP address” button. Proceed to enter the IP address, Subnet mask and 
Default gateway. Also enter the Preferred DNS server and the Alternate DNS 
server IP addresses if available. During the setup, the preferred DNS server for 
JMPSSERVER1 should be the IP address of its own Gigabit Ethernet adapter. For 
JMPSSERVER2, it must be the IP address of the Gigabit Ethernet adapter on 
JMPSSERVER1. Once the addresses are entered click the “OK” button. 

f) On the Local Area Connection 3 Properties dialog box click the “OK” button. 
g) The Local Network dialog box may open, with the message: 
 

“You must shut down and restart your computer before the new settings will take 
effect. 
 
Do you want to restart your computer now?” 
 
If this message appears, click the “Yes” button to proceed with the reboot.  
 

h) If the restart message does not appear, force a manual reboot by going to Start-
>Shutdown. In the Shut Down Windows dialog select “Restart” from the drop 
down box. Click the “OK” button to perform the system restart. 

i) The system will reboot, leave the Compaq Network Server Adapters and Upgrade 
Modules CD in the CD-ROM drive. 

j) Once the system restarts, open the Windows Explorer, Start->Programs-
>Accessories->Windows Explorer. 

k) On the left-hand side of the Explorer window click on the System (C:) partition to 
select it. 

l) On the Explorer menu select “File” and then “New->Folder” from the drop-down 
menu that appears. 

m) The new folder will appear in the System C: partition on the right-had side of 
Explorer screen. The folder name will be highlighted in dark blue, enter in the 
name “W2KNC7131 Driver” and press “Enter”. 

n) In the Explore browse out to the Compaq Network Server Adapters and Upgrade 
Modules CD-ROM, double click on the top level NCDE61(G:) folder to expand 
the contents of the CD. Select the “WIN2000” subfolder, right click on it and 
select “Copy” from drop down menu that appears. 
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o) Back on the System C: partition click on the newly created W2KNC7131 Driver 
folder, right click and select “Paste” from the drop down menu. This operation 
will place a copy of the Compaq NC7131 Gigabit Server Adapter driver onto the 
System C: partition for future use if required. 

p) Close the Explorer. 
q) Proceed to Section 6.5. 

 

6.5 Procedure: Load the Fibre Channel FCA-2101 Adapter Driver 
 

NOTES 
 

THE FCA-2101 DRIVER MUST BE DOWNLOADED 
FROM THE COMPAQ WEB SITE. AT THE TIME 
THIS INSTRUCTION WAS WRITTEN IT COULD 
BE LOCATED AT THE WEB SITE NOTED BELOW. 
HOWEVER SINCE HP CONTINOUOUSLY 
UPDATES THEIR SITE, THIS LOCATION MAY 
CHANGE.  
 
(http://b18000.www1.hp.com/products/storageworks/softw
aredrivers/33mhzpcifibre/kgpsa_cb_482a9.html#200). 
 
THE CURRENT DRIVER AT THE TIME THIS 
INSTRUCTION WAS WRITTEN WILL BE IN A ZIP 
FILE CALLED “5-482a9driverkit.zip”. IT IS 
SUGGESTED THAT THIS FILE BE PLACED ON A 
FLOPPY AND THEN COPIED TO THE SYSTEM C: 
PARTITION FOR FUTURE AVAILABILITY. AT 
THE TIME THIS PROCEDURE WAS BEING 
WRITTEN THE FCA-2101 DRIVERS MAY HAVE 
BEEN PROVIDED VIA THE NAVY RESELLER ON 
CD. CHECK THE SERVER SOFTWARE 
DISTRIBUTION PACK TO DETERMINE IF THIS 
DISK WAS SENT WITH THE SERVER. IF THE 
DISK IS AVAIABLE THEN IT CAN BE USED TO 
EXECUTE THIS PROCEDURE, NO DOWNLOAD 
WILL BE REQUIRED IN THIS CASE. 
 
THE FCA-2101 LOAD PROCEDURES PRESENTED 
IN THIS SECTION WILL APPLY TO ALL THE 
JMPS SERVER CONFIGURATIONS SINCE THE 
FIBRE CHANEL CARDS ARE IN ALL SERVERS. IN 
THE CASE OF THE PICO SERVER THE FIBRE 
CHANNEL CARDS WILL NOT BE USED AT THE 
PRESENT TIME HOWEVER THIS SECTION 
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SHOULD BE EXECUTED TO LOAD THE DRIVER 
FOR THESE CARDS SO THEY ARE 
OPERATIONAL FOR POSSIBLE FUTURE USE. 
 
AT THIS TIME DO NOT CONNECT FIBRE 
CHANNEL CARDS TO THE FIBRE SWITCHES OR 
TO THE CIPRICO NETARRAY 1100s. 

 
Step 1. Logon to the server into the administrator account. Close the Windows 2000 

Configure Your Server dialog. 
Step 1. Select Start->Programs->Accessories->Windows Explorer. 
Step 2. The Windows Explorer window will open, in the left-hand box double click on 

the “My Computer” item to expand it. 
Step 3. An expanded list will now appear, double click on the System (C:) partition. 
Step 4. The folders in System C: will now be visible in the directory tree. Click on 

System (C:) to select it and then on the Explorer menu click “File”. 
Step 5. On the File drop down menu select “New” and then from the presented list select 

“Folder”. 
Step 6. The New Folder icon will appear in the right-hand Explorer box and the title will 

be highlighted in blue. Type in the label “FCA2101 Driver” and then press “Enter”. 
Step 7. Insert the floppy disk containing the down loaded driver file “5-

482a9driverkit.ZIP” into the (A:) floppy drive. 
Step 8. In the Explorer, in the left-hand box, click on the “3 1/2 Floppy (A:)” drive. 
Step 9. The right-hand Explore box will update to show the contents of the drive, select 

the “5-482a9driverkit.zip” file and then right click. From the pop-up menu that 
appears select “Copy”. 

Step 10. On the left-hand Explorer box re-select the new FCA2101 Driver folder in the 
tree under System C:. Click in the right-hand Explore box and then right click. From 
the pop-up menu that appears select “Paste”. The 5-482a9driverkit.zip file will be 
copied to the new FCA2101 Driver folder. 

Step 11. Remove the driver disk from the (A:) Floppy drive. 
Step 12. In the C:\FCA2101 Driver folder double click on the 5-482a9driverkit.zip file 

to unzip it. 
Step 13. The WinZip 5-482a9driver.zip dialog box will appear, click the "Extract” 

button. 
Step 14. The Extract dialog box will appear. In the Folders/drivers box set the path to 

the FCA2101 Driver folder (C:\FCA2101 Driver). 
Step 15. Once the path is set, click the “Extract” button. 
Step 16. When the extraction is completed, close the WinZip - 5-482a9driverkit.zip 

window. 
Step 17. Close the Windows Explorer. 
Step 18. Select Start->Programs->Administrative Tools->Computer Management. 
Step 19. The Computer Management window will open, in the left-hand list double 

click on the “Device Manager”. 
Step 20. The device list will appear in the right-hand side of the Computer 

Management window. If required, double click on the “Other devices” item to expand 
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the list. In the presented list locate the first “Fibre Channel Controller” device and 
double click on it (the device will have a yellow question mark on it at this point). 

Step 21. The Fibre Channel Controller Properties dialog box will open, on the General 
TAB click the “Reinstall Driver” button. 

Step 22. The Upgrade Device Driver Wizard Welcome dialog box will appear, click 
the “Next” button. 

Step 23. The Install Hardware Device Drivers dialog box will open. Accept the default 
“Search for a suitable driver for my device (recommended)” choice and click the 
“Next” button. 

Step 24. The Locate Driver Files dialog box will open. Uncheck the “Floppy disk 
drives” and the “CD-ROM drives” search locations. Check the “Specify a location” 
choice and click the “Next” button. 

Step 25. The Upgrade Device Driver Wizard dialog box will open, click the “Browse” 
button. 

Step 26. In the Locate File dialog box set the path the FCA2101 Driver folder 
(C:\FCA2101 Driver). Click the “Open” button. 

Step 27. On the Upgrade Device Driver Wizard dialog verify the path in the Copy 
manufacturer’s files from box has updated to “C:\FCA2101 Driver” and then click the 
“OK” button. 

Step 28. The Driver Files Search Results dialog box will open, a search will be 
executed and the FCA2101 driver will be found in the designated folder (C:\fca2101 
driver\oemsetup.inf). A message will be displayed on the dialog box: 

 
“Windows found a driver that is a closer match for this device than your current 
driver. To install the driver Windows found, click Next.” 
 
Click the Next button to load the driver. 
 

Step 29. The Completing the Upgrade Device Driver Wizard dialog will open with the 
following information: 

 
“ Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) 
 
Window has finished installing the software for this device.” 
 
Click the “Finish” button. 
 

Step 30. A window dialog box may open, with the message: 
 

“You must shut down and restart your computer before the new settings will take 
effect. 
 
Do you want to restart your computer now?” 
 

 If this message appears, click the “No” button. 
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Step 31. The Ethernet Controller Properties dialog box title will update to “Compaq 

KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver)” and the device status will 
update to “This device is working properly.” Click the “Close” button on the 
properties dialog box. 

Step 32. The Computer Management window will update. The “Other devices” list will 
no longer have the first Fibre Channel Controller. Now that the driver has been 
loaded the Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) will 
move to the “SCSI and RAID controllers” list. 

Step 33. In the right-hand list on the Computer Management window double click on 
the SCSI and RAID controllers device if required to expand the list. Verify that the 
Fibre Channel HBA now appears in the list. The list should look like: 

 
“Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) 
  Compaq Smart Array 5i” 

 
Step 34. Close the Computer Management window. 
Step 35. Select Start->Shut Down. 
Step 36. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button.  
Step 37. Upon boot the Windows 2000 Configure Your Server window will appear. 

Close this dialog. 
Step 38. A window dialog box may open, with the message: 

 
“You must shut down and restart your computer before the new settings will take 
effect. 
 
Do you want to restart your computer now?” 
 

 If this message appears, click the “Yes” button. 
 
Step 39. Allow the server to restart and then log back onto the system into the 

administrator account. Wait for a few minutes while the second FCA2101 is detected 
and the driver automatically is loaded. Some New Hardware Found dialog boxes may 
open briefly and then close during this process. 

Step 40. Select Start->Programs->Administrative Tools->Computer Management. 
Step 41. The Computer Management window will open, in the left-hand list double 

click on the “Device Manager”. 
Step 42. Double click on the “Other devices” item to inspect the list. 
Step 43. The Computer Management window should be updated. The “Other devices” 

list will no longer have the second Fibre Channel Controller. Now that the driver has 
been loaded the Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) 
will move to the “SCSI and RAID controllers” list. 

Step 44. In the right-hand list on the Computer Management window double click the 
SCSI and RAID controllers device if required to expand the list. Verify that both 
Fibre Channel HBAs now appear in the list. The list should now look like: 
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“Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) 
  Compaq KGPSA-xx, PCI-Fibre Channel HBA (with adjunct driver) 
  Compaq Smart Array 5i” 

 
Step 45. Close the Computer Management window. 
Step 46. Continue with Section 6.6. 
 
 

6.6 Procedure: Load the AIT 50 Tape Drive Driver 
 
Step 1. Logon to the server into the administrator account. 
Step 2. Insert the CD labeled “Storage Works by Compaq Native Drivers” into the CD-

ROM drive. If the Storage Works by Compaq window appears, close it. 
Step 3. Select Start->Programs->Administrative Tools->Computer Management. 
Step 4. The Computer Management window will open, in the left-hand list double click 

on the “Device Manager”. 
Step 5. The device list will appear in the right-hand side of the Computer Management 

window. Under the “Other devices” item locate the “Compaq SDX-500C SCSI 
Sequential Device” device and double click on it (the device will have a yellow 
question mark on it at this point). 

Step 6. The Compaq SDX-500C SCSI Sequential Device Properties dialog box will open, 
click on the Driver TAB to bring it forward. 

Step 7. On the Driver TAB click the “Update Driver” button. 
Step 8. The Upgrade Device Driver Wizard Welcome dialog box will appear, click the 

“Next” button. 
Step 9. The Install Hardware Device Drivers dialog box will open. Accept the default 

“Search for a suitable driver for my device (recommended)” choice and click the 
“Next” button. 

Step 10. The Locate Driver Files dialog box will open. Check the “CD-ROM drives” 
search location and uncheck the other search locations. Click the “Next” button. 

Step 11. The Drivers Files Search Results dialog box will the appear with the message: 
 

“The wizard found a driver for the following device: 
 
COMPAQ SDX-500C SCSI Sequential Device 
 
Windows found a driver that is a closer match for this device than your current 
driver. To install the driver Windows found, click Next. 
 
g:\drivers\standalonetapedrives\w2000\ait\caitw2i.inf” 
 
Click the “Next” button. 

 
Step 12. The Completing the Upgrade Device Driver Wizard dialog box will open with 

the following information: 
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“Compaq AIT 50 GB Drive 
 
Windows has finished installing the software for this device.” 
 
Click the “Finish” button. 

 
Step 13. The Compaq SDX-500C SCSI Sequential Device Properties dialog box title 

will update to “Compaq AIT 50 GB Drive Properties” and the device status will 
update to “This device is working properly.” Click the “Close” button on the 
properties dialog box. 

Step 14. The Computer Management window will update. The “Other devices” list will 
no longer exist at this point in the server configuration. Now that the driver has been 
loaded the Compaq AIT 50 GB drive will move to the “Tape drives” device list. 

Step 15. In the right-hand list on the Computer Management window double click the 
Tape drives device to expand the list if necessary. Verify that the Compaq AIT 50 
tape drive now appears in the list. The list should look like: 

 
“Compaq AIT 50 GB Drive” 

 
Step 16. Close the Computer Manager. 
Step 17. Open the Windows Explorer, Start->Programs->Accessories->Windows 

Explorer. 
Step 18. On the left-hand side of the Explorer window click on the System (C:) 

partition to select it. 
Step 19. On the Explorer menu select “File” and then “New->Folder” from the drop-

down menu that appears. 
Step 20. The new folder will appear in the System C: partition on the right-had side of 

Explorer screen. The folder name will be highlighted in dark blue, enter in the name 
“AIT50 Tape Driver” and press “Enter”. 

Step 21. In the Explore browse out to the Compaq StorageWorks by Compaq Native 
Drivers CD. Double click on the top level Native_Drvrs_1.2(G:) folder to expand the 
contents of the CD. Select the “DRIVERS” subfolder, right click on it and select 
“Copy” from drop down menu that appears. 

Step 22. Back on the System C: partition click on the newly created AIT50 Tape 
Driver folder, right click and select “Paste” from the drop down menu. This operation 
will place a copy of the Compaq AIT 50 Tape driver on onto the System C: partition 
for future use if required. 

Step 23. Close the Explorer. 
Step 24. Remove the Storage Works by Compaq Native Drivers CD from CD-ROM 

drive. 
Step 25. Continue with Section 6.7. 
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6.7 Procedure: Copy I386 Folder and Install Administrator Pack and 2000 

Resource Kit 
 
Step 1. Logon to the server into the administrator account. Close the Windows 2000 

Configure Your Server dialog. 
Step 2. Place the Windows 2000 Advanced Server CD into the CD-ROM drive. 
Step 3. If the Auto-Start Microsoft Windows 2000 Advanced Server Installation screen 

appears click the “Exit” button  
Step 4. Start the Windows Explorer, Start->Programs->Accessories->Windows Explorer. 
Step 5. In the Explore browse out to the CD-ROM, to the Windows 2000 Advanced 

Server CD. Double click on the CD to expand the view to include its subfolders. 
Step 6. In the left-hand pane of the Explorer window, from the directory tree on the CD 

select the “I386” folder and right click on it. 
Step 7. Select “Copy” from the pop-up menu that appears. 
Step 8. In the Explorer tree select the System C: partiton and right click on it. 
Step 9. From the pop-up memu select “Paste”. This will place a copy of the I386 folder 

on the system partition for future use. 
Step 10. Once the I386 folder copy operation completes, in the Explore browse to the 

new I386 folder on the System C: partition, select it and then double clickon it to 
open it. 

Step 11. In the main I386 folder locate the “ADMINPAK.MSI” installer package, then 
double click on it to begin the installation of the Windows 2000 Administration 
Tools. 

Step 12. The Windows 2000 Administration Tools Setup Wizard dialog box will open 
with the Welcome to the Windows 2000 Administration Tools Setup Wizard dialog. 
Click the “Next” button to begin the installation. 

Step 13. If the Windows 2000 Administrative Tools Setup Wizard - Setup Options 
dialog box appears, select the “Install all of the Administrative Tools” choice and 
click the “Next” button. If this prompt does not appear the full suite of administrative 
tools will automatically be installed. 

Step 14. When the installation completes, the Completing the Windows 2000 
Administration Tools Setup Wizard - You have successfully installed the Windows 
2000 Administration Tools dialog will open, click the “Finish” button. 

Step 15. Back in the Windows Explorer, browse back out to the Windows 2000 
Advanced Server CD. 

Step 16. Browse to the Tools subfolder on the CD (SUPPORT\TOOLS). 
Step 17. In the Tools folder double click on Setup.exe to begin the installation of the 

Windows 2000 Resource Kit. 
Step 18. The Windows 2000 Support Tools Setup Wizard Welcome dialog box will 

open, click the “Next” button. 
Step 19. The User Information dialog will open next, it will be filled in with the 

information that was entered during the Windows 2000 Advanced Server software 
installation, click the “Next” button to continue. 

Step 20. The Select An Installation Type dialog box will then open, leave the default 
“Typical” choice selected and click the “Next” button. 
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Step 21. The Begin Installation dialog box will open next, click the “Next” button to 

begin the installation of the support tools. 
Step 22. The Completing the Windows 2000 Support Tools Setup Wizard dialog box 

will open when the installation completes, click the “Finish” button. 
Step 23. Close the Windows Explorer. 
Step 24. Remove the Windows 2000 Advanced Server CD from the CD-ROM drive. 
Step 25. Continue with Section 6.8. 
 
 

6.8 Procedure: Installation of Microsoft Windows 2000 Resource Kit 
 

NOTE 
 

THE MICROSOFT WINDOWS 2000 RESOURCE 
KIT SHOULD BE INCLUDED WITH THE JMPS 
SERVER. THIS KIT CONTAINS THE FULL 
DOCUMENTATION LIBRARY AND THE CD 
CONTAINING THE RESOURCE KIT. 

 
Step 1. Logon to the server into the administrator account. 
Step 2. Place the Microsoft Windows 2000 Server Resource Kit CD into the CD-ROM 

drive. 
Step 3. The Microsoft Windows 2000 Server Resource Kit installation should start 

automatically, the Microsoft Windows 2000 Resource Kit CD-ROM window should 
open. If it does not follow the sub-steps below. 

 
a) Select Start->Run. 
b) On the Run dialog box click the “Browse” button. 
c) On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the setup file for the Resource Kit (RESKIT2000 (G:) 
d) In the main folder double click on the “Setup.exe” file to set the path to it in the 

Run dialog box. 
e) On the Run dialog box click the “OK” button to begin the installation of the 

Resource Kit. 
 
Step 4. On Microsoft Windows 2000 Server Resource Kit CD-ROM window, click the 

“Install Resource Kit” button. 
Step 5. The Welcome to the Microsoft Windows 2000 Resource Kit Setup Wizard dialog 

box will open, click the “Next” button. 
Step 6. The End User License Agreement dialog box will appear next, click the “I Agree” 

button and then click the “Next” button to accept the license. 
Step 7. The User Information dialog will open next, it will be filled in with the 

information that was entered during the Windows 2000 Advanced Server software 
installation, click the “Next” button to continue. 
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Step 8. The Select An Installation Type dialog box will then open, leave the default 

“Typical” choice selected and click the “Next” button. 
Step 9. The Begin Installation dialog box will open next, click the “Next” button to begin 

the installation of the Resource Kit. 
Step 10. The Progress dialog box will appear to show the status of the installation 

process, wait until the installation completes. 
Step 11. The Completing the Microsoft Windows 2000 Resource Kit Setup Wizard 

dialog box will open when the installation completes, click the “Finish” button. 
Step 12. On the Microsoft Windows 2000 Resource Kit CD-ROM window click the 

“<Exit>” button. 
Step 13. Remove the Windows 2000 Server Resource Kit CD from the CD-ROM 

drive. 
Step 14. Continue the installation with Section 6.9. 
 
 

6.9 Procedure: Installation of JAVA SDK 
 

NOTE 
 
THE JAVA SDK INSTALLATION FILE WILL NEED 
TO BE DOWNLOADED FROM THE INTERNET 
AND A CD CONTAINING THIS FILE WILL NEED 
TO BE MADE FOR THIS PROCEDURE. JMPS 
WEBSITE HOSTED BY CHINA LAKE HAS THIS 
FILE ON THE SAME WEB PAGE AS THE LATEST 
JC1 BUILDS. 

 
Step 1. Logon to the server into the administrator account. 
Step 2. Place the CD containing the Java SDK installation program into the CD-ROM 

drive. 
Step 3. Select Start->Run. 
Step 4. On the Run dialog box click the “Browse” button. 
Step 5. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the setup file for the Java SDK application “j2sdk-1_4_1_02-
windows-i586.exe” and double click on it to set the path to it in the Run dialog box. 

Step 6. On the Run dialog box click the “OK” button to execute the Java SDK setup file. 
Step 7. The Java(TM) 2 SDK, Standard Edition, v1.4.1_02 Setup screen will appear with 

the Welcome dialog box, click the “Next” button. 
Step 8. The Software License Agreement dialog box will then appear click the “Yes” 

button to accept it. 
Step 9. The Choose Destination Location dialog box will then appear, accept the default 

location “C:\jdk1.4.1_02” click the “Next” button. 
Step 10. The Select Browsers dialog box will then open. Since both Microsoft Internet 

Explorer and Netscape will be utilized, click both the “Microsoft Internet Explorer” 
and “Netscape” selection boxes; then click the “Next” button. 
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Step 11. The Select Components dialog box will then open, by default all the 

components will be selected, accept this choice by clicking the “Next” button. 
Step 12. The Copying program files… dialog box will open briefly then close after the 

files are copied. 
Step 13. The Setting Up Java 2 Run Time Environment, Please wait dialog will open 

briefly and then close after the environment is setup. 
Step 14. The Setup Complete dialog box will then open, click the “Finish” button. 
Step 15. Remove the Java SDK CD from the CD-ROM drive. 
Step 16. On the Start Menu Bar select Start->Shut Down. 
Step 17. On the Shut Down Windows dialog box that appears use the down-arrow key 

and select the “Restart” option. Click the “OK” button to restart the system. 
Step 18. Continue the installation with Section 6.10. 
 
 

6.10 Procedure: Active Directory (AD) and Domain Name Server Configuration 
(DNS) 

6.10.1 JMPS Enterprise 

6.10.1.1 First Server in the Cluster 
 

NOTES 
 

FOR THE JMPS ENTERPRISE CONFIGURATION 
VERIFY THAT THE JMPS SERVERS ARE 
ISLOATED TOGETHER ON THE NETWORK AT 
THIS TIME. IF OTHER WINDOWS 2000 DOMAIN 
CONTROLLERS ARE PRESENT ON THE 
NETWORK DURING THE ACTIVE DIRECTORY 
CONFIGURATION ON THE FIRST JMPS SERVER, 
PROBLEMS MAY RESULT. 
 
FOR THE JMPS ENTERPRISE CONFIGURATION 
VERIFY THAT THE TWO ON-BOARD 10/100 NICS 
ARE NOT CONNECTED AT THIS TIME AND THAT 
THEY ARE DISABLED AND UNREGISTERED 
FROM DNS AS PER SECTION 6.1. ENSURE THAT 
THE GIGABYTE NICS IN BOTH SERVERS ARE 
NOW CONNECTED TO THE NETWORK. ALSO 
VERIFY THAT THE PERFERED DNS ADDRESS IS 
SET ON BOTH GIGABYTE NICS TO THE IP 
ADDRESS OF THE GIGABYTE NIC LOCATED IN 
THE FIRST JMPS SERVER. THE 10/100 NICS WILL 
BE DEDICATED TO CLUSTERING OPERATIONS 
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FOR THE ENTERPRISE CONFIGURATION LATER 
IN THE PROCEDURES. 
 
ONCE THE DNS SETTINGS ARE MADE IN THIS 
SECTION, THE CLIENT MACHINES SHALL BE 
GIVEN THE ADDRESS OF JMPSSERVER1 AS THE 
PRIMARY DNS SERVER AND THE ADDRESS OF 
JMPSSEVER2 AS THE SECONDARY DNS SERVER. 
 

 
Step 1. Shut down JMPSSERVER2.  
Step 2. On JMPSSERVER1 select Start->Shut Down. 
Step 3. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button. 
Step 4. Logon to the system into the administrator account. 
Step 5. The Windows 2000 Configure Your Server windows will appear.  On the left-

hand side of this window click the “Active Directory” button. 
Step 6. The Active Directory dialog will open.  Use the scroll bar to go to the bottom of 

the dialog, locate the “Start the Active Directory wizard” button and click on it. 
Step 7. The Welcome to the Active Directory Installation Wizard dialog will appear, click 

the “Next” button to continue. 
Step 8. The Domain Controller Type dialog box will then open.  Since JMPS will have its 

own domain, a new one will have to be created.  Select the “Domain controller for a 
new domain” option and then click the “Next” button. 

Step 9. The Create Tree or Child Domain dialog box will open, for JMPSSERVER1 
select the “Create a new domain tree” choice and click the “Next” button. 

Step 10. The Create or Join a Forest dialog box will then open.  Accept the default 
“Create a new forest of domain tress” option.  Click the “Next” button. 

Step 11. The New Domain Name dialog will appear requesting domain information: 
 

“Type the full DNS name for the new domain. 
 
If your organization already has a DNS domain name registered with an Internet 
naming authority, you can use that name.” 
 
The Active Directory for JMPS will consist of a single domain for each deployment 
case.  Enter the domain name “JMPS.(SHIP/SITE NAME).NAVY.SMIL.MIL” in the 
Full DNS name for new domain box (where the “SHIP” name will be the standard 
form used by GOTS-DELTA and the “SITE” name is a descriptive name for the site, 
i.e. for SSC-SD C4I Philadelphia it would be “PHILLY”).  The Internet registered 
domain name is “smil.mil”.  Click the “Next” button.  This may take a few minutes, 
be patient and wait for the process to complete. 

 
Step 12. The NetBIOS Domain Name dialog will then open.  The Domain NetBIOS 

name by default will be the first part of the domain name defined above, “JMPS”.  
Accept the default “JMPS” NetBIOS name and click the “Next” button. 
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Step 13. The Database and Log Locations dialog box will open next.  Accept the 

default locations (C:\WINNT\NTDS for the Active Directory database and 
C:\WINNT\NTDS for the Active Directory log) by clicking the “Next” button. 

Step 14. The Share System Volume dialog box will then open.  Accept the default 
location (C:\WINNT\SYSVOL) by clicking the “Next” button.  This may take a few 
minutes, be patient and wait for the process to complete. 

Step 15. If the JMPS system is on an isolated network, which it should be during this 
setup, the Active Directory Installation Wizard Warning dialog box may appear with 
the following message: 

 
“The wizard cannot contact the DNS server that handles the name 
“JMPS.(SHIP/SITE NAME).navy.smil.mil” to determine if it supports dynamic 
update. Confirm your DNS configuration, or install and configure a DNS server on 
this computer. 
 
Click the “OK” button to acknowledge this warning. 

 
Step 16. The Configure DNS dialog box will then open.  Select the “No, I will install 

and configure DNS myself” option, then click the “Next” button. 
Step 17. The Permissions dialog box will then appear.  Select the “Permissions 

compatible only with Windows 2000 servers” button and then click the “Next” 
button. 

Step 18. The Directory Services Restore Mode Administrator Password dialog box will 
then open.  Enter the password for the administrator account into both the Password 
and Confirm boxes.  Press the “Next” button when finished. 

Step 19. The Summary dialog will then open.  Review the choices made, if required 
press the “Back” key to fix any mistakes, otherwise press the “Next” button to install 
Active Directory on the server. 

Step 20. Several Windows Component Wizard and Active Directory dialog boxes will 
open and close as the configuration proceeds.  Wait until all these processes 
complete. 

Step 21. The Completing the Active Directory Installation Wizard dialog will appear.  
Click the “Finish” button. 

Step 22. The Active Directory Installation Wizard dialog box will open with the 
following message: 

 
“Windows must be restarted before the changes made by the Active Directory 
Installation wizard take effect.” 
 
Click the “Restart Now” button. 

 
Step 23. Upon restart, log back onto the system into the administrator account.  When 

the server restarts it is likely that a “Service Control Manger” error dialog box will 
appear.  If this event occurs, restart the server a second time.  (During initial testing 
its was noted that not all the services may start upon the first boot with Active 
Directory installed, a second restart appeared to solve these issues.) 
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Step 24. After restarting and logon, the Windows 2000 Configure Your Server dialog 

box will open.  Uncheck the “Show this screen at startup” check box and then close 
the Windows 2000 Configure Your Server dialog box to prevent this screen from 
appearing each time the server is started. 

Step 25. Go to Start  Run and type “regedit”. Click OK. 
Step 26. In the tree in the left pane, navigate to 

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup. 
Step 27. In the right pane, double-click on the SourcePath key. 
Step 28. In the window that comes up, change “D:\” to “C:\”. 
Step 29. Click OK. 
Step 30. Close the Registry Editor window. 
Step 31. On the Start Menu Bar click Start->Settings->Control Panel. 
Step 32. The Control Panel dialog box will then open.  Double click on the 

“Add/Remove Programs” icon. 
Step 33. The Add/Remove Programs dialog box will open. On the left-hand side click 

on the “Add/Remove Windows Components” button. 
Step 34. The Windows Components Wizard dialog box will open, use the scroll bar, 

and select the “Networking Services” component.  Double click on it to open its 
subcomponents. 

Step 35. The Networking Services Subcomponents of Networking Service dialog box 
will open.  On the list verify that the “Dynamic Host Configuration Protocol 
(DHCP)” component is not selected.  If it is selected, deselect it.  Click the “OK” 
button. (During the JMPS server operating system configuration this was not selected 
however this step is taken to ensure that DHCP was not installed by the Active 
Directory service setup.  Since JMPS will run on classified networks, DHCP must be 
removed or deactivated). 

Step 36. On the Windows Components dialog box use the scroll bar, check the box 
next to the “Message Queuing Service” component.  Click the “Next” button. 

Step 37. The Message Queuing Type dialog box will open, accept the default 
“Message Queuing server” selection and check the “Enable routing” check box.  
Click the “Next” button. 

Step 38. The Windows NT 4.0 Message Queuing Clients dialog box will then open.  
Accept the default “No, do not change the permissions” choice, click the “Next” 
button. 

Step 39. The Configuring Component dialog box will open, some files will be copied, 
and the Configuring Components dialog box will begin to update. It may take several 
minutes for the process to complete.  When completed the Completing the Windows 
Components Wizard dialog box will open, click the “Finish” button. 

Step 40. Close the Add/Remove window, click the “Close” button. 
Step 41. Close the Control Panel window. 
Step 42. Select Start->Shut Down. 
Step 43. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button. Allow the server to restart. 
Step 44. Logon back onto the system into the administrator account. 
Step 45. Select Start->Settings->Network and Dial-up Connections. 
Step 46. Double click on the “Local Area Connection 3” connection. 
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Step 47. On the Local Area Connection 3 Status box that appears click the “Properties” 

button. 
Step 48. On the Local Area Connection 3 Properties box that opens verify that the card 

description is “Compaq NC7131 Gigabit Server Adapter”.  If this is not the correct 
NIC, repeat Steps 41 and 42 on the other Local Area Connections listed in the 
Network and Dial-up Connections dialog until the one for the NC7131 is located. 

Step 49. Once the Compaq NC7131 Gigabit Server Adapter properties dialog has been 
located, double click on the “Internet Protocol (TCP/IP)” component. 

Step 50. The Internet Protocol (TCP/IP) Properties dialog box will open.  Verify that 
the address is correct.  During the design of the JMPS server it was noted that if the 
DHCP service was removed the IP address for the Gigabyte NIC changed to 
10.10.1.1.  If the address has changed repeat Steps 15 and 16 in Section 6.4 to correct 
this condition.  If the IP address is correct, click the “Cancel” button on the Internet 
Protocol (TCP/IP) Properties box, and on the Local Area Connection Properties 
dialog box.  Also close the Local Area Connection Status and the Network and Dial-
up Connections dialog boxes. 

Step 51. Go to Start->Programs->Administrative Tools->Configure Your Server. 
Step 52. In the left pane, click on Networking and then click on DNS right below 

Networking. 
Step 53. In the right pane, click on Set Up DNS. Some files will be copied. 
Step 54. Close the Configure Your Server window. 
Step 55. Go to the DNS configuration tool (Start->Programs->Administrative Tools-

>DNS. 
Step 56. The DNS configuration dialog box will open.  In the left-hand pane select the 

JMPSSERVER1 and right-click.  Select “Configure the Server..” from the menu. 
Step 57. The Configure DNS Server Wizard dialog will open, click the “Next” button. 
Step 58. The Collecting Setup Information dialog will open and then the Root Server 

dialog box will appear. 
Step 59. Accept the default “This is the first DNS server on this network” choice, click 

the “Next” button. 
Step 60. The Forward Lookup Zone dialog will then open.  Select the “Yes, create a 

forward lookup zone.”. 
Step 61. The Zone Type dialog box will then open, select the “Active Directory-

integrated” type.  Click the “Next” button. 
Step 62. The Zone Name dialog will then open.  Set the name of the zone to 

“JMPS.(SHIP/SITE NAME).NAVY.SMIL.MIL” and click the “Next” button. 
Step 63. The Reverse Lookup Zone dialog box will open.  Select the “Yes, create a 

reverse lookup zone” choice.  Click the “Next” button. 
Step 64. The Zone Type dialog box will then open, select the “Active Directory-

integrated” type.  Click the “Next” button. 
Step 65. The Reverse Lookup Zone dialog box will then open.  Leave the Network ID 

choice selected and enter in the first part of the IP address assigned to the NC7131 
NIC on JMPSSERVER1.  For example, if the IP address of the NIC is 
123.456.789.012, enter 123.456.789. The Reverse lookup zone name box will 
automatically update as the IP address is filled in.  Click the Next button. 
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Step 66. The Completing the Configure DNS Server Wizard dialog box will open.  

Click the “Finish” button. 
Step 67. A DNS warning box may appear at this point with the following warning: 
 

“The forward lookup zone cannot be added to the server. The zone already 
exists.” 
 
If this warning appears click the “OK” button to continue. 

 
Step 68. Select Start->Shut Down. 
Step 69. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button.  Allow JMPSSERVER1 to restart. 
 
Proceed to Section 6.10.1.2 and start the installation of Active Directory and DNS on 
JMPSSERVER2 at this point. At the end of that section there will be a note to come 
back to this point to complete JMPSSERVER1 installation. 
 
Step 70. Logon to JMPSSERVER1 into the administrator account. 
Step 71. Go to the DNS configuration tool (Start->Programs->Administrator Tools-

>DNS. 
Step 72. In the left-hand pane select the Forward Lookup Zones and double click on it 

to expand the sub-tree.  Under the Forward Lookup Zones branch select the “.” (root) 
DNS Zone, then right-click on it. 

Step 73. On the pop-up menu select “Delete” to delete the root DNS Zone from 
JMPSSERVER1. 

Step 74. The DNS confirm delete dialog will open, click the “OK” button to proceed. 
Step 75. Close all DNS dialogs. 
Step 76. Select Start->Shut Down. 
Step 77. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button.  Allow JMPSSERVER1 to restart. A warning window about 
mmc.exe not closing may come up. Click End Now to proceed with the reboot. 

Step 78. Logon back onto JMPSSERVER1 into the administrator account. 
Step 79. Go to the DNS configuration tool (Start->Programs->Administrator Tools-

>DNS. 
Step 80. In the left-hand pane of the DNS dialog select the JMPSSERVER1 server and 

double click on it to expand the DNS tree. 
Step 81. The JMPSSERVER1 Properties dialog box will open.  Click on the 

“Forwarders” TAB to bring it to the front. 
Step 82. On the Forwarders TAB for the second server click the “Enable forwarders” 

check box to enable the forwarding feature. 
Step 83. In the IP Address box enter the first DNS forwarding address to be the address 

of the shipboard DNS server, and then click the “Add” button to add this address to 
the forwarder IP list. 

Step 84. Repeat Step 74 for any additional DNS servers that JMPS will require as 
forwarders, adding each to the Forwarder list. 
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Step 85. Once completed, click the “OK” button the JMPSSERVER1 Properties 

dialog. 
Step 86. Close all DNS dialogs. 
Step 87. On JMPSSERVER1 select Start->Shut Down. 
Step 88. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button. 
Step 89. Allow the server to fully restart, logon is not necessary at this time.  
 
Proceed back to Step 70 in Section 6.10.1.2 at this time to complete the DNS setup 
for the JMPS Enterprise Server configuration. 
 
 

6.10.1.2 Second Server in the Cluster 
 

NOTES 
 

AT THIS POINT IN THE PROCEDURE, IT IS 
ASSUMED THAT SECTIONS 6.1 TO 6.9 HAVE 
BEEN EXECUTED ON JMPSSERVER2 FOR THE 
JMPS ENTERPRISE CONFIGURATION. IF THESE 
STEPS HAVE NOT BEEN COMPLETED ON THE 
SECOND SERVER, EXECUTE THEM NOW 
BEFORE CONTINUING WITH THIS SECTION. 
 
ONCE THE DNS SETTINGS ARE MADE IN THIS 
SECTION, THE NETWORK CONFIGURATION OF 
THE CLIENT MACHINES SHALL BE GIVEN THE 
ADDRESS OF JMPSSERVER1 AS THE PRIMARY 
DNS SERVER AND THE ADDRESS OF 
JMPSSEVER2 AS THE SECONDARY DNS SERVER. 

 
Step 1. Power ON JMPSSERVER2 in the Enterprise suite. 
Step 2. Logon to the local system into the administrator account. The Windows 2000 

Configure Your Server windows will appear. 
Step 3. Go to Start  Run and type “regedit”. Click OK. 
Step 4. In the tree in the left pane, navigate to 

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup. 
Step 5. In the right pane, double-click on the SourcePath key. 
Step 6. In the window that comes up, change “D:\” to “C:\”. 
Step 7. Click OK. 
Step 8. Close the Registry Editor window. 
Step 9. In the Windows 2000 Configure Your Server window, click the “One or more 

servers are already running in my network” selection and then click the “Next” 
button. 
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Step 10. The Configure Your Server dialog will then open.  A menu of the available 

services that can be installed will be presented on the left-hand side of the screen. 
Click the “Active Directory” choice. 

Step 11. The Active Directory dialog will open, use the scroll bar to go to the bottom 
of the box and click the “Start” link to begin the setup of Active Directory on 
JMPSSERVER2. 

Step 12. The Active Directory Installation Wizard dialog box will open with the 
Welcome to the Active Directory Installation Wizard dialog, click the “Next” button. 

Step 13. The Domain Controller Type dialog box will then open. Select the 
“Additional domain controller for an existing domain” choice and then click the 
“Next” button. 

Step 14. The Network Credentials dialog box will open, enter in the information for the 
administrator account (on JMPSSERVER1) where the domain was initially 
configured and the name of the domain in the appropriate boxes.  Click the “Next” 
button to continue.  

Step 15. The Additional Domain Controller dialog box will open. Click Browse.  
Step 16. In the window that opens, single-click on the only domain name listed 

(JMPS.(SHIP/SITE NAME).NAVY.SMIL.MIL). Click OK. Press the “Next” button 
to continue when completed. 

Step 17. The Database and Log Locations dialog will then open.  Accept the default 
location of “C:\WINNT\NTDS” for the Active Directory database and the default 
location of “C:\WINNT\NTDS” for the Active Directory log.  Click the “Next” 
button. 

Step 18. The Shared System Volume dialog box will then open.  Accept the default 
“C:\WINNT\SYSVOL” location and click the “Next” button. 

Step 19. The Directory Services Restore Mode Administrator Password dialog box will 
open, enter the password for the JMPSSERVER2 administrator account in the 
Password and Confirm password boxes.  Click the “Next” button when finished. 

Step 20. The Summary dialog box will then open with a display of the selected choices 
for the Active Directory setup on JMPSSERVER2, review the choices and then click 
the “Next” button. 

Step 21. The Configuring Active Directory dialog will appear, allow the process to 
complete. 

Step 22. The Completing the Active Directory Installation Wizard dialog will then 
appear. Click the “Finish” button. 

Step 23. The Active Directory Installation Wizard dialog box will then open with the 
message: 

 
“Windows must be restarted before the changes made by the Active Directory 
Installation wizard take effect.” 
 
Click the “Restart Now” button. 

 
Step 24. Upon restart, log back onto the system into the Administrator account.  The 

password for the Administrator account will now be the same as the one used on 
JMPSSERVER1.  After restarting and logon, the Windows 2000 Configure Your 
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Server dialog box will open, uncheck the “Show this screen at startup” check box and 
then close the Windows 2000 Configure Your Server dialog box to prevent this 
screen from appearing each time the server is started. 

Step 25. On the Start Menu Bar click Start->Settings->Control Panel. 
Step 26. The Control Panel dialog box will then open. Double click on the 

“Add/Remove Programs” icon. 
Step 27. The Add/Remove Programs dialog box will open. On the left-hand side click 

on the “Add/Remove Windows Components” button. 
Step 28. The Windows Components Wizard dialog box will open, use the scroll bar, 

and select the “Networking Services” component. Double click on it to open its 
subcomponents. 

Step 29. The Networking Services Subcomponents of Networking Service dialog box 
will open. On the list uncheck the “Dynamic Host Configuration Protocol (DHCP)” 
component if it is selected and click the “OK” button.  If it is not selected, click the 
“Cancel” button and continue at Step 23. (During the JMPS server operating system 
configuration this was not selected however the Active Directory service setup may 
re-install it.  Since JMPS will run on classified networks, DHCP must be removed or 
deactivated.) 

Step 30. On the Windows Components dialog box use the scroll bar, check the box 
next to the “Message Queuing Service” component.  Click the “Next” button. 

Step 31. The Message Queuing Type dialog box will open, accept the default 
“Message Queuing server” selection and check the “Enable routing” check box.  
Click the “Next” button. 

Step 32. The Configuring Components dialog box will begin to update, it may take 
several minutes for the process to complete. When completed the Completing the 
Windows Components Wizard dialog box will open, click the “Finish” button. 

Step 33. Close the Add/Remove window. 
Step 34. Close the Control Panel window. 
Step 35. Select Start->Shut Down. 
Step 36. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button, allow JMPSSERVER2 to restart. 
Step 37. Logon to the local system into the administrator account. 
Step 38. Select Start->Settings->Network and Dial-up Connections. 
Step 39. Double click on the “Local Area Connection 3” connection. 
Step 40. On the Local Area Connection 3 Status box that appears click the “Properties” 

button. 
Step 41. On the Local Area Connection 3 Properties box that opens verify that the card 

description is “Compaq NC7131 Gigabit Server Adapter”.  If this is not the correct 
NIC, repeat Steps 33 and 34 on the other Local Area Connections listed in the 
Network and Dial-up Connections dialog until the one for the NC7131 is located. 

Step 42. Once the Compaq NC7131 Gigabit Server Adapter properties dialog has been 
located, double click on the “Internet Protocol (TCP/IP)” component. 

Step 43. On the Local Area Connection Properties box that opens double click on the 
“Internet Protocol (TCP/IP)” component. 

Step 44. The Internet Protocol (TCP/IP) Properties dialog box will open.  Verify that 
the address is correct.  During the design of the JMPS server it was noted that if the 
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DHCP service was removed the IP address for the Gigabyte NIC changed to 
10.10.1.1.  If the address has changed repeat Steps 16 and 17 in Section 6.4 to correct 
this condition.  If the IP address is correct, click the “Cancel” button on the Internet 
Protocol (TCP/IP) Properties box, and on the Local Area Connection 3 Properties 
dialog box.  Also close the Local Area Connection 3 Status and the Network and 
Dial-up Connections dialog boxes. 

Step 45. Go to Start->Programs->Administrative Tools->Configure Your Server. 
Step 46. In the left pane, click on Networking and then click on DNS right below 

Networking. 
Step 47. In the right pane, click on Set Up DNS. Some files will be copied. 
Step 48. Close the Configure Your Server window. 
Step 49. Open the DNS configuration tool (Start->Programs->Administrator Tools-

>DNS. 
Step 50. The DNS configuration dialog box will open.  In the left-hand pane select the 

JMPSERVER2 and right-click.  Select “Configure the Server..” from the menu. 
Step 51. The Configure DNS Server Wizard dialog will open, click the “Next” button. 
Step 52. The Collecting Setup Information dialog will open and then the Root Server 

dialog box may appear. If not, skip the next step and proceed with step 54. 
Step 53. If the Root Server dialog box appears, select the “One or more DNS servers 

are running on this network” choice.  In the IP Address box enter the address of 
JMPSSERVER1 and click the “Next” button. 

Step 54. The Forward Lookup Zone dialog will then open.  Select the “Yes, create a 
forward lookup zone.”. 

Step 55. The Zone Type dialog box will then open, select the “Active Directory-
integrated” type.  Click the “Next” button. 

Step 56. The Zone Name dialog will then open.  Set the name of the zone to the same 
one setup for the first JMPS Server in Section 6.10.1.1, “JMPS.(SHIP/SITE 
NAME).NAVY.SMIL.MIL” and click the “Next” button. 

Step 57. The Reverse Lookup Zone dialog box will open.  Select the “Yes, create a 
reverse lookup zone” choice.  Click the “Next” button. 

Step 58. The Zone Type dialog box will then open, select the “Active Directory-
integrated” type.  Click the “Next” button. 

Step 59. The Reverse Lookup Zone dialog box will then open.  Leave the Network ID 
choice selected and enter in the first part of the IP address assigned to 
JMPSSERVER2, this should be exactly the same as the address used for the 
JMPSSERVER1, (the Reverse lookup zone name box will automatically update as 
the IP address is filled in).  Click the “Next” button. 

Step 60. The Completing the Configure DNS Server Wizard dialog box will open.  
Click the “Finish” button. 

Step 61. A DNS warning box may at this point with the following warning: 
 

“The forward lookup zone cannot be added to the server. The zones already 
exists.” 
 
If this warning appears just click the “OK” button to continue. 
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Step 62. The same warning may appear regarding reverse lookup zone. Just click 

“OK” to continue. 
Step 63. In the left-hand pane of the DNS dialog, select JMPSSERVER2 and then right 

click.  On the drop down menu select “Properties”. 
Step 64. The JMPSSERVER2 Properties dialog box will open.  Click on the 

“Forwarders” TAB to bring it to the front. 
Step 65. On the Forwarders TAB click the “Enable forwarders” check box to enable 

the forwarding feature. 
Step 66. In the IP Address box enter the first DNS forwarding address to be the 

Gigabyte network card of the JMPSSERVER1, and then click the “Add” button to 
add this address to the forwarder IP list. 

Step 67. Repeat Step 55 and enter the address of the shipboard DNS server. 
Step 68. Repeat Step 55 for any additional DNS servers that JMPS will require as 

forwarders. 
Step 69. Once completed, click the “OK” button the JMPSSERVER2 Properties 

dialog. 
 
At this point, return to step 70 in Section 6.10.1.1. At the end of that section there 
will be a note to return to the step below to complete the installation. 
 
Step 70. On JMPSSERVER2, select Start->Shut Down. 
Step 71. In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button. 
Step 72. Allow JMPSSERVER2 to fully restart and continue the setup for the 

Enterprise suite at Section 6.11. 
 
 

6.10.2 JMPS Enterprise Lite 
 

NOTES 
 

FOR THE JMPS ENTERPRISE LITE 
CONFIGURATION VERIFY THAT THE TWO ON-
BOARD 10/100 NICS AND THE GIGABYTE NIC 
ARE CONNECTED TO THE NETWORK FROM 
THE SINGLE SERVER. 

 
Since the JMPS Enterprise Lite configuration will include only a single server, the 
procedures outlined in Section 6.10.2 for the first server in the Enterprise configuration 
should be executed to configure the Active Directory and DNS. 
 

6.10.3 JMPS PICO 
 

NOTES 
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FOR THE JMPS PICO CONFIGURATION VERIFY 
THAT THE TWO ON-BOARD 10/100 NICS AND 
THE GIGABYTE NIC ARE CONNECTED TO THE 
NETWORK FROM THE SINGLE SERVER. 
 

 
Since the JMPS PICO configuration will include only a single server, the procedures 
outlined in Section 6.10.2 for the first server in the Enterprise configuration should be 
executed to configure the Active Directory and DNS. 
 

6.11 Procedure: Configure Ciprico NetArray 1100 RAID 
 

NOTES 
 

THIS SECTION CAN BE SKIPPED FOR THE PICO 
CONFIGURATION SINCE THIS CONFIGURATION 
DOES NOT CONTAIN A CIPRICO NETARRAY 1100 
RAID ARRAY. 

 

6.11.1 JMPS Enterprise 
 

NOTES 
 

FOR THE JMPS ENTERPRISE CONFIGURATION 
THERE WILL BE TWO SERVERS. POWER DOWN 
JMPSSERVER2 AT THIS POINT. LOAD THE 
CIPRICO STORAGE MANAGEMENT SOFTWARE 
ON JMPSSERVER1 FOLLOWING THE 
PROCEDURES PRESENTED BELOW. IN THE 
PROCEDURE JMPSSERVER2 WILL BE POWERED 
BACK ON LATER AND THE STORAGE 
MANAGEMENT SOFTWARE WILL BE 
INSTALLED ON IT AFTER JMPSSERVER1 HAS 
BEEN LOADED AND USED TO CONFIGURE THE 
SHARE DISK RESOURCES (CIPRICO NETARRY 
1100). 

 
! NOTES ! 

 
FOR THE ENTERPRISE CASE, STEPS 2 AND 3 
BELOW SPECIFY TO CONNECT THE DUAL 
FIBRE CHANNEL CARDS LOCATED IN THE 
DL380 SERVERS AND THE DUAL CONTROLLERS 
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ON THE TWO NETARRAYS TO THE FIBRE 
CHANNEL SWITCHES (SILKWORM 3200). 
HOWEVER DUE TO ISSUES WITH PATH 
RECONITION THE DUAL PATHS CAN NOT BE 
CONNECTED AT THIS TIME. ONLY CONNECT 1 
FIBRE CHANNEL CARD FROM EACH SERVER 
(BOTTOM CARD) TO THE FIRST FIBRE 
CHANNEL SWITCH ALONG WITH THE 
CONTROLLER A PORT FROM ONE OF THE TWO 
CIPRICO NETARRAY 1100s. THEN PROCEED TO 
STEP 4 BELOW. PROCEDURES FOR 
CONNECTING THE SECOND RAID ALONG WITH 
DUAL DATA PATHS TO BOTH ARRAYS ARE 
PROVIDED AT THE END OF THIS DOCUMENT. 
 

NOTE 
 
THIS SECTION REQUIRES DOWNLOADING 
CIPRICO STORAGE MANAGER 3.2 FROM THE 
CIPRICO FTP SITE. THE LINK TO THAT FILE IS 
LISTED BELOW. UNZIP THE FILE AND PLACE 
THE CONTENTS ON A CD. 

 
ftp://ftp.ciprico.com/pub/Software/WIN2000/Utility/STORM3.2_W2K.zip 
 
 
 
Step 1. Shut Down the Compaq DL380 server(s). 
Step 2. (See “! NOTES !” above before executing this step).  On the Compaq DL380 

Server(s) connect the two Fibre Channel Cards on the server(s) to Fibre Channel 
switches using LC to SC fiber cables. From each of the servers, connect the Fibre 
Channel HBA card located in the top PCI slot to the first switch and the second Fibre 
Channel HBA card located in the middle PCI slot to the second Fibre Channel switch.  
Refer to Figure 4. 

Step 3. (See “! NOTES !” above before executing this step).  On the Ciprico NetArray 
1100(s) Connect the two Controllers (A&B) Fibre Channel ports to the Fibre Channel 
Switches using SC to SC fiber cables. From each of the NetArrays connect Controller 
A to the first Fibre Channel switch and Controller B to the second Fibre Channel 
switch for redundancy.  Refer to Figure 4. 

Step 4. Power on the Silk Worm 3200 Fibre Channel Switches. It takes 5 minutes for the 
switch to perform all self-testing. Be patient and wait until all lights on the switch 
stop flashing.  

Step 5. Power the NetArray 1100(s) on via the switch on the right rear and left rear of the 
cabinet (dual power supplies). 

Step 6. Power only the primary server (JMPSSERVER1) back on. Logon to the system 
into the administrator’s account. 
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Step 7. The NetArray 1100 drive LEDs may be blinking Blue-Green at this time and then 

should be a steady Green. The array is ready to be used when all 10 lights are steady 
Green.  

Step 8. Insert the CD containing Ciprico Storage Manager 3.2 in to the CD-ROM drive 
on the server.  

Step 9. Follow these sub-steps: 
 

a) Select Start->Run. 
b) The Run dialog box will open, click the “Browse” button. 
c) The Browse dialog box will then open. Set the path to the CD-ROM drive. 
d) Double click on the “windows” folder to open it. 
e) Select the “StrMan32.exe” file and then double click on it to set the path to it 
in the Run dialog box. 
f) On the Run dialog box click the “OK” button to start the Ciprico Storage 
Manager 3.2 installer. 

 
Step 10. The Language dialog box will open, click the “OK” button to accept the 

default “English” choice. 
Step 11. The Store_Manager32 dialog box will open with the Introduction message, 

click the “Next” button to continue. 
Step 12. The Important Information dialog will then open. Click the “Next” button to 

continue. 
Step 13. The Choose Product Features dialog box will then open. Select the “Server & 

Client” choice and then click the “Next” button. 
Step 14. The Choose Install Folder dialog will then open. Accept the default 

installation location “C:\Program Files\Ciprico”. Click the “Next” button. 
Step 15. The Choose Shortcut Folder dialog will open. Accept the default new Program 

Group “Ciprico Storage Manager”. Click the “Install” button. 
Step 16. The Install Complete dialog box will open, click the “Done” button. 
Step 17. Remove the Ciprico Storage Manager 3.2 CD from the CD-ROM drive. 
Step 18. Open the Windows Explorer, Start->Programs->Accessories->Windows 

Explorer. 
Step 19. In the Explorer navigate to the Ciprico folder “C:\Program Files\Ciprico”. 

Select the “Ciprico” folder and double click on it to open it. 
Step 20. In the Ciprico folder display, on the left-hand side of the Explorer window, 

select the “startServer.bat” file and right-click on it. Select “Edit” from the pop-up 
menu. 

Step 21. The “startServer.bat” file will open in the NotePad editor. Find the line in the 
.bat file that states “set ARGS=” and modify it to “set ARGS= -TRACE -
SECURITY” to enable the tracing and security options. 

Step 22. On the startServer.bat - Notepad menu click “File->Exit”. 
Step 23. The Notepad dialog box will then open wit the following message: 
 

“The text in the C:\Program Files\Ciprico\startServer.bat file has changed. 
 
Do you want to save the changes?” 
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Click the “Yes” button to save the changed file. 
 
Step 24. In the Ciprico folder display, on the right-hand side of the Explorer window, 

select the “StorageManager.bat” file and right-click on it. Select “Edit” from the pop-
up menu. 

Step 25. The “StorageManager.bat” file will open in the NotePad editor. Find the line 
in the .bat file that states “set ARGS=” and modify it to “set ARGS= -adv” to enable 
the client security options. This will turn on the login feature of the Storage Manager 
software so that array configuration permissions can be assigned to the designated 
personnel. 

Step 26. On the StorageManager.bat - Notepad menu click “File->Exit”. 
Step 27. The Notepad dialog box will then open wit the following message: 
 

“The text in the C:\Program Files\Ciprico\StorageManager.bat file has changed. 
 
Do you want to save the changes?” 

 
Click the “Yes” button to save the changed file. 

 
Step 28. Close the Explorer. 
Step 29. On the Desktop double click on the “Ciprico Storage Manager Server” icon to 

start the server portion of the Storage Management software. 
Step 30. A DOS window will open and then auto-minimize to the Start Bar with the 

“cipServer” title. 
Step 31. On the Desktop double click on the “Ciprico Storage Manager” icon to start 

the client portion of the Storage Management software. 
Step 32. The Storage Manager DOS window will open with the “- advanced options 

enabled - ”line. The Ciprico Storage Manager window will then open with the Ciprico 
Storage Manager introduction splash screen. 

Step 33. On the Ciprico Storage Manager menu select “File->Select Server”. 
Step 34. The Server Selection dialog box will open. In the Enter Server Name box type 

in the name assigned to the JMPS server followed by “:2004”. Use the DNS name, 
the basic name without the “.” extensions. (ex. JMPSSERVER1:2004). Click the 
“Okay” button when completed. 

Step 35. On the Ciprico Storage Manager menu select “File->Search for Devices”. 
Step 36. The “Searching” dialog will open and then the Ciprico Storage Manager will 

appear with System View TAB open. The server tree will be displayed in the left-
hand part of the window and the connected NetArray will be displayed in the right-
hand side. 

Step 37. On the menu bar select “File->Server Login”. 
Step 38. The Server Login dialog will open, enter “admin” for the Username and leave 

the Password box empty (these are the default settings to allow entry for the first time 
configuration). Click the “OK” button to log in. The padlock symbol on the Ciprico 
Storage Manager menu bar should now be open.  
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Step 39. Click on the “Security Setup” TAB located at the bottom right-hand side of 

the Ciprico Storage Manager window. 
Step 40. The Security TAB will open. Click the “Show Users” button. The user list 

will appear. (In the Enterprise case, with dual servers, two “Admin” users may appear 
in the user list.) 

Step 41. In the Username: box enter “Admin”, leave the Old Password box blank and 
then enter a selected password for the Admin account into the New Password and the 
Confirm New Password boxes. When finished click the “Change Password” button. 
(Note: This action will only change the password for the local “Admin” account.) 

Step 42. The Password successfully changed message will appear in the lower left-
hand corner of the Ciprico Storage Manager window. 

Step 43. With the password on the local Admin account changed, its time to configure 
the NetArray 1100. Click on the “System View” TAB to bring it forward. 

Step 44. On the System View TAB the connected NetArray 1100 should appear on the 
right-hand side of the window. Select the NetArray 1100 and double click on it to 
open the NetArray RAID Array dialog box. (It may be necessary to double click the 
title bar on this NetArray RAID Array window to be able to fully view the lower part 
of the screen with the action buttons.) 

Step 45. From the factory the Ciprico NetArray 1100 may be pre-configured into two 
Logical Units (LUNs). One should contain two 180GB hard drives in a RAID 1 
configuration and the other should contain seven 180GB hard drives in a 6 + 1 RAID 
5 configuration, one of the drives will be a hot spare. The 10th drive in the NetArray 
will also be configured as a hot spare. The Controller View TAB display on the left-
hand side of the NetArray RAID Array dialog box should reflect this configuration. It 
should show V0 and V1 disk groupings along with 2 hot spare drives. It is suggested 
that the configuration of the NetArray be wiped and then rebuilt using the following 
sub-steps presented below, a new RAID 5 storage area will be built: 

 
a) On the NetArray RAID Array dialog box, on the Controller Details TAB, click 

the “Clear Configuration” button.  (It may be necessary to double click on the 
NetArray RAID Array window title bar to make it full-size in order to see the 
buttons on the near the bottom of the Controller Details dialog.) 

b) The Warning! Dialog box will appear with the following message: 
 

“You are about to clear the configuration. 
 
You may need to reboot the server system for changes to be visible. 
 
Are you sure you want to continue?” 
 
Click the “Yes” button. The system will pause for a few minutes, wait until 
the operation completes. 

 
c) Leave the default settings selected on the Controller Details TAB. 
d) At the lower part of the NetArray RAID Array dialog click on the “Logical 

Unit Creation” TAB. The Create a Logical Unit dialog box will open. 
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e) On the Controller View, the left-hand side of the NetArray RAID Array 
dialog box will have updated from the clear operation. All the drives will now 
be yellow in color (yellow = drive is free). 

f) In the Available Drive box select Disk #1 and then click the down-arrow 
button located in the center of the TAB, the drive should then move to the 
Drives to be included box. 

 
NOTE 

 
THE JMPS APPLICATION HAS A PROBLEM 
INSTALLING THE DATA TO A DISK DRIVE 
LARGER THAN 1 TB. UNTIL THIS PROBLEM 
WITH THE JMPS APPLICATION IS SOLVED THE 
MAXIMUM DISK SIZE FOR ANY PARTITION IN 
THE ENTERPRISE RAID WILL BE LIMITED TO 
896 GB (6 HARD DRIVES) CONFIGURATION. 
ONLY SELECT DRIVE IDS 1 TO 3 IN STEPS (f-g) 
AND ONLY SELECT DRIVE IDS 4 TO 9 IN STEPS 
(m-n) BELOW. DEFINE 1 SPARE DRIVE AS 
SHOWN IN STEP (t) BELOW. 

 
g) Repeat the procedure outlined in Step (f) for Disk #2, 3. All three disks should 

appear in the Drives to be included box. 
h) On the Create a Logical Unit dialog box click the down-arrow button on the 

RAID Level box, from the RAID type list select “5”. 
i) Ensure that the Write Cache box is not checked. 
j) The Physical Capacity for this RAID 5 LUN using 180 GB drives (3 drives 

for now) should be 537.59863 GB, and the Usable Capacity should be 
358.39908 GB. Click the “Create” button to build this main LUN. 

k) The Notice! dialog will appear with the message: 
“After the Logical Unit is created, you may need to reboot the server system 
for it to be visible.” 
 
Click the “OK” button to proceed with the build. 

 
l) The build will take several minutes to complete, when finished the Controller 

View, on the left-hand side of the NetArray RAID Array dialog box, will 
update. The drives selected to be part of the RAID volume will now be green 
in color (green = Drive is a Member of a Volume) and all will be part of the 
new V0. 

m) In the Available Drive box select Disk #4 and then click the down-arrow 
button located in the center of the TAB, the drive should then move to the 
Drives to be included box. 

n) Repeat the procedure outlined in Step (m) for Disk #5, 6, 7, 8, 9. All six disks 
should appear in the Drives to be included box. 
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o) On the Create a Logical Unit dialog box click the down-arrow button on the 
RAID Level box, from the RAID type list select “5”. 

p) Ensure that the Write Cache box is not checked. 
q) The Physical Capacity for this RAID 5 LUN using 180 GB drives (6 drives 

for now) should be 1075.1973 GB, and the Usable Capacity should be 
895.9977 GB. Click the “Create” button to build this main LUN. 

r) The Notice! dialog will appear with the message: 
“After the Logical Unit is created, you may need to reboot the server system 
for it to be visible.” 
 
Click the “OK” button to proceed with the build. 

 
s) The build will take several minutes to complete, when finished the Controller 

View, on the left-hand side of the NetArray RAID Array dialog box, will 
update. The drives selected to be part of the RAID volume will now be green 
in color (green = Drive is a Member of a Volume) and all will be part of the 
new V1. 

t) On the Controller View TAB click on Disk # 10 and then right-click. From 
the pop-up menu select “Designate as a Spare Drive”. The process will take a 
minute but then the drive color will change to light blue (light blue = Drive is 
a Spare). 

u) Close the NetArray RAID Array dialog (File->Close). 
v) On the Ciprico Storage Manager dialog select “File->Exit”. The Notice! 

Dialog will open with the message: 
 

You are about to exit Storage Manager. 
 
Are you sure you wish to exit? 
 
Click the “Yes” button. 
 

w) Select Start->Shut Down. 
x) In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button. Allow the server to restart. 
Step 46. Power the second server back on at this time. Execute only Steps (8) to (44) 

above. This will install the Ciprico NetArray Storage Manager on the second server to 
allow the NetArray to be managed from the second server in the JMPS Enterprise 
suite if the first server should fail. 

Step 47. Continue at Section 6.12. 
 
 

6.11.2 JMPS Enterprise Lite  (E.S. Must be edited and verified. Do not use for now) 
 

NOTES 
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THE JMPS ENTERPRISE LITE CONFIGURATION 
WILL CONSIST OF A SINGLE SERVER AND A 
CIPRICO NETARRY 1100. LOAD THE CIPRICO 
STORAGE MANAGEMENT SOFTWARE ON THE 
SINGLE SERVER AND THEN CONFIGURE THE 
CIPRICO NETARRAY ACCORDING TO THE 
FOLLOWING PROCEDURES. 
 

! NOTES ! 
 

STEPS 2 AND 3 BELOW SPECIFY TO CONNECT 
THE DUAL FIBRE CHANNEL CARDS LOCATED 
IN THE DL380 SERVERS AND THE DUAL 
CONTROLLERS ON THE NETARRAY.  HOWEVER 
DUE TO ISSUES WITH PATH RECONITION THE 
DUAL PATHS CAN NOT BE CONNECTED AT THIS 
TIME. ONLY CONNECT A SINGLE FIBRE 
CHANNEL CARD FROM THE ENTERPRISE LITE 
SERVER (TOP CARD) TO THE CONTROLLER A 
PORT ON THE CIPRICO NETARRAY 1100.  THEN 
PROCEED TO STEP 4 BELOW.  WHEN THIS ISSUE 
IS RESOLVED THESE PROCEDURES WILL BE 
UPDATED TO INCLUDE THE SECOND DATA 
PATH TO THE CIPRICO NETARRAY 1100 RAID. 

 
Step 1. Shut Down the Compaq DL380 server. 
Step 2. (See “! NOTES !” above before executing this step) On the Compaq DL380 

Server connect the top Fibre Channel card on the server to Controller A on the 
Ciprico NetArray 1100 RAID.  Connect the Fibre Channel card located in the middle 
PCI slot on the server to Controller B on the Ciprico NetArray 1100 RAID.  Use the 
LC to SC fiber cables to accomplish these connections.  Refer to Figure 5. 

Step 3. (See “! NOTES !” above before executing this step) On the Ciprico NetArray 
1100 Connect both Controllers (A&B) Fibre Channel ports to the Fibre Channel 
switch (Silk Worm 3200) using SC to SC fiber cables for redundancy.  Refer to 
Figure 5. 

Step 4. Power on the Silk Worm 3200 Fibre Channel Switch. 
Step 5. Power the NetArray 1100 on via the switch on the right rear and left rear of the 

cabinet (dual power supplies). 
Step 6. Power the server back on. Logon to the system into the administrator’s account. 
Step 7. The NetArray 1100 drive LEDs may be blinking Blue-Green at this time and then 

should be a steady Green. 
Step 8. Insert the CD labeled Ciprico Storage Manager 3.1 in to the CD-ROM drive on 

the server. 
Step 9. The installation should start automatically if it does not follow these sub-steps: 
 

a) Select Start->Run. 
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b) The Run dialog box will open, click the “Browse” button. 
c) The Browse dialog box will then open. Set the path to the CD-ROM drive. 
d) Double click on the “windows” folder to open it. 
e) Select the “StrMan31.exe” file and then double click on it to set the path to it 
in the Run dialog box. 
f) On the Run dialog box click the “OK” button to start the Office 2000 installer. 

 
Step 10. The Language dialog box will open, click the “OK” button to accept the 

default “English” choice. 
Step 11. The Store_Manager31 dialog box will open with the Introduction message, 

click the “Next” button to continue. 
Step 12. The Important Information dialog will then open. Click the “Next” button to 

continue. 
Step 13. The Choose Product Features dialog box will then open. Select the “Server & 

Client” choice and then click the “Next” button. 
Step 14. The Choose Install Folder dialog will then open. Accept the default 

installation location “C:\Program Files\Ciprico”. Click the “Next” button. 
Step 15. The Choose Shortcut Folder dialog will open. Accept the default new Program 

Group “Ciprico Storage Manager”. Click the “Install” button. 
Step 16. The Install Complete dialog box will open, click the “Done” button. 
Step 17. Remove the Ciprico Storage Manager 3.1 CD from the CD-ROM drive. 
Step 18. Open the Windows Explorer, Start->Programs->Accessories->Windows 

Explorer. 
Step 19. In the Explorer navigate to the Ciprico folder “C:\Program Files\Ciprico”. 

Select the “Ciprico” folder and double click on it to open it. 
Step 20. In the Ciprico folder display, on the left-hand side of the Explorer window, 

select the “startServer.bat” file and right-click on it. Select “Edit” from the pop-up 
menu. 

Step 21. The “startServer.bat” file will open in the NotePad editor. Find the line in the 
.bat file that states “set ARGS=” and modify it to “set ARGS= -TRACE -
SECURITY” to enable the tracing and security options. 

Step 22. On the startServer.bat - Notepad menu click “File->Exit”. 
Step 23. The Notepad dialog box will then open wit the following message: 
 

“The text in the C:\Program Files\Ciprico\startServer.bat file has changed. 
 
Do you want to save the changes?” 

 
Click the “Yes” button to save the changed file. 

 
Step 24. In the Ciprico folder display, on the left-hand side of the Explorer window, 

select the “StorageManager.bat” file and right-click on it. Select “Edit” from the pop-
up menu. 

Step 25. The “StorageManager.bat” file will open in the NotePad editor. Find the line 
in the .bat file that states “set ARGS=” and modify it to “set ARGS= -adv” to enable 
the client security options. This will turn on the login feature of the Storage Manager 
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software so that array configuration permissions can be assigned to the designated 
personnel. 

Step 26. On the StorageManager.bat - Notepad menu click “File->Exit”. 
Step 27. The Notepad dialog box will then open wit the following message: 
 

“The text in the C:\Program Files\Ciprico\StorageManager.bat file has changed. 
 
Do you want to save the changes?” 

 
Click the “Yes” button to save the changed file. 

 
Step 28. Close the Explorer. 
Step 29. On the Desktop double click on the “Ciprico Storage Manager Server” icon to 

start the server portion of the Storage Management software. 
Step 30. A DOS window will open and then minimize to the Start Bar with the 

“cipServer” title. 
Step 31. On the Desktop double click on the “Ciprico Storage Manager” icon to start 

the client portion of the Storage Management software. 
Step 32. The Storage Manager DOS window will open with the “- advanced options 

enabled - ”line.  The Ciprico Storage Manager window will then open with the 
Ciprico Storage Manager introduction splash screen. 

Step 33. On the Ciprico Storage Manager menu select “File->Select Server”. 
Step 34. The Server Selection dialog box will open.  In the Enter Server Name box 

type in the name assigned to the JMPS server (use the DNS name, the basic name 
without the “.” extensions).  Click the “Okay” button when completed. 

Step 35. On the Ciprico Storage Manager menu select “File->Search for Devices”. 
Step 36. The “Searching” dialog will open and then the Ciprico Storage Manager will 

appear with System View TAB open.  The server tree will be displayed in the left-
hand part of the window and the connected NetArray(s) will be displayed in the right-
hand side. 

Step 37. On the menu bar select “File->Server Login”. 
Step 38. The Server Login dialog will open, enter “admin” for the Username and leave 

the Password box empty (these are the default settings to allow entry for the first time 
configuration). Click the “OK” button to log in. 

Step 39. The padlock symbol on the Ciprico Storage Manager menu bar should now be 
open.  Click on the “Security Setup” TAB located at the bottom right-hand side of the 
Ciprico Storage Manager window. 

Step 40. The Security TAB will open. Click the “Show Users” button.  The user list 
will appear. 

Step 41. In the Username: box enter “Admin”, leave the Old Password box blank and 
then enter a selected password for the Admin account into the New Password and the 
Confirm New Password boxes.  When finished click the “Change Password” button. 

Step 42. The ‘Password successfully changed’ message will appear in the lower left-
hand corner of the Ciprico Storage Manager window upon successful password 
change. 
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Step 43. With the password on the local Admin account changed, its time to configure 

the NetArray 1100.  Click on the “System View” TAB to bring it forward. 
Step 44. On the System View TAB the connected NetArray 1100 should appear on the 

right-hand side of the window.  Select the NetArray 1100 and double click on it to 
open the NetArray RAID Array control dialog box. 

Step 45. From the factory the Ciprico NetArray 1100 may be pre-configured into two 
Logical Units (LUNs).  One should contain two 180GB hard drives in a RAID 1 
configuration and the other should contain seven 180GB hard drives in a 6 + 1 RAID 
5 configuration, one of the drives will be a hot spare.  The 10th drive in the NetArray 
will also be configured as a hot spare.  The Controller View TAB display on the left-
hand side of the NetArray RAID Array dialog box should reflect this configuration.  
It should show V0 and V1 disk groupings along with 2 hot spare drives. For the 
Enterprise Lite configuration, with no clustering, the NetArray will be configured into 
a large RAID 5 storage area.  The configuration of the NetArray be wiped and rebuilt 
using the following sub-steps presented below. 

 
a) On the NetArray RAID Array dialog box, on the Controller Details TAB, click 

the “Clear Configuration” button. (It may be necessary to double click on the 
NetArray RAID Array window title bar to make it full-size in order to see the 
buttons on the near the bottom of the Controller Details dialog.) 

b) The Warning! Dialog box will appear with the following message: 
 

“You are about to clear the configuration. 
 
You may need to reboot the server system for changes to be visible. 
 
Are you sure you want to continue?” 
 
Click the “Yes” button. The system will pause for a few minutes, wait until the 
operation completes. 

 
c) Leave the default settings selected on the Controller Details TAB. 
d) At the lower part of the NetArray RAID Array dialog click on the “Logical Unit 

Creation” TAB.  The Create a Logical Unit dialog box will open. 
e) The Controller View, on the left-hand side of the NetArray RAID Array dialog 

box, will update.  All the drives will now be yellow in color (yellow = drive is 
free). 

f) In the Available Drive box select Disk #1 and then click the down-arrow button 
located in the center, the drive should then move to the ‘Drives to be included 
box’. 

 
NOTE 

 
THE JMPS APPLICATION HAS A PROBLEM 
INSTALLING THE DATA TO A DISK DRIVE 
LARGER THAN 1TB. UNTIL THIS PROBLEM 
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WITH THE JMPS APPLICATION IS SOLVED THE 
MAXIMUM DISK SIZE FOR THE ENTERPRISE 
LITE RAID WILL BE LIMITED TO 895.9 GB (6 + 2) 
CONFIGURATION. ONLY SELECT DRIVE IDS 1 
TO 6 IN STEP (g) BELOW UNTIL FURTHER 
NOTICE. LEAVE THE EXTRA DRIVES FREE, 
DEFINE THE 2 SPARE DRIVES AS SHOWN IN 
STEP (m) BELOW. 

 
g) Repeat the procedure outlined in Step (f) for Disk #2, 3, 4, 5, and 6, all six of the 

disks should appear in the ‘Drives to be included’ box. 
h) Once the drives have been assigned, on the Create a Logical Unit dialog box click 

the down-arrow button on the RAID Level box, from the RAID type list select 
“5”. 

i) Ensure that the Write Cache box is not checked. 
j) The Physical Capacity for this RAID 5 (only 6 drives for now) LUN using 180 

GB drives should be 1075.1973 GB, and the Usable Capacity should be 895.9977 
GB.  Click the “Create” button to build this LUN. 

k) The Warning! dialog will appear with the message: 
“After the Logical Unit is created, you may need to reboot the server system for it 
to be visible.” 
 
Click the “OK” button to proceed with the build. 

 
l) The build will take several minutes to complete, when finished the Controller 

View, on the left-hand side of the NetArray RAID Array dialog box, will update. 
The drives selected will now be green in color (green = Drive is a Member of a 
Volume) and will be part of the newly created V0. 

m) In the Controller View TAB on the left-hand side of the NetArray RAID Array 
window, click on Disk # 9 and then right-click.  From the pop-up menu select 
“Designate as a Spare Drive”. The process will take a minute but then the drive 
color will change to light blue (light blue = Drive is a Spare). 

n) Repeat Step (m) for Disk # 10. 
o) Close the NetArray RAID Array dialog (File->Close). 
p) On the Ciprico Storage Manager dialog select “File->Exit”. The Notice! Dialog 

will open with the message: 
 

You are about to exit Storage Manager. 
 
Are you sure you wish to exit? 
 
Click the “Yes” button. 
 

q) Select Start->Shut Down. 
r) In the Shut Down Windows dialog select “Restart” from the drop down box. 

Click the “OK” button.  Allow the server to restart. 
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Step 46. Logon to the server into the administrator account. 
Step 47. Select Start->Programs->Administrative Tools->Computer Management. 
Step 48. The Computer Management dialog box will open, in the left-hand side of the 

dialog click on the “Disk Management” folder. 
Step 49. The Write Signature and Upgrade Disk Wizard dialog will open because of 

the newly added NetArray 1100 RAID drive. Press the “Next” button. 
Step 50. The Select Disk to Write Signature dialog will then open. Select all the disks 

presented in the list and click the “Next” button. 
Step 51. The Select Disks to Upgrade dialog will then open, uncheck the disks and 

click the “Next” button (do not upgrade the disks to Dynamic Disks, leave them as 
Basic so that primary partitions can be created on them). 

Step 52. The Completing the Write Signature and Upgrade Disk Wizard dialog box 
will appear, click the “Finish” button. 

Step 53. In the right-hand pane of the Computer Management window the volume 
information will appear for the NetArray drives connected to the system. Click on the 
Unallocated space for Disk 1 and then right-click. Select “Create Partition” from the 
pop-up menu. 

Step 54. The Create Partition Wizard dialog box will open with the Welcome to the 
Create Partition Wizard message. Click the “Next” button. 

Step 55. The Select Partition Type dialog will then appear, select the “Primary 
partition” choice and click the “Next” button. 

Step 56. The Specify Partition Size dialog will then appear, accept the total amount of 
disk space for the partition. Click the “Next” button. 

Step 57. The Assign Drive Letter or Path dialog will then open. On the Assign a drive 
letter line click the down-arrow button and select “E:” from the drive letter list 
presented. Click the “Next” button. 

Step 58. The Format Partition dialog box will open. Set the File system to “NTFS”, 
leave the Allocation unit size at “Default” and enter “Data” for the Volume label. 
Leave the Perform a Quick Format and the Enable file and folder compression boxes 
unchecked. Click the “Next” button. 

Step 59. The Completing the Create Partition Wizard dialog will open, click the 
“Finish” button. 

Step 60. Wait until the format operation is completed, the drive status will change to 
“Healthy” when its is completed. 

Step 61. Close the Computer Management window. 
Step 62. Select Start->Programs->Administrative Tools->Computer Management. 
Step 63. On the left-hand side of the Computer Management dialog box double click 

on “Disk Management”. The right-hand side of the dialog box should update to show 
the Disk configuration. Verify that the System C:, the Segments D, Data E: (main 
RAID 5 storage on the NetArray) are all available and healthy. The display should 
look like Figure X.X below (to be added later…) 

Step 64. Close the Computer Management dialog. 
Step 65. Continue at Section 6.12. 
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6.12 Procedure: Veritas Cluster Server 2.0 (VCS) Installation 
 
 

NOTES 
 

THIS PROCEDURE SHALL BE SKIPPED IF 
LOADING THE JMPS ENTERPRISE LITE OR PICO 
SERVER CONFIGURATIONS, SINCE THESE 
CONFIGURATIONS WILL NOT REQUIRE THE 
CLUSTER SOFTWARE TO BE LOADED. 
 
VERITAS CLUSTER SOFTWARE REQUIRES THAT 
SERVICE PACK 2 BE LOADED ON THE SERVER. 
THIS SERVICE PACK WILL BE LOADED AT THE 
BEGINNING OF THIS PROCEDURE TO ALLOW 
THE VERITAS SOFTWARE TO BE PROPERLY 
INSTALLED. LATER IN THE PROCEDURES 
WHEN COE IS LOADED SERVICE PACK 3 WILL 
BE LOADED, THIS SHOULD NOT CAUSE ANY 
PROBLEMS OR ISSUES. 
 
A CD CONTAINING WINDOWS SERVICE PACK 2 
WILL BE IN THE SOFTWARE PACKAGE SHIPPED 
WITH THE SERVER. LOCATE THIS CD FOR THIS 
PROCEDURE. 
 
LOACATE THE VERITAS CLUSTER SERVER 2.0 
CD FOR THIS PROCEDURE. 

 
 
Step 1. Logon to the server into the administrator account. 
Step 2. Place the Microsoft Windows 2000 Service Pack 2 CD into the CD-ROM drive. 
Step 3. The Microsoft Windows 2000 Service Pack 2 installation should start 

automatically, if it does close it. 
Step 4. Select Start->Run. 
Step 5. On the Run dialog box click the “Browse” button. 
Step 6. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the setup file for the Service Pack (W2KSP2_EN (G:). 
Step 7. In the folder double click on the “W2KSP2.exe” file to set the path to it in the 

Run dialog box. 
Step 8. On the Run dialog box click the “OK” button to begin the installation of Service 

Pack 2. 
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Step 9. The Windows 2000 Service Pack Setup dialog box will open. Check the “Accept 

the License Agreement (must accept before installing the Service Pack)” box and 
uncheck the “Backup files necessary to uninstall this Service Pack at a later time” 
check box. Then click the “Install” button. 

Step 10. The Microsoft Windows 2000 Service Pack 2 Setup dialog box will then open 
to show the progress of the installation. Wait for this process to complete. 

Step 11. The Windows 2000 Service Pack Setup dialog box will open with the 
following message: 

 
“Windows 2000 Service Pack 2 installation is complete. You must restart your 
computer for the Service Pack update to take effect.” 
 
Click the “Restart” button. 

Step 12. The server will then restart. Remove the Microsoft Windows 2000 Service 
Pack 2 CD from the CD-ROM drive. Allow JMPSSERVER1 to reboot fully before 
going to the next step. 

Step 13. Repeat Steps (1) to (12) above on JMPSSERVER2. 
Step 14. Back on the primary server logon into the administrator account. 
Step 15. Disable auto-negotiation on both private network cards on both servers.  

a. Start on the first server, JMPSSERVER1. 
b. Right-click on My Network Places  Properties.  
c. In the Network and Dial-up Connections window, double-click the Local Area 

Connection icon. This will enable the connection.  
d. Double-click on Local Area Connection again. 
e. Click on Properties  Configure. 
f. Click on the Advanced tab. 
g. For the Link Speed & Duplex field, select 100Mbps/Half Duplex. Click OK twice 

to close both windows. 
h. Repeat steps (b) to (g) above for Local Area Connection 2 on JMPSSERVER1. 
i. Repeat the same steps for the same two network adapters on JMPSSERVER2. 
j. Reboot both servers. 

Step 16. Place the VCS 2.0 CD in the CD-ROM on JMPSSERVER1.  
Step 17. Copy the Cluster Server CD to a temporary directory on JMPSSERVER1. The 

installation program may start automatically when the CD is inserted. Click “Exit” on 
the bottom right corner to quit the setup application.  

Step 18. Go to the temp directory containing the VCS files that were just copied and 
double-click on Setup.exe 

Step 19. Click Cluster Server in the left pane, then click Cluster Server Installation. 
Step 20. In the Welcome screen, read the text and click Next. 
Step 21. In the Installation Options dialog box, click Create a new VCS cluster and 

click Next. 
Step 22. In the License Agreement click Next. 
Step 23. In the License Key dialog box, select Node Licenses and click Next. 
Step 24. In the Domain Selection dialog box, click Browse for a list of available 

domains on the network. 
Step 25. Select jmps.xxxx.navy.smil.mil. It should be the only one shown. Click OK. 
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Step 26. Click Next. 
Step 27. In the Cluster Identification dialog box, enter “JMPS_Cluster” for the cluster 

name and “1” for the cluster ID number, then click Next. 
Step 28. In the VCS Administrator Account dialog box, enter a desired user name and 

password, confirm the password, and click Next. This is a user name and password 
that is used only to administer the cluster. This user name is not related to any JMPS 
domain account. 

Step 29. In the Node Selection dialog box, click Browse for a list of available nodes 
within the selected domain.  

Step 30. Select the two nodes shown – JMPSSERVER1 and JMPSSERVER2. Click 
OK and click Next. 

Step 31. In the Node License Key dialog box, click a node in the list, JMPSSERVER1, 
and click Edit, or double-click the node. 

Step 32. Enter the License Key for JMPSSERVER1 and click OK. The License Key 
displays next to the node. 

Step 33. Enter the License Key for JMPSSERVER2 and click OK. The License Key 
displays next to the node. 

Step 34. Click Next. 
Step 35. In the Installation Directory dialog box, leave the default directory for both 

servers and click Next. 
Step 36. In the Private Network dialog box, select the two 10/100 internal network 

adapters on each node. They are Local Area Connection and Local Area Connection 
2. Click Next. 

Step 37. In the Cluster Manager (Web Console) Configuration dialog box, clear the 
check box next to Enable Cluster Manager (Web Console) on this cluster and then 
click Next. 

Step 38. In the Summary dialog box, review the chosen selections and click Next. 
Step 39. In the Installing VCS on Selected Nodes dialog box, a progress bar shows the 

status of installation on each node in the new cluster. 
Step 40. In the Reboot Nodes dialog box, leave the check marks next to both servers 

and click Next to reboot. JMPSSERVER2 will start rebooting immediately.  
Step 41. On JMPSSERVER1, click on Finish on the “Completing VCS Installation 

Manager Wizard …” window.  
Step 42. Click Yes on the next window to reboot JMPSSERVER1. 
Step 43. After the servers reboot, continue with section 6.13. 

6.13 Procedure: Veritas Cluster Manager installation 
 
Step 1. On JMPSSERVER1, go to the temp directory containing the VCS files that were 

copied in the last section and double-click on Setup.exe 
Step 2. Click Cluster Manager in the left pane, then click Cluster Manager (Java Console) 

Installation. 
Step 3. In the Welcome screen, read the text and click Next. 
Step 4. In the Destination Folder dialog box, click Next to install at the default location. 
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Step 5. In the Ready to Install the Program dialog box, click Install, or click Back to 

make changes. A Setup window displays the status of the installation. The 
InstallWizard Completed dialog box displays after the installation is complete. 

Step 6. In the Install Wizard Completed dialog box, click Finish. 
Step 7. When the installation is complete, two icons appear on your desktop: one 

representing the VCS Cluster Manager (Java Console), and one representing the VCS 
Configuration Editor. 

Step 8. Place the VCS 2.0 CD in the CD-ROM on JMPSSERVER2. The installation 
program may start automatically when the CD is inserted. Click “Exit” on the bottom 
right corner to quit the setup application. 

Step 9. Copy the Cluster Server CD to a temporary directory on JMPSSERVER2.  
Step 10. Perform steps 1-7 above on JMPSSERVER2. 
Step 11. Now continue with section 6.14. 
 

6.14 Procedure: Veritas Volume Manager 3.1 (VVM) installation 
 
 

NOTE 
 

VERITAS VOLUME MANAGER 3.1 AND HOTFIX 
02 FOR VERITAS VOLUME MANAGER 3.1 HAVE 
TO BE DOWNLOADED FROM THE VERITAS 
WEBSITE, EXTRACTED (THESE ARE SELF-
EXTRACTING EXECUTABLES), AND PLACED ON 
A CD. THE LINKS ARE LISTED BELOW.  

 
http://seer.support.veritas.com/docs/251599.htm - VVM 3.1 
http://seer.support.veritas.com/docs/260611.htm - Hotfix 02 
 
Step 1. Place the CD containing VVM 3.1 in the CD-ROM on JMPSSERVER1. Copy the 

VVM CD to a temporary directory on JMPSSERVER1. 
Step 2. To begin the installation, double-click on Launch.exe in the root of the temporary 

directory created above. There is a delay while Windows Installer prepares to install; 
then the VERITAS Volume Manager 3.1 InstallShield wizard appears. 

Step 3. In the popup window that appears indicating that the VERITAS Enterprise 
Administrator (VEA) will be installed before Volume Manager 3.1 is installed, click 
Yes to continue. Click Next to continue in the installation wizard. 

Step 4. Click OK to confirm that VEA Language Pack will be installed.  
Step 5. The Setup Type screen appears. Choose “Server” as an installation setup type and 

click Next. 
Step 6. In the Customer Information screen that appears next, enter the relevant 

information. Also enter the license key. Click Next. 
Step 7. The Custom Setup Screen appears next. By default all the licensed components 

will be selected for installation. Click on the Drive Symbol next to the Volume 
Manager 3.1 MSCS Support option. On the drop down menu that appears select the 
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“This feature will not be available” option. A red “X” should appear on this option on 
the Custom Setup screen. Leave only the following two options: Volume Manager 3.1 
VCS Support and Volume Manager 3.1 DMP Support. 

Step 8. The Custom Setup Screen also provides the option to change the installation path. 
Leave the default installation path. 

Step 9. Click Next after selecting the necessary options and installation directory. 
Step 10. Click OK to accept the DMP warning. 
Step 11. The Ready to Install the Program screen appears. Click Install to install 

the program. 
Step 12. A screen appears indicating that the program is installing. The Online 

Registration wizard starts. Click Cancel to continue with the installation.  
Step 13. Click Yes to verify that registration will be cancelled. 
Step 14. When the installation finishes, a screen appears, indicating that the 

installation was successful. Click Finish to exit the installer. 
Step 15. At the dialog box asking to reboot the computer, click Yes to reboot now. 

Allow JMPSSERVER1 to reboot completely. 
Step 16. Repeat steps 1-15 on JMPSSERVER2. 
Step 17. Now continue with Section 6.15. 
 
 

6.15 Procedure: Adding Disk Signatures in VVM 
 
Step 1. Log onto JMPSSERVER1 with administrator privileges.  
Step 2. To start the program: Select Start  Programs  VERITAS Enterprise 

Administrator. The VERITAS Enterprise Administrator (VEA) console comes up, the 
Volume Manager program is activated, and the Connection dialog box is displayed. 

Step 3. Click the More button to expand the Connection dialog box. Enter “jmpsserver1” 
for the hostname of the server to connect to. Enter the administrator user name and 
password. Select the “Remember password” checkbox to save the user name and 
password entered. Click OK to connect. This step will need to be performed on 
JMPSSERVER2 when VEA is used there to save the user name and password for 
convenience.  

Step 4. Note: Volume Manager and the VEA console can also be started through the 
Computer Management window. From the Start menu, select Start  Programs  
Administrative Tools  Computer Management.  The Computer Management 
window appears. In the tree view of the left pane of the window, click to select 
VERITAS Enterprise Administrator. It is located under the Volume Management 
node, which is in the Storage folder.  

Step 5. When VVM is first started, it scans the server for all available hard drives. If the 
RAID partitions are newly created before the VCS/VVM installation, the two RAID 
drives will not have a disk signature. There will be two unsigned disks – Harddisk1 
and Harddisk2. To see the disks, expand jmpsserver1 in the left pane of the VEA 
window. Then expand disks. Click on the three disks shown there Harddisk0, 
Harddisk1, and Harddisk2. The disk will display with the message No Disk Signature 
in the tree view. The disk type will be No Disk Signature. The signature must be 
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added according to the steps below. Again, this is only necessary if the RAID drives 
are newly created. This procedure is not necessary if the disk signatures for the RAID 
partitions have already been setup in Windows using the standard Disk Management 
tool. If the disk type is Basic, the disks already have signatures. Skip the rest of the 
steps and continue with the next section below. 

Step 6. To add a signature to a disk right-click on the unsigned disk in the tree view. The 
Write Signature command appears in the context menu. (The Write Signature 
command appears only if a disk does not have a signature on it.) 

Step 7. Select Write Signature from the context menu. The Write Disk Signature dialog 
box will appear. Select the disks that need a signature to be added to them – 
Harddisk1 and Harddisk2. To select a disk, click on it in the list of available disks and 
click the Add button. 

Step 8. Once the disks are selected, click the OK button. Once a signature appears on a 
disk, the disk will display as a basic disk. 

Step 9. Now continue with section 6.16. 
 

6.16 Procedure: Creating Dynamic Cluster Disk Groups in VVM 
 

Step 1. Right-click the Disk Groups folder in VEA tree view on the left side of the screen. 
Step 2. Select New Dynamic Disk Group from the context menu that comes up. The New 

Dynamic Disk Group wizard screen appears. 
Step 3. Click Next to continue. A screen comes up for defining the attributes of the 

dynamic disk group. 
Step 4. Enter “JMPS_SQL_GRP” for the dynamic disk group name, and indicate which 

disks should be included in the group. Do this by selecting Harddisk1 in available 
disks and clicking Add. Harddisk1 will be moved from Available disks to Selected 
disks. Click the appropriate check box to Create Cluster Group and click Next. 

Step 5. The next screen confirms the disk that was selected. Choose Next to continue if 
disk selection is correct. If the wrong disk is accidentally selected, click the Back 
button to go back to the previous screen in order to modify the disk choice.  

Step 6. Click Yes to confirm upgrade to dynamic disk group. 
Step 7. Click Finish in the final screen. 
Step 8. Perform the steps above to create the second dynamic disk group. The name 

should be “JMPS_SHARE_GRP”. Now there should be two dynamic disk groups.  
Step 9. Continue with section 6.17. 
 

6.17 Procedure: Creating Dynamic Volumes in VVM 
 
Step 1. It is possible that existing unused volumes already exist on the RAID. It would be 

beneficial to delete them before proceeding.  
Step 2. Expand the Volumes folder in the VEA tree view on the left side of the screen. If 

other volumes besides C:\ and D:\ are shown, delete them according to the steps 
below. Do not delete G:\. That is the local CD-ROM. If there are no other volumes, 
proceed to step 6.  
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Step 3. Right-click on the volume shown there. The name could be E:\ or F:\. 
Step 4. Select Delete Volume from the pop-up context menu. Confirm the deletion by 

clicking Yes on the next window. 
Step 5. Repeat steps 3 and 4 for the other volume if it is there. 
Step 6. Right-click the Volumes folder in VEA tree view on the left side of the screen and 

select New Volume from the context menu that comes up. 
Step 7. The Create Volume wizard appears. Click Next to continue. 
Step 8. Select the attributes listed below for the volume, and click Next to continue. 
Step 9. A default dynamic disk group will appear in the Group name box. Select 

JMPS_SQL_GRP from the pull-down list if it is not already there. 
Step 10. Enter “JMPS_SQL_VOL” for the volume name. 
Step 11. Provide a size for the volume by clicking on Max Size button.  
Step 12. Select Concatenated for the layout. 
Step 13. Click Next to continue.  
Step 14. The default selection in the Assign Disks for Volume screen is fine. 

Harddisk1 will be automatically selected. Click Next to continue. 
Step 15. In the Add Drive Letter and Path screen, assign a drive letter by using the 

pull-down list. Select “E” if it is not automatically selected. Click Next to continue. 
Step 16. In the Create File System screen that appears next, select the following 

options: 
Step 17. Check the box next to Format this Volume.  
Step 18. Select NTFS for the file system. 
Step 19. Select default Allocation size. 
Step 20. Enter JMPS_SQL_VOL for the File System Label if it is not automatically 

entered. 
Step 21. Leave the box next to Perform Quick Format unchecked. 
Step 22. Click Next to continue. 
Step 23. Check your selections in the final screen and click Finish. By clicking the 

Back button, the necessary changes can be before clicking Finish. The formatting will 
take about 15 minutes. 

Step 24. Volume Manager will begin the formatting process. Click the Tasks tab in 
the bottom left corner of the lower pane to see a text entry indicating the status and 
progress of the formatting process.  

Step 25. Repeat the above process to create the second dynamic volume. 
“JMPS_SHARE_GRP” dynamic disk group should be used. The name of the volume 
should be “JMPS_SHARE_VOL” and the drive letter is “F”. The formatting will take 
about 40 minutes. 

Step 26. There should now be two new drives in Windows Explorer – 
JMPS_SQL_VOL (E:) and JMPS_SHARE_VOL (F:). 

Step 27. Now unmount the two volumes to proceed with SQL installation. 
Step 28. Right-click on JMPS_SQL_VOL volume in the tree view in VEA, select 

File System from the context menu, and then select Change Drive Letter and Path 
from the File System submenu. The Drive Letter and Paths screen appears. 

Step 29. Selected the Remove option and click OK. 
Step 30. Click Yes in the confirmation screen that appears. 
Step 31. Repeat the same steps to unmount JMPS_SHARE_VOL. 
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Step 32. Right-click on JMPS_SQL_GRP and select Deport Dynamic Disk Group 

from the menu that appears. 
Step 33. Click Yes to the warning message asking if the group should be deported. 
Step 34. Repeat the same two steps above to deport JMPS_SHARE_GRP. 
Step 35. Continue with section 6.18. 
 

6.18 Procedure: Reserving the disks on JMPSSERVER1 for SQL Server 2000 
Enterprise Edition installation. 

 
Step 1. This work is performed on JMPSSERVER1.  
Step 2. Start VEA on JMPSSERVER1 (Select Start  Programs  VERITAS Enterprise 

Administrator). Select JMPSSERVER1 from the drop-down box and click OK. 
Step 3. Expand JMPSSERVER1 in the tree view and click on Disk Groups. There should 

be two dynamic disk groups – JMPS_SHARE_GRP and JMPS_SQL_GRP. Both 
should be listed as deported.  

Step 4. Right-click on the dynamic disk group JMPS_SQL_GRP and select Import 
Dynamic Disk Group from the menu that appears. A window will come up where a 
new name for the disk group can be specified. Leave the default name that is listed.  

Step 5. Click OK to import the dynamic disk group. The status should change to 
Imported. 

Step 6. Start the Disk Reservation utility by selecting Start  Programs  VERITAS 
Cluster Server  Tools  Disk Reservation Utility 

Step 7. Click Reserve Disks and click Next. 
Step 8. The Reserve Disks dialog box displays a list of mounted volumes and their drive 

letters. Check the box at the bottom of the window that allows reservation of 
additional volumes. Click Next. 

Step 9. In the Unmounted disk group volumes pane, select the volume to be reserved in 
the Mount column by checking the box to the left of JMPS_SQL_VOL. 

Step 10. Select a drive letter for the volume in the Drive Letter column. Use E: 
Step 11. Click Next to mount and reserve the volume. 
Step 12. In the Completing the Disk Reservation dialog box, select Quit this utility. 

The Disk Reservation Utility will be restarted later to release the volume after 
installing SQL Server. 

Step 13. Click Finish. The VEA window can now be minimized. 
Step 14. Follow instructions in section 6.19 to install SQL Server 2000 Enterprise 

Edition on JMPSSERVER1. 
 
 

6.19 Procedure: Installation of SQL 2000 and Service Pack 3 for SQL on 
JMPSSERVER1 

 
NOTE 
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THE SQL SERVER 2000 SERVICE PACK 3 WILL 
NEED TO BE DOWNLOADED FROM THE 
MICROSOFT WEB SITE AND PLACED ONTO A CD 
FOR THIS PROCEDURE. 

 
 
Step 1. Place the SQL Server 2000 Enterprise Edition installation CD into the CD-ROM 

drive of JMPSSERVER1. 
Step 2. If the SQL Server 2000 Enterprise Edition screen does not appear perform steps 3 

to 6 below, otherwise skip to Step 7. 
Step 3. Select Start->Run. 
Step 4. On the Run dialog box click the “Browse” button. 
Step 5. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the setup file for SQL Server 2000 Enterprise Edition 
“Autorun.exe” and double click on it to set the path to it in the Run dialog box. 

Step 6. On the Browse dialog box click the “OK” button. 
Step 7. The Microsoft SQL Server 2000 Enterprise Edition screen will appear, click the 

“SQL Server 2000 Components choice. 
Step 8. The SQL Server 2000 Enterprise Edition - Install Components screen will then 

appear. Click on the “Install Database Server” choice. 
Step 9. The Enterprise Edition - Microsoft SQL Server 2000 screen along with the 

Welcome dialog box will open, click the “Next” button. 
Step 10. The Computer Name dialog box will then appear with the following message: 
 

“Enter the name of the computer on which you want to create a new instance of SQL 
Server or modify an existing instance of SQL Server” 
 
Accept the default “Local Computer” choice and click the “Next” button. 

Step 11. The Installation Selection - Select one of the following installation options 
dialog will appear.  Accept the default “Create a new instance of SQL Server, or 
install Client Tools ” choice and click the “Next” button. 

Step 12. The User Information dialog box will then appear.  It will be filled in with the 
Name and Company information from the installation of the Windows 2000 
Advanced Server.  Click the “Next” button to continue. 

Step 13. The Software License Agreement dialog box will then appear, click the “Yes” 
button to accept the license. 

Step 14. The CD-Key dialog box will then open, enter the key from the SQL Server 
2000 Enterprise CD sleeve and then click the “Next” button. 

Step 15. The Installation Definition dialog box will then open, accept the default 
“Server and Client Tools” choice, click the “Next” button. 

Step 16. The Instance Name dialog box will then appear.  Uncheck the “Default” box 
and in the Instance name box enter “JMPS_SQL_SERVER”.  Click the “Next” 
button. 

Step 17. The Setup Type dialog box will then open.  Select the “Typical” installation 
type.  Accept the default location of the Program Files in “C:\Program 
Files\Microsoft SQL Server”.  Click the Browse button next to the Data Files, on the 
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Choose Folder dialog box that opens set the path for the SQL Data to “e:\Program 
Files\Microsoft SQL Server”.  Click the “OK” button. The Setup Type dialog box 
should update to the new path. Click the “Next” button to proceed. 

Step 18. The Service Accounts dialog box will open. Click Customize the settings for 
each service and clear the Auto Start Service check box. SQL Server check box will 
be selected at this moment. 

Step 19. In the Service Setting box accept the default “Use a Domain User Account” 
choice. Enter in the password for the administrator account and verify the domain is 
correct. 

Step 20. Now click on the SQL Server Agent check box and enter the password for the 
administrator account and verify the domain is correct. Click the “Next” button. 

Step 21. The Authentication Mode dialog box will then open, accept the default 
“Windows Authentication Mode” choice and click the “Next” button. 

Step 22. The Start Copying Files dialog box will then appear, click the “Next” button. 
Step 23. The Choose Licensing Mode dialog will open next. Select the “Per Seat for” 

choice and set the devices number to the number of licenses that were shipped with 
the server for the specific site. Click the “Continue” button. 

Step 24. Setup will start to copy files, several setup dialogs will open then close and 
then the copying files status bar will open with the installation progress. 

Step 25. The Shutting Down Tasks dialog box may appear with the message: 
 

“Setup has detected that the following tasks are using files that setup needs to install. 
In order to avoid rebooting the machine at the end of setup, it is recommended that 
you shutdown the following tasks. 
 
TASK 
 
Nspm.exe 
Svchost.exe 
Vxsvc.exe” 

 
Click the “Next” button if this dialog does appear.  

 
Step 26. The Installing the Software dialog box will then open. Click the “Finish” 

button to complete the installation of SQL Server. 
Step 27. The Setup Complete dialog box will then appear. Select “No, I will restart my 

computer later.” 
Step 28. Start the Disk Reservation utility (Start  Programs  VERITAS Cluster 

Server  Tools  Disk Reservation Utility), click Release Disks in the Welcome to 
the Disk Reservation Utility dialog box, and then click Next. 

Step 29. In the Release Disks dialog box do the following: 
a. Select the mount path to release by clicking on the E: drive or by clicking 

on the bar with text “Mount Path” on it. Clicking on the bar selects all 
listed drives to be released. 

b. Select the Unassign the drive letter check box to unmount the drive letter 
before releasing the volume.  
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c. Click Next to release the volume. Note: If some window or application is 
accessing drive E:, disk reservation utility will fail to release the disk and 
will give an error. Make sure Windows Explorer is not showing the 
contents of the E: drive and no application is accessing it. 

Step 30. In the Confirmation dialog box, click Finish to exit the utility. 
Step 31. Reboot JMPSSERVER1. Remove the SQL Server 2000 CD from the CD-

ROM drive. 
Step 32. Logon back onto JMPSSERVER1 into the administrator account. 
Step 33. Check the SQL server symbol in the lower right-hand corner of the system 

tray. It should have a red stop sign indicating that SQL server is not running. 
Step 34. Reserve the disk group using the Veritas Cluster Server Disk Reservation 

Utility. This was described in the section above - Reserving the disks for SQL Server 
2000 Enterprise Edition installation.  

Step 35. The E: drive should now be visible in Windows Explorer.  
Step 36. Start SQL Server by right-clicking on the SQL Server icon in the system tray 

and selecting MSSQL Server – Start. 
Step 37. Verify that the SQL Server is running by checking for the server symbol in the 

lower right-hand corner of the Start Menu Bar. The server symbol should have a 
green arrow indicating that it is running. 

Step 38. Place the CD containing the SQL Server 2000 Service Pack 3 into the CD-
ROM drive. 

Step 39. Select Start->Run. 
Step 40. On the Run dialog box click the “Browse” button. 
Step 41. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the installation file for SQL Server Service Pack 3 
“SQL2KSP3.EXE”.  Select the file and double click on it to set the path to it in the 
Run dialog box. 

Step 42. On the Browse dialog box click the “OK” button. 
Step 43. The Installation Folder dialog box will open, the path to the Installation Folder 

will be “C:\sql2ksp3”. Accept this default location and click the “Finish” button. 
Step 44. The PackageForTheWeb dialog will open with the following message: 
 

“The specified output folder does not exist. Create it?” 
 
Click the “Yes” button to create the folder and to unpack the SQL patch. 

 
Step 45. The Reading Package…dialog box will open, then the Unpacking dialogs will 

appear and close. The PackageForTheWeb dialog will then re-appear with the 
message: 

 
“The package has been delivered successfully.” 
 
Click the “OK” button. 

Step 46. Select Start->Run 
Step 47. On the Run dialog that appears click the “Browse” button. 
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Step 48. On the Browse dialog that opens set the path to the “C:\sql2ksp3” folder. In 

the “sql2ksp3” folder select the “setup.bat” file and double-click on it to set the path 
to it in the Run box. 

Step 49. On the Run dialog box click the “OK” button to start the SQL patch 
installation. 

Step 50. A Warning dialog box may then open with the following warning: 
 

“If you have not rebooted since installing SQL Server 2000, please do so at this 
time.” 

 
Since the server was restarted after the SQL Server was installed, click the “Next” 
button if this dialog should appear. 

Step 51. The Service Pack 3 screen will open with the Welcome dialog box, click the 
“Next” button. 

Step 52. The Software License Agreement dialog box will then open. Click the “Yes” 
button to accept the license. 

Step 53. The Instance Name dialog box will then appear, click the “Next” button to 
apply the service patch to the default instance of SQL Server 2000. 

Step 54. The Connect to Server dialog box will open, accept the default “The Windows 
account information I use to log on to my computer with (Windows Authentication)” 
choice and click the “Next” button. 

Step 55. The SA Password Warning dialog box will appear with the following 
message: 

 
“Service pack setup has detected that your SA password is set to blank.  It is highly 
recommended that you set a strong password and secure your database server, even 
if you are using Windows authentication.” 
 
Enter a SA password into the Enter SA Password and Confirm SA Password boxes, 
click the “OK” button when finished. 

 
Step 56. The SQL Server 2000 Service Pack 3 Setup Backward Compatibility 

Checklist dialog box will open.  Click the “Upgrade Microsoft Search and apply SQL 
2000 SP3 (required)” selection.  Click the “Continue” button. 

Step 57. The Error Reporting dialog will then open.  Click the “OK” button to 
continue, do not select the automatic error notification feature. 

Step 58. The Start Copying Files dialog box will then appear.  Click the “Next” button. 
Step 59. The Shutting Down Tasks dialog box may appear with the message: 
 

“Setup has detected that the following tasks are using files that setup needs to install. 
In order to avoid rebooting the machine at the end of setup, it is recommended that 
you shutdown the following tasks. 
 
TASK 
 
Nspm.exe 
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Snmp.exe 
Svchost.exe” 

 
Click the “Next” button if this dialog does appear. A restart will be executed after the 
Service Pack is applied. 
 

Step 60. The Installing the Software dialog box will then appear, click the “Finish” 
button. 

Step 61. When the installation competes the Setup dialog box will open with the 
following message: 

 
“You should now backup your master and msdb databases since this installation has 
updated their content.” 
 
Click the “OK” button. 

 
Step 62. The Setup Complete dialog box will then appear. Select the “No, I will restart 

my computer later” choice from the Setup Complete dialog box from the SQL 
installation and click the “Finish” button.  

Step 63. Start the Disk Reservation utility (Start  Programs  VERITAS Cluster 
Server  Tools  Disk Reservation Utility) and click Release Disks in the Welcome 
to the Disk Reservation Utility dialog box. 

Step 64. In the Release Disks dialog box do the following: 
a. Select the mount path to release by clicking on E:.  
b. Select the Unassign the drive letter check box to unmount the drive letter 

before releasing the volume.   
c. Click Next to release the volume. 

Step 65. In the Confirmation dialog box, click Finish to exit the utility. 
Step 66. Remove the CD containing the SQL Server 2000 Service Pack 3 and reboot 

JMPSSERVER1. 
Step 67. Logon back onto JMPSSERVER1 into the administrator account. 
Step 68. Check the SQL server symbol in the lower right-hand corner of the system 

tray. It should have a red stop sign indicating that SQL server is not running. 
Step 69. Reserve the disk group using the Veritas Cluster Server Disk Reservation 

Utility. This was described in the section above - Reserving the disks for SQL Server 
2000 Enterprise Edition installation.  

Step 70. The E: drive should now be visible in Windows Explorer.  
Step 71. Start SQL Server by right-clicking on the SQL Server icon in the system tray 

and selecting MSSQL Server – Start. 
Step 72. Verify that the SQL Server is running by checking for the server symbol in the 

lower right-hand corner of the Start Menu Bar. The server symbol should have a 
green arrow indicating that it is running. 

Step 73. From the Start menu, select Programs  Microsoft SQL Server  Server 
Network Utility. 

Step 74. In the Instance(s) on this server box, select the appropriate instance from the 
drop-down list box. Select JMPS_SQL_SERVER. 
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Step 75. Select TCP/IP under Enabled protocols and click Properties. 
Step 76. In the Default port box, enter the specific port for the instance in the cluster 

and click OK. The default value that is shown there can be used. Write down that 
port value. It will be needed later. Note: If a different port value is chosen, SQL 
server must be restarted. Right-click on SQL Server icon in the system tray and select 
MSSQL Server – Stop. Wait about 10 seconds. Now Right-click on SQL Server icon 
again and select MSSQL Server – Start. Wait another 10 seconds before continuing. 
For JMPSSERVER2 installation only: When later executing this step on 
JMPSSERVER2, use the port written down in this step during JMPSSERVER1 
setup and then restart SQL server according to steps just described. 

Step 77. From the Start menu, select Programs  Microsoft SQL Server  Client 
Network Utility.  

Step 78. Click the Alias tab, then click Add. 
Step 79. In the Add Network Library Configuration dialog box, type the 

servername\instance in the Server alias box. Type 
JMPSSERVER1\JMPS_SQL_SERVER. 

Step 80. Click TCP/IP under Network Libraries.  
Step 81. Clear the Dynamically determined port check box. 
Step 82. Enter the port number that was written down previously for the instance in the 

cluster in the Port number box and click OK. For JMPSSERVER2 installation 
only: When later executing this step on JMPSSERVER2, use the port written 
down in step 76 during JMPSSERVER1 setup. 

Step 83. In the SQL Server Client Network Utitity dialog box, click OK to accept the 
changes. 

Step 84. From the Start menu, click Programs  Microsoft SQL Server  Query 
Analyzer. The Connect to SQL Server dialog box displays. 

Step 85. Click the ellipsis (...). Two server listings may be shown. Click OK. The first 
JMPSSERVER1\JMPS_SQL_SERVER will be selected automatically. 

Step 86. Click Windows authentication. Click OK to continue. 
Step 87. In the Query dialog box, type “sp_helpserver” (without the double quotes) and 

press F5 to execute. This command shows the name of the instance needed for the 
next step. Be careful to type the commands exactly as instructed in this manual. If an 
error message is displayed, erase the previous text in the query dialog box in the top 
window pane and type the command again. 

Step 88. If the previous command was successful, erase the previous text 
(sp_helpserver) in the query dialog box in the top window pane. In the Query dialog 
box, now type “sp_dropserver ‘JMPSSERVER1\JMPS_SQL_SERVER’ ” and press 
F5 to execute. When the command is successful, messages in the lower window pane 
that say “(1 row(s) affected)” will be displayed. Otherwise an error message will be 
displayed. If an error message is displayed, erase the previous text in the query dialog 
box in the top window pane and type the command again. 

Step 89. If the previous command was successful, erase the previous text 
(sp_dropserver ‘JMPSSERVER1\JMPS_SQL_SERVER’) in the query dialog box in 
the top window pane. In the Query dialog box now type the following: “sp_addserver 
‘JMPS_SQL_SERVER\JMPS_SQL_SERVER’, local” and press F5 to execute. 
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There is a space between the comma and the word “local”. SQL Server is now 
configured on JMPSSERVER1. 

Step 90. Exit Query Analyzer by going to File  Exit. Click the No to All button at 
the warning message about saving text. 

Step 91. Stop SQL server by right-clicking on the SQL icon in the system tray and 
selecting MSSQL Server – Stop. Click Yes to confirm that SQL Server will be 
stopped. 

Step 92. Release the E: drive using the Disk Reservation Utility as done previously. 
Step 93. Reboot JMPSSERVER1. 
Step 94. Continue with section 6.20. 
 
 

6.20 Procedure: Reserving the disks on JMPSSERVER2 for SQL Server 2000 
Enterprise Edition installation 

 
Step 1. This work is performed on JMPSSERVER2.  
Step 2. Follow steps 1-3 from section 6.15 to start VEA and configure VEA on 

JMPSSERVER2.  
Step 3. Continue with steps 3-14 in sections 6.18 to reserve the E: drive on 

JMPSSERVER2. The steps are identical to JMPSSERVER1 except for the server 
names. 

Step 4. When finished, continue with the next section. 

6.21 Procedure: Installation of SQL 2000 and Service Pack 3 for SQL on 
JMPSSERVER2 

 
Step 1. Open Windows Explorer and find the SQL installation directory on the shared E 

drive. It should be e:\Program Files\Microsoft SQL Server. Delete that directory. 
Click Yes if a warning regarding deletion of files appears. If the directory 
(E:\Program Files\…) is present when you start installing SQL on JMPSSERVER2, 
the installation will fail.  

Step 2. Close Windows Explorer. 
Step 3. Follow the steps in section 6.19 to install SQL on JMPSSERVER2. The steps are 

identical to JMPSSERVER1, except for the server names. Watch for notes specific to 
JMPSSERVER2 installation in steps 76 and 82. 

Step 4. Continue with the next section when finished. 
 

6.22 Procedure: Configuring VCS SQL agent 
 
Step 1. On JMPSSERVER1, insert the VCS Enterprise Agent for SQL Server 2000 CD. 
Step 2. In the autorun browser, click Install from the left pane, and click VCS Enterprise 

Agent for SQL Server 2000. 
Step 3. In the Welcome dialog box, read the text and click Next. 
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Step 4. Click Next again when the system completes the validation. This may take a few 

minutes. 
Step 5. In the Agent Installation Manager (AIM) Options dialog box, select the option to 

Install the enterprise agent and click Next. 
Step 6. In the License Agreement dialog box, select the option to accept the terms and 

click Next. 
Step 7. In the System Selection dialog box, select the check box next to the nodes on 

which the agent will be installed and click Next. Click Select All to select both 
JMPSSERVER1 and JMPSSERVER2. 

Step 8. In the Summary dialog box, review the information and click Next to continue or 
Back to make changes. Various messages are displayed indicating the status of the 
installation. 

Step 9. In the Completing the Enterprise Agent Installation dialog box, uncheck the 
option to Launch the configuration wizard. The configuration wizard will be started 
manually. 

Step 10. Click Finish to complete the installation. Click Exit to quit VCS SQL agent 
setup utility. 

Step 11. Use VEA and VCS Disk Reservation utility to mount the E: drive on 
JMPSSERVER1 according to instructions provided in section 6.18 

Step 12. Log on to the cluster using Veritas Cluster Manager by double-clicking 
the VERITAS Cluster Manager (Java Console) icon on the desktop. 

Step 13. After starting Cluster Manager, the first window that appears is Cluster 
Monitor. This window includes a toolbar, menus, and one or more cluster panels 
displaying general information about the clusters. 

Step 14. On the Cluster Monitor File menu, click New Cluster. 
Step 15. In the New Cluster - Connectivity Configuration dialog box, enter the 

relevant information: 
a. “JMPS_Cluster” for the cluster alias 
b. “JMPSSERVER1” for the host name 
c. Leave the default port number and number of failover retries. VCS sets the 

default port number to 14141 and failover retries number to 12.  
Step 16. Click OK. An inactive, gray panel for JMPS_Cluster will appear in 

Cluster Monitor. 
Step 17. The Login window will also appear automatically. 
Step 18. In the Login window, enter a valid VCS user name and password. This 

user name and password was created in Step 28 in section 6.12. 
Step 19. Click OK. 
Step 20. In the warning message window that comes up, click No to the warning 

message regarding creation of service groups. 
Step 21. From JMPSSERVER1, launch the configuration wizard  by selecting Start 

 Programs  VERITAS Cluster Server  SQL Server 2000 Enterprise Agent  
Configuration Wizard. 

Step 22. In the Welcome dialog box, click Next. 
Step 23. In the Wizard Options dialog box, click Create Service Group to add a 

new service group to the node.  
Step 24. Click Next.  
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Step 25. The wizard may ask to change configuration to read-write mode. Click on 

Yes.  
Step 26. In the Service Group Configuration dialog box, enter JMPS_SRV_SQL 

for the service group name.  
Step 27. Select the nodes in the Available Cluster System list to configure and click 

the right arrow to add them to the Systems in Priority Order list. Both JMPSERVER1 
and JMPSSERVER2 should be added. The nodes added to the service group system 
list are listed in priority order. JMPSSERVER1 should be listed first and 
JMPSSERVER2 second. Note: Use the up and down arrow to change the priority of 
the clustered nodes on which the service group will run.  

Step 28. Click Next. 
Step 29. In the SQL Server 2000 Instance Selection dialog box, select the instance 

from the Available Instance list and click Next. Only one instance 
JMPS_SQL_SERVER should be listed. 

Step 30. In the SQL Server 2000 Service Configuration dialog box, select both of 
the additional services you want to monitor and click Next.  

Step 31. In the Detail Monitoring Configuration dialog box click Next. Do not 
select Detailed Monitoring. 

Step 32. In the Virtual Server Configuration dialog box, enter 
“JMPS_SQL_SERVER” for the virtual server name. Also enter a unique virtual IP 
address and subnet mask. Two Gigabit Ethernet adapters (Local Area Connection 3) 
should be shown below as well. 

Step 33. Click Next. 
Step 34. In the Service Group Summary dialog box, click on a resource to review 

its attribute information. 
Step 35. Click Next to create the SQL Server 2000 service group. 
Step 36. From the Warning dialog box, click Yes to run the commands to create the 

service group. 
Step 37. In the Completing the SQL Server 2000 Configuration Wizard dialog box, 

click the Bring Service Group Online checkbox and then click Finish. Window will 
close and the SQL service group will come up automatically. In Veritas Cluster 
Explorer, status will change to Online after 1-2 minutes. 

Step 38. Save your configuration. (File  Close Configuration) 
Step 39. Logon to JMPSSERVER2 as an Administrator. 
Step 40. Log on to the cluster using Veritas Cluster Manager by double-clicking 

the VERITAS Cluster Manager (Java Console) icon on the desktop. 
Step 41. After starting Cluster Manager, the first window that appears is Cluster 

Monitor. This window includes a toolbar, menus, and one or more cluster panels 
displaying general information about the clusters. 

Step 42. On the Cluster Monitor File menu, click New Cluster. 
Step 43. In the New Cluster - Connectivity Configuration dialog box, enter the 

relevant information: 
a. “JMPS_Cluster” for the cluster alias 
b. “JMPSSERVER2” for the host name 
c. Leave the default port number and number of failover retries. VCS sets the 

default port number to 14141 and failover retries number to 12.  
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Step 44. Click OK. An inactive, gray panel for JMPS_Cluster will appear in 

Cluster Monitor. 
Step 45. Continue with section 6.23. 

 

6.23 Procedure: Configuring VCS File Share agent 
 
Step 1. The work will be performed on JMPSSERVER1.  
Step 2. The dynamic volume containing the file share (F:\) must be mounted on 

JMPSSERVER1 for VCS File Share agent configuration.  
Step 3. Start VEA on JMPSSERVER1 and click on Disk Groups in the tree view. Two 

dynamic disk groups will be visible – JMPS_SHARE_GRP and JMPS_SQL_GRP. 
The status for both should be Deported.  
Note: If both dynamic groups are not visible, a rescan of the computer may be 
necessary. This can be done by right-clicking on the server name (JMPSSERVER1 in 
this case) in the tree view and selecting Rescan. After a few seconds, select Refresh 
from the same menu to update the tree view. 

Step 4. Right-click on the dynamic disk group JMPS_SHARE_GRP and select Import 
Dynamic Disk Group from the menu that appears. A window will come up where a 
new name for the disk group can be specified. Leave the default name that is listed.  

Step 5. Click OK to import the dynamic disk group. The status should change to 
Imported. 

Step 6. Now Right-click on JMPS_SHARE_VOL in the volumes tree view, select File 
System from the context menu, and then select Change Drive Letter and Path from 
the File System submenu. The Drive Letter and Paths screen appears.  

Step 7. Select Add. Assign a Drive Letter box becomes available. Select F: drive letter 
from the drop-down list. Click OK. 

Step 8. Wait a few seconds. The file share F: drive should now be visible in Windows 
Explorer.  

Step 9. Use Windows Explorer to create a directory called “JMPS_Data” on drive F. 
Step 10. Start the FileShare configuration wizard. Click Start  Programs  

VERITAS Cluster Server  FileShare ConfigurationWizard.  
Step 11. Read the Welcome screen and click Next. 
Step 12. In the Wizard Options dialog box, click the Create service group option 

and click Next. 
Step 13. In the Service Group Configuration dialog box, enter a name for the 

service group and click the systems on which to configure the service group. 
a. In the Service Group Name field, enter “JMPS_SRV_SHARE” for the file 

share service group. 
b. In the Available Cluster Systems box, click the systems on which to 

configure the service group. Select both JMPSSERVER1 and 
JMPSSERVER2. Click the right arrow or double-click the system name to 
include a selected system in the service group’s system list. The selected 
systems are transferred to the Systems in Priority Order box. To remove a 
system from the service group’s system list, click the system in the 
Systems in Priority Order box and click the left arrow. 
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c. JMPSSERVER1 should be listed at the top and JMPSSERVER2 should 
be second. To change a system’s priority in the service group’s system list, 
click the system in the Systems in Priority Order box and click the up and 
down arrows. System priority defines the order in which service groups 
are failed over to systems. The system at the top of the list has the highest 
priority; the system at the bottom has the lowest. JMPSSERVER1 is the 
system with the higher priority. 

Step 14. Click Next. The wizard may ask to change configuration to read-write 
mode. Click on Yes.  

Step 15. The wizard then starts validating the configuration. Various messages 
indicate the status. After the validations are completed, the FileShare Configuration 
dialog box is displayed.  

Step 16. In the FileShare Configuration dialog box, specify the configuration 
information for the file share resources to be created. 

a. In the Virtual Computer Name field, enter a unique virtual computer name 
by which the server will be known to clients. Enter “JMPSSERVER”. 

b. In the Path column, enter or click the path of the directories to be shared. 
Click the Edit icon (...) to browse for folders. Browse to F: and select 
F:\JMPS_Data. The wizard will validates the selected directory FileShare 
Configuration Wizard.  

c. In the Share Name column, simply click once on the box that should 
contain the share name. “JMPS_Data” will automatically be entered in the 
box. 

d. Check the Share Subdirs box to share the subdirectories on our file share 
drive. The other two options, Hide Shares and Hide Child Shares should 
not be checked. 

e. Click Next. The wizard begins validating your configuration. Various 
messages indicate the status. After the validations are completed, the 
Share Permissions dialog box is displayed. 
Note: If the wizard cannot contact JMPSSERVER2, it is possible that DNS 
information for the internal network adapters was imported into DNS and 
JMPSSERVER1 does not associate JMPSSERVER2 with the correct IP 
address of the external Gigabit Ethernet adapter in JMPSSERVER2. In 
this case, DNS information for the internal 2 cards needs to be deleted 
from DNS and DNS database needs to be flushed on both JMPSSERVER1 
and JMPSSERVER2. The wizard can then be restarted.  

Step 17. In the Share Permissions dialog box, click the file share users and assign 
permissions to them. 

a. In the FileShares drop-down list box, click the file share with which to 
associate user permissions. JMPS_Data should be shown. 

b. In the Look In drop-down list box, click the domain, to which the users 
belong. JMPS should be shown there. 

c. In the Users drop-down list box, double-click the Everyone user name in 
the Users list to transfer the user to the Selected Users list. 

93 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 94 
 

d. In the Selected Users list, click the Everyone user whose default 
permission you want to change. On the Type Of Access list, select 
FULL_CONTROL 

e. Click Next. The Network Configuration dialog box is displayed.  
Step 18. In the Network Configuration dialog box, specify information related to 

your network. 
a. In the Virtual IP Address field, enter a unique virtual IP address for the 

virtual server.  
b. In the Subnet Mask field, enter the subnet to which the virtual server 

belongs.  
c. For each system in the cluster, enter or click the public network adapter 

name. To view the adapters associated with a system, click the Adapter 
Name field and click the arrow. Note that the wizard displays all TCP/IP 
enabled adapters on a system, including the private network adapters, if 
applicable. Verify that the selected adapter is assigned to the public 
network, not the private. The two gigabit Ethernet adapters should be 
shown for both servers under Adapter Display name. Place the mouse over 
the connection name and a tool tip will pop up stating that the gigabit card 
is being used. 

d. Click Next. The Service Group Summary dialog box is displayed the 
Cluster Manager.  

Step 19. In the Service Group Summary dialog box, review the configuration and 
click Next. 

Step 20. Click Yes to create service group. 
Step 21. In the completion dialog box, click the Bring the service group online 

check box.  
Step 22. Click Finish. The file share service group is created in your configuration. 
Step 23. The file share service group will come up automatically and status will 

change to Online in Veritas Cluster Explorer. This will take 1-2 minutes. 
Step 24. Continue with section 6.24. 
 

6.24 Procedure: Installing Veritas Backup Exec 9.0 for Windows Servers (BE) 
 
Step 1. In Veritas Cluster Explorer, expand the configuration tree on the left side until 

both service groups are visible. A status view will be shown on the right side of the 
window. 

Step 2. Right-click on the first group, JMPS_SRV_SHARE, select Offline, and click the 
appropriate system from the menu. Click Yes to confirm the operation. This step will 
take about 1 minute. Be patient. When the service group is taken offline, the status 
view will show JMPS_SRV_SHARE as being offline on JMPSSERVER1. 

Step 3. Right-click on the second group, JMPS_SRV_SQL, select Offline, and click the 
appropriate system from the menu. Click Yes to confirm the operation. This step will 
take about 1 minute. Be patient. When the service group is taken offline, the status 
view will show JMPS_SRV_SQL as being offline on JMPSSERVER1. 
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Step 4. Exit Cluster Explorer by going to File  Close. Window asking whether to save 

the configuration may appear. Click Yes to save configuration if the warning window 
does appear. 

Step 5. Exit Cluster Monitor by going to File  Exit. 
Step 6. Go to Start  Run and type “cmd”.  
Step 7. When the command window appears, type “hastop –all”. Note: There is a space 

between “hastop” and “-all”.  
Step 8. Close command window. 
Step 9. Use VEA and disk reservation utility to mount disks E and F. This was described 

in section 6.18. Mount both JMPS_SQL_VOL and JMPS_SHARE_VOL with drive 
letters E and F respectively.  

Step 10. Start SQL Server by right-clicking on the SQL icon in the system tray and 
selecting MSSQL Server – Start. 

Step 11. Place the CD containing Veritas Backup Exec 9.0 for Windows Servers in 
the CD-ROM on JMPSSERVER1. 

Step 12. If the Veritas Backup Exec(TM) 9.0 for Windows Servers screen does not 
appear, perform steps 13 to 16 below, otherwise skip to Step 17. 

Step 13. Select Start->Run. 
Step 14. On the Run dialog box click the “Browse” button. 
Step 15. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the Veritas “Browser.exe” file and double click on it to set the 
path to it in the Run dialog box. 

Step 16. On the Browse dialog box click the “OK” button.   
Step 17. A window asking to choose installation language may come up. Click OK 

to select English. 
Step 18. The Veritas Backup Exec(TM) 9.0 for Windows Servers screen will 

appear. 
Step 19. On the Veritas Backup Exec(TM) 9.0 screen click the “Backup Exec 

Installation” selection. 
Step 20. The Pre-Installation Information checklist will appear, click the “Start Backup 

Exec Installation” choice. 
Step 21. The Windows Installer dialog will open then close. 
Step 22. The Veritas Welcome dialog box will then open.  Click the “Next” button. 
Step 23. The License Agreement dialog box will then open.  Click the “I accept the 

terms of the license agreement” button and then click “Next”. 
Step 24. The Veritas Backup Exec for Windows Servers Install Menu dialog will then 

open.  Leave the default “Local Install - Install Backup Exec software and options” 
choice selected, click the “Next” button. 

Step 25. The Use Local SQL with Backup Exec dialog will open.  Take the Select and 
existing SQL instance on which to run Backup Exec choice.  Since the SQL Server 
was installed ahead of Veritas Backup the “JMPS_SQL_SERVER” should appear in 
the list.  Click the “Next” button. 

Step 26. The Backup Exec warning dialog box will appear with the warning to install 
at least service pack 2 on SQL, this was done during the SQL setup, click the “OK” 
button.  Click the “Next” button. 

95 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 96 
 
Step 27. The Veritas Backup Exec Serial Numbers dialog box will then open.  Enter 

the designated Backup Exec, WIN, SVRS, V9.0, License Product Activation Number 
from the Veritas Software License Certificate.  Click the “Add” button, the activation 
number should then appear in the “Existing Serial Number” box. 

Step 28. Enter the designated Backup Exec, WIN, MICROSOFT SQL SVR AGENT 
W/CLIENT ACCESS, V9.0, License Product Activation Number from the Veritas 
Software License Certificate.  Click the “Add” button, the activation number should 
then appear in the “Existing Serial Number” box. 

Step 29. Enter the designated Backup Exec, WIN, REMOTE AGENT (CAL) FOR 
WIN SVRS 1 PACK, V9.0, License Product Activation Number from the Veritas 
Software License Certificate.  Click the “Add” button, the activation number should 
then appear in the “Existing Serial Number” box. 

Step 30. Enter the designated Backup Exec, WIN, ADVANCED OPEN FILE OPTION 
WITH CLIENT ACCESS LICENSE FOR WIN SVRS 1 PACK, V9.0, License 
Product Activation Number from the Veritas Software License Certificate.  Click the 
“Add” button, the activation number should then appear in the “Existing Serial 
Number” box. 

Step 31. Once the product serial numbers have been entered, click the “Next” button. 
Step 32. The Veritas Backup Exec Local Features review dialog box will then open.  

Review the options selected.  Click the “Next” button. 
Step 33. The Veritas Backup Exec Services dialog box will then appear.  Enter the 

Administrator password in the Password box and then click the “Next” button. 
Step 34. The Veritas Backup Exec(TM) 9.0 for Windows Servers dialog may open 

with the following message: 
 

“The account JMPS\Administrator has been granted the following rights: Create 
a token object”. 

 
Click the “OK” button. 

 
Step 35. The Veritas Tape Device Drivers dialog will then open.  Accept the default 

“Use Veritas device drivers for all tape devices (recommended)” selection, click the 
“Next” button. 

Step 36. The Ready to Install the Program dialog box will open.  Click the “Install” 
button. 

Step 37. The Installing Veritas Backup Exec for Windows Servers dialog will open as 
the software is loaded. 

Step 38. The Veritas Volume Software License Program dialog box may then open 
with the following message: 

 
“Thank you for purchasing Veritas Backup Exec for Windows NT using our flexible 
volume software license program. 
 
We hope you find that using this program makes it easier for you to acquire and 
deploy Veritas Software Corporation products.” 
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Click the “OK” button. 
 
Step 39. The Veritas installation will then proceed.  When it finishes the Veritas Install 

Wizard Completed dialog box will open.  Uncheck all options except “Create desktop 
shortcut”.  Click the “Finish” button. 

Step 40. Click Exit to quit the Backup Exec browser. 
Step 41. Click Yes in the confirmation window. 
Step 42. Stop SQL Server by right-clicking on the SQL icon in the system tray and 

selecting MSSQL Server – Stop. Then click Yes to confirm.  
Note: It has been noted that the SQL icon occasionally disappears from the system 
tray. In that case, go to Start  Programs  Microsoft SQL Server  Service 
Manager. Click the Stop button. Then click Yes to confirm. The status at the bottom of 
the window will eventually transition to “Stopped”. Service Manager can be closed 
at this point. 

Step 43. Unreserve the two disks, E and F, using the disk reservation utility. This 
process was described in Step 28 through Step 30 in section 6.19.  

Step 44. Go to Start  Programs  Administrative Tools  Services.  
Step 45. Find Backup Exec Device & Media Service and double-click on it.  
Step 46. In the Startup Type pull-down menu, select Manual instead of Automatic and 

click OK. 
Step 47. Repeat the same steps for the following two services: Backup Exec Job 

Engine and Backup Exec Server.  
Step 48. Close the Services Window. 
Step 49. Remove the Veritas Backup Exec v9.0 CD from JMPSSERVER1. 
Step 50. Reboot JMPSSERVER1. Allow it to reboot fully before continuing with the 

next step. 
Step 51. On JMPSSERVER1, log on to the cluster using Veritas Cluster Manager by 

double-clicking the VERITAS Cluster Manager (Java Console) icon on the desktop. 
Step 52. After starting Cluster Manager, the first window that appears is Cluster 

Monitor. An inactive, gray panel for JMPS_Cluster appears in Cluster Monitor.  
Step 53. Click that panel to log on to and monitor the cluster. 
Step 54. In the Login window, enter a valid VCS user name and password. Click OK. 

Cluster Explorer window will open and the two service groups will be shown in the 
explorer.  

Step 55. In the configuration tree on the left side, right-click on the first group, 
JMPS_SRV_SHARE, select Autoenable, and then select JMPSSERVER2. 

Step 56. In the configuration tree on the left side, right-click on the first group, 
JMPS_SRV_SQL, select Autoenable, and then select JMPSSERVER2. 

Step 57. In the configuration tree on the left side, right-click on the first group, 
JMPS_SRV_SHARE, select Online, and then select JMPSSERVER1. Click Yes to 
confirm. This step will take about 1-2 minutes. Be patient. When the service group is 
online, the status view will show JMPS_SRV_SHARE as being online on 
JMPSSERVER1 and offline on JMPSSERVER2. 

Step 58. In the configuration tree on the left side, right-click on the second group, 
JMPS_SRV_SQL, select Online, and then select JMPSSERVER1. Click Yes to 
confirm. This step will take about 1-2 minutes. Be patient. When the service group is 
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online, the status view will show JMPS_SRV_SQL as being online on 
JMPSSERVER1 and offline on JMPSSERVER2. SQL Server icon will have a green 
arrow on it to indicate that SQL is running. 
Note: The following steps to online service group(s) on a server will be used 
frequently in subsequent software installations. The steps will not be described in 
detail then. The instruction will be to simply online the service group(s) on a server. 
It is assumed that the operator will be able to repeat instructions above. 

Step 59. Double click on the Veritas Backup Exec desktop icon to start the Veritas 
Backup software for the first time. 

Step 60. Connect to Media Server dialog will come up. Click on Services. 
Step 61. In the Services Manager window that comes up, click on Start All Services. 
Step 62. Click OK to close the status window once all services are started.  
Step 63. Click Close to close the Services Manager window.  
Step 64. Back on Connect to Media Server dialog, enter Administrator password and 

click OK. 
Step 65. The Welcome to the First Time Startup Wizard dialog box will open.  Click 

the “Next” button. 
Step 66. The Media Management with Media Sets dialog will open.  Click the “Next” 

button. 
Step 67. The Default Media Set Properties dialog box will open.  Accept the default 

choice “Yes, I want to edit this set or create new media sets that will allow Backup 
Exec to automatically recycle some media for my backups.”  Click the “Next” button. 

Step 68. The Welcome to the Media Set Wizard dialog box will open.  Click the 
“Next” button to continue. 

Step 69. The Create or Edit a Media Set dialog will open.  Leave the default “Create a 
new media set” choice selected and click the “Next” button. 

Step 70. The Name the Media Set dialog box will open.  Enter in “Daily Incremental” 
for the media set.  Click the “Next” button. 

Step 71. The Set the Overwrite Protection Period dialog box will open.  Click on the 
down arrow button and select “Days”, and the default value of “1”.  Click the “Next” 
button. 

Step 72. The Set Append Period dialog will open.  Click on the down arrow button and 
select “Days”, and the default value of “1”.  Click the “Next” button. 

Step 73. The Media Set Summary dialog will open.  Verify the choices set, click the 
“Next” button. 

Step 74. The Completing the Media Set Wizard dialog will open.  At this time 
additional Media Sets could be defined by clicking the “Add or edit another media set 
after clicking Finish” box.  Click the “Finish” box. 

Step 75. The Preferred Overwrite Media Type dialog box will open.  Leave the default 
choice of “Overwrite scratch media before overwriting recyclable media…” selected.  
Click the “Next” button. 

Step 76. The Overwrite Protection Level dialog box will open.  Accept the default 
“Partial” selection, click the “Finish” button. 

Step 77. The Welcome to the Device Configuration Wizard dialog will open.  Click the 
“Next” button. 
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Step 78. The Detected Hardware dialog box will then open.  The “COMPAQ 1 (Port: 

2, Bus: 0, Target ID: 5, Lun:0) should appear in the Backup device(s) list.  Click the 
“Next” button. 

Step 79. The Detected Backup-to-Disk Folders dialog will open.  No Backup-to Disk 
Folders are defined at this point for JMPS.  Click the “Next” button. 

Step 80. The Drive Configuration dialog box will open.  The COMPAQ 1 drive should 
be listed under the “Stand-alone Drives”.  Click the “Next” button. 

Step 81. The Completing the Device Configuration Wizard dialog will then open.  
Click the “Finish” button. 

Step 82. The Welcome to the Logon Account Wizard dialog will open.  Click the 
“Next” button. 

Step 83. The Setup Your Default Logon Account dialog box will open.  Select the 
“Select an existing logon account” choice and then click the “Next” button. 

Step 84. The Select a Logon Account dialog box will open.  Accept the default 
“System Logon Account (JMPS\Administrator)” account.  Click the “Next” button. 

Step 85. The Completing the Logon Account Wizard dialog box will open.  Click the 
“Finish” button. 

Step 86. Exit Backup Exec by selecting File  Exit. 
Step 87. Using Windows Explorer go to the C:\Program Files\Veritas\Backup Exec\NT 

and double-click on ServicesMgr.exe. 
Step 88. Click on Stop All Services and then click Yes to confirm.  
Step 89. Click OK to close the status window.  
Step 90. Click Close to close Services Manager.  
Step 91. Offline the two service groups (JMPS_SRV_SQL and JMPS_SRV_SHARE) 

from JMPSSERVER1 according to the following steps: 
a. In Veritas Cluster Explorer, in the configuration tree on the left side, 

single-click on the first group, JMPS_SRV_SHARE. A status view will be 
shown on the right side of the window. 

b. Right-click the service group in the configuration tree, click on Offline, 
and click the appropriate system from the menu. Click Yes to confirm the 
operation. This step will take about 1-2 minutes. Be patient. When the 
service group is offlined, the status view will show JMPS_SRV_SHARE 
as being offline on JMPSSERVER1. 

c. Perform steps a and b above to offline the second service group, 
JMPS_SRV_SQL, from JMPSSERVER1.  

Note: The following steps to offline service group(s) from a server will be 
used frequently in subsequent software installations. The steps will not be 
described in detail then. The instruction will be to simply offline the service 
group(s) from a server. It is assumed that the operator will be able to repeat 
instructions above. 

Step 92. On JMPSSERVER2, use VEA and disk reservation utility to mount disks E 
and F. This was described in section 6.18. Mount both JMPS_SQL_VOL and 
JMPS_SHARE_VOL with drive letters E and F respectively.  

Step 93. Start SQL Server by right-clicking on the SQL icon in the system tray and 
selecting MSSQL Server – Start. 
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Step 94. Place the CD containing Veritas Backup Exec 9.0 for Windows Servers in 

the CD-ROM on JMPSSERVER2. 
Step 95. If the Veritas Backup Exec(TM) 9.0 for Windows Servers screen does not 

appear, perform steps 98 to 101 below, otherwise skip to Step 102. 
Step 96. Select Start->Run. 
Step 97. On the Run dialog box click the “Browse” button. 
Step 98. On the Browse dialog box that appears set the path to the CD-ROM drive and 

then to the location of the Veritas “Browser.exe” file and double click on it to set the 
path to it in the Run dialog box. 

Step 99. On the Browse dialog box click the “OK” button.   
Step 100. A window asking to choose installation language may come up. Click OK 

to select English. 
Step 101. The Veritas Backup Exec(TM) 9.0 for Windows Servers screen will 

appear. 
Step 102. On the Veritas Backup Exec(TM) 9.0 screen click the “Backup Exec 

Installation” selection. 
Step 103. The Pre-Installation Information checklist will appear, click the “Start Backup 

Exec Installation” choice. 
Step 104. The Windows Installer dialog will open then close. 
Step 105. The Veritas Welcome dialog box will then open.  Click the “Next” button. 
Step 106. The License Agreement dialog box will then open.  Click the “I accept the 

terms of the license agreement” button and then click “Next”. 
Step 107. The Veritas Backup Exec for Windows Servers Install Menu dialog will then 

open.  Leave the default “Local Install - Install Backup Exec software and options” 
choice selected, click the “Next” button. 

Step 108. The Use Local SQL with Backup Exec dialog will open.  Take the Select and 
existing SQL instance on which to run Backup Exec choice.  Since the SQL Server 
was installed ahead of Veritas Backup the “JMPS_SQL_SERVER” should appear in 
the list.  Click the “Next” button. 

Step 109. The Backup Exec warning dialog box will appear with the warning to install 
at least service pack 2 on SQL, this was done during the SQL setup, click the “OK” 
button.  Click the “Next” button. 

Step 110. The Veritas Backup Exec Serial Numbers dialog box will then open.  Enter 
the designated Backup Exec, WIN, SVRS, V9.0, License Product Activation Number 
from the Veritas Software License Certificate.  Click the “Add” button, the activation 
number should then appear in the “Existing Serial Number” box. 

Step 111. Enter the designated Backup Exec, WIN, INTELLIGENT DISASTER 
RECOVERY OPTION, V9.0, License Product Activation Number from the Veritas 
Software License Certificate.  Click the “Add” button, the activation number should 
then appear in the “Existing Serial Number” box. 

Step 112. Enter the designated Backup Exec, WIN, MICROSOFT SQL SVR AGENT 
W/CLIENT ACCESS, V9.0, License Product Activation Number from the Veritas 
Software License Certificate.  Click the “Add” button, the activation number should 
then appear in the “Existing Serial Number” box. 

Step 113. Enter the designated Backup Exec, WIN, REMOTE AGENT (CAL) FOR 
WIN SVRS 1 PACK, V9.0, License Product Activation Number from the Veritas 
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Software License Certificate.  Click the “Add” button, the activation number should 
then appear in the “Existing Serial Number” box. 

Step 114. Enter the designated Backup Exec, WIN, ADVANCED OPEN FILE OPTION 
WITH CLIENT ACCESS LICENSE FOR WIN SVRS 1 PACK, V9.0, License 
Product Activation Number from the Veritas Software License Certificate.  Click the 
“Add” button, the activation number should then appear in the “Existing Serial 
Number” box. 

Step 115. Once the product serial numbers have been entered, click the “Next” button. 
Step 116. The Veritas Backup Exec Local Features review dialog box will then open.  

Review the options selected.  Click the “Next” button. 
Step 117. The Veritas Backup Exec Services dialog box will then appear.  Enter the 

Administrator password in the Password box and then click the “Next” button. 
Step 118. The Veritas Backup Exec(TM) 9.0 for Windows Servers dialog may open 

with the following message: 
 

“The account JMPS\Administrator has been granted the following rights: Create 
a token object”. 

 
Click the “OK” button. 

 
Step 119. The Veritas Tape Device Drivers dialog will then open.  Accept the default 

“Use Veritas device drivers for all tape devices (recommended)” selection, click the 
“Next” button. 

Step 120. The Ready to Install the Program dialog box will open.  Click the “Install” 
button. 

Step 121. The Installing Veritas Backup Exec for Windows Servers dialog will open as 
the software is loaded. 

Step 122. The Veritas Volume Software License Program dialog box may then open 
with the following message: 

 
“Thank you for purchasing Veritas Backup Exec for Windows NT using our flexible 
volume software license program. 
 
We hope you find that using this program makes it easier for you to acquire and 
deploy Veritas Software Corporation products.” 
 

Click the “OK” button. 
 
Step 123. The Veritas installation will then proceed.  When it finishes the Veritas Install 

Wizard Completed dialog box will open.  Uncheck all options except “Create desktop 
shortcut”.  Click the “Finish” button. 

Step 124. Click Exit to quit the Backup Exec browser. 
Step 125. Click Yes in the confirmation window. 
Step 126. Stop SQL Server by right-clicking on the SQL icon in the system tray and 

selecting MSSQL Server – Stop. Then click Yes to confirm.  
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Note: It has been noted that the SQL icon occasionally disappears from the system 
tray. In that case, go to Start  Programs  Microsoft SQL Server  Service 
Manager. Click the Stop button. Then click Yes to confirm. The status at the bottom of 
the window will eventually transition to “Stopped”. Service Manager can be closed 
at this point. 

Step 127. Unreserve the two disks, E and F, using the disk reservation utility. This 
process was described in Step 28 through Step 30 in section 6.19.  

Step 128. Go to Start  Programs  Administrative Tools  Services.  
Step 129. Find Backup Exec Device & Media Service and double-click on it.  
Step 130. In the Startup Type pull-down menu, select Manual instead of Automatic and 

click OK. 
Step 131. Repeat the same steps for the following two services: Backup Exec Job 

Engine and Backup Exec Server.  
Step 132. Close the Services Window. 
Step 133. Remove the Veritas Backup Exec v9.0 CD from JMPSSERVER2. 
Step 134. Reboot JMPSSERVER2. Allow it to reboot fully before continuing with the 

next step. 
Step 135. On JMPSSERVER2, log on to the cluster using Veritas Cluster Manager by 

double-clicking the VERITAS Cluster Manager (Java Console) icon on the desktop. 
Step 136. After starting Cluster Manager, the first window that appears is Cluster 

Monitor. An inactive, gray panel for JMPS_Cluster appears in Cluster Monitor.  
Step 137. Click that panel to log on to and monitor the cluster. 
Step 138. In the Login window, enter a valid VCS user name and password. Click OK. 

Cluster Explorer window will open and the two service groups will be shown in the 
explorer.  

Step 139. Online both service groups, JMPS_SRV_SQL and JMPS_SRV_SHARE, on 
JMPSSERVER2. 

Step 140. Double click on the Veritas Backup Exec desktop icon to start the Veritas 
Backup software for the first time. 

Step 141. Connect to Media Server dialog will come up. Click on Services. 
Step 142. In the Services Manager window that comes up, click on Start All Services. 
Step 143. Click OK to close the status window once all services are started.  
Step 144. Click Close to close the Services Manager window.  
Step 145. Back on Connect to Media Server dialog, enter Administrator password and 

click OK. 
Step 146. The Welcome to the First Time Startup Wizard dialog box will open.  Click 

the “Next” button. 
Step 147. The Media Management with Media Sets dialog will open.  Click the “Next” 

button. 
Step 148. The Default Media Set Properties dialog box will open.  Accept the default 

choice “Yes, I want to edit this set or create new media sets that will allow Backup 
Exec to automatically recycle some media for my backups.”  Click the “Next” button. 

Step 149. The Welcome to the Media Set Wizard dialog box will open.  Click the 
“Next” button to continue. 

Step 150. The Create or Edit a Media Set dialog will open.  Leave the default “Create a 
new media set” choice selected and click the “Next” button. 
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Step 151. The Name the Media Set dialog box will open.  Enter in “Daily Incremental” 

for the media set.  Click the “Next” button. 
Step 152. The Set the Overwrite Protection Period dialog box will open.  Click on the 

down arrow button and select “Days”, and the default value of “1”.  Click the “Next” 
button. 

Step 153. The Set Append Period dialog will open.  Click on the down arrow button and 
select “Days”, and the default value of “1”.  Click the “Next” button. 

Step 154. The Media Set Summary dialog will open.  Verify the choices set, click the 
“Next” button. 

Step 155. The Completing the Media Set Wizard dialog will open.  At this time 
additional Media Sets could be defined by clicking the “Add or edit another media set 
after clicking Finish” box.  Click the “Finish” box. 

Step 156. The Preferred Overwrite Media Type dialog box will open.  Leave the default 
choice of “Overwrite scratch media before overwriting recyclable media…” selected.  
Click the “Next” button. 

Step 157. The Overwrite Protection Level dialog box will open.  Accept the default 
“Partial” selection, click the “Finish” button. 

Step 158. The Welcome to the Device Configuration Wizard dialog will open.  Click the 
“Next” button. 

Step 159. The Detected Hardware dialog box will then open.  The “COMPAQ 1 (Port: 
2, Bus: 0, Target ID: 5, Lun:0) should appear in the Backup device(s) list.  Click the 
“Next” button. 

Step 160. The Detected Backup-to-Disk Folders dialog will open.  No Backup-to Disk 
Folders are defined at this point for JMPS.  Click the “Next” button. 

Step 161. The Drive Configuration dialog box will open.  The COMPAQ 1 drive should 
be listed under the “Stand-alone Drives”.  Click the “Next” button. 

Step 162. The Completing the Device Configuration Wizard dialog will then open.  
Click the “Finish” button. 

Step 163. The Configure Intelligent Disaster Recovery options dialog box will open 
next.  Click the “Cancel” button. Then click Yes to confirm. Note: IDR will be 
configured later. 

Step 164. The Welcome to the Logon Account Wizard dialog will open.  Click the 
“Next” button. 

Step 165. The Setup Your Default Logon Account dialog box will open.  Select the 
“Select an existing logon account” choice and then click the “Next” button. 

Step 166. The Select a Logon Account dialog box will open.  Accept the default 
“System Logon Account (JMPS\Administrator)” account.  Click the “Next” button. 

Step 167. The Completing the Logon Account Wizard dialog box will open.  Click the 
“Finish” button. 

Step 168. Exit Backup Exec by selecting File  Exit. 
Step 169. Using Windows Explorer go to the C:\Program Files\Veritas\Backup Exec\NT 

and double-click on ServicesMgr.exe. 
Step 170. Click on Stop All Services and then click Yes to confirm.  
Step 171. Click OK to close the status window.  
Step 172. Click Close to close Services Manager. 
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Step 173. Transfer the two service groups (JMPS_SRV_SQL and JMPS_SRV_SHARE) 

from JMPSSERVER2 to JMPSSERVER1 according to the following steps: 
a. In Veritas Cluster Explorer, in the configuration tree on the left side, 

single-click on the first group, JMPS_SRV_SHARE. A status view will be 
shown on the right side of the window. 

b. Right-click the service group in the configuration tree, click on Switch To, 
and click the appropriate system from the menu. This step will take about 
1-2 minutes. Be patient. When the service group is transferred, the status 
view will show JMPS_SRV_SHARE as being offline on JMPSSERVER2 
and online on JMPSSERVER1. 

c. Perform steps a and b above to transfer the second service group, 
JMPS_SRV_SQL, from JMPSSERVER2 to JMPSSERVER1.  

Note: The following steps to transfer service groups from one server to 
another will be used frequently in subsequent software installations. The steps 
will not be described in detail then. The instruction will be to simply transfer 
the service groups from one server to another. It is assumed that the operator 
will be able to repeat instructions above. 

Step 174. Backup Exec is now installed and configured on both servers. Continue with 
the next section. 

 

6.25 Procedure: Installation of Common Operating Environment (COE) 
 

NOTES 
 

THE COE KERNEL SOFTWARE MUST BE 
OBTAINED FROM YOUR DESIGNATED COE 
SOURCE. IT MAY BE NECESSARY TO 
MANUALLY CREATE A CD WHICH CONTAINS 
THE COE KERNEL AND THE NECESSARY COE 
SEQMENTS. 
 
IT IS RECOMMENDED THAT ALL NON-COE 
COMPONENTS BE LOADED BEFORE COE, 
INCLUDING ANY NECESSARY DEVICE DRIVERS. 
 
AFTER INSTALLATION OF THE COE KERNEL A 
LONGER BOOT UP TIME WILL BE NOTED, THIS 
IS NORMAL. 
 
THE INSTALLATION PROCEDURES FOR THE 
COE KERNEL AND SEGMENTS IN THE 
FOLOWING SECTIONS MAY BE SLIGHTLY 
DIFFERENT THEN THE ACTUAL PROCEDURE. 
THE EXACT PATH TO THE KERNEL AND 
SEGMENTS MAY DIFFER DUE TO THE WAY THE 

104 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 105 
 

COE SOURCE CD WAS BUILT. FOR EXAMPLE, IF 
THE SEGMENTS ARE EACH IN THEIR OWN 
DIRECTORY THEN THE PATH WILL HAVE TO BE 
SET AS OUTLINED BELOW AND AN 
INDIVIDULAL “READ TABLE OF CONTENTS” 
OPERATION WILL HAVE TO BE DONE FOR 
EACH SEGMENT. HOWEVER IF THE COE CD 
SUPPLIED HAS THE SEGMENTS GROUPED INTO 
A SINGLE DIRECTORY THEN DOING A SINGLE 
“READ TABLE OF CONTENTS” WILL DISPLAY 
ALL THE AVAILABLE SEGMENTS AT ONE TIME. 
THE PROCEDURES OULTINED BELOW MAY 
HAVE TO BE ADJUSTED BY THE INSTALLER 
ACCORDING TO HOW THE COE CD IS BUILT, 
THE ONES PROVIDED ASSUME THAT EACH 
SEGMENT IS LOCATED IN ITS OWN SUB-
FOLDER. THESE INSTRUCTIONS, HOWEVER, 
PROVIDE THE OVERALL STEPS REQUIRED TO 
LOAD THE COE KERNEL AND SEGMENTS ON 
THE JMPS SERVERS. THE STEPS BELOW WILL 
HAVE TO BE REPEATED FOR BOTH SERVERS. 

 
JMPS will operate under the Common Operating Environment (COE).  This 

environment consists of a kernel package and various segments.  Table 1 below outlines 
the current COE components that must be loaded on the JMPS servers, no matter which 
configuration is being setup.  The detailed steps to load each of the COE components / 
segments are presented in the following sub-sections. 
 
COE Segment Name Version Partition Installed 
COE Kernel Windows 2000 4.2.0.5 C: 
COE Kernel 4.2 Patch 
(K42PXB) 

4.2.0.0P8 C: 

Windows 2000 Patch Update  
(W2KPTH) 

4.6.1.0 C: 

Java Platform 2 
(JAVA2) 

4.7.0.0 D: 

COE Update System Security Level 
(UPDTSL) 

4.6.0.0 C: 

COE Security Banner 
(SECBNR) 

4.6.0.0 C: 

JMTK Utilities Segment 
(JMU) 

4.6.0.1 D: 

Microsoft Office 2000 Pro 
(OFFICE) 

4.6.0.0 D: 

Netscape Web Browser 
(NSWEB) 

4.7.0.0 D: 
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Adobe Acrobat Reader 
(ACRORD) 

4.5.1.0 D: 

Norton Anti Virus 
(NAV) 

4.5.3.0 D: 

Perl 4.7.0.0 D: 
J2SE JRE 1.4 (Includes Web Start) 
(JAVA 1.4) 

4.7.0.0 D: 

Microsoft Security Configuration 
Templates 
(W2KCET) 

4.6.0.1 C: 

MissionBinder Repository 1.0.0.7 D: 
 

Table 1 - JMPS Server COE Components List 

6.25.1 Sub-procedure: Taking VCS service groups offline 
 
Step 175. Log on to the cluster using Veritas Cluster Manager by double-clicking the 

VERITAS Cluster Manager (Java Console) icon on the desktop. 
Step 176. After starting Cluster Manager, the first window that appears is Cluster 

Monitor. An inactive, gray panel for JMPS_Cluster appears in Cluster Monitor. 
Step 177. Click that panel to log on to and monitor the cluster.  
Step 178. In the Login window, enter a valid VCS user name and password. Click OK. 

Cluster Explorer window will open and the two service groups will be shown in the 
explorer.  

Step 179. In the configuration tree on the left side, single-click on the first group, 
JMPS_SRV_SHARE. A status view will be shown on the right side of the window. 

Step 180. Right-click the service group in the configuration tree, click on Offline, and 
click the appropriate system from the menu. This step will take about 1 minute. Be 
patient. When the service group is transferred, the status view will show 
JMPS_SRV_SHARE as being offline on JMPSSERVER1. 

Step 181. Continue with the next sub-procedure. 
 

6.25.2  Sub-procedure: Disabling Automatic Group Starting in VCS 2.0 
 
Step 1. In Veritas Cluster Explorer, on the File menu, click Open Configuration. If Open 

Configuration is grayed out, the configuration file is already opened. Proceed to the 
next step. 

Step 2. From Cluster Explorer, click the JMPS_SRV_SHARE service group in the 
configuration tree.  

Step 3. On the Tools menu, click System Manager. 
Step 4. Uncheck the Startup box for both JMPSSERVER1 and JMPSSERVER2. 
Step 5. Click OK.  
Step 6. From Cluster Explorer, click the JMPS_SRV_SQL service group in the 

configuration tree.  
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Step 7. On the Tools menu, click System Manager. 
Step 8. Uncheck the Startup box for both JMPSSERVER1 and JMPSSERVER2. 
Step 9. Click OK.  
Step 10. On the File menu, click Save Configuration. 
Step 11. Continue with the next sub-procedure. 
 

6.25.3 Sub-procedure: Installation of COE Kernel 
 
Step 1. Logon to the server into the administrator account. 
Step 2. Place the CD containing the COE 4205 Kernel installation program into the CD-

ROM drive. 
Step 3. Select Start->Run. 
Step 4. On the Run dialog box click the “Browse” button. 
Step 5. On the Browse dialog box click the “Files of Type” down-arrow and select “All 

Files” from the list, this will enable the “kernel.msi” file to be seen. 
Step 6. Continuing on the Browse dialog box set the path to the CD-ROM drive and then 

to the location of the setup file for the COE 4205 Kernel, the path to the “kernel.msi” 
file may look like something like “COE 4.6(G:)\Kernel[1].NT40W2K.4205\”.  Once 
in the proper subfolder double click the “kernel.msi” file to set the path to it in the 
Run dialog box. 

Step 7. On the Run dialog box click the “OK” button to begin the installation of the COE 
kernel. 

Step 8. The DII COE Kernel Setup dialog box will open with the Welcome to the DII 
COE Kernel Installation Wizard message: 

 
“It is strongly recommended that you exit all Windows programs before running 
this setup program.  
 
Click Cancel to quit the setup program, then close any programs you have 
running. Click Next to continue the installation. 
 
WARNING: This program is protected by copyright law and international 
treaties. 
 
Unauthorized reproduction or distribution of this program, or any portion of it, 
may result in severe civil and criminal penalties, and will be prosecuted to the 
maximum extent possible under law.” 

 
If required cancel the COE installation and stop any programs that are running, 
otherwise click the “Next” button to begin the COE Kernel installation. 

 
Step 9. The Destination Folder dialog box will open next, click the Browse button to 

change the destination folder. 
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Step 10. The DII COE Kernel Setup dialog box will then open, in the “Folder name:” 

box enter “C:\” to direct the COE Kernel installation to the System C: partition.  
Click the “OK” button. 

Step 11. Back on the Destination Folder dialog box verify that the path has changed to 
“C:\”, click the “Next” button to proceed. 

Step 12. The Ready to Install the Application dialog box will open, click the “Next” 
button to begin the installation. 

Step 13. The Updating System dialog box will open, the status of the installation will 
be shown.  The Installation Status dialog box will open.  Then the first Please Enter a 
New Password dialog box will open.  Enter in the desired Secman password in the 
Password and Confirm Password boxes.  This password must be 8 characters in 
length.  Click the “OK” button when finished. 

Step 14. The second Please Enter a New Password dialog box will open.  Enter in the 
desired keyman password in the Password and Confirm Password boxes.  This 
password must be 8 characters in length.  Click the “OK” button when finished. 

Step 15. The Please Reply dialog will open in the back ground as the installation 
proceeds. It may be necessary to click on Please Reply button on the Start Bar to 
access this dialog.  The dialog message asks the question Enable APM 
Authentication? Click the “No” button; do not enable APM at this time. 

Step 16. The Installation Status dialog will begin to update. Wait as the installation 
continues. 

Step 17. The DII COE Kernel has been successfully installed dialog will appear when 
the installation completes.  Click the “Finish” button. 

Step 18. The Installer Information dialog box will then open with the following 
message: 

 
“You must restart your system for the configuration changes made to DII COE 
Kernel to take effect. Click Yes to restart now or No if you plan to manually restart 
later.” 
 
Click the “Yes” button to restart the system. 

 
NOTES 

 
THE COE KERNEL SOFTWARE WILL CHANGE 
THE LOGON PROCESS. STEPS 20 TO 25 BELOW 
WILL NEED TO BE FOLLOWED FROM THIS 
POINT FORWARD FOR LOGON WITH COE 
INSTALLED. 
 
IF THE “PLEASE WAIT RUN_ONCE IN 
PROGRESS” DIALOG BOX SHOULD APPEAR 
DURING THE LOGON PROCESS, ALLOW IT TO 
COMPLETE, DO NOT CLICK THE OK BUTTON 
ON THIS DIALOG. WAIT UNTIL THE “COE 
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LOGIN PROCESSING IS COMPLETE” DIALOG 
APPEARS (SEE STEP 24 BELOW). 

 
Step 19. COE will change the logon process.  The blue Defense Information Systems 

Agency banner will now appear on the screen at boot.  Wait for the logon box to 
appear.  It is normal for this process to take several minutes. 

Step 20. The Welcome to Windows dialog will open, press “CTRL-ALT-DEL” as 
usual to logon to the system. 

Step 21. The United States Department of Defense Warning Statement dialog box will 
open, click the “OK” button to acknowledge it. 

Step 22. The Log On to Windows dialog box will then appear, but the User name box 
will now be empty due to the security settings applied by the COE Kernel.  It will 
now be required to enter in the user name and password each time.  Enter in 
“administrator” for the User name along with the administrator password to log back 
onto the system.  Click the “OK” button. 

Step 23. At logon the Please wait run_once in progress dialog box may appear.  If it 
does WAIT until this process completes. 

Step 24. The COE login processing is complete dialog will appear, click the “OK” 
button to acknowledge it, logon is now complete. 

Step 25. At the first logon after COE is installed a Service Control Manager error 
dialog will appear with the following message: 

 
“At least one service or driver failed during system startup. Use Event Viewer to 
examine the event log for details.” 
 
This startup failure is an expected problem.  Since the SQL Server used during this 
initial loading procedure development was not a COE segment, COE modifies the 
user account information for the startup permissions of the SQL Server.  This 
modification prevents the SQL Server service from starting at boot as evident by the 
red arrow in the SQL Server symbol located in the right-hand corner of the Start 
Menu bar.  The logon password must be reset so that the SQL Server is permitted to 
start at boot.  The following sub-steps must be executed to reset the SQL Server logon 
information: 

 
a) Select Start->Programs->Administrative Tools->Computer Management. 
b) The Computer Management window will open, in the left-hand list double click 

on “Services and Applications”. 
c) The Service and Applications list will appear in the right-hand side of the 

Computer Management window.  Double click on the Services item. 
d) In the right-hand box the services will appear.  On the Computer Management 

menu select “View” and from the drop-down list that appears click the “Detail” 
choice.  This will change the service display from Icons to a list format so that the 
necessary SQL services can be easily located. 

e) In the right-hand box all the services should be displayed.  Use the scroll bar to 
locate the “MSSQL$JMPS_SQL_SERVER” service, select it and then double 
click on it to open the MSSQL$JMPS_SQL_SERVER Properties box. 
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f) On the properties box click the “Log On” TAB to bring it forward. 
g) In the “This Account” box, delete the Password and Confirm password boxes 

content, re-enter the administrator password in both boxes. (Note: Leave the 
account set to the domain account, it should be 
“%domainname%\Administrator”). 

h) On the MSSQL$JMPS_SQL_SERVER Properties dialog box click the “OK” 
button. The Microsoft Management Console dialog box will open with the 
following message: 

 
“The account %administrator%\Administrator has been granted the Log On As 
A Service right.” 
 
Click the “OK” button. 

 
i) Back on the Computer Management window, in the right-hand box, use the scroll 

bar to locate the “MSQLServerADHelper” service, select it and then double click 
on it to open the MSSQLServerADHelper Properties box. 

j) On the properties box click the “Log On” TAB to bring it forward. 
k) Click the “This Account” button if its not selected. Delete the Password and 

Confirm password boxes content, re-enter the administrator password in both 
boxes. (Note: Leave the account set to the domain account, it should be 
“%domainname%\Administrator”, if it is not set to this value, use the Browse 
button to reset it.). 

l) On the MSSQLServerADHelper Properties dialog box click the “OK” button. 
m) Back on the Computer Management window, in the right-hand box, use the scroll 

bar to locate the “SQLAgent$JMPS_SQL_SERVER” service, select it and then 
double click on it to open the SQLAgent$JMPS_SQL_SERVER Properties box. 

n) On the properties box click the “Log On” TAB to bring it forward. 
o) In the “This Account” box, delete the Password and Confirm password boxes 

content, re-enter the administrator password in both boxes. (Note: Leave the 
account set to the domain account, it should be 
“%domainname%\Administrator”). 

p) On the SQLAgent$JMPS_SQL_SERVER Properties dialog box click the “OK” 
button. 

q) Close the Computer Manager. 
r) On the Start Menu Bar select Start->Shut Down. 
s) On the Shut Down Windows dialog box that appears use the down-arrow key and 

select the “Restart” option. Click the “OK” button to restart the system. 
t) After restart logon to the system and verify that the Service Control Manager 

error does not appear, also verify that the SQL Server symbol present on the Start 
Menu bar has a green arrow, indication that the server is up and running. 

Step 26. Continue with the next sub-procedure. 
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6.25.4 Sub-procedure: Installation of COE Kernel Patch P8 COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer. (Note:  The Installer Icon may not appear in the Start 

Menu, in this case it will be necessary to Browse to 
C:\h\COE\Comp\COEInstaller\bin\ and set a Desktop shortcut to the COE Installer 
(COEInstaller.exe) or add a shortcut to the Start Menu.  It will happen after loading 
the COE P8 patch, the shortcut will have to be defined so that the administrator can 
access the COEInstaller easily.) 

Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 
the pop-up menu. 

Step 5. The Disk Drive Selection dialog box will then open.  If it is set to C: click the 
“Cancel” button.  If it is not set to C:\ click the down-arrow button and select the C:\ 
partition as the install location for the COE Kernel patch (the kernel patch must be 
placed on the same partition as the kernel).  Then click the “OK” button on the Disk 
Drive Selection dialog box.  The COEInstaller main title bar should update to reflect 
the new target “COEInstaller - Installed software - target is C:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive”.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
folder location of the COE Kernel Patch Segment.  The path may be similar to the 
following: COE4.6(G:)\K4PX_WIN_4200P8\.  Select the folder and then click the 
“OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “DII COE Kernel 4.2 Patch (4.2.0.0P8)” segment.  Select this 
segment by clicking the check box next to it (the selection will then be highlighted in 
dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the COE Kernel 
Patch segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Wait until this process 
completes. 

Step 12. When completed, the COEInstaller dialog box will pop-up with the “Install 
was successful” message.  Click the “OK” button to acknowledge it. 

Step 13. The COEInstaller dialog will then appear with the following message: 
 

“In order for segment installation(s) to be complete the system must be rebooted. Do 
you wish to reboot now?” 
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Click the “Yes” button to proceed with the reboot and to finish the installation of the 
COE Kernel patch segment. 

Step 14. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 15. Continue with the next sub-procedure. 
 
 

6.25.5 Sub-procedure: Installation of Windows 2000 Patch COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double click the desktop icon defined in Step 6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open. If it is set to C: click the 

“Cancel” button. If it is not set to C:\ click the down-arrow button and select the C:\ 
partition as the install location for the COE Kernel patch (the kernel patch must be 
placed on the same partition as the kernel).  Click the “OK” button on the Disk Drive 
Selection dialog box. The COEInstaller main title bar should update to reflect the new 
target “COEInstaller - Installed software - target is C:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive”.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Windows 2000 Patch Segment.  The path to the file may look like 
something like: COE 4.6(G:)\03_W2KPTH4610_021203. Select the folder and then 
click the “OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “W2k Patch Update” (4.6.1.0) segment.  Select this segment 
by clicking the check box next to it (the selection will then be highlighted in dark 
blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Windows 2000 
Patch segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Wait until this process 
completes, since this involves applying Service Pack 3 to the Windows 2000 system, 
it will take several minutes to complete.  Do not panic if the progress appears to stop 
at 97% for a long period of time, wait until the process completes. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. The COEInstaller dialog will then appear with the following message: 
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“In order for segment installation(s) to be complete the system must be rebooted. Do 
you wish to reboot now?” 

 
Click the “Yes” button to proceed with the reboot and to finish the installation of the 
Windows 2000 Patch Segment. 

Step 14. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 15. Logon to the server into the administrator account, following the logon 
procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 

Step 16. Upon startup the W2KPTH Message dialog will appear with the message: 
 

“Answer no to any prompts asking to reboot the computer” 
 
Click the “OK” button in response to this warning. 

Step 17. The Microsoft Internet Explorer Update dialog box will open requesting that 
the system be restarted.  Click the “No” button. 

Step 18. The Microsoft Data Access Components Hotfix Installer dialog will open.  
Apply the Hotfix KB Article Q318203 by clicking the “OK” button. 

Step 19. The Setup is complete dialog box will appear.  Click the “OK” button. 
Step 20. The System Settings Change dialog box will then open requesting a restart of 

the system.  Click the “No” button. 
Step 21. The Microsoft Data Access Components Hotfix Installer dialog will open.  

Apply the Hotfix KB Article Q329414 by clicking the “OK” button. 
Step 22. The Setup is complete dialog box will appear.  Click the “OK” button. 
Step 23. The System Settings Change dialog box will then open requesting a restart of 

the system.  Click the “No” button. 
Step 24. The final steps to apply SP3 will automatically be executed, commands will 

scroll inside the W2KPTH Message dialog and then the system will automatically 
restart. 

Step 25. Continue with the next sub-procedure. 
 
 

6.25.6 Sub-procedure: Installation of Java Platform 2 COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If the destination is set to D: 

click the “Cancel” button.  If not, click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
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Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive”.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Java Platform 2 COE segment.  The path may look like something like 
COE 4.6(G:)\JAVA2_WIN_4700.  Select the folder and then click the “OK” button 
on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Java Platform 2” (4.7.0.0) segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Java 2 COE 
segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message.  Click the “OK” button to acknowledge it. 

Step 13. The COEInstaller dialog will then appear with the following message: 
 

“In order for segment installation(s) to be complete the system must be rebooted. Do 
you wish to reboot now?” 

 
Click the “Yes” button to proceed with the reboot and to finish the installation of the 
Java 2 COE segment. 

Step 14. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 15. Continue with the next sub-procedure. 
 
 

6.25.7 Sub-procedure: Installation of COE Update System Security Level Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 

114 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 115 
 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to C: click the 

“Cancel” button. If it is not set to C:\ click the down-arrow button and select the C:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box. The COEInstaller main title bar should update to reflect the new 
target “COEInstaller - Installed software - target is C:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive”. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the COE Update System Security Level segment.  The path may look like 
something like COE 4.6(G:)\UPDTSL_NTW2K_4600.  Select the folder and then 
click the “OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “COE Update System Security Level” (4.6.0.0) segment. 
Select this segment by clicking the check box next to it (the selection will then be 
highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Update System 
Security Level COE segment. 
The Segment Installation Status dialog box and the COEInstaller Console window 
will open to show the segment installation progress.  The progress will appear to stop 
at 97%.  
 

Step 11. The Local Security Level Manager dialog box will open. On this dialog click 
the Classification Level down-arrow key and select “UNCLASSIFIED” for the 
security level, leave the Security Server Type set to “Local”. 

Step 12. On the Local Security Level Manager dialog select “OK”. 
Step 13. When completed the COEInstaller dialog box will pop-up with the “Install 

was successful” message.  Click the “OK” button to acknowledge it 
Step 14. On the main COEInstaller menu select “File->Exit”. 
Step 15. The COEInstaller dialog box will open with the question: 
 

“Are you sure that you want to exit the DII COE Installer?” 
 

Click the “Yes” button. 
Step 16. Continue with the next sub-procedure. 
 

6.25.8 Sub-procedure: Installation of COE Security Banner Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
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Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to C: click the 

“Cancel” button.  If it is not set to C:\ click the down-arrow button and select the C:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is C:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the COE Security Banner Data Template segment.  The path may look 
like something like COE 4.6(G:)\SECBNR_NTW2K_4600.  Select the folder and 
then click the “OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Security Banner Data” segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Security 
Banner Data COE segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress. Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. The green “UNCLASSIFIED” box will appear in the center of the screen, 
select it and hold the right mouse button, slide it off to the side of the screen. 

Step 14. On the main COEInstaller menu select “File->Exit”. 
Step 15. The COEInstaller dialog box will open with the question: 
 

“Are you sure that you want to exit the DII COE Installer?” 
 

Click the “Yes” button. 
Step 16. Continue with the next sub-procedure. 
 
 

6.25.9 Sub-procedure: Installation of JMTK Utilities COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
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Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the JMTK Utilities Segment (JMU) segment.  The path may look like 
something like COE 4.6(G:)\JMTKbundle_WIN_4601.  Select the folder and then 
click the “OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “JMTK Analysis”, JMTK SDBM” and the JMTK Utilities 
Segment” segments.  Select only the JMTK Utilities Segment by clicking the check 
box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the JMTK Utilities 
segment. 

Step 17. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 11. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 18. On the main COEInstaller menu select “File->Exit”. 
Step 19. The COEInstaller dialog box will open with the question: 
 

“Are you sure that you want to exit the DII COE Installer?” 
 

Click the “Yes” button. 
Step 20. Continue with the next sub-procedure.. 
 
 

6.25.10 Sub-procedure: Installation of Microsoft Office 2000 Professional COE 
Segment 
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Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button.  If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the COE Microsoft Office 2000 Professional segment.  The path may look 
like something like: COE 4.6(G:)\Office_W2K_2000.  Select the folder and then 
click the “OK” button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Microsoft Office 2000 Pro” segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Microsoft 
Office 2000 Pro COE segment. 

Step 11. The Please Reply dialog box will then open with the message: 
 

“Installation of this segment required the Microsoft Office 2000 CD-ROM 
 
Do you wan to continue?” 

  
Click the “Yes” button. 

 
Step 12. The Segment Installation Status dialog box and the COEInstaller Console 

window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 13. The following dialog will appear: 
 

“This computer must now be rebooted.  Software installation will automatically 
resume when you log in again.” 

 
Click the “OK” button, the server will restart automatically. 
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Step 14. The COEInstaller dialog will appear with message “Install was successful”.  

Click the “OK” button to acknowledge it. 
Step 15. The COEInstaller dialog will appear with the reboot necessary message, click 

the “Yes” button.  The System Shutdown warning will appear briefly.  The system 
will then restart. 

Step 16. Logon to the server into the administrator account, following the logon 
procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 

Step 17. The Office 2000 Setup dialog will appear at logo n with the message: 
 

“Please insert the Microsoft Office CD 1 into the CD-ROM drive. Once the CD-
ROM drive light goes out, click OK.” 
 
Place the Microsoft Office CD 1 into the CD-ROM and click the “OK” button 
after the CD has been recognized by the system. 

 
Step 18. The IMPORTANT!! Dialog box will open wit the following message: 
 

“Wait for the CD Setup program to finish before clicking OK to this message.  
Respond NO to any prompts by Microsoft setup program which request a 
reboot.” 
 
Click the “OK” button to proceed. 

 
Step 19. The Welcome to Microsoft Office 2000 window will open atop of the 

message box in Step 18 above with the Please enter your customer information 
dialog.  The User Name and Organization boxes will contain the information entered 
during the Windows 2000 Advanced Server setup.  In the CD Key box enter the 25-
character alphanumeric key.  Click the “Next” button when completed. 

Step 20. The Microsoft Office 2000 License and Support Information dialog will open. 
Click the “I accept the terms in the License Agreement” choice and then click the 
“Next” button. 

Step 21. The Setup is ready to install Microsoft Office 2000 SR-1 Professional dialog 
will open, click the “Customize…” button. 

Step 22. The Install Office 2000 at: dialog will then open, direct the installation to the 
Segment D: partition by setting the path to “D:\Microsoft Office\”. Click the “Next” 
button. 

Step 23. The SETUP dialog box will then open.  In the right-hand pane of the window 
click the down arrow next to the drive box symbol on the “Microsoft Office” label. 
From the drop down menu that appears click the “Run all from My Computer” 
choice.  All the drive boxes on the SETUP dialog should all turn clear indicating that 
all the components are selected. 

Step 24. On the SETUP dialog box click the “Install Now” button. 
Step 25. The Installing Microsoft Office 2000 dialog will open with the message: 
 

“Please wait while Windows configures Microsoft Office 2000.” 
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Wait until the process completes. 
 
Step 26. The Microsoft Office 2000 Setup dialog will then open with the message: 
 

“Microsoft Office 2000 SR-1 Professional setup completed successfully.” 
 
Click the “OK” button on this dialog. 

Step 27. Back on the IMPORTANT!! dialog box, click the “OK” button. 
Step 28. The Clip Gallery Live File Transfer Manager Update dialog will open with the 

following message: 
 

“Do you want to install the update to the Clip Gallery Live File Transfer Manager?” 
 
Click the “Yes” button. 

Step 29. The Clip Gallery Live File Transfer Manager Update license agreement will 
then open. Click the “Yes” button to accept it. 

Step 30. The Clip Gallery Live File Transfer Manager Update dialog will then open 
with the message: 

 
“The update to the Clip Gallery Live File Transfer Manager was installed 
successfully.” 
 
Click the “OK” button. 

Step 31. The Microsoft Office UA Control Security Update dialog box will then open 
with the message: 

 
“This program will install the Microsoft Office UA Control Security Update. Do you 
want to continue?” 
 
Click the “Yes” button. 

Step 32. The Microsoft Office UA Control Security Update license dialog box will 
then open. Click the “Yes” button to accept it. 

Step 33. The Microsoft Office UA Control Security Update dialog box will open with 
the message: 

 
“Microsoft Office UA Control Security Update completed successfully.” 
 
Click the “OK” button. 

Step 34. The Microsoft Office 2000 Service Pack 2 dialog will open with the following 
message: 

 
“This program will install SP-2.  Do you want to continue?” 
 
Click the “Yes” button. 
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Step 35. The Microsoft Office 2000 Service Pack 2 license agreement dialog will open.  

Click the “Yes” button to accept it and start the installation of SP-2. 
Step 36. The Microsoft Office SP-2 dialog will open stating that the update was 

applied successfully, click the “OK” button. 
Step 37. The Microsoft FrontPage Web Client Security Update dialog box will then 

open with the following message: 
 

“This program will install the Microsoft FrontPage Web Client Security Update. Do 
you want to continue?” 
 
Click the “Yes” button. 

Step 38. The Microsoft FrontPage Web Client Security Update license dialog box will 
then open. Click the “Yes” button to accept it. 

Step 39. The Microsoft FrontPage Web Client Security Update dialog box will then 
open with the message: 

 
“The update was applied successfully.” 
 
Click the “OK” button to acknowledge it. 

Step 40. The Microsoft PowerPoint 2000 SR-1 Security Update dialog box will then 
open with the message: 

 
“This program will install the PowerPoint 2000 SR-1 Security Update. Do you 
want to continue?” 
 
Click the “Yes” button (the headings will show as SP-1 when actually SP-2 is being 
applied, this is a known problem). 

Step 41. The Microsoft PowerPoint 2000 SR-1 Security Update license dialog box will 
then open, click the “Yes” button to accept it. 

Step 42. The PowerPoint 2000 SR-1 Security Update dialog box will then appear with 
the message: 

 
“The upgrade was applied successfully.” 
 
Click the “OK” button. 

Step 43. The Excel 2000 SR-1 Macro Modification Security Update - April 2002 
dialog box will open, click the “Yes” button to apply it. 

Step 44. The Excel 2000 SR-1 Macro Modification Security Update license dialog will 
then open.  Click the “Yes” button to accept it. 

Step 45. The Excel 2000 SR-1 Macro Modification Security Update - April 2002 
dialog will appear stating that the update was successfully applied.  Click the “OK” 
button. 

Step 46. The PowerPoint 2000 SR-1 Macro Security Update dialog will open, click the 
“Yes” button to apply this update. 

Step 47. The PowerPoint 2000 SR-1 Macro Security Update license agreement dialog 
will then open.  Click the “Yes” button to accept it. 
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Step 48. The PowerPoint 2000 SR-1 Macro Security Update dialog will appear stating 

that the update was successfully applied.  Click the “OK” button. 
Step 49. The Excel 2000 Update: June 19 2002 dialog will open.  Click the “Yes” 

button to apply this update. 
Step 50. The Excel 2000 Update: June 10 2002 license dialog box will then appear, 

click the “Yes” button to accept it. 
Step 51. The Excel 2000 Update: June 19 2002 dialog box will appear stating that the 

update was applied successfully.  Click the “OK” button. 
Step 52. The Office Web Components Security Update dialog box will open, click the 

“Yes” button to apply the update. 
Step 53. The Office Web Components Security Update license dialog box will open, 

click the “Yes” button to accept it. 
Step 54. The Office Web Components Security Update dialog box will open stating 

that the update was installed successfully, click the “OK” button. 
Step 55. The Word 2000 SR-1a Macro Security Update dialog will appear, click the 

“Yes” button to apply the update. 
Step 56. The Word 2000 SR-1a Macro Security Update license dialog box will open, 

click the “Yes” button to accept it. 
Step 57. The Word 2000 SR-1a Macro Security Update dialog box will open stating 

that the update was applied successfully, click the “OK” button. 
Step 58. The Word 2000 SR-1 Update: April 25th 2002 dialog box will open, click the 

“Yes” button to apply it. 
Step 59. The Word 2000 SR-1 Update: April 25th 2002 license dialog box will open, 

click the “Yes” button to accept the license. 
Step 60. The Word 2000 SR-1 Update: April 25th 2002 dialog box will open stating 

that the update was applied successfully, click the “OK” button. 
Step 61. The Word 2000 Update: October 16, 2002 dialog box will open, click the 

“Yes” button to apply it. 
Step 62. The Word 2000 Update: October 16, 2002 license dialog box will open, click 

the “Yes” button to accept it. 
Step 63. The Word 2000 Update: October 16, 2002 dialog box will appear stating that 

the update was applied successfully, click the “OK” button. 
Step 64. The System SHUTDOWN warning dialog will appear briefly and the system 

will then restart. 
Step 65. Remove the Microsoft Office 2000 CD from the CD-ROM drive and allow 

the system to restart. 
Step 66. Continue with the next sub-procedure. 
 
 

6.25.11 Sub-procedure: Installation of Netscape Web Browser COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
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Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button.  If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Netscape Web Browser segment.  The path may look like something 
like COE 4.6 (G:)\NSWEB_W2K_4700.  Select the folder and then click the “OK” 
button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Netscape Browser” segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Netscape Web 
Browser COE segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress. Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 12. The Netscape Communicator 7.0 Setup dialog box will open, and then close.  
The Netscape question box will appear with the question: 

 
Netscape is not currently set as the default browser, would you like to set it as the 
default? 

 
Click the “Yes” button to set Netscape as the default browser.  The Netscape 
boxes will then automatically close. 

 
Step 13. When the installation completes the COEInstaller dialog box will pop-up with 

the “Install was successful” message.  Click the “OK” button to acknowledge it. 
Step 14. The next COEInstaller dialog box will open with the message: 
 

“In order for segment installation(s) to be complete the system must be rebooted. 
Do you wish to reboot now?” 
 
Click the “Yes” button to proceed with the restart. 
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Step 15. The System SHUTDOWN warning dialog will appear briefly and the system 

will then restart. 
Step 16. Logon back onto the server into the administrator account, following the 

logon procedures outlined in COE Kernel installation procedure found in Section 
6.27.1. 

Step 17. The Netscape Register dialog box will open automatically upon logon asking 
to define an AOL Instant Messenger screen name.  On the Resister menu click on 
“Edit” and then “Preferences…” choice in the presented drop down menu. 

Step 18. The Preferences dialog box will open, under the Instant Messager settings, 
uncheck the “Launch automatically at system start” box.  Click the “OK” button. 

Step 19. Close the Register dialog box. 
Step 20. Continue with the next sub-procedure. 
 
 

6.25.12 Sub-procedure: Installation of Adobe Acrobat Reader COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Adobe Acrobat Reader segment.  The path may look like something 
like COE 4.6 (G:)\ACRORD_WIN4510.  Select the folder and then click the “OK” 
button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Adobe Acrobat Reader” (4.5.1.0) segment. Select this 
segment by clicking the check box next to it (the selection will then be highlighted in 
dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Adobe Acrobat 
Reader COE segment. 
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Step 11. The Segment Installation Status dialog box and the COEInstaller Console 

window will open to show the segment installation progress. The Usage dialog box 
will open with Microsoft Setup information, click the “OK” button to acknowledge it. 
Do not panic if the progress appears to stop at 97% for a long period of time, wait 
until the process completes. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. The Installer Information dialog box will then open with the following 
message: 

 
“In order for segment installation(s)to be complete the system must be rebooted.” 
 
Do you wish to reboot now? 
 
Click the “Yes” button to restart the system. 

Step 21. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart.  The Adobe Acrobat Read 5.0 Icon will now be present on the 
desktop. 

Step 22. Continue with the next sub-procedure. 
 
 

6.25.13 Sub-procedure: Installation of Norton Anti Virus COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button.  If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive.  
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Norton Anti Virus.  The path may look like something like: “COE 4.6 
(G:)\NAV_NT2WK_4530”.  Select the folder and then click the “OK” button on the 
Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 
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Step 9. The bottom Available Software window inside the main COEInstaller window 

will update to show the “Norton Anti-Virus” (4.5.3.0) segment.  Select this segment 
by clicking the check box next to it (the selection will then be highlighted in dark 
blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Norton Anti- 
Virus COE segment. 

Step 21. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 22. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message.  Click the “OK” button to acknowledge it. 

Step 14. The Installer Information dialog box will then open with the following 
message: 

 
“In order for segment installation(s)to be complete the system must be rebooted.” 
 
Do you wish to reboot now? 
 
Click the “Yes” button to restart the system. 

Step 23. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 11. Upon restart, logon to the server into the administrator account, following the 
logon procedures outlined in COE Kernel installation procedure found in Section 
6.27.1. 

 
NOTE 

 
THE VIRUS DEFINITION FILES MUST BE 
UPDATED. THE CURRENT NAV VIRUS 
DEFINITION FILE WILL HAVE TO BE 
DOWNLOADED FROM THE INFOSEC WEB SITE 
AND PLACED ON A CD FOR USE IN THE NAV 
DEFINITION FILE UPDATE PROCEDURES 
OUTLINED IN STEPS 23 TO  BELOW. 
OPTIONALLY, IF THE SERVER IS CONNECTED 
TO A NETWORK WITH ACCESS TO THE 
NIPERNET THE LIVE UPDATE VIA NORTON CAN 
BE EXECUTED. IF THE SERVER IS ON A 
NETWORK CONNECTED TO THE SIPRNET, THE 
SIPRNET ACCESS FILE WILL HAVE TO BE 
DOWNLOADED AND THEN INSTALLED PRIOR 
TO RUNNING LIVE UPDATE VIA THE SIPRNET. 
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Step 23. Insert the CD containing the latest Norton Anti Virus definition files into the 

CD ROM. Select Start->Run. 
Step 24. On the Run dialog box click the “Browse” button. 
Step 25. On the Browse dialog box that appears set the path to the CD-ROM drive and 

to the location of the Norton Anti-Virus update definition file.  Double click on the 
file to set the path to it in the Run dialog box. 

Step 26. On the Run dialog box click the “OK” button to execute the update. 
Step 27. The SARC Intelligent Updater dialog will open, click the “Yes” button to 

proceed with the update. 
Step 28. The SARC Intelligent Update box will open briefly and then close. Another 

SARC Intelligent Updater dialog box will open with the message: 
 

“SARC Intelligent Updater 
Version 4.01.08A 
Copyright (c) 1997-2000 by Symantec Corporation 
 
The Symantec virus definition files are used to detect viruses. 
Intelligent Updater updates the virus definition files to the latest version 
automatically. 
 
For program options, type the name of this program and /?. 
 
Do you want to update your virus definition files?” 
 
Click the “Yes” button to proceed with the updates. 
 

Step 29. The SARC Intelligent Updater will run and apply the updates, afterward it 
will pop-up the following message: 
 
“A Symantec product containing virus protection was found and was updated. This 
product uses the latest engine and virus definition system available. However, if you 
have other older Symantec products, in addition to those detected, you must run 
Intelligent Updater version 2 to update their virus protection.” 
 
Click the “OK” button. 
 

Step 30. Remove the CD containing the NAV definition update file from the CD-ROM 
drive. 

Step 31. Continue with the next sub-procedure. 
 
 

6.25.14 Sub-procedure: Installation of Perl COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1 
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Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 12. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 3. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 4. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 5. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 6. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Perl COE segment.  The path may look like something like “COE 4.6 
(G:)\Perl_4700”.  Select the folder and then click the “OK” button on the Browse for 
Folder dialog box. 

Step 7. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu. The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 8. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Perl” segment (4.7.0.0).  Select this segment by clicking the 
check box next to it (the selection will then be highlighted in dark blue). 

Step 9. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Perl COE 
segment. 

Step 10. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress. Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 11. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message.  Click the “OK” button to acknowledge it. 

Step 32. Continue with the next sub-procedure. 
 

6.25.15 Sub-procedure: Installation of Java 1.4 and Java Web Start COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
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Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the Java Web Start COE segment.  The path may look like something like 
COE 4.6 (G:)\J2JRE_WIN_4700.  (Note: A Java segment is being selected, it has 
Web Start as an integral part).  Select the folder and then click the “OK” button on the 
Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “J2SE JRE 1.4.1” (4.7.0.0) segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Java Web Start 
COE segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. The Installer Information dialog box will then open with the following 
message: 

 
“In order for segment installation(s)to be complete the system must be rebooted.” 
 
Do you wish to reboot now? 
 
Click the “Yes” button to restart the system. 
 

Step 14. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 15. Continue with the next sub-procedure. 
 

6.25.16 Sub-procedure: Microsoft Security Configuration Templates COE Segment 
 
Step 1. Logon to the server into the administrator account, following the logon 

procedures outlined in COE Kernel installation procedure found in Section 6.27.1. 
Step 2. Place the CD containing the COE segments into the CD-ROM drive. 
Step 3. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
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Step 4. On the COEInstaller main menu select “File” and then “Select Target drive” 

from the pop-up menu. 
Step 5. The Disk Drive Selection dialog box will then open.  If it is set to C: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the C:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is C:\”. 

Step 6. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 7. On the Browse for Folder dialog box set the path to the CD drive and then to 
the location of the Java Web Start COE segment.  The path may look like something 
like COE 4.6 (G:)\W2KCET_WIN_4601.  Select the folder and then click the “OK” 
button on the Browse for Folder dialog box. 

Step 8. On the COEInstaller main menu select “File” and then “Read Table of 
Contents” from the pop-up menu.  The Reading TOC Header Information… dialog 
will appear briefly then close. 

Step 9. The bottom Available Software window inside the main COEInstaller window 
will update to show the “MS Security Config Template” (4.6.0.1) segment.  Select 
this segment by clicking the check box next to it (the selection will then be 
highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Microsoft 
Security Configuration Templates COE segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 97% for a long period of time, wait until the process 
completes.  The COEInstaller Console DOS window will open and processes will be 
executed as the segment is installed. 

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. The Installer Information dialog box will then open with the following 
message: 

 
“In order for segment installation(s)to be complete the system must be rebooted.” 
 
Do you wish to reboot now? 
 
Click the “Yes” button to restart the system. 
 

Step 14. The System Shutdown dialog will briefly appear on the screen and then the 
system will restart. 

Step 15. Continue with the next sub-procedure. 
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6.25.17 Sub-procedure: Modifying Domain Controller Security Policy to allow 

VCS 2.0 and BE 9.0 to operate 
 
Step 1. Go to Start  Programs  Administrator Tools  Domain Controller Security 

Policy. 
Step 2. In the left pane navigate to Windows Settings  Security Settings  Local 

Policies  User Rights Assignment. 
Step 3. In the right pane double-click on Act as part of the operating system. 
Step 4. In the window that comes up click the Add button. 
Step 5. In the window that comes up click the Browse button. 
Step 6. Scroll down until Administrator user name is shown.  
Step 7. Single-click on Administrator and click the Add button below. 
Step 8. Click OK three times to go back to the Domain Controller Security Policy 

window.  
Step 9. In the right pane double-click on Create Token Object. 
Step 10. Repeat steps 4-8 above.  
Step 11. Close the Domain Controller Security Policy window. 
Step 12. Continue with the next sub-procedure. 
 

6.25.18 Sub-procedure: Resetting Logon Parameters for Backup Exec Services 
 
Step 1. Using Windows Explorer navigate to C:\Program Files\Veritas\Backup Exec\NT 
Step 2. Double-click on ServicesMgr.exe. A window will come up. 
Step 3. Click on the Service Credentials button. 
Step 4. Check the box that says Change Service Account Information 
Step 5. Enter the following info: 

d. Administrator for the User Name 
e. JMPS for the domain 
f. Enter the Administrator password 
g. Re-enter the Administrator password 

Step 6. Click OK.  
Step 7. Continue with the next sub-procedure. 

6.25.19 Sub-procedure: Resetting Logon Parameters for SQL Server Services 
 
Note: The addition of Microsoft Security Templates COE segment prevents the SQL 
Server service from starting at boot.  The logon password must be reset so that the SQL 
Server is permitted to start at boot.  The following sub-steps must be executed to reset the 
SQL Server logon information: 
 
Step 1. Select Start->Programs->Administrative Tools->Computer Management. 
Step 2. The Computer Management window will open, in the left-hand list double click 

on “Services and Applications”. 
Step 3. The Service and Applications list will appear in the right-hand side of the 

Computer Management window.  Double click on the Services item. 
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Step 4. In the right-hand box the services will appear.  On the Computer Management 

menu select “View” and from the drop-down list that appears click the “Detail” 
choice.  This will change the service display from Icons to a list format so that the 
necessary SQL services can be easily located. 

Step 5. In the right-hand box all the services should be displayed.  Use the scroll bar to 
locate the “MSSQL$JMPS_SQL_SERVER” service, select it and then double click 
on it to open the MSSQL$JMPS_SQL_SERVER Properties box. 

Step 6. On the properties box click the “Log On” TAB to bring it forward. 
Step 7. In the “This Account” box, delete the Password and Confirm password boxes 

content, re-enter the administrator password in both boxes. (Note: Leave the account 
set to the domain account, it should be “%domainname%\Administrator”). 

Step 8. On the MSSQL$JMPS_SQL_SERVER Properties dialog box click the “OK” 
button.  The Microsoft Management Console dialog box will open with the following 
message: 
 

“The account %administrator%\Administrator has been granted the Log On 
As A Service right.” 

 
Click the “OK” button. 

 
Step 9. Back on the Computer Management window, in the right-hand box, use the scroll 

bar to locate the “SQLAgent$JMPS_SQL_SERVER” service, select it and then 
double click on it to open the SQLAgent$JMPS_SQL_SERVER Properties box. 

Step 10. On the properties box click the “Log On” TAB to bring it forward. 
Step 11. In the “This Account” box, delete the Password and Confirm password 

boxes content, re-enter the administrator password in both boxes. (Note: Leave the 
account set to the domain account, it should be “%domainname%\Administrator”). 

Step 12. On the SQLAgent$JMPS_SQL_SERVER Properties dialog box click the 
“OK” button. 

Step 13. Close the Computer Manager. 
Step 14. Continue with the next sub-procedure. 

6.25.20 Sub-procedure: Re-enabling Automatic Group Starting in VCS 2.0 
 
Step 1. Log on to the cluster using Veritas Cluster Manager by double-clicking the 

VERITAS Cluster Manager (Java Console) icon on the desktop. 
Step 2. After starting Cluster Manager, the first window that appears is Cluster 

Monitor. An inactive, gray panel for JMPS_Cluster appears in Cluster Monitor. 
Step 3. Click that panel to log on to and monitor the cluster. 
Step 4. In the Login window, enter a valid VCS user name and password. Click OK. 

Cluster Explorer window will open. 
Step 5. On the File menu, click Open Configuration. If Open Configuration is grayed out, 

the configuration file is already opened. Proceed to the next step. 
Step 6. From Cluster Explorer, click the JMPS_SRV_SHARE service group in the 

configuration tree.  
Step 7. On the Tools menu, click System Manager. 
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Step 8. Check the Startup box for both JMPSSERVER1 and JMPSSERVER2. 
Step 9. Click OK.  
Step 10. From Cluster Explorer, click the JMPS_SRV_SQL service group in the 

configuration tree.  
Step 11. On the Tools menu, click System Manager. 
Step 12. Check the Startup box for both JMPSSERVER1 and JMPSSERVER2. 
Step 13. Click OK.  
Step 14. On the File menu, click Save Configuration. 
Step 15. Reboot both servers for all changes to take effect. 
Step 16. Continue with section 6.26. 
 

6.26 Procedure: Installing Veritas Cluster Server 2.0 Service Pack 2 
 
Step 1. This work will be performed on JMPSSERVER2. Service Pack 2 (SP2) cannot be 

installed from a primary domain controller, JMPSSERVER1 in this case. It can only 
be installed from another domain controller, JMPSSERVER2 in this case. The 
installation will update VCS on both servers. 

Step 2. Copy VERITAS Cluster Server 2.0 Service Pack 2 to a temporary directory on 
JMPSSERVER2.  

Step 3. Double-click the file Update.exe. 
Step 4. Read the Welcome screen and click Next. 
Step 5. The Prerequisites dialog box is displayed. The installer verifies that the cluster 

meets all requirements for installing the service pack. Click Next after all 
requirements are validated.  

Step 6. On the Select Option dialog box, select the Install VCS 2.0 Service Pack 2 option 
and click Next. 

Step 7. On the Select Nodes dialog box, make sure that the nodes on which you want to 
install the service pack are selected and click Next. Both JMPSSERVER1 and 
JMPSSERVER2 should be selected. All listed nodes can be selected by clicking 
Select All. 

Step 8. The Installing VCS 2.0 Service Pack 2 dialog box displays the status of the 
service pack installation. A message is displayed informing that the installer will stop 
VCS on all nodes.  

Step 9. On the Completing the Installation dialog box, select the Launch Lanman 
Configuration Wizard check box and click Finish. 

Step 10. Read the Welcome screen and click Next. 
Step 11. On the Update Lanman resources dialog box, specify values for the new 

attributes of the Lanman agent. All check boxes should be selected. 
Step 12. Click Next. 
Step 13. On the Lanman user credentials dialog box, enter the name and password 

of a JMPS domain (system) administrator and click Next. 
Step 14. The Completing the Lanman Configuration Wizard dialog box displays 

the status of the update. Click Finish when the update is completed. 
Step 15. Continue with section 6.27. 
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6.27 Procedure: Modifying Active Directory replication frequency 
 
Step 1. Go to Start  Programs  Administrative Tools  Active Directory Users and 

Computers. 
Step 2. Right-click on Domain Controlers  and click on Properties. 
Step 3. Select the Group Policy tab. 
Step 4. Select the Default Domain Controllers Policy. This should be the only policy 

shown. 
Step 5. Click Edit. 
Step 6. In the Group Policy UI that opens, navigate to Computer Configuration  

Windows Settings  Security Settings  System Services. 
Step 7. Double-click on Indexing Service. 
Step 8. Click the button for Edit Security. 
Step 9. Click the Add button and add SYSTEM with full control 
Step 10. Click Ok. 
Step 11. Repeat steps 7 - 10 for Internet Connection Sharing. 
Step 12. Repeat steps 7 - 10 for Irmon. 
Step 13. Repeat steps 7 – 10 for NetMeeting Remote Desktop Sharing. 
Step 14. Close the Group Policy window. 
Step 15. On the Domain Controllers Properties window click Ok. 
Step 16. Close Active Directory Users and Computers. 
Step 17. Go to Start  Run and type “cmd”. 
Step 18. In the command window that  opens, type "secedit /refreshpolicy 

machine_policy /enforce" 
Step 19. Close the command line window. 
Step 20. Reboot both servers. 
Step 21. Continue with section 6.30 if there is no ETI Technologies Shipboard UPS 

present.  
 

6.28 Procedure: UPS Power Monitoring Software Setup 
 
Step 1. On JMPSSERVER1 and JMPSSERVER2, verify that the UPS monitoring serial 

cable is connected to the serial port of the server and the STATUS port on the UPS.  
Step 2. On JMPSSERVER1, copy all files from the UPS software floppy disk to a 

temporary directory on the C:\ drive. (Ex. C:\eti_ups) 
Step 3. Navigate to the temporary directory above and double-click on Setup.exe. 
Step 4. Click Next twice. 
Step 5. Select “Typical” for the type of installation and click Next twice. The software 

will be installed. 
Step 6. Click OK in the window to confirm that the installation was completed.  
Step 7. Start PowerMon II by going to Start  Programs  PowerMon II  PowerMon 

II. 
Step 8. Click OK to accept default options. 
Step 9. UPS status window will come up automatically. 
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Step 10. Minimize the status window. There will be an “OK” symbol in the 

minimized status window. 
Step 11. Perform steps 2-10 on JMPSSERVER2. 
 

6.29 Procedure: Installation of JC1 
 
Refer to the Software Installation Instructions for JMPS Combat One for the procedures 
to accomplish the JMPS load.  These instructions are not repeated in this document 
because the developer Northrop Grumman Information Technology (NGIT) is writing 
and maintaining these JMPS load instructions.  However, the following notes shall apply 
in conjunction with the NGIT document. JC1 2549QAa build was used to describe JMPS 
installation in a clustered environment. 
 

6.29.1 Sub-procedure: Installation of JC1 on JMPSSERVER1 
 
Step 1. Verify in Veritas Cluster Explorer that both service groups are online on 

JMPSSERVER1. If they are, both E: and F: drives will be visible in Windows 
Explorer. 

Step 2. On JMPSSERVER1, copy the JC1 Install folder to a temporary directory on C:\ 
and execute the installation from this location.  

Step 3. For the JMPS Program install, select the Server option. 
Step 4. Select Yes to apply DII COE security settings. 
Step 5. Select Custom for the Setup Type and then select D:\Program Files\JMPS for 

installation of JMPS on the server.  This places the JMPS program on the D: 
(Segments) partition. 

Step 6. For the JMPS Data install, select Custom for Setup Type. 
Step 7. Select E:\Data for the installation of JMPS Data on the server.  This places the 

JMPS data on the E: (Data) partition. In the case of the JMPS Enterprise and JMPS 
Enterprise Lite configurations the E: partition will be the external Ciprico NetArray 
1100.  In the case of the JMPS PICO Configuration, E: will be located on the internal 
DL380 RAID 5. 

Step 8. Wait for the JMPS Data installation to complete (5+ minutes). 
Step 9. Select “No” if asked to reboot at the end of JMPS Data installation. 
Step 10. Continue with the next section to install Mission Binders on 

JMPSSERVER1. 
 

6.29.2 Sub-procedure: Installation of Mission Binders 1.0.0.7 COE Segment on 
JMPSSERVER1 

 
Step 1. Place the CD containing the Mission Binders segment into the CD-ROM drive. 
Step 2. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
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Step 3. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 4. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 5. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 6. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the MissionBinderRepository_1.0.0.7 COE segment.  The path may look 
like something like COE 4.6 (G:)\MissionBinderRepository_1.0.0.7.  Select the folder 
and then click the “OK” button on the Browse for Folder dialog box. 

Step 7. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 8. The bottom Available Software window inside the main COEInstaller window 
will update to show the “Mission Binder” (1.0.0.7) segment.  Select this segment by 
clicking the check box next to it (the selection will then be highlighted in dark blue). 

Step 9. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the Mission 
Binders COE segment. 

Step 10. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.  Do not panic if the 
progress appears to stop at 100% for a long period of time, wait until the process 
completes. 

Step 11. The MissionBinder Introduction dialog box will open.  Click the “Next” 
button. 

Step 12. The Choose Install Folder will then open.  Click the “Choose…” button. 
Step 13. The Browse for Folder dialog box will open.  Set the path to Segments 

(D:)\h\COTS so that the Mission Binder COE segment resides on D; with all the other 
installed COE segments. 

Step 14. Verify that the path displayed on the Choose Install Folder dialog has updated 
to “D:\h\COTS”.  Click the “Next” button. 

Step 15. The Choose a Folder to Store MissionBinder data files dialog box will open.  
Set the path in the Please Choose a Folder box to “E:\MissionBinder”.  Click the 
“Next” button when complete. 

Step 16. The Pre-Installation Summary dialog will then open.  Review the installation 
parameters and if correct click the Install button.  If problems are noted then click the 
“Previous” button and make the necessary corrections. 

Step 17. The Installing MissionBinders dialog will open and then quickly close.  The 
Install Complete dialog will then open.  Click the “Done” button. 

Step 18. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 19. The Installer Information dialog box will then open with the following 
message: 
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“In order for segment installation(s)to be complete the system must be rebooted.” 
 
Do you wish to reboot now? 
 
Click the “No” button. 
 

Step 20. Transfer the VCS service groups from JMPSSERVER1 to JMPSSERVER2. 
Step 21. Reboot JMPSSERVER1. 
Step 22. Continue with the next sub-procedure. 
 

6.29.3 Sub-procedure: Installation of JC1 and Mission Binders on JMPSSERVER2 
 
 
 
Step 1. Once JMPSSERVER1 comes back online, transfer VCS service groups from 

JMPSSERVER2 back to JMPSSERVER1.  
Step 2. Use the JMPS Admin tool to detach the following JMPS databases. Directions for 

using the JMPS Admin tool are provided in NGIT JC1 documentation. 
a. AimPoints 
b. DAFIF 
c. JTIDS 
d. LocalPoints 
e. OrderOfBattle 
f. PointExport 
g. ThreatParameters 

Step 3. Transfer the VCS service groups from JMPSSERVER1 to JMPSSERVER2. 
Step 4. Install JC1 on JMPSSERVER2 according to the JC1 installation instructions in 

the previous section. Installation may go quicker than on the first server due to the 
fact that JMPS data files on the E: drive are already present and do not have to be 
copied again. 

Step 5. When asked to reboot after JMPS Data install, click “No”. 
Step 6. Install Mission Binders on JMPSSERVER2 according to the installation 

instructions in the previous section. Installation may go quicker than on the first 
server. 

Step 7. When asked to reboot after Mission Binders install, click “No”. 
Step 8. Transfer the VCS service groups from JMPSSERVER2 to JMPSSERVER1. 
Step 9. Reboot JMPSSERVER2. 
Step 10. On JMPSSERVER1, user the JMPS Admin tool to attach all listed databases.  
Step 11. Attach the Mission Binders database using JMPS Admin tool. 
Step 12. Continue with the next sub-procedure. 
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6.29.4 Sub-procedure: Installing JMPS Framework and JMPS Framework Data 

COE segments 
 
Step 1. On JMPSSERVER1, place the CD containing the JMPS Framework and JMPS 

Framework Data segments into the CD-ROM drive. 
Step 2. Select Start->DII Installer, or double-click the desktop icon defined in Step 

6.27.2. 
Step 3. On the COEInstaller main menu select “File” and then “Select Target drive” from 

the pop-up menu. 
Step 4. The Disk Drive Selection dialog box will then open.  If it is set to D: click the 

“Cancel” button. If it is not set to D:\ click the down-arrow button and select the D:\ 
partition as the install location.  Then click the “OK” button on the Disk Drive 
Selection dialog box.  The COEInstaller main title bar should update to reflect the 
new target “COEInstaller - Installed software - target is D:\”. 

Step 5. On the COEInstaller main menu select “File” and then “Select Source drive. 
Double-click on the CD-ROM drive, the Browse for Folder dialog box will open. 

Step 6. On the Browse for Folder dialog box set the path to the CD drive and then to the 
location of the JMPS Framework segments.   

Step 7. On the COEInstaller main menu select “File” and then “Read Table of Contents” 
from the pop-up menu.  The Reading TOC Header Information… dialog will appear 
briefly then close. 

Step 8. The bottom Available Software window inside the main COEInstaller window 
will update to show the two segments, JMPS Framework and JMPS Framework Data.   

Step 9. Select JMPS Framework by clicking the check box next to it (the selection will 
then be highlighted in dark blue). 

Step 10. On the main COEInstaller menu select “Available Software” and then select 
“Install” from the pop-up menu to proceed with the installation of the JMPS 
Framework COE segment. 

Step 11. The Segment Installation Status dialog box and the COEInstaller Console 
window will open to show the segment installation progress.   

Step 12. When completed the COEInstaller dialog box will pop-up with the “Install 
was successful” message. Click the “OK” button to acknowledge it. 

Step 13. Follow steps 9-12 above to install JMPS Framework Data segment. 
Step 14. Exit COE installer. 
Step 15. Transfer VCS service groups from JMPSSERVER1 to JMPSSERVER2. 
Step 16. Reboot JMPSSERVER1. 
Step 17. Follow steps 1-13 to install JMPS Framework and JMPS Framework Data 

segments on JMPSSERVER2. 
Step 18. Transfer VCS service groups from JMPSSERVER2 to JMPSSERVER1. 
Step 19. Reboot JMPSSERVER2. 
 

6.29.5 Sub-procedure: Manual JMPS changes specific to build 2549QAa 
 

NOTE 
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SINCE JC1 IS STILL IN DEVELOPMENT, EACH 
BUILD HAS UNIQUE INSTRUCTIONS THAT 
CANNOT BE ACCOUNTED FOR IN THIS 
INSTALLATION MANUAL. CONTACT THE SSC-SD 
C4I PROGRAMS OFFICE PHILADELPHIA FOR 
INSTRUCTIONS ON SPECIFIC BUILD NOTES. 

 
Step 1. Follow instructions in the build notes to change JMPSPublisher service properties 

on JMPSSERVER1.  
Step 2. Follow the same instructions to make changes on JMPSSERVER2.  
Step 3. On JMPSSERVER1, modify the JMPSUPDataServer COM+ application 

according to the build notes. 
Step 4. Transfer VCS service groups from JMPSSERVER1 to JMPSSERVER2. 
Step 5. Reboot JMPSSERVER1. 
Step 6. On JMPSSERVER2, modify the JMPSUPDataServer COM+ application 

according to the build notes. 
Step 7. Transfer VCS service groups from JMPSSERVER2 to JMPSSERVER1. 
Step 8. Reboot JMPSSERVER2. 
Step 9. Continue with the next sub-procedure. 
 

6.29.6 Sub-procedure: Restarting MissionBinderFilesService Service 
 
Step 1. On JMPSSERVER1, go to Start  Administrative Tools  Services. 
Step 2. Scroll down until MissionBinderFileService is visible.  
Step 3. Single-click on the service. 
Step 4. Click on the last button on the right on the Services window toolbar. That is the 

Restart button. 
Step 5. The service will stop and then start again. 
Step 6. JMPS is now ready to run. 
Step 7. Continue with the next sub-procedure. 
 

NOTE 
 
MISSIONBINDERFILESERVICE SERVICE NEEDS 
TO BE RESTARTED EVERY TIME A SERVER IS 
REBOOTED. VERIFY THAT BOTH SERVICE 
GROUPS ARE ONLINE ON THE SERVER WHERE 
JMPS WILL BE RUNNING AND THEN RESTART 
THE SERVICE. 

 

6.29.7 Sub-procedure: Active Directory Schema changes to support collaboration 
(Optional) 

 
 E.S. Needs to be documented 

139 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 140 
 
 
 

6.30 Procedure: Installing Dynamic Multi-Path (DMP) drivers for the Ciprico 
RAIDs 

 
Step 1. Log into Veritas Cluster Monitor on JMPSSERVER1. 
Step 2. From the Tools menu, select Command Center.  
Step 3. In the tree-view on the left side of the window, double-click on Operations  

Controls  Offline Service group.  
Step 4. In the right side of the window, two panes will be shown – Service Groups and 

Systems. Two service groups will be shown.  
Step 5. Click the first service group, JMPS_SRV_SQL. The system on which that service 

group is active, JMPSSERVER1, will show up in the Systems pane.  
Step 6. Click on JMPSSERVER1. Both the service group and the system should now be 

selected.  
Step 7. Click Apply to take the service group offline. 
Step 8. Take the second service group offline according to the steps above. 
Step 9. Click Close to close the window. 
Step 10. Place the CD containing Veritas Volume Manager 3.1 HotFix 02 and the 

DMP driver in the CD-ROM on JMPSSERVER1. 
Step 11. Copy all files to a temporary directory on the C: drive.  
Step 12. Go to the temporary directory that was just created and double-click on 

VM2K31HF02aENU_260611.exe.  
Step 13. In the window that comes up, enter a temporary location where the files 

can be extracted to. Remember that directory.  
Step 14. Navigate to the temporary directory above and double-click on 

VMW2K31HF02a.msi file to start the installation. The install utility's Welcome 
screen appears and then a dialog box displays on top. 

Step 15. The dialog box prompts you to close all applications before continuing 
and informs you that VEA will be installed. Click Yes to continue. 

Step 16. At the install utility's Welcome screen, click Next to continue. 
Step 17. A dialog box requests that you wait while the VEA Language Pack is 

installed. Click OK to continue. 
Step 18. Click Install to proceed with the installation. The hotfix installation runs 

automatically and will install the files modified by the hotfix to the appropriate 
directories. 

Step 19. In the final screen, click Finish. A message appears prompting you to 
restart your system.  

Step 20. Click No to restart later. 
Step 21. Using Windows Explorer, Go to the DDI_Ciprico directory in the 

temporary directory that was created above. 
Step 22. Double-click on install.cmd. 
Step 23. Using Windows Explorer, go to C:\winnt\system32\drivers and rename 

vxdmp.sys to vxdmp.orig.sys 
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Step 24. Copy vxdmp.sys from the Private119933 directory (located in the 

temporary directory that was created earlier) to C:\winnt\system32\drivers. 
Step 25. Execute steps 10-24 on JMPSSERVER2. 
Step 26. Reboot both JMPSSERVER1 and JMPSSERVER2. 
 
Note: In order to prevent VCS from getting confused about which server is up and which 
is being rebooted, it is recommended that only one server at the time is rebooted. Before 
rebooting JMPSSERVER1, switch VCS service groups from JMPSSERVER1 to 
JMPSSERVER2. Then reboot JMPSSERVER1. When JMPSSERVER1 comes back up, 
transfer VCS service groups back to JMPSSERVER1 and then reboot JMPSSERVER2. 
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6.31 Procedure: Adding DMP support to Veritas Volume Manager 
 

NOTE 
 
IN ORDER TO ENABLE DMP SUPPORT, A 
SEPARATE DRIVER HAS BEEN INSTALLED. THE 
APPROPRIATE FIBRE CHANNEL CONNECTIONS 
MUST NOW BE MADE TO PROVIDE REDUNDANT 
PATHS TO THE DUAL CIPRICO RAIDS. SEE THE 
DIAGRAM ABOVE FOR CONNECTION 
DESCRITIONS. AT THIS POINT, ONLY 
CONNECTIONS 1, 2, AND 3 SHOULD BE MADE. 
THEY WILL PROVIDE A SINGLE PATH TO THE 
FIRST CIPRICO RAID. THE NEXT STEP IS TO 
CREATE A SECOND PATH TO THE FIRST 
CIPRICO RAID. 

 
Step 1. Ensure that the second Brocade Silkworm 3200 fibre switch is powered on. If it is 

not, power it on. It takes the switch approximately 4-5 minutes to perform self-testing 
and come online. Be patient. 

Step 2. Open Veritas Enterprise Administrator (VEA) on JMPSSERVER1. 
Step 3. Expand jmpsserver1 in the left pane of the VEA window. Then expand the Disks 

folder. Click on Harddisk1. 
Step 4. Select the Paths tab in the right pane. This tab displays the paths to the selected 

disk. Only one path will be shown. 
Step 5. Right-click on the path and the path context menu appears. 
Step 6. Right-click the path and select Array Settings from the path context menu that 

comes up. The Array Settings window comes up. The Exclude checkbox is checked. 
Step 7. Uncheck the Exclude checkbox. 
Step 8. Under Load Balancing, select Active/Active if it is not selected by default. 
Step 9. Click OK. 
Step 10. Click on Harddisk2. 
Step 11. Select the Paths tab in the right pane. This tab displays the paths to the 

selected disk. Only one path will be shown. 
Step 12. Right-click on the path and the path context menu appears. 
Step 13. Right-click the path and select Array Settings from the path context menu 

that comes up. The Array Settings window comes up. The Exclude checkbox is 
checked. 

Step 14. Uncheck the Exclude checkbox. 
Step 15. Under Load Balancing, select Active/Active if it is not selected by default. 
Step 16. Click OK. 
Step 17. Make connections 4 and 5 according to Figure 7 above. 
Step 18. VVM should automatically recognize the second path to the disk array. If 

it does not, Select Actions  Rescan from the VEA menu bar. Volume Manager 
rescans the array and updates the display. 
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Step 19. Two paths should now be shown for both Harddisk1 and Harddisk2.  
Step 20. Make connection 6 according to Figure 7 above. 
Step 21. Select Actions  Rescan from the VEA menu bar. Volume Manager 

rescans the array and updates the display. Two more disks will be shown – Harddisk3 
and Harddisk4. 

Step 22. Harddisk3 and Harddisk4 need to have signatures added to them. To add a 
signature to a disk right-click on the unsigned disk in the tree view. The Write 
Signature command appears in the context menu. 

Step 23. Select Write Signature from the context menu. The Write Disk Signature 
dialog box will appear. Select the disks that need a signature to be added to them – 
Harddisk3 and Harddisk4. To select a disk, click on it in the list of available disks and 
click the Add button. 

Step 24. Once the disks are selected, click the OK button. Once a signature appears 
on a disk, the disk will display as a basic disk. 

Step 25. Right-click on Harddisk3 the tree view or the Disk View tab in the right 
pane. 

Step 26. In the context menu that comes up, select Add Disk to Dynamic Disk 
Group. 

Step 27. The Add Disk to Dynamic Disk Group wizard appears. Click Next to 
continue. 

Step 28. In the next screen, select Harddisk3 by clicking the Add button if 
Harddisk3 is not already selected. Select JMPS_SQL_GRP for the dynamic disk 
group name. Click Next. 

Step 29. A confirmation screen appears listing the selected disk. Click Next to 
continue if the disk selection is satisfactory, or choose Back to go back to modify the 
disk selection. 

Step 30. Click Finish in the final screen. 
Step 31. Expand the Disks folder in the left pane of the VEA window. Click on 

Harddisk3. 
Step 32. Select the Paths tab in the right pane. This tab displays the paths to the 

selected disk. Only one path will be shown. 
Step 33. Right-click on the path and the path context menu appears. 
Step 34. Right-click the path and select Array Settings from the path context menu 

that comes up. The Array Settings window comes up. The Exclude checkbox is 
checked. 

Step 35. Uncheck the Exclude checkbox. 
Step 36. Under Load Balancing, select Active/Active if it is not selected by default. 
Step 37. Click OK. 
Step 38. Click on Harddisk4. 
Step 39. Select the Paths tab in the right pane. This tab displays the paths to the 

selected disk. Only one path will be shown. 
Step 40. Right-click on the path and the path context menu appears. 
Step 41. Right-click the path and select Array Settings from the path context menu 

that comes up. The Array Settings window comes up. The Exclude checkbox is 
checked. 

Step 42. Uncheck the Exclude checkbox. 
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Step 43. Under Load Balancing, select Active/Active if it is not selected by default. 
Step 44. Click OK. 
Step 45. Make connections 7 and 8 according to Figure 7 above. 
Step 46. VVM should automatically recognize the second path to the disk array. If 

it does not, Select Actions  Rescan from the VEA menu bar. Volume Manager 
rescans the array and updates the display. 

Step 47. Two paths should now be shown for both Harddisk3 and Harddisk4. 
Step 48. Right-click on JMPS_SQL_VOL in the Volumes folder in VEA tree view 

on the left side of the screen. 
Step 49. Select Mirror  Add from the context menu. The Add Mirror dialog box 

will appear. 
Step 50. Auto-select Disks radio button will be selected along with Harddisk3 

already shown in the right pane below. 
Step 51. Click OK to add the mirror. This operation will take several days to 

complete. The disk array can be used during this time, although with reduced 
performance. 

Step 52. Right-click on JMPS_SHARE_VOL in the Volumes folder in VEA tree 
view on the left side of the screen. 

Step 53. Select Mirror  Add from the context menu. The Add Mirror dialog box 
will appear. 

Step 54. Auto-select Disks radio button will be selected along with Harddisk4 
already shown in the right pane below. 

Step 55. Click OK to add the mirror. This operation will take several days to 
complete. The disk array can be used during this time, although with reduced 
performance. 

Step 56. The status of volume mirroring can be observed by clicking on the Tasks 
tab at the bottom of the main VEA window. 

 
 
 
 
 
 
 
 
 
 
 
 
 

6.32 Procedure: Fixing Microsoft Outlook Warning Message at Boot up 
 
After installing Backup Exec, the following warning message may pop-up when Backup 
Exec services are started: 
 

145 



 D4233-ENG-127 
 Revision: 1.3 
 Page: 146 
 

146 

Either there is no default mail client or the current mail client cannot fulfill the 
messaging request. Please run Microsoft Outlook and set it as the default mail client. 
 
To fix this problem, follow the steps below on both JMPS servers: 
 
Step 1. Start the Registry editor by going to Start  Run and typing “regedit” 
Step 2. Within Registry editor, navigate to 

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail hive. 
Step 3. Keeping Mail key highlighted, click Registry menu. 
Step 4. Select Export Key 
Step 5. Provide the path to save the selected registry key (Ex. 

C:\registry_backup\backup.reg). This will provide a backup of the original registry 
key. 

Step 6. Right-click on a registry key called PreFirstRun from the 
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail registry hive and click 
Rename. 

Step 7. Enter “PreFirstRun_no_longer_being_used” for the value and hit Enter. 
Step 8. Close the Registry editor. 
Step 9. Continue with section 6.27. 
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