CONFIGURE WINDOWS 2000 ADVANCED SERVER

SECTION 1


MUGU SERVER INSTALL V2.04
JUN 27  2003  
BASIC LOAD OF THE WINDOWS 2000 ADVANCED OPERATING SYSTEM

NOTE:  FOR A TOTAL RELOAD OF SYSTEM

Power down Server , RAID ARRAY , MAP server 

NOTE: Pull hard drives ID# 2,3,4  for Enterprise Lite install

Insert hard drives ID#2,3,4 for Pico Server

Power up Server ONLY – leave RAID ARRAY and MAP server off

BUILD A SMART ARRAY 5I DRIVER ON FLOPPY DISK 

(Floppy called Compaq DL380 Smart Array 5I- skip if step previously done)
Need following for this section:

Microsoft Windows 2000 Advanced Server - CD

Compaq SmartStart for Servers CD
Blank formatted Floppy labeled:  Compaq Smart Array5i driver  
Restart Server 

As the server starts insert the Compaq SmartStart for Servers CD 

SmartStart for Servers screen will appear several times

System Utilities screen will open

Double click on the “Create Support Software” icon.

The Compaq SmartStart - Diskette Builder screen will open

Double click on the “Compaq” icon to expand the list 

Select  “Compaq Support Paq for Microsoft Windows 2000 Supplemental Diskettes version 5.40A”

Click the “Next” button.

Select “Create software diskettes to floppy only” 

Click the “Next” button.

Insert blank diskette into floppy drive 

Click the “OK” button

When completed click “Finish” 

Click the “Exit” button

Click the “OK” button on the exiting SmartStart warning dialog

Remove the SmartStart CD and floppy disk created 

Label this disk “Compaq DL380 SmartArray 5I Driver”

Press any key to reboot the server.

CONFIGURE PARTITION DRIVES

During boot Press “F8” to enter the configuration utility – watch for prompt

Main Option ROM Configuration for Arrays (ORCA) screen will appear

Use down-arrow key to select the “View Logical Drive” selection

(it will be highlighted in dark blue when selected) 

Press “Enter”.

If the system has been pre-configured or previously loaded, logical drives will appear in the list

If desired follow the sub-steps (delete logical drives) below to wipe all the existing logical drives

(This option would be the case for a totally clean installation)

If server shipped pre-configured , to keep partitions as is, go to verify boot order

IF SYSTEM HAS NO LOGICAL DRIVES DEFINED

The following will appear There are no available logical drives Press <ESC> to return to the main menu 

Press “ESC” and continue to create the new logical drives
DELETE LOGICAL DRIVES

If not at main ORCA screen – go there

Select View logical drives

Observe drives present

For Enterprise – Logical Drive #1 33.9 Gbytes  should be displayed

For Pico server – Logical Drives #### will be displayed
Esc to return to main ORCA screen

Select “Delete Logical Drive” selection

Press “Enter”

The Available Logical Drive list will appear

Select the first logical drive in list (the selected drive will be highlighted in dark blue)

Press “F8” to delete it

Acknowledge red warning dialog box:

Press “F3” to delete the logical drive.

The Saving Configuration… message will flash 

The Configuration saved Press <Enter> to continue dialog will open

Press “Enter”

Repeat above steps to delete each logical drive in the Available Logical Drive list

When  the message:

There are no available logical drives. Press <ESC> to return to the main menu message appears

Delete operation has completed

When there are no more drives, press “ESC” to go back to the main ORCA screen

Continue boot process

BUILD THE LOGICAL DRIVES

The logical drive creation procedure will differ between the JMPS Enterprise, JMPS Enterprise Lite and the JMPS PICO server configurations

JMPS ENTERPRISE LITE CONFIGURATIONS

BUILD THE LOGICAL DRIVES

JMPS Enterprise Lite configurations may contain 2 drives or the full compliment of 5 drives.

The first two drives will be configured into a RAID 0+1 (mirrored) configuration

Drives 0 ,1  mirrored system boot disk

Drives 2,3,4 configured as spares if present
On ORCA Main Menu select “Create Logical Drive” selection

Press “Enter”

The Available Physical Drives, Raid Configurations and Spare boxes will open 
Assure both drive ID 0 and drive ID 1 are selected

(If not selected click Space Bar to place an “X” in brackets next to the drive )
NOTE

If for there are more than 2 hard drives present in the system the extra drives must be de-selected on Enterprise Lite
De-select by clicking Space Bar to remove 

 “X” should not be present on any drives except for drive ID 0 and ID 1

Press  “Tab” key to move to Raid Configurations box (drive ID 0 and ID 1 selected)

Select the RAID 1 (1+0) choice with using arrow key

Press “Enter” to create the logical drive

The following message will appear:

“You have selected a logical drive with a total data size of xxx.x GB and

RAID 1 fault tolerance…..

Press “F8” to save the configuration.

The Saving Configuration… message will flash 

Configuration saved Press <Enter> to continue dialog will open

Press “Enter”

Select “View Logical Drive” selection 

Press “Enter”

The Available Logical Drives list will open

Verify new Logical Drive defined appears as Logical Drive # 1 and is RAID 1 configuration.

Press “ESC” to go back to the ORCA main screen

Press “ESC” to exit the ORCA utility and continue boot sequence

JMPS PICO CONFIGURATION

BUILD THE LOGICAL DRIVES

JMPS PICO Configuration has total of 5 hard drives
Two drives will be configured into a RAID 0+1 (mirrored)  Boot Disk

The remaining three drives will be configured into a RAID 5 

On Orca main Menu Select  “Create Logical Drive” 

Press “Enter”.

The Available Physical Drives, Raid Configurations and Spare boxes will open

Assure both drive ID 0 and drive ID 1 are selected

If not selected click Space bar to place “x” in bracket next to drive

NOTE

If for there are more than 2 hard drives present in the system the extra drives must be de-selected 

De-select by clicking Space Bar to remove “x”

“X” should not be present on any drives except for drive ID 0 and ID 1
Press “Tab” key to move to Raid Configurations box (drive ID 0 and ID 1 selected)
Select RAID 1 (1+0) choice using the arrow key

Press “Enter” to create the logical drive

The following message will appear:

“You have selected a logical drive with a total data size of xxx.x GB and

RAID 1 fault tolerance….

Press “F8” to save the configuration.

The Saving Configuration… message will flash

The Configuration saved Press <Enter> to continue dialog will open

Press “Enter”

Select “View Logical Drive” selection 
Press “Enter”

Available Logical Drives list will open

Verify new Logical Drive defined appears and is RAID 1 configuration

Press “ESC” to exit the Logical Drive display.

Back on the ORCA Main Menu select the “Create Logical Drive” selection

Press “Enter”.

Available Physical Drives, Raid Configurations and Spare boxes will open on ORCA screen

In Available Physical Drives box select remaining three drives

Drive ID 2, drive ID 3 and drive ID 4

(These should be selected by default, if not select each one 

Click the Space Bar to place “X” in brackets next to the drive 

Press “Tab” key to move to the Raid Configurations box ( drive ID 2, 3 and 4 selected)
Select the RAID 5 using arrow key

Press “Enter” to create the logical drive

The following message will appear:

“You have selected a logical drive with a total data size of xxx.x GB and

RAID 5 fault tolerance…..

Press “F8” to save the configuration.

The Saving Configuration… message will flash

The Configuration saved Press <Enter> to continue dialog will open

Press “Enter”

Select “View Logical Drive” 

Press “Enter”

Available Logical Drives list will open

Verify new Logical Drive # 2 defined appears in the list and is RAID 5 configuration

Press “ESC” to go back to the ORCA main screen.

Press “ESC” to exit the ORCA utility and continue the server install

VERIFY BOOT ORDER

( skip this step if previously verified)
Watch boot sequence for the following message :

Press F9 key for ROM-Based Setup Utility

When message appears , Press “F9” to enter the ROM-Based Setup Utility

Use down-arrow key to select  “Standard Boot Order (IPL)”  

(it should be highlighted in dark blue) 

Press “Enter”

The boot order list will appear

If CD-ROM is set as IPL:1 press “ESC” and continue at end

If CD-ROM not set to IPL:1 then do following sub-steps:

Using the up/down arrow keys select the CD-ROM

(the IPL: number will be highlighted in black on the selected item)

Press “Enter”

From list using up/down arrows keys, select “Set the IPL Device Boot Order to 1” 

Press “Enter”

This will move the CD-ROM to the top of the boot list (IPL:1 CD-ROM)

Press “ESC” on boot list to return to main ROM-Based Setup Utility screen

Verify boot order changed on the main ROM-Based Setup Utility screen 

Press “ESC” to exit the utility.

Press “F10” to confirm exit from ROM-Based Setup Utility and save changes.

LOAD WINDOWS 2000 ADVANCED SERVER SETUP FILES

As the system reboots place Microsoft Windows 2000 Advanced Server in CD-ROM drive

The blue “Windows 2000 Setup” screen will appear with message:

 “Setup is loading files…” Allow the file loading process to continue.

Watch for the following prompt during the loading process:

Press <F6> if you need to install third party SCSI or RAID driver…

(Prompt appears briefly if missed press CTRL - ALT - DEL to 
reboot and restart the Windows 2000 Advanced Server installation.)

When prompt appears press “F6”. 
Setup screen will appear with the mass storage specification screen. 

Press “s” to load the Compaq Smart Array5I SCSI controller driver

The blue Windows 2000 Setup screen will appear with the instruction:

“Please insert the disk labeled Manufacturer-supplied hardware support disk into Drive A:

Insert floppy disk containing Compaq Smart Array5i SCSI controller driver 

Press “Enter”

(Leave this disk in the floppy drive until instructed to remove it)

Blue Windows 2000 Setup screen will appear with array type selection screen

Use arrow keys to select “Compaq Smart Array 5i, 532, 5312 Controllers” choice 

(the selection will be highlighted in white)

Press “Enter”

The dialog Setup is loading files.. will appear briefly on the bottom of screen

The mass storage specification screen will reappear

Press “Enter” to continue (No further drivers are required to be loaded)

(Setup will then to continue to load files)

The Windows 2000 Server Setup blue screen will appear

Press “Enter” to begin setup of Windows 2000

PARTITION DISKS

Next blue Windows 2000 Server Setup blue screen display following messages:

“Setup has determined that your computer’s start up hard disk is new or has been erased….

CAUTION: Any data currently on your computer’s startup hard disk will be lost.”

Press “C” to continue with Setup.

The Microsoft® Windows 2000 Licensing Agreement will appear 

Press “F8 = I agree” to accept the license.

INFORMATION

According to general DII-COE installation guidelines disk is partitioned into three partitions

C: partition for the system files named “System”

D: partition for the COE segments named “Segments”

E: partition for the user data named “Data”

JMPS Enterprise Lite configuration as follows:

Internal mirrored boot disk should be split into two equal partitions

System C:

Segments D:

Data E: partition will be placed on the external Ciprico NetArray 1100 RAID

In the JMPS PICO server configuration as follows:

Internal mirrored boot disk will be split into two equal partitions:

System C: 

Segments D: 

Data E: partition will be an internal (inside the DL380 server) RAID 5 storage area

The following procedures will detail how this operation is completed.

The following partition information screen messages will appear:

“The following list shows the existing partitions and unpartitioned space on this

computer…..

The following disk summary might  be displayed:

34728 MB Disk0 at Id4 on bus on cpqcissm

Unpartitioned space 34728MB

Make sure that the Unpartitioned space is selected (highlighted in white)

Press “C” to create a new C: partition.

Next blue Windows 2000 Server Setup screen will appear with following message:

• To create the new partition, enter a size below and press Enter

• To go back to the previous screen without creating the partition, press ESC.

Calculate the necessary size for the C: partition using the actual size of the hard drive

(an example using a 36.4GB drive, it will roughly be 34724 * .5 = 17364 MB)

Enter partition size in the white highlighted block

Press “Enter” to create it.

Blue Windows 2000 Server Setup screen will display the partition info as:

34728 MB Disk0 at I4 on bus 0 on cpqcissm

C: New(Unformattted) 17364 MB

Unpartitoned space 17364 MB

(Note: The above drive size may be different, these are the expected size with 36.4

GB hard drives. If larger drives are used in the server, the sizes will differ.)

Press “ENTER” to install the partition

Do not create any other partitions; this task will be addressed via the Windows 2000 Disk Manager.

Blue Windows 2000 Server Setup Format Type screen will appear with the following:

“The partition you selected is not formatted. Setup will now format the partition.

Select “Format the partition using the NTFS file system”

Press “Enter” to start formatting process

Blue “Windows 2000 Server Setup” screen will appear with following message:

“Please wait while Setup formats the partition C:….

The progress bar will also be displayed:

Setup is formatting… XX %

Wait until the formatting operation is completed.

CONFIGURE WINDOWS COMPONENTS

When the formatting operation is completed install will continue

Blue Windows 2000 Server Setup screen display “Checking System” notification

The progress bar will also be displayed:

Wait until the copy operation finishes.

Next blue Windows 2000 Server Setup screen to appear 

“Setup has completed copying files, the system will now reboot”

Allow the system to reboot

Do not remove the Windows 2000 Advanced Server CD from drive

Window 2000 Server Setup dialog box will appear over the Windows 2000 Server screen. 

Wait for the next dialog box to open.

Windows 2000 Setup screen “Welcome to the Windows 2000 Setup Wizard” will appear. 

Click the “Next” button.

Windows 2000 Server Screen will appear with  “Installing Devices…” dialog 

(at this time setup is detecting and installing devices  the screen may flicker during this period)

Wait until this process is finished.

The Windows 2000 Server Setup screen will appear with the “Regional Settings” dialog box

Click “Next” button to accept the default (English, US Keyboard) settings

Windows 2000 Server Setup screen will appear with “Personalize Your Software” dialog box

Enter the server host name 

Enter the organization NavMPS

When finished click the “Next” button

“Your Product Key” dialog box will appear
Enter the 25 alphanumeric license key 

Press the “Next” button 

“Licensing Modes” dialog box will appear
Select the “Per Seat - Each computer must have its own Client Access License” choice

Note the statement that appears on this screen:

“To avoid violation of the License Agreement, use Licensing (which is located in

Administrative Tools) to record the number of Client Access Licenses purchased.”

Click the “Next” button to continue the installation.

 “Computer Name and Administrator Password” dialog will appear
Enter server host name
Enter administrator password 

( recommend using COE compliant password – 8 characters , upper case , lower case, numeric)

Enter the administrator password in Confirm Password box

Press the “Next” button to continue with the installation

“Window 2000 Components” dialog  will appear
Double click on Accessories and Utilities component to open subcomponent list

Accessories and Utilities dialog box will open
Subcomponents of Accessories and Utilities list will display
Perform the following operations on the subcomponent list:

Leave the Accessibility Wizard box checked

Double click the Accessories subcomponent

Subcomponents of Accessories list will appear
Verify all components checked

Click the “OK” button

Double click Communications subcomponent

Subcomponents of Communications list will appear

Uncheck the Chat and Phone Dialer subcomponents

Only the HyperTerminal subcomponent should be installed

Click the “OK” button

Communications check box will now be gray (due to the custom settings that were applied)

Uncheck Games subcomponent 

Double click the Multimedia subcomponent

Subcomponents of Multimedia list will appear

Verify that all subcomponents are checked

Click the “OK” button

On the Accessories and Utilities dialog box, click the “OK” button

On “Windows 2000 Components” dialog box

Uncheck Certificate Services component 

Uncheck Cluster Services component 

Check Indexing Services component 

On “Windows 2000 Components”

Double click on the Internet Information Services (IIS) 

The (IIS) dialog box will open with the Subcomponents  (IIS) list

Perform the following operations on the subcomponent list:

Check Common Files subcomponent 
Uncheck the Documentation subcomponent

Check the File Transfer Protocol (FTP) Server subcomponent selection box 

Uncheck the FrontPage 2000 Server Extensions subcomponent

Check Internet Information Services Snap-In subcomponent 
Uncheck the Internet Services Manager (HTML) subcomponent

Uncheck NNTP Service subcomponent 
Uncheck the SMTP Service subcomponent

Uncheck Visual InterDev RAD Remote Deployment Support subcomponent
Uncheck the World Wide Web Server subcomponent

Click the “OK” button on the Subcomponents of Internet Information Services (IIS) dialog box

Internet Information Services (IIS) check box will show gray (due to the custom settings selected)
On “Windows 2000 Components” select Management and Monitoring Tools component by checking the selection box

Double click on Management and Monitoring Tools component to open its subcomponent list

Perform the following operations on the subcomponent list:

Uncheck the Connection Manager Components subcomponent

Check Network Monitor Tools subcomponent 

Check Single Network Management Protocol subcomponent 
On Subcomponents of Management and Monitoring Tools click the “OK” button

Management and Monitoring Tools check box will show gray (due to the custom settings selected)
Uncheck Message Queuing Services 
(Message Queuing Services will need to be added for JC1 later in the installation procedure

after Active Directory has been configured)

On “Windows 2000 Components” select Networking Services component 

Double click Networking Services component 
Perform the following operations on the subcomponent list:

Check COM Internet Services Proxy subcomponent 
Uncheck the Domain Name Server (DNS) subcomponent

Uncheck the Dynamic Host Configuration Protocol (DHCP) subcomponent

Check Internet Authentication Service subcomponent 

Uncheck the QoS Admission Control Service subcomponent

Check Simple TCP/IP Services subcomponent 

Uncheck Site Server ILS Services subcomponent 

Uncheck Windows Internet Name Services (WINS) subcomponent 
Click “OK” button On Subcomponents of Networking Services dialog box

Networking Services check box will show as gray (due to the custom settings selected)
On “Windows 2000 Components” dialog box
Uncheck Other Network File and Print Services component 
Uncheck Remote Installation Services component 

Uncheck Remote Storage component 

Check  Script Debugger component 

Uncheck Terminal Services component 
Uncheck  Terminal Services Licensing component 

Check Windows Media Services component 

Double click on Windows Media Services component to open its subcomponent list

Perform the following operations on the subcomponent list:

Check Windows Media Services subcomponent 
Check Windows Media Services Admin subcomponent 

Click “OK”  On Windows Media Services Subcomponents of Windows Media Services 
All Windows 2000 components have been selected 
Click the “Next” button.

SET DATE/TIME

Windows 2000 Server Setup screen displays “Date and Time Settings” 

In the Date and Time boxes enter the correct date and the GMT time and time

Leave “Automatically adjust clock for daylight saving changes” box Checked

Click the “Next” button on Date and Time Settings dialog box

CONFIGURE NETWORK COMPONETS

(After the Network Settings installation runs, the Windows 2000 Server Setup

screen with the “Network Settings” dialog box will appear)

Select “Custom Settings”

Click “Next” button.

Windows 2000 Server Setup screen with Networking Components dialog box will appear

The For Device line will display the network card that the settings will apply to

For Compaq DL380 system should be second onboard NIC “Compaq NC3163 Fast Ethernet NIC #2”

Components for this NIC shown in Components checked are used by this connection box

Perform the following operations on the component list:

Check Client for Microsoft Networks component 

Double click on Client for Microsoft Networks component to open the component properties

Verify that Name service provider is set to Windows Locator
Click the “OK” button

On Networking Components list

Uncheck Network Load Balancing component 

Check File and Printer Sharing for Microsoft Networks component 

Double click File and Printer Sharing for Microsoft Networks component

File and Printer Sharing for Microsoft Networks Properties dialog box will open

Verify that “Maximize data throughput for file sharing” choice is selected
If it is not, select it

Click the “OK” button

Check Internet Protocol (TCP/IP) component 

Double click on the Internet Protocol (TCP/IP) component to open the component properties

Click the “Use the following IP address” button

Proceed to enter the IP address, Subnet mask and Default gateway

Also enter the Preferred DNS server and the Alternate DNS server IP addresses if available

Once the addresses are entered click the “OK” button

All necessary components are loaded/configured for the second network card

On Networking Components dialog box click the “Next” button

The second “Networking Components” dialog box will appear

The For Device line will display the network card that the settings will apply to

For Compaq DL380 system should be first onboard NIC “Compaq NC3163 Fast Ethernet NIC”

Components for network card are shown in the Components checked are used by this connection box. Perform the following operations on the component list:

Check Client for Microsoft Networks component 

Double click on the Client for Microsoft Networks component to open the component properties

Verify that Name service provider is set to Windows Locator
Click the “OK” button

Uncheck Network Load Balancing component 

Check File and Printer Sharing for Microsoft Networks component 

Double click on File and Printer Sharing for Microsoft Networks component to open properties

The File and Printer Sharing for Microsoft Networks Properties dialog box will open

Verify that the “Maximize data throughput for file sharing” choice is selected

Click the “OK” button

Check Internet Protocol (TCP/IP) component 
Double click on the Internet Protocol (TCP/IP) component to open the component properties

Click the “Use the following IP address” button

Proceed to enter the IP address, Subnet mask and Default gateway

Enter Preferred DNS server and the Alternate DNS server IP addresses

Click the “OK” button

All necessary components loaded/configured for the first network card

Click the “Next” button

Windows 2000 Server Setup screen will open with “Workgroup or Computer Domain” dialog 

Accept default “No, this computer is not on a network, or is on a network without a domain” choice

(Actual workgroup/ domain configurations will be done later in the procedure)

Click the “Next” button

Windows 2000 Setup screen with Installing Components dialog box will display message:

“Please wait while Setup installs the components. This may take several minutes”.

(The Status bar will show the progress of the installation. 

The “Performing Final Tasks” dialog will appear during the final steps

Wait until the setup completes)

Windows 2000 Server Setup screen “Completing the Windows 2000 Setup Wizard” will display

Remove the Windows 2000 Advanced Server CD from the CD-ROM drive

Remove floppy containing the Compaq Smart Array5i drive from the floppy drive

NOTE

PRIOR TO RESTARTING THE SERVER ENSURE THAT THE NETWORK CARDS ARE CONNECTED TO THE NETWORK AND THAT THE PORTS THEY ARE CONNECTED TO ARE ACTIVE. 

IF THE NETWORK CARDS ARE NOT CONNECTED, SEVERAL SERVICE CONTROL MANAGER ERRORS RELATED TO NETWORKING SERVICES WILL OCCURR AT BOOT. THIS IS NOT A MAJOR ISSUE BUT CAN BE ADVOIDED IF THE NETWORK IS AVAILABLE
Click the “Finish” button

The server will restart.

When system boots, “Welcome to Windows - Press Ctrl-Alt-Delete to begin” dialog will appear

Logon to the system using administrator account

Upon boot the Windows 2000 Configure Your Server window will appear

Close this dialog 
SET VIDEO PROPERTIES

Right click on Desktop

Properties( Settings tab

Screen resolution = 1024-768 pixels
Colors = True Color 32bit

Select advanced ( monitor tab

Refresh frequency = minimum 75 HZ or higher

Select Apply to confirm

Window will display with message about – Select OK

Windows will resize

Select Yes do you want to keep settings
Select OK ( back to Display Properties window

Set screen saver 20 min
Right click on Desktop

Properties( Screen Saver

Select Login Screen Saver 20 min

Select apply to confirm

Select OK to exit

Open windows explorer

Select Tools(folder Options(View tab

Deselect hide extensions for known file types

Click OK to exit
 FORMAT D AND E PARTITIONS     

The procedures to format hard drives between the JMPS Enterprise Lite and the JMPS PICO configurations will differ due to the different server hard drive configurations

Select the appropriate path based on the configuration being deployed

JMPS ENTERPRISE LITE CONFIGURATIONS 

FORMAT D AND E PARTITIONS  

NOTE

JMPS Enterprise Lite configurations will contain two hard drives that have been setup in a hardware RAID 0+1 configuration  The first partition C: was defined for the basic operating system 

Labeling and formatting operations must now be completed to define the second partition

Select Start->Programs->Administrative Tools->Computer Management

In the left-hand box double click on the “Disk Management” folder

In right-hand pane of window the volume information will appear for disk drives 

Click on the CDRom 0 drive label box

Right-click

Select “Change Drive Letter and Path…” from the pop-up menu.

Change Drive Letter and Paths for (D:) will appear

Click the “Edit” button

On Assign drive letter line, click the down-arrow key , select the “G:” drive letter 

Click the “OK” button to set it

Confirm dialog box will open with following message:

“Changing the drive letter of a volume may cause programs to no longer run. Are

you sure you want to change this drive letter?”

Click the “Yes” button

Drive letter for the CDRom0 will change to “G:” on the Computer Management window

On the Start Menu Bar click Start->Shut Down (“Restart” 

Click the “OK” button

The server will restart

After the server restarts logon as the administrator

Windows 2000 Configure Your Server window will appear

Close this dialog 

Select Start->Programs->Administrative Tools->Computer Management.

In the left-hand box double click on the “Disk Management” folder

In the right-hand pane the volume information will appear for the disk drives 

Verify that the CDRom 0 drive label is “G:”

On Disk 0 display click on C: partition 

Right-click on it

From the pop-up menu select “Properties”

On General TAB, in the Label box enter “System” 

Click the “OK” button

Verify name of  C: partition is  “System”

Select and then right-click on the Unallocated space on Disk 0

Select “Create Partition” from the pop-up menu

Create Partition Wizard dialog box will open with Welcome to the Create Partition Wizard 

Click the “Next” button

The Select Partition Type dialog will then appear

Select the “Primary partition” choice

Click the “Next” button

Specify Partition Size dialog will then appear

Accept the total amount of disk space for the “Segment” partition

(For the JMPS Enterprise and Enterprise Lite configuration size will be approximately 1/2 of the RAID 1 area.) 

Click “Next” button

The Assign Drive Letter or Path dialog will then open

On the Assign a drive letter line click the down-arrow button and select “D:”

Click the “Next” button

The Format Partition dialog box will open

Set the File system to “NTFS”

Leave Allocation unit size at “Default” 

Enter “Segments” for the Volume label

Leave Perform a Quick Format and Enable file and folder compression boxes unchecked

Click the “Next” button

The Completing the Create Partition Wizard dialog will then appear

Click the “Finish” button to start the format process

The status of the Segments D: partition will be “Formatting: (xx%)” 

The format status percentage updating

Wait until the format operation is completed

The drive status will change to “Healthy” omplete

Close the Computer Management window.

Proceed onto Section 6.5.

 JMPS PICO  - CONFIGURE D AND E DRIVES    

Logon to the server into the administrator account.

Upon startup the Windows 2000 Configure Your Server window will open

Close this window for now

In the JMPS PICO Server configuration the server will contain:

Two hard drives that have been setup in a hardware RAID 1 configuration

Three drives configured in a RAID 5

The first partition C: was defined for the basic operating system space

Labeling and formatting operations must now be completed on second and third partitions

Select  Start->Programs->Administrative Tools->Computer Management

The Computer Management window will open

In the left-hand box double click on the “Disk Management” folder 

Write Signature and Upgrade Disk Wizard dialog box will appear

On the signature dialog click the “Next” button.

The Select Disk to Write Signature dialog will then open

Select Disk 1 by clicking the check box next to it and then click “Next”

The Select Disks to Upgrade dialog will then open

De-select Disk 1 and click the “Next” button

The Completing the Write Signature and Upgrade Disk Wizard dialog will open

Click the “Finish” button.

Change drive letter for CD Rom as follows:

Click on the CDRom 0 drive label box and then right-click

Select “Change Drive Letter and Path…” from the pop-up menu.

The Change Drive Letter and Paths for (D:) will appear

Click the “Edit” button

The Edit Drive Letter or Path dialog box will open

Assign the drive letter “G:” from the drop down list

Click the “OK” button to set it.

The Confirm dialog box will then open 
Click the “Yes” button to confirm

The drive letter for the CDRom0 will change to “G:” 

Reboot Server

Select Start (Shut Down(Restart

Click the “OK” button

The server will restart.

After the server restarts logon as the administrator 

Upon boot the Windows 2000 Configure Your Server window will appear

For now just close this dialog 

Select Start->Programs->Administrative Tools->Computer Management.

Click the “Cancel” button on the Write Signature and Upgrade Disk Wizard dialog box.

The Computer Management window will open

In the left-hand box double click on the “Disk Management” folder

Verify that the CDRom 0 drive label is now “G:”

On the Disk 0 display click on the C: partition and then right-click

From the pop-up menu select “Properties”

The Local Disk (C:) Properties dialog box will open

On the General TAB, in the Label box enter “System” and click the “OK” button

Display will show the name of the C: partition as “System”

Select and then right-click on the Unallocated space on Disk 0

Select “Create Partition” from the pop-up menu

The Create Partition Wizard dialog box will open with the Welcome to the

Create Partition Wizard message

Click the “Next” button

Select the “Primary partition” choice and click the “Next” button

The Specify Partition Size dialog will then appear

accept the total amount of disk space for the “Segment” partition

(For the JMPS PICO Server configuration the size of the D: partition will be approximately 1/2 of the RAID 1 area.) 

Click the “Next” button

Assign drive letter  “D:” from the drive letter list if it is not already the default choice

Click the “Next” button

The Format Partition dialog box will open

Set the File system to “NTFS”, leave the Allocation unit size at “Default” 

Enter “Segments” for the Volume label

Leave Perform a Quick Format and the Enable file and folder compression boxes unchecked

Click the “Next” button

The Completing the Create Partition Wizard dialog will then appear

Click the “Finish” button to start the format process

The status of the Segments D: partition will 

Drive status will change to “Healthy” when its is completed

Select and then right-click on the Unallocated space on Disk 1

Select “Create Partition” from the pop-up menu

The Create Partition Wizard dialog box will open with the Welcome to the

Create Partition Wizard message

Click the “Next” button.

Select the “Primary partition” choice and click the “Next” button

The Specify Partition Size dialog will then appear

Accept the total amount of disk space available on the RAID 5 disk for the “Data” partition

Click the “Next” button

The Assign Drive Letter or Path dialog will then open

Assign the  drive letter  “E:” from the drive letter list

Click the “Next” button

The Format Partition dialog box will open

Set the File system to “NTFS”

Leave the Allocation unit size at “Default”

nter “Data” for the Volume label

Leave Perform Quick Format and the Enable file and folder compression boxes unchecked

Click the “Next” button

The Completing the Create Partition Wizard dialog will then appear

Click the “Finish” button to start the format process

The status of the Data E: partition will be 

The drive status will change to “Healthy” when its is completed

Close the Computer Management window.

CREATE GHOST IMAGE CONTAINING WIN 2000 ADVANCED SERVER ONLY

Plug external Iomega Hard drive into power before inserting USB

Plug Iomega hard drive into USB port

Insert Ghost 2003 into CD Drive (Exit Ghost startup window if it comes up

Reboot Server to boot from Ghost CD in DOS mode

Start ( shutdown ( reboot ( OK

During end of boot up sequence – watch for following prompt

Attempting to boot from CD Rom

Press any key to boot from CD Rom
Press a key when prompted to boot from CD Rom

Boot options will display

Select option to boot with USB 1.1 drivers

At completion of DOS boot:

Iomega Quest driver version 8.5 should display

Drive letter should be listed as “D”

DOS prompt A:\>  should display

At  A:\>  prompt change drive letter to “C” as follows:

A:\> C:   ( hit return

C:\> should display

Change directory to “SUPPORT” by typing in as follows:

C:\> cd support   ( Hit return

C:\SUPPORT>    should display

Type in ghost to start Ghost image as follows:

C:\SUPPORT> ghost     ( hit return key
Select “local(partition(to image”

Select drive 1 ( OK ( part 1 and 2 ( OK

Select D:[GHOST] local drive in look in window

For Server Lite Double click on serverL folder to open ( will store server lite images in this folder) 

For PicoServer Double click on serverP folder to open ( will store pico server images in this folder)
Type in CDWINNAD in file name  ( C and D drive with NO Active directory) ( save

Select HIGH compression ( yes to proceed with image

When image complete ( exit Ghost ( ctrl-Alt-Del to reboot

Remove CD

INSTALL WIN 2000 SERVER   DRIVERS

INSTALL THE NC7131 GIGABIT SERVER ADAPTER DRIVER   

NOTE

ENSURE THAT THE NC7131 NIC IS CONNECTED TO THE NETWORK PRIOR TO EXECUTING THE PROCEDURES IN THIS SECTION.

Logon to the server into the administrator account

Close the Windows 2000 Configure Your Server dialog

Select Start->Programs->Administrative Tools->Computer Management

In the left-hand list double click on the “Device Manager”

List of devices will appear in right-hand side of Computer Management window

Under “Other devices” locate “Ethernet Controller” device 

Double click on it

(the device will have a yellow question mark on it at this point)

Ethernet Controller Properties dialog box will open

On the General TAB click  “Reinstall Driver” button

Upgrade Device Driver Wizard Welcome dialog box will appear

Click the “Next” button

Install Hardware Device Drivers dialog box will open

Accept the default “Search for a suitable driver for my device (recommended)”

Click the “Next” button

Locate Driver Files dialog box will open

Uncheck “Floppy disk drives” location

Check  “CD-ROM drives” search location 

Insert Compaq Network Server Adapters and Upgrade Modules CD into drive

Click the “Next” button

Driver Files Search Results dialog box will open

Search will be executed and NC7131 driver will be found on CD (g:\win2000\netcpqg.inf)

Message will be displayed on the dialog box:

“Windows found a driver that is a closer match for this device than your current

driver. To install the driver Windows found, click Next.”

Click the Next button to load the driver

Completing Upgrade Device Driver Wizard dialog will open with following:

“ Compaq NC7131 Gigabit Server Adapter

Window has finished installing the software for this device.”

Click the “Finish” button.

Ethernet Controller Properties dialog box title will update to “Compaq NC7131 Gigabit Server Adapter Properties” 

Device status will update to “This device is working properly.” 

Click the “Close” button on the properties dialog box

The Computer Management window will update

The “Other devices” list will no longer have the Ethernet Controller

In Computer Management double click Network adapters

Verify that the NC7131 now appears in the list as:

“Compaq NC3163 Fast Ethernet NIC

Compaq NC3163 Fast Ethernet NIC #2

Compaq NC7131 Gigabit Server Adapter”

Close the Computer Manager.

CONFIGURE THE NC7131 GIGABIT ADAPTER
Select Start-Settings->Network and Dial-up Connections

Network and Dial-up Connections dialog box will open

New Connection 3, will now be present ( NC7131 adapter)

Double click on this connection to access properties

Local Area Connection 3 Properties dialog will open with General TAB open

Click the “Properties” button and perform the following:
Check Client for Microsoft Networks component 

Double click on the Client for Microsoft Networks component 

Verify that the Name service provider is set to Windows Locator
Click the “OK” button

Uncheck Network Load Balancing component 
Networking Components list 

Check File and Printer Sharing for Microsoft Networks component 

Double click on File and Printer Sharing for Microsoft Networks component

Verify that the “Maximize data throughput for file sharing” choice is selected

Click the “OK” button

Check Network Monitor Driver component 
Check Internet Protocol (TCP/IP) component 

Double click Internet Protocol (TCP/IP) component - component properties opens

Click the “Use the following IP address” button

Proceed to enter the IP address, Subnet mask and Default gateway

Enter Preferred DNS server and the Alternate DNS server IP addresses 

Click the “OK” button

On Local Area Connection 3 Properties dialog box click  “OK” button.

The Local Network dialog box may open, with the message:

“You must shut down and restart your computer before the new settings will take

effect.

Do you want to restart your computer now?”

If the restart message does not appear restart server

Start->Shutdown(“Restart”(“OK” button 
The system will reboot

Leave “Compaq Network Server Adapters and Upgrade Modules CD” in drive

After reboot – login into administrator account

Open the Windows Explorer, Start->Programs->Accessories->Windows Explorer

In Explorer click on the System (C:) partition to select it

Select “File” (“New(Folder” from the drop-down menu 
Enter name “W2KNC7131 Driver” as folder new name  

Press “Enter”.

Browse to “Compaq Network Server Adapters and Upgrade Modules” CD-ROM

Double click on top level NCDE61(G:) folder to expand contents CD

Select “WIN2000” subfolder

Copy and paste “WIN2000” subfolder into newly created W2KNC7131 Driver folder

(This will place copy of the Compaq NC7131 Gigabit Server Adapter driver onto System C: partition for future)

Close the Explorer

LOAD FIBRE CHANNEL FCA-2101 ADAPTER DRIVER 

The FCA-2101 load procedures presented in this section will apply to all the JMPS server configurations since the fibre chanel cards are in all servers. In the case of the pico server the fibre channel cards will not be used at the present time however this section should be executed to load the driver for these cards so they are operational for possible future use.

AT THIS TIME DO NOT CONNECT FIBRE CHANNEL CARDS TO THE FIBRE SWITCHES OR TO THE CIPRICO NETARRAY 1100s.

FIBRE CHANNEL FCA-2101 ADAPTER #1
Logon to the server into administrator account

Close the Windows 2000 Configure Your Server dialog

Select Start->Programs->Accessories->Windows Explorer

In the left-hand box double click “My Computer” 

Double click on the System (C:) partition

Click on System (C:) to select it  ( highlight selection)

On the Explorer menu click “File”( “New”(“Folder”

Type in folder name label “FCA2101 Driver” 

Press “Enter”

If driver is on CD ,  where applicable insert CD and copy files to new folder
If driver files already unzipped -  skip steps to unzip

Insert the floppy disk containing Driver file “5-4.54A7.ZIP” 

In the Explorer click on the “3 1/2 Floppy (A:)” drive

Select the “5-4.54a7.zip” file  ( highlight selection)

Copy and paste the “5-4.54a7.zip” file into the new FCA2101 Driver folder

(The 5-4.54a7.zip file will be copied to the new FCA2101 Driver folder)

Remove the driver disk from the (A:) Floppy drive.

In C:\FCA2101 Driver folder double click on 5-4.54a7.zip file to unzip it

The WinZip 5-4.54a7.zip dialog box will appear

Click the "Extract” button

In the Folders/drivers box set the path to the FCA2101 Driver folder (C:\FCA2101 Driver).

Click the “Extract” button

When the extraction is completed, close the WinZip - 5-4.54a7.zip window.

Close the Windows Explorer.

Select Start->Programs->Administrative Tools->Computer Management.

In the left-hand list double click on the “Device Manager”

Device list will appear in right-hand side of the Computer Management window (If required, double click on the “Other devices” item to expand the list)

In presented list locate first “Fibre Channel Controller” device and double click on it

(the device will have a yellow question mark on it at this point)

The Fibre Channel Controller Properties dialog box will open

On the General TAB click “Reinstall Driver” button

Upgrade Device Driver Wizard Welcome dialog box will appear

Click the “Next” button

The Install Hardware Device Drivers dialog box will open

Accept the default “Search for a suitable driver for my device (recommended)” choice Click the “Next” button

Locate Driver Files dialog box will open

Uncheck “Floppy disk drives” and  “CD-ROM drives” search locations

Check “Specify a location” choice

Click the “Next” button

The Upgrade Device Driver Wizard dialog box will open

Click the “Browse” button

Set path to the FCA2101 Driver folder (C:\FCA2101 Driver)

Click the “Open” button

On Upgrade Device Driver Wizard dialog verify the path in the Copy 

manufacturer’s files from box has updated to “C:\FCA2101 Driver” 

Click the “OK” button

The Driver Files Search Results dialog box will open

A search will be executed and the FCA2101 driver will be found in the designated folder (C:\fca2101driver\oemsetup.inf)

A message will be displayed on the dialog box:

“Windows found a driver that is a closer match for this device than your current

driver. To install the driver Windows found, click Next.”

Click the Next button to load the driver.

Completing the Upgrade Device Driver Wizard dialog will open with the

following information:

“ Compaq KGPSA-xx, PCI-Fibre Channel HBA

Window has finished installing the software for this device.”

Click the “Finish” button.

Ethernet Controller Properties dialog title will update to “Compaq

KGPSA-xx, PCI-Fibre Channel HBA Properties”

Device status will update to “This device is working properly.”

Click the “Close” button on the properties dialog box

The Computer Management window will update

The “Other devices” list will no longer have the first Fibre Channel Controller

In Computer Management window double click on SCSI and RAID controllers Verify that Fibre Channel HBA now appears in the list

The list should look like:

“Compaq KGPSA-xx, PCI-Fibre Channel HBA

Compaq Smart Array 5i”

Close the Computer Management window.

Select Start->Shut Down(RestartOK

After reboot Windows 2000 Configure Your Server window will appear.

Close this dialog and proceed with Step 37.

FIBRE CHANNEL FCA-2101 ADAPTER #2
logon as administrator 

Wait for a few minutes while second FCA2101 is detected

The second driver is automatically is loaded

Some New Hardware Found dialog boxes may open and then close during this process

Select Start->Programs->Administrative Tools->Computer Management.

In the left-hand list double click on the “Device Manager”

Double click on the “Other devices” item to inspect the list

The Other devices” list will no longer have second Fibre Channel Controller 

On Computer Management window double click on SCSI and RAID controllers 

Verify that both Fibre Channel HBAs now appear in the list as follows:

“Compaq KGPSA-xx, PCI-Fibre Channel HBA

Compaq KGPSA-xx, PCI-Fibre Channel HBA

Compaq Smart Array 5i”

Close the Computer Management window.

Continue with Section 6.8.

 LOAD THE AIT 50 TAPE DRIVE DRIVER  

Logon to the server into the administrator account.

Insert CD labeled “Storage Works by Compaq Native Drivers” drive

If the Storage Works by Compaq window appears, close it

Select Start->Programs->Administrative Tools->Computer Management.

In the left-hand list double click on the “Device Manager”

Under “Other devices” item locate “Compaq SDX-500C SCSI Sequential Device” device 

Double click on it (the device will have a yellow question mark on it at this point).

The Compaq SDX-500C SCSI Sequential Device Properties dialog box will open

Click on Driver TAB to bring it forward.

Click the “Update Driver” button

Click the “Next” button.

Install Hardware Device Drivers dialog box will open

Accept the default “Search for a suitable driver for my device (recommended)” choice 

Click “Next” button.

Check “CD-ROM drives” search location uncheck other search locations

Click the “Next” button.

The Drivers Files Search Results dialog box will the appear with the message:

“The wizard found a driver for the following device:

COMPAQ SDX-500C SCSI Sequential Device

Windows found a driver that is a closer match for this device than your current

driver. To install the driver Windows found, click Next.

g:\drivers\standalonetapedrives\w2000\ait\caitw2i.inf”

Click the “Next” button.

Completing Upgrade Device Driver Wizard dialog will open with the following:

“Compaq AIT 50 GB Drive

Windows has finished installing the software for this device.”

Click the “Finish” button.

The Compaq SDX-500C SCSI Sequential Device Properties dialog box title

will update to “Compaq AIT 50 GB Drive Properties”

The device status will update to “This device is working properly.” 

Click the “Close” button 

The Computer Management window will update.

The “Other devices” list will no longer exist at this point 

In Computer Management window double click Tape drives device

Verify that the Compaq AIT 50 tape drive now appears in the list as follows:

“Compaq AIT 50 GB Drive”

Close the Computer Manager.

Open Windows Explorer, Start->Programs->Accessories->Windows Explorer

Click on the System (C:) partition to select it

On Explorer menu select (File(New(Folder”

Enter the new folder name “AIT50 Tape Driver” and press “Enter”

Browse to Compaq StorageWorks by Compaq Native Drivers CD

Double click on top level Native_Drvrs_1.2(G:) folder to expand contents of the CD. Select the “DRIVERS” subfolder

Copy and Paste the  DRIVERS” subfolder into the  newly created AIT50 Tape

Driver folder

(Will place copy of Compaq AIT 50 Tape driver onto System C: partition for future use

Close the Explorer.

Remove the Storage Works by Compaq Native Drivers CD from CD-ROM drive

CONFIGURE CIPRICO NETARRAY 1100 RAID     

NOTES
SKIPPED FOR THE PICO CONFIGURATION SINCE THIS CONFIGURATION DOES NOT CONTAIN A CIPRICO NETARRAY 1100 RAID ARRAY
Required for this step:    Ciprico Storage Manager 3.1 CD

JMPS ENTERPRISE LITE     

CONFIGURE CIPRICO NETARRAY 1100 RAID     

NOTES

ONLY CONNECT A SINGLE FIBRE CHANNEL CARD FROM THE ENTERPRISE LITE SERVER (TOP CARD) TO THE CONTROLLER A PORT ON THE CIPRICO NETARRAY 1100.

Steps below specify to connect the dual fibre channel cards located in the DL380 servers and the dual controllers on the netarray. However due to issues with path recognition the dual paths can not be connected at this time. 

When this issue is resolved these procedures will be updated to include the second data path to the ciprico netarray 1100 raid.

Shut Down server

(See “! NOTES !” above before executing this step)

On Compaq DL380 Server connect top Fibre Channel card on server to Controller A on the Ciprico NetArray 1100 RAID   (Use the LC to SC fiber cables)

Connect middle Fibre Channel card on server to Controller B on the Ciprico NetArray 1100 RAID. 

 (See “! NOTES !” above before executing this step) On the Ciprico NetArray

1100 Connect both Controllers (A&B) Fibre Channel ports to the Fibre Channel

switch (Silk Worm 3200) using SC to SC fiber cables for redundancy.

Power on the Silk Worm 3200 Fibre Channel Switch
Power NetArray 1100 on via switch on right rear and left rear of cabinet

(Dual power supplies).

Wait until NetArray 1100 drive LEDs are a steady Green

(Will blink Blue-Green during spin-up)

Power server back on

Logon to administrator’s account

Insert CD labeled Ciprico Storage Manager 3.1 into drive 

Installation should start automatically

If not follow these sub-steps:

Select Start->Run(Browse

Set path to CD-ROM (Double click on “windows” folder 

Select “StrMan31.exe” (Double click to set path in Run box

Click “OK” button to start the Office 2000 installer

Language dialog box will open

Click “OK” button to accept default “English” choice

Store_Manager31 dialog box will open with Introduction message

Click “Next” button 

The Important Information dialog will open

Click “Next” button 

The Choose Product Features dialog box will open

Select “Server & Client” choice

Click “Next” button

Choose Install Folder dialog will then open

Accept default installation location  “D:\Program Files\Ciprico” 

Click “Next” button

Choose Shortcut Folder dialog will open

Accept default new Program Group “Ciprico Storage Manager”

Click “Install” button.

The Install Complete dialog box will open

Click  “Done” button

Remove Ciprico Storage Manager 3.1 CD from drive

Open Windows Explorer, Start->Programs->Accessories->Windows(Explorer

Navigate to Ciprico folder “D:\Program Files\Ciprico”

Select “Ciprico” folder 

Double click on it to open it

In Ciprico folder click  file  “startServer.bat” to highlight 

Right-click on it

Select “Edit” from the pop-up menu

The “startServer.bat” file will open in the NotePad editor

Find the line in the .bat file that states “set ARGS=” 

Modify to “set ARGS= -TRACE -SECURITY”

(enables tracing and security options)

On the startServer.bat - Notepad menu click “File->Exit”.

Notepad dialog box will open with following message:

“The text in the C:\Program Files\Ciprico\startServer.bat file has changed.

Do you want to save the changes?”

Click “Yes” button to save changes

In Ciprico folder click file “StorageManager.bat” to highlight

Right-click on it

Select “Edit” from the popup menu

The “StorageManager.bat” file will open in the NotePad editor

Find line in the .bat file that states “set ARGS=” 

Modify to “set ARGS= -adv” 

(To enable client security options)

(This will turn on the login feature of the Storage Manager software so that array configuration permissions can be assigned to the designated personnel)

On the StorageManager.bat - Notepad menu click “File->Exit”.

Notepad dialog box will open with following message:

“The text in the C:\Program Files\Ciprico\StorageManager.bat file has changed.

Do you want to save the changes?”

Click “Yes” button to save changes

Close the Explorer.

On Desktop double click on “Ciprico Storage Manager Server” icon

(To start the server portion of the Storage Management software)

DOS window will open then minimize to the Start Bar with the “cipServer” title

On Desktop double click on “Ciprico Storage Manager” icon

(To start the client portion of the Storage Management software)

Storage Manager DOS window will open with  “- advanced options enabled - ”line

The Ciprico Storage Manager window will open with Ciprico Storage Manager intro splash screen.

On Ciprico Storage Manager menu select “File->Select Server”

Server Selection dialog box will open

In Enter Server Name box type in the name assigned to the JMPS server

(Use the DNS name, the basic name without the “.” extensions)

Click the “Okay” button when completed

On the Ciprico Storage Manager menu select “File->Search for Devices”

 “Searching” dialog will open

Ciprico Storage Manager will appear with System View TAB open

The server tree will be displayed in the lefthand part of the window

Connected NetArray(s) will be displayed in the righthand side

Click on “Security Setup” TAB located at the bottom right-hand side storage Manager window

Click the “Show Users” button

Check the logins – During previous installs , there were two admin logins after logging in 

If admin login already exits – skip login

On the menu bar select “File->Server Login”

The Server Login dialog will open

Enter “admin” for the Username

Leave the Password box empty

(these are the default settings to allow entry for the first time configuration)

Click “OK” button to log in

The padlock symbol on Ciprico Storage Manager menu bar should now be open

Click on “Security Setup” TAB located at the bottom right-hand side storage Manager window

Click the “Show Users” button

The user list will appear

(If the JMPS Enterprise configuration is being setup and the second

server is present on the network, two “Admin” users may be present)

(If the JMPS Enterprise Lite configuration is being setup then only a single “Admin” user will be

present in the list at this time)

DO WE NEET TO SET PASSWORD???????

In Username: box enter “Admin”

Leave the Old Password box blank 

Enter a selected password for the Admin account into the New Password and the Confirm New Password boxes

When finished click the “Change Password” button

Password successfully changed message will appear in Ciprico Storage Manager window

 (With the password on the local Admin account changed, its time to configure

the NetArray 1100) 

Click on the “System View” TAB to bring it forward

The connected NetArray 1100 should appear on the right-hand side of the window

Select NetArray 1100 and double click on it to open the NetArray RAID Array control dialog

MODIFY DEFAULT FACTORY SETTING

NOTE: ONLY NEEDED IF RECONFIGURING CIPRICO ARRAY

From the factory the Ciprico NetArray 1100 should be pre-configured into two Logical Units (LUNs). One should contain two 180GB hard drives in a RAID 1 configuration and the other should contain seven 180G hard drives in a 6 + 1 RAID 5 configuration, one of the drives will be a hot spare. The 10th drive in the NetArray will also be configured as a hot spare. The Controller View TAB display on the lefthand side of the NetArray RAID Array dialog box should reflect this configuration. It should show V0 and V1 disk groupings along with 2 hot spare drives. For the

Enterprise Lite configuration, with no clustering, the NetArray will be configured into a large RAID 5 storage area. The configuration of the NetArray will be wiped and rebuilt using the following sub-steps presented below.)

SKIP SECTION TO RECONFIGURE ARRAY

On NetArray RAID Array dialog , on Controller Details TAB, click “Clear Configuration” button

The Warning! Dialog box will appear with the following message:

“You are about to clear the configuration.

You may need to reboot the server system for changes to be visible.

Are you sure you want to continue?”

Click the “Yes” button

The system will pause for a few minutes, wait until the operation completes

Leave the default settings selected on the Controller Details TAB

On the NetArray RAID Array dialog click on the “Logical Unit Creation” TAB

The Create a Logical Unit dialog box will open

Controller View  on the NetArray RAID Array dialog box, will update

All the drives will now be yellow in color (yellow = drive is free).

In Available Drive box select Disk #1

Click the down-arrow button located in the center of the TAB

Te drive should then move to the Drives to be included box

NOTE

The JMPS pplication has a problem installing the data to a disk drive larger than 1TB.

Util this problem with the jmps application is solved the maximum disk size for the enterprise

lite raid will be limited to 895.9 gb (6 + 2) configuration. Only select drive ids 1 to 6 in step (g) below until further notice. Leave the extra drives free, define the 2 spare drives as shown in

step (m) below.

g) Repeat the procedure outlined in Step (f) for Disk #2, 3, 4, 5, and 6

All six of the disks should appear in the Drives to be included box

h) Once assigned, on Create Logical Unit dialog click down-arrow button on RAID Level box

Fom the RAID type list select “5”

i) Ensure that the Write Cache box is not checked.

j) The Physical Capacity for this RAID 5 (only 6 drives for now) LUN using 180

GB drives should be 1075.1973 GB

The Usable Capacity should be 895.9977 GB

Click the “Create” button to build this LUN

k) The Warning! dialog will appear with the message:

“After the Logical Unit is created, you may need to reboot the server system for it

to be visible.”

Click “OK” button to proceed 

(l) Build will take several minutes, when finished Controller View  will update.

Drives selected will be green in color (green = Drive is Member of Volume),will be part of new V0.)

m) On Controller View TAB click on Disk # 9 then right-click

. From the

pop-up menu select “Designate as a Spare Drive”. The process will take a minute

but then the drive color will change to light blue (light blue = Drive is a Spare).

n) Repeat Step (m) for Disk # 10.

o) Close the NetArray RAID Array dialog (File->Close).

p) On the Ciprico Storage Manager dialog select “File->Exit”. The Notice! Dialog

will open with the message:

You are about to exit Storage Manager.

Are you sure you wish to exit?

Click the “Yes” button.

q) Select Start->Shut Down.

r) In the Shut Down Windows dialog select “Restart” from the drop down box.

Click the “OK” button. Allow the server to restart.

Step 46. Logon to the server into the administrator account.

Step 47. Select Start->Programs->Administrative Tools->Computer Management.

Step 48. The Computer Management dialog box will open, in the left-hand side of the

dialog click on the “Disk Management” folder.

Step 49. The Write Signature and Upgrade Disk Wizard dialog will open because of

the newly added NetArray 1100 RAID drive. Press the “Next” button.

Step 50. The Select Disk to Write Signature dialog will then open. Select all the disks

presented in the list and click the “Next” button.

Step 51. The Select Disks to Upgrade dialog will then open, uncheck the disks and

click the “Next” button (do not want to upgrade the disks to Dynamic Disks, leave

them as Basic so that primary partitions can be created on them).

Step 52. The Completing the Write Signature and Upgrade Disk Wizard dialog box

will appear, click the “Finish” button.

Step 53. In the right-hand pane of the Computer Management window the volume

information will appear for the NetArray drives connected to the system. Click on the

Unallocated space for Disk 1 and then right-click. Select “Create Partition” from the

pop-up menu.

Step 54. The Create Partition Wizard dialog box will open with the Welcome to the

Create Partition Wizard message. Click the “Next” button.

Step 55. The Select Partition Type dialog will then appear, select the “Primary

partition” choice and click the “Next” button.

Step 56. The Specify Partition Size dialog will then appear, accept the total amount of

disk space for the partition. Click the “Next” button.

Step 57. The Assign Drive Letter or Path dialog will then open. On the Assign a drive

letter line click the down-arrow button and select “E:” from the drive letter list

presented. Click the “Next” button.

Step 58. The Format Partition dialog box will open. Set the File system to “NTFS”,

leave the Allocation unit size at “Default” and enter “Data” for the Volume label.

Leave the Perform a Quick Format and the Enable file and folder compression boxes

unchecked. Click the “Next” button.

Step 59. The Completing the Create Partition Wizard dialog will open, click the

“Finish” button. (Note: the RAID 5 - 8+1 NTFS format on the Ciprico NetArray 1100

will take several hours to format (approximately **TBD** hours).

Step 60. Wait until the format operation is completed, the drive status will change to

“Healthy” when its is completed.

Step 61. Close the Computer Management window.

Step 62. Select Start->Programs->Administrative Tools->Computer Management.

Step 63. On the left-hand side of the Computer Management dialog box double click

on “Disk Management”. The right-hand side of the dialog box should update to show

the Disk configuration. Verify that the System C:, the Segments D, Data E: (main

RAID 5 storage on the NetArray) are all available and healthy. The display should

look like Figure X.X below (to be added later…)

Step 64. Close the Computer Management dialog.

*************************************************

SKIP THIS PROCEDURE FOR ALL JMPS SERVER

CONFIGURATIONS UNTIL FURTHER NOTICE, PENDING

RESULTS OF VERITAS DRIVER ISSUES.

*************************************************

Procedure: Installation of Veritas Volume Manager 3.0

NOTES

THIS PROCEDURE CAN BE SKIPPED IF LOADING

THE JMPS PICO SERVER CONFIGURATION,

SINCE THIS CONFIGURATION WILL NOT

REQUIRE THE VERITAS VOLUME MANAGER

SOFTWARE TO BE LOADED.

JMPS Enterprise First Server

Step 1. In the JMPS Enterprise configuration logon to the primary server into the

administrator account.

Step 2. Place the Volume Manager 3.0 for Windows 2000 CD into the CD-ROM drive.

Step 3. The Veritas Volume Manager installation should start automatically, the Veritas

Volume Manager 3.0 - Install Wizard window will open. If the installation program

does not start automatically follow the sub-steps shown below.

a) Select Start->Run.

b) On the Run dialog box click the “Browse” button.

c) On the Browse dialog box that appears set the path to the CD-ROM drive and

then to the location of the setup file for the Veritas Cluster Server installation

package (VM_3.0_Windows_(G:).

d) On the Browse dialog box click the down arrow key for the Files of Type box,

select “All Files” from the presented list.

e) Back in the main Browse folder double click on the “Setup.msi” file to set the

path to it in the Run dialog box.

f) On the Run dialog box click the “OK” button to begin the installation of the

Veritas Volume Manager.

Step 4. A Question dialog box will appear over the Veritas Volume Manager 3.0 - Install

Wizard window. The question dialog will display the following question

“VERITAS Enterprise Administrator will be installed prior to installing VERITAS

Volume Manager 3.0. Click YES to continue”

Click the “YES” button to proceed with the installation of the Veritas Enterprise

Administrator.

Step 5. The next dialog to appear will be the Welcome to the InstallShiled Wizard for

Veritas Volume Manager 3.0. Click the “Next” button on this welcome dialog to

continue.

Step 6. The Setup type dialog box will then open, select the “Server” choice and then

click the “Next” button.

Step 7. The Customer Information dialog will then appear, the User and Organization

information should be filled in already, in the License Key box enter the Volume

Manager license key that was shipped with the server and click the “Next” button

when finished.

Step 8. The Custom Setup dialog box will then open. By default all the licensed

components will be selected for installation. Click on the Drive Symbol next to the

Volume Manager 3.0 MSCS Support option. On the drop down menu that appears

select the “This feature will not be available” option. A red “X” should appear on this

option on the the Custom Setup screen. Click the “Next” button.

Step 9. Click on the Drive Symbol next to the Volume Manager 3.0 VCS Support option.

VCS will be installed later in the procedure. On the drop down menu that appears

select the “This feature will not be available” option. A red “X” should appear on this

option on the the Custom Setup screen. When finished, click the “Next” button.

Step 10. The Warning dialog box will open with the message:

“DMP support is being installed with an excluded option. You will need to install

DMP with only one path. Attaching a second path before including the array could

result in data loss.”

Click the “OK” button to acknowledge this warning.

Step 11. The Ready to Install the Program dialog box will open. Click the “Install”

button.

Step 12. The Welcome to the Online Registration Wizard dialog box will then open.

Click the “Register later” button on the dialog and then the “Next” button to continue.

Step 13. The InstallShield Wizard Completed dialog box will then open. Click the

“Finish” button.

Step 14. The VERITAS Volume Manager 3.0 Installer Information dialog will open

with the message:

“You must restart your system for the configuration chnages made to Veritas Volume

Manager 3.0 to take effect. Click Yes to restart now or No if you plan to restart

later.”

INSTALLATION OF SQL 2000 AND SERVICE PACK 3 FOR SQL

REQUIRED:  

SQL Server 2000 Enterprise Edition installation CD
SQL Service pack 3 for 
NOTE:

Logon to the server into the administrator account.

Place the SQL Server 2000 Enterprise Edition installation CD Rom.

Select Start(Run (Browse (Set path to CD-ROM drive(Autorun.exe(Double click OK

The Microsoft SQL Server 2000 Enterprise Edition screen will appear

Click “SQL Server 2000 Components 

The SQL Server 2000 Enterprise Edition 

Install Components screen will then appear

Click on the “Install Database Server” choice.

The Enterprise Edition - Microsoft SQL Server 2000 screen along with the

Welcome dialog box will open

Click the “Next” button.

The Computer Name dialog box will then appear with the following message:

“Enter the name of the computer on which you want to create a new instance of SQL

Server or modify an existing instance of SQL Server”

Accept the default “Local Computer” choice

Click the “Next” button

Installation Selection - Select one of the following installation options dialog will appear. 

Accept the default “Create a new instance of SQL Server, or install Client Tools ”

Click “Next” button.

The User Information dialog box will then appear

Click the “Next” button

The Software License Agreement dialog box will then appear

Click the “Yes” button to accept the license

The CD-Key dialog box will then open (Enter key 

Click the “Next” button.

The Installation Definition dialog box will then open

Accept the default “Server and Client Tools” choice

Click the “Next” button

The Instance Name dialog box will then appear

Deselect “Default” instance name 

Enter new instance name ( JMPS_SQL_SERVER

Click the “Next” button

The Setup Type dialog box will then open

Select the “Typical” installation type

Accept the default location of the Program Files in “C:\Program Files\Microsoft SQL Server”

Click the Browse button next to the Data Files

Choose Folder dialog box will open 

set path for SQL Data to “D:\Program File\Microsoft SQL Server”

Click the “OK” button

The Setup Type dialog box should update to the new path

Click the “Next” button to proceed.

The Service Accounts dialog box will open

Accept the default “Use the same account for each service Auto start SQL Server Service 

In the Service Setting box accept the default “Use a Domain User Account” choice

Enter password for administrator account and verify the Domain is correct

Click the “Next” button.

The Authentication Mode dialog box will then open

Accept the default “Windows Authentication Mode” choice

Click the “Next” button

The Start Copying Files dialog box will then appear

Click the “Next” button.

The Choose Licensing Mode dialog will open next

Select the “Per Seat for” choice and set the devices number to the number of licenses that were shipped with the server for the specific site

Click the “Continue” button.

Setup will start to copy files, several setup dialogs will open then close and

then the copying files status bar will open with the installation progress.

The Shutting Down Tasks dialog box may appear with the message:

“Setup has detected that the following tasks are using files that setup needs to install.

In order to avoid rebooting the machine at the end of setup, it is recommended that

you shutdown the following tasks.

TASK

Nspm.exe

Svchost.exe”

Click the “Next” button if this dialog does appear

A restart will be executed after the service pack  is installed  !!!  check this

System will now reboot












!!!   check this

The Installing the Software dialog box will then open

Click the “Finish” 

The Setup Complete dialog box will then appear

Accept the default “Yes, I want to restart my computer now.” Choice

Click the “Finish” button

The system will then restart

Remove the SQL Server 2000 CD from the CD-ROM drive.

After system boots up

Login as administrator account

Verify SQL Server is running by checking for server symbol Start Menu Bar

The server symbol should have a green arrow indicating that it is running.

Place the CD containing the SQL Server 2000 Service Pack 3 into the CDROM 

Select Start->Run ( Browse ( 

On the Browse dialog box that appears set the path to the CD-ROM drive ( “SQL2KSP3.EXE” Select the file and double click on it 

On the Browse dialog box click the “OK” button.

The Installation Folder dialog box will open

The path to the Installation Folder will be “C:\sql2ksp3”

Accept this default location and click the “Finish” button

The PackageForTheWeb dialog will open with the following message:

“The specified output folder does not exist. Create it?”

Click “Yes” to create folder and to unpack the SQL patch.

The Reading Package…dialog box will open, then the Unpacking dialogs will

appear and close

The PackageForTheWeb dialog will then re-appear with message:

“The package has been delivered successfully.”

Click the “OK” button.

Select Start->Run ( Browse (Set path to “C:\sql2ksp3” folder

In the “sql2ksp3” folder select the “setup.bat” file

Double-click on it to set the path 

Click the “OK” button to start the SQL patch installation

A Warning dialog box may then open with the following warning:

“If you have not rebooted since installing SQL Server 2000, please do so at this time.”

Click the “Next” button if this dialog should appear

(Since the server was restarted after the SQL Server was installed) 

The Service Pack 3 screen will open with the Welcome dialog box

Click the “Next” button

The Software License Agreement dialog box will then open

Click the “Yes” button to accept the license

The Instance Name dialog box will then appear

Click the “Next” button to apply the service patch to the default instance of SQL Server 2000

Accept the default “The Windows account information I use to log on to my computer with …  

Click the “Next” button

The SA Password Warning dialog box will appear with the following message:

“Service pack setup has detected that your SA password is set to blank. It is highly

recommended that you set a strong password and secure your database server, even

if you are using Windows authentication.”

Enter SA password into the Enter SA Password and Confirm SA Password boxes,

Click “OK” button 

The SQL Server 2000 Service Pack 3 Setup Backward Compatibility Checklist dialog will open. Click the “Upgrade Microsoft Search and apply SQL 2000 SP3 (required)” selection

Click the “Continue” button

The Error Reporting dialog will then open

Click the “OK” button to continue

Do not select the automatic error notification feature.

The Start Copying Files dialog box will then appear

Click the “Next” button

The Shutting Down Tasks dialog box may appear with the message:

“Setup has detected that the following tasks are using files that setup needs to install.

In order to avoid rebooting the machine at the end of setup, it is recommended that

you shutdown the following tasks.

TASK

Nspm.exe

Snmp.exe

Svchost.exe”

Click the “Next” button if this dialog does appear

A restart will be executed after the Service Pack is applied

The Installing the Software dialog box will then appear

Click the “Finish” button

When the installation completes the Setup dialog box will open with the following message:

“You should now backup your master and msdb databases since this installation has

updated their content.”

Click the “OK” button.

The Setup Complete dialog box will then appear

Accept the “Yes, I want to restart my computer now.” 

Click the “Finish” button

The system will restart.

Remove the CD containing the SQL Server 2000 Service Pack 3.

LOAD VERITAS BACKUP EXEC 9.0 FOR WINDOWS SERVERS

This section requires:

Veritas Backup Exec 9.0 for Windows Servers CD

Veritas 9.0.4367 Patch 7 Floppy

Logon in as administrator

Insert Veritas Backup Exec 9.0 for Windows Servers CD drive

Perform following steps If the Veritas Backup Exec screen does not appear

Select Start (Run ( Browse.exe ( set path to CD-ROM drive 

Set path to  the Veritas “Browser.exe” file 

Double click Browse.exe file to set name in dialog box

Click the “OK” button.

The Veritas Backup Exec(TM) 9.0 for Windows Servers screen will appear.

Click the “Backup Exec Installation” selection – wait for start

The Pre-Installation Information checklist will appear

Click the “Start Backup Exec Installation” choice – wait for start

The Windows Installer dialog will open then close

The Veritas Welcome dialog box will then open

Click the “Next” button

The License Agreement dialog box will then open

Click “I accept the terms of the license agreement” button

Click “Next”

Veritas Backup Exec for Windows Servers Install Menu dialog will open

Leave default “Local Install - Install Backup Exec software and options” selected

Click the “Next” button

The Use Local SQL with Backup Exec dialog will open

Accept default “Create the default Backup Exec MSDE instance: JMPS_SQL_SERVER

Click the “Next” button

The Veritas Backup Exec Serial Numbers dialog box will then open

Enter the Product Activation keys for the following:

Backup Exec License Product Activation Number

Click “Add” button

Activation number should appear in the “Existing Serial Number” box

Backup Exec INTELLIGENT DISASTER RECOVERY OPTION License Product No. 

Click “Add” button

Activation number should appear in “Existing Serial Number” box

Backup Exec SQL SVR AGENT W/CLIENT ACCESS Number

Click the “Add” button

Activation number should appear in “Existing Serial Number” box

Backup Exec REMOTE AGENT (CAL) FOR WIN SVRS 1 PACK Number 

Click the “Add” button

Activation number should appear in “Existing Serial Number” box

Once the product serial numbers have been entered, click the “Next” button.

The Veritas Backup Exec Local Features review dialog box will then open

Review the options selected

Click the “Next” button

The Veritas Backup Exec Services dialog box will then appear

Enter Administrator password in Password box

Click the “Next” button

Veritas Backup Exec(TM) 9.0 for Windows Servers dialog will open with message:

“The account JMPS\Administrator has been granted the following rights: Create

a token object”.

Click the “OK” button.

The Veritas Tape Device Drivers dialog will then open

Accept the default: “Use Veritas device drivers for all tape devices (recommended)” selection

click “Next” button

The Ready to Install the Program dialog box will open

Click  “Install” button.

Installing Veritas Backup Exec for Windows Servers dialog will open as software loads

Veritas Volume Software License Program dialog box will then open with message:

“Thank you for purchasing Veritas Backup Exec for Windows NT using our flexible

volume software license program.

We hope you find that using this program makes it easier for you to acquire and

deploy Veritas Software Corporation products.”

Click the “OK” button.

The Veritas installation will then proceed

When finished Veritas Install Wizard Completed dialog box will open

Uncheck all options except “Create desktop short” and “Restart System”

Click “Finish” button

Remove Veritas Backup Exec v9.0 CD 

The server will restart.

Login as administrator

Insert the Floppy Disk or CD that contains the Veritas 9.0.4367 Patch 7

Start->Run (Browse (Set path to Floppy Disk drive

Open folder Veritas Exec patch 7

Double click on “be4367RHF7_255407.exe” file to set path

Click the “OK” button on the Run dialog box

Veritas Self-Extractor dialog box will open

Click on the “…” button – ( next to extract path)

Set the extract location to the TEMP folder (System C:\WINNT\Temp)

Click the “OK” button

The Extract to: box on the dialog should update to “C:\WINNT\Temp”

Click the “Extract” button

The “Finished” dialog will open

Click the “OK” button

The Notepad Editor will open automatically with the “readme” file

Review the patch application process and then close this file

Patch will be applied using following steps:

Open the Windows Explorer, Start->Programs->Accessories->Windows Explorer

Browse to C:\Program Files\Veritas\BackupExec\NT\Agents\RANT32 directory

Once in the RANT32 folder, right click  “setup.exe” to highlite

Select rename from window

Once the name is highlighted in blue, change it to “SETUP.HF7”

(It may be necessary to change the folder view options to see the file extensions)

Press “Enter” 

The Rename warning dialog box will appear. Click the “Yes” button.

The Confirm File Rename dialog will open. Click the “Yes” button.

In the Explorer browse to the C:\WINNT\Temp folder.

Right click new Veritas “Setup.exe” file and select “Copy” 

In Explorer browse back to C:\Program Files\Veritas\BackupExec\NT\Agents\RANT32 dir

Once in the directory, right click and select “Paste” from the presented menu.

Close the Explorer.

Double click on Veritas Backup Exec desktop icon to start Veritas Backup software for first time

Welcome to First Time Startup Wizard dialog box will open

Click the “Next” button

The Media Management with Media Sets dialog will open

Click the “Next” button

The Default Media Set Properties dialog box will open

Accept default choice “Yes, I want to edit this set or create new media sets that will allow Backup Exec to automatically recycle some media for my backups.”

Click the “Next” button

The Welcome to the Media Set Wizard dialog box will open

Click the “Next” 

The Create or Edit a Media Set dialog will open

Leave default “Create a new media set” choice selected

Click the “Next” button

The Name the Media Set dialog box will open

Enter in “Daily Incremental” for the media set

Click the “Next” button

The Set the Overwrite Protection Period dialog box will open

Click on the down arrow button and select “Days”, and the default value of “1”

Click the “Next” button.

The Set Append Period dialog will open

Click on the down arrow button and select “Days”, and the default value of “1”

Click the “Next” button

The Media Set Summary dialog will open. Verify the choices set

Click the “Next” button

The Completing the Media Set Wizard dialog will open

At this time additional Media Sets could be defined by clicking the “Add or edit another media set after clicking Finish” box

Click the “Finish” box

The Preferred Overwrite Media Type dialog box will open

Leave default choice of “Overwrite scratch media before overwriting recyclable media…”  

Click the “Next” button.

The Overwrite Protection Level dialog box will open

Accept the default“Partial” selection

Click the “Finish” button.

The Welcome to the Device Configuration Wizard dialog will open

Click the “Next” button

The Detected Hardware dialog box will then open

The “COMPAQ 1 (Port: 2, Bus: 0, Target ID: 5, Lun:0) should appear in Backup device(s) list Click the “Next” button

The Detected Backup-to-Disk Folders dialog will open

No Backup-to Disk Folders are defined at this point for JMPS

Click the “Next” button

The Drive Configuration dialog box will open

The COMPAQ 1 drive should be listed under the “Stand-alone Drives”

Click the “Next” button

The Completing the Device Configuration Wizard dialog will then open

Click the “Finish” button

The Configure Intelligent Disaster Recovery options dialog box will open

Click the “Next” button

The Enter an Alternate Data Path dialog will open

Since the  D: drive E: drive on the different JMPS server suites is a physically different drive from the mirrored boot disk set, it will be selected as the target location for the disaster recovery file

Set the path to “D:\Veritas\Backup Exec\IDR\Data\” 

(we will use the D drive until we can Ghost the E Netarray drive)

Click the “Next” button

The Bootable tape device detected dialog will open

Leave the “Yes, create the image now (recommended)” choice selected

Click the “Next” button

The Starting Tape Image Creation dialog box will open

Leave “Let IDR automatically partition the boot and system drive (Windows 2000 only)” selected Click the “Next” button

The Insert Windows operating system Installation Media dialog box will open

Insert the Windows 2000 Advanced Server CD in to the CD-ROM drive 

Click the “Next” button

If Microsoft Windows 2000 Advanced Server installation auto-starts click “Exit” button

The Intelligent Disaster Recovery Preparation Wizard window will open

“Enter the Windows Product Key dialog” should open

Enter Win 2000 Server key and click the “Next” button

The Creating Disaster Recovery Image dialog will open

The status of the bootable image will be shown

When complete – “Done’ will display on bottom of window

“Bootable image is created” will display on top     !!!check this

When done, click the “Next” button

(This utility will need to be run periodically to update the recovery information. The image has been

created but will not be written until a full backup of the computer being protected is

ran.)

Click the “Finish” button.

The Welcome to the Logon Account Wizard dialog will open

Click the “Next” button.

The Setup Your Default Logon Account dialog box will open

Select the “Select an existing logon account” choice and then click the “Next” button.

The Select a Logon Account dialog box will open

Accept the default “System Logon Account (JMPS\Administrator)” account

Click the “Next” button.

The Completing the Logon Account Wizard dialog box will open

Click the “Finish” button

Exit Veritas Window

GHOST IMAGE WITH WIN 2000 ADVANCED SERVER APPS AND DRIVERS

Plug external Iomega Hard drive into power before inserting USB

Plug Iomega hard drive into USB port

Insert Ghost 2003 into CD Drive (Exit Ghost startup window if it comes up

Reboot Server to boot from Ghost CD in DOS mode

Start ( shutdown ( reboot ( OK

During end of boot up sequence – watch for following prompt

Attempting to boot from CD Rom

Press any key to boot from CD Rom
Press a key when prompted to boot from CD Rom

Boot options will display

Select option to boot with USB 1.1 drivers

At completion of DOS boot:

Iomega Quest driver version 8.5 should display

Drive letter should be listed as “D”

DOS prompt A:\>  should display

At  A:\>  prompt change drive letter to “C” as follows:

A:\> C:   ( hit return

C:\> should display

Change directory to “SUPPORT” by typing in as follows:

C:\> cd support   ( Hit return

C:\SUPPORT>    should display

Type in ghost to start Ghost image as follows:

C:\SUPPORT> ghost     ( hit return key
Select “local(partition(to image”

Select drive 1 ( OK ( part 1 and 2 ( OK

Select D:[GHOST] local drive in look in window

Double click serverL folder to open for Server Lite

Double click serverP folder to open for PicoServer 

Type in CDWINDR in file name  ( save

( This will ghost C and D drive with Active Directory before COE applied)

Select HIGH compression ( yes to proceed with image

When image complete ( exit Ghost ( ctrl-Alt-Del to reboot

Remove CD

INSTALLATION OF WINDOWS 2000 ADMINISTRATION TOOLS

COPY I386 FOLDER AND INSTALL ADMINISTRATOR PACK AND 2000

RESOURCE KIT  6.7 PROCEDURE:
Logon to the server into the administrator account

Close the Windows 2000 Configure Your Server dialog

Place Windows 2000 Advanced Server CD into drive

If Auto-Start Microsoft Windows Server Install screen appears click Exit button

Start Windows Explorer, Start->Programs->Accessories->Windows Explorer

Browse to CD-ROM - Windows 2000 Advanced Server CD

Double click on CD to expand subfolders

Select the “I386” subfolder on CD and right click on it

Copy and Paste I386 subfolder in System C: partition

.This will place copy of I386 folder on system partition

When copy complete Browse to I386 folder on  System C: partition

Select it - double click to open 

In main I386 folder locate “ADMINPAK.MSI” installer package

Double click it to begin installation of the Windows 2000 Administration Tools

Windows 2000 Admin Tools Setup Wizard dialog will open

Welcome to Windows 2000 Admin Tools Setup Wizard dialog will display

Click “Next” button to begin installation

If Win 2000 Admin Tools Setup Wizard - Setup Options dialog appears

Select the “Install all of the Administrative Tools” choice

Click “Next” button

(If prompt does not appear full suite of admin tools will automatically be installed

When installation completes following will display:

“Completing the Windows 2000 Administration Tools Setup Wizard - You have successfully installed the Windows 2000 Administration Tools”  

Click “Finish” button.

INSTALL WINDOWS 2000 SUPPORT TOOLS 
Browse back out to the Windows 2000 Advanced Server CD

Browse to Tools subfolder on the CD (SUPPORT\TOOLS).

Double click on “2000RKST.MSI” installer package

( This will begin installation of the Windows 2000 Resource Kit)

Windows 2000 Support Tools Setup Wizard Welcome dialog will open

Click “Next” button.

User Information dialog will open , it will be filled in with 

information that was entered during Windows 2000 Advanced Server software

install

Click “Next” button to continue.

Select An Installation Type dialog box will open

Leave default “Typical” choice selected

Click “Next” button

Begin Installation dialog box will open

Click “Next” button to begin the installation of the support tools

Completing  Support Tools Setup Wizard will open when install completes

Click the “Finish” button.
Close the Windows Explorer.

Remove Windows 2000 Advanced Server CD from  drive.

INSTALL MICROSOFT WINDOWS 2000 RESOURCE KIT  

Note

The Microsoft windows 2000 resource kit should be included with the JMPS

server. This kit contains the full documentation library and the CD containing the resource kit.

Logon to server as administrator 

Place Microsoft Windows 2000 Server Resource Kit CD into drive

Microsoft Windows 2000 Server Resource Kit install should start automatically Microsoft Windows 2000 Resource Kit CD-ROM window should Open

If not follow sub-steps below

a) Select Start->Run.

b)  “Browse” button.

c) Set path to CD drive location of setup file for the Resource Kit (RESKIT2000 (G:)

d) In main folder double click on “Setup.exe” file to set the path in Run dialog box

e) On Run dialog box click “OK” to begin install

On Microsoft Win2K Server Resource Kit CD-ROM window, click the

“Install Resource Kit” button.

Welcome to Microsoft Win 2000 Resource Kit Setup Wizard will open

Click “Next” button.

End User License Agreement dialog box will appear

Click “I Agree” button

Click “Next” button to accept license

 (User Information dialog will open, it will be filled in with information that was entered during the Windows 2000 Advanced Server software install

Click “Next” button to continue

Select An Installation Type dialog box will open

Leave default “Typical” selected 

Click “Next” button.

Begin Installation dialog box will open

Click “Next” button to begin installation of  Resource Kit

Progress box will appear to show the status of install 

Wait until install completes

 (Completing Microsoft Windows 2000 Resource Kit Setup Wizard dialog box will open when install completes)

Click “Finish” button.

Click “<Exit>” button on Microsoft Win 2000 Resource Kit CD window 

Remove Win2K Server Resource Kit CD from drive

ACTIVE DIRECTORY (AD)/DOMAIN NAME SERVER CONFIGURATION 

JMPS ENTERPRISE LITE    JMPS PICO 

NOTES

JMPS ENTERPRISE LITE  and PICO CONFIGURATION VERIFY THAT THE TWO ON-BOARD 10/100 NICS AND THE GIGABYTE NIC ARE CONNECTED TO NETWORK 

(DNS)

JMPS ENTERPRISE/ JMPS ENTERPRISE LITE/ PICO SERVER  
Select Start->Shut Down 

Select “Restart” ( “OK” button

Logon as administrator 

Start(Settings(Control panel( Administrative Tools 

Double click on  Configure your server

Windows 2000 Configure Your Server windows will appear

On left hand side of window click “Active Directory” selection

Click on “Start the Active Directory wizard” button  - bottom

Welcome to the Active Directory Installation Wizard dialog will appear

Click “Next” button to continue

Domain Controller Type dialog box will open

Select “Domain controller for a new domain” option

Click “Next” button

Create Tree or Child Domain dialog box will open

Select “Create a new domain tree” 

Click “Next” button

Create or Join a Forest dialog box will open

Select default “Create a new forest of domain trees” as default setup

Click “Next” button

New Domain Name dialog will appear requesting domain 
Enter domain name as “JMPS.smil.mil” in Full DNS name for new domain box

(The Internet registered domain name is assumed to be “smil.mil”)

Click “Next” button

(This may take a few minutes - wait for the process to complete)

NetBIOS Domain Name dialog will open

(Domain NetBIOS name by default will be first part of domain name  “JMPS”)

Click “Next” button to accept NetBIOS name

Database and Log Locations dialog box will open

Click Next button to accept default location C:\WINNT\NTDS for Active Directory database

Click next to accept default location C:\WINNT\NTDS for Active Directory log

The Share System Volume dialog box will open

Cick “Next” button to accept default location (C:\WINNT\SYSVOL) 

(May take a few minutes wait for the process to complete)

Active Directory Installation Wizard Warning dialog box will appear :

“The wizard cannot contact the DNS server that handles the name “JMPS.smil.mil”

to determine if it supports dynamic update. Confirm your DNS configuration, or

install and configure a DNS server on this computer.

(Unless JMPS system is not on isolated network)

Click OK” button to acknowledge

Configure DNS dialog box will then open

Select “No, I will install and configure DNS myself” option

Click “Next” button.

The Permissions dialog box will then appear

Select “Permissions compatible only with Windows 2000 servers” 

Click “Next” button

Directory Services Restore Mode Administrator Password dialog will open

Enter admin password into both Password and Confirm password boxes

Press “Next” when finished

Summary dialog will then open

Review choices made 

Press “Next” button to install Active Directory

(Several Windows Component Wizard and Active Directory dialog boxes will

open and close as the configuration proceeds)

Wait until all these processes complete

Completing the Active Directory Installation Wizard dialog will appear

Click “Finish” button

The Active Directory Installation Wizard dialog box will open with the

following message:

“Windows must be restarted before the changes made by the Active Directory

Installation wizard take effect.”

Click “Restart Now” button

Server will restart

Logon as administrator ( will now be logged into Domain account)

When server restarts it is likely that a “Service Control Manger” error dialog box will appear

If this event occurs, restart the server a second time. During initial testing its

was noted that not all the services may start upon the first boot with Active Directory

installed, a second restart appeared to solve these issues.
Windows 2000 Configure Your Server dialog box will open

Uncheck “Show this screen at startup” check box to disable screen ( close screen

On the Start Menu Bar click Start->Settings->Control Panel.

Double click on the “Add/Remove Programs” icon

Click on “Add/Remove Windows Components” button

The Windows Components Wizard dialog box will open

Select “Networking Services” component

Double click on it to open subcomponents.

Networking Services Subcomponents of Networking Service dialog box will open

Uncheck “Dynamic Host Configuration Protocol (DHCP)” component 

Click the “OK” button

(During the JMPS server operating system configuration this was not selected however this step is taken to ensure that DHCP was not installed by the Active Directory service setup. Since JMPS will run on classified networks, it is highly recommended that DHCP be removed or deactivated. It was decided that removing the component was the best solution to prevent the DHCP service from ever servicing clients on the network).

Select Message Queuing Service component on Windows Components dialog box

Click “Next” button.

Accept default “Message Queuing server” selection 

Check the “Enable routing” check box

Click “Next” button.

The Windows NT 4.0 Message Queuing Clients dialog box will then open

Accept default “No, do not change the permissions” choice

Click “Next” button

Configuring Component dialog box will open

Files Needed dialog box will open

In the Copy files from box enter the path to the I386 folder (C:\I386) 

Click the “OK” button 

(Configuring Components dialog box will begin to update, it may take

several minutes for the process to complete)

When completed the Completing the Windows Components Wizard dialog box will open

Click “Finish” button

Close the Add/Remove window

Click the “Close” button

Close the Control Panel window

Select Start->Shut Down( Restart ( “OK” button (Allow server to restart

Logon as administrator 

Select Start->Settings->Network and Dial-up Connections

Right Click on the “Local Area Connection 3” connection

On Local Area Connection 3 Status box click the “Properties” button

Right click on “Internet Protocol (TCP/IP)” component

The Internet Protocol (TCP/IP) Properties dialog box will open

Verify that the address is correct

(During the design of the JMPS server it was noted that if the DHCP service was removed the IP address for the Gigabyte NIC changed to 10.10.1.1. If the address has changed repeat Steps 15 and 16 in Section 6.6 to correct this condition

If IP address correct

Close all windows

CONFIGURE DNS SERVER HERE 

Logon as system administrator
Add DNS Services through “ADD/Remove” windows components

Start(Settings(Control Panel(Add Remove Programs

Select Add/Remove Windows Components

Wait for window to display ( will appear on taskbar sometimes)

Double click on  Networking Services ( details

Click to select (Domain Name System) DNS

Click OK ( Next to install ( wait for install to begin

Browse to C:\I386 Folder when window appears

Click Open ( Open ( OK to install

Click finish when complete ( close all windows

Go to the DNS configuration tool as follows:

Start->Programs->Admin Tools->DNS

Select Server name to highlight

Click Action ( Configure Server

Select Next 

Accept default ( This is the first DNS sever on the network

Select next

Accept default ( Yes create a Forward Lookup zone

Next

Select Active Directory  - integrated

Type next

For zone type in :  jmps.smil.mil

Next

Select No , do not create a reverse lookup zone

Click Next ( Finish

In DNS configuration tool window

In left-hand pane select the JMPS server

Double click on it to expand the DNS tree

Select the “.” (root) DNS Zone , then right-click 
On the pop-up menu select “Delete” to delete the root DNS Zone  
DNS confirm delete dialog will open, click the “OK” button to proceed 
IF DNS Active Directory warning dialog box opens

Click “Yes” button to confirm the deletion of the root DNS Zone 
Close all DNS dialogs

Reboot the server
Logon as system administrator. 
Go to DNS configuration tool as follows:

Start->Programs->Administrator Tools->DNS

The DNS configuration dialog box will open 
In the left-hand pane select the JMPS server and right-click on it

On the pop-up menu that appears select “Properties” 
The DNS Properties dialog box will open

Click the “Fowarders” TAB to bring it to the front

On “Forwarder” TAB check the “Enable forwarders” check box

In the “IP Address” box enter the IP address for this DNS server 

(Since no DNS to forward , will use this DNS as a Forwarder for JMPS)

Click the “Add” button to enter this address into the list

Click the “OK” button when finished 

On the DNS Properties dialog box click the “Root Hints” TAB to bring it to the front

This TAB displays the default DNS Root Hints

Use the Add, Edit and Remove buttons to edit the list as necessary

These will need to be updated to the proper shipboard / schoolhouse / lab facility root hints  
Close all DNS dialogs and then reboot the server
Check DNS _ add to this

CREATE GHOST IMAGE WITH  ACTIVE DIRECTORY  - DNS

Plug external Iomega Hard drive into power before inserting USB

Plug Iomega hard drive into USB port

Insert Ghost 2003 into CD Drive (Exit Ghost startup window if it comes up

Reboot Server to boot from Ghost CD in DOS mode

Start ( shutdown ( reboot ( OK

During end of boot up sequence – watch for following prompt

Attempting to boot from CD Rom

Press any key to boot from CD Rom
Press a key when prompted to boot from CD Rom

Boot options will display

Select option to boot with USB 1.1 drivers

At completion of DOS boot:

Iomega Quest driver version 8.5 should display

Drive letter should be listed as “D”

DOS prompt A:\>  should display

At  A:\>  prompt change drive letter to “C” as follows:

A:\> C:   ( hit return

C:\> should display

Change directory to “SUPPORT” by typing in as follows:

C:\> cd support   ( Hit return

C:\SUPPORT>    should display

Type in ghost to start Ghost image as follows:

C:\SUPPORT> ghost     ( hit return key
Select “local(partition(to image”

Select drive 1 ( OK ( part 1 and 2 ( OK

Select D:[GHOST] local drive in look in window

Double click serverL folder to open for Server Lite

Double click serverP folder to open for PicoServer

Type in CDADDIR in file name  ( C and D drive with COE) ( save

Select HIGH compression ( yes to proceed with image

When image complete ( exit Ghost ( ctrl-Alt-Del to reboot

Remove CD

INSTALLATION OF COE 4205 KERNEL  

Required CD’s for this section:

COE DISK USED FOR THIS INSTALL IS :

SSC-SD C41  Philidelphia   

COE  4.2.0.5 Kernel P8

May 14  2003  

Unless otherwise noted

COE version 4.6 dated 22 July 2002 

NOTES

It is recommended that all non-COE components be loaded before COE, including any necessary device drivers. After installation of the COE kernel a longer boot up time will be noted, this is normal.

the procedures outlined below may have to be adjusted according to how the COE CD is built, the ones provided assume that each segment is located in its own subfolder

Logon as administrator 

Place CD containing  COE 4205 Kernel installation program into  Drive

Select Start->Run.

On Run dialog box click “Browse” button.

On files of  type  select All files 

This will allow  “kernel.msi” file to be seen

On the Browse dialog box point COE 4.6 CD

Double click on  Kernel[1].NT40W2k.4205 folder

double click the “kernel” file to set the path 

On the Run dialog box click the “OK” button to begin the installation

Select next

DII COE Kernel Setup dialog box will open

Click the Browse button to change destination

DII COE Kernel Setup dialog box will then open

In “Folder name:”  set path to  “C:\”

This will direct the COE Kernel installation to the System C: partition. , top level

Click OK

Destination Folder dialog box will open next

Verify path has changed to “C:\”

Click “Next” button to begin the COE Kernel installation

The Ready to Install the Application dialog box will open

Click “Next” button to begin installation

Status of the installation will be shown

The first Please Enter a New Password dialog box will open

Enter in Secman password as secman12#

Click the “OK” button 

Second Please Enter a New Password dialog box will open

Enter in keyman password in Password and Confirm Password boxes  (keyman12#)

Click “OK” button 

Installation status window will sometimes hide the next window

It may be necessary to move this window to access the following APM message:

Enable APM Authentication?  NO

NOTE: Current direction is to NOT install APM manager (SPAWAR)
Click the “No” button; do not enable APM at this time.

The Installation Status window will begin to update

Wait as the installation continues

DII COE Kernel has been successfully installed dialog will appear when install completes

Click “Finish”

The Installer Information dialog box will then open with the following message:

“You must restart your system for the configuration changes made to DII COE

Kernel to take effect. Click Yes to restart now or No if you plan to manually restart

later.”

Click the “Yes” button to restart the system.

COE will change the logon process. The blue Defense Information Systems

Agency banner will now appear on the screen at boot. Wait for the logon box to

appear. It is normal for this process to take several minutes.

The Log On to Windows dialog box will then appear

Ctrl Alt Delete to logon

The United States Department of Defense Warning Statement dialog box will Open

Click the “OK” button to acknowledge it

User name box will now be empty due to the security settings applied by the COE Kernel

Login as administrator 

If the “please wait run_once in progress” dialog box should appear

during the logon process, allow it to complete, do not click the ok button on this dialog. 

Wait until the “COE login processing is complete” dialog appears 

Check Taskbar for dot_login.cmd , if present wait for completion

Click the “OK”

CORRECT SQL SERVER PASSWORD PROBLEM after reboot

At the first logon after COE is installed a Service Control Manager error

dialog will appear with the following message:

“At least one service or driver failed during system startup. Use Event Viewer to

examine the event log for details.”

This startup failure is an expected problem. Since the SQL Server used during this

initial loading procedure development was not a COE segment, COE modifies the

user account information for the startup permissions of the SQL Server. This

modification prevents the SQL Server service from starting at boot as evident by the

red arrow in the SQL Server symbol located in the right-hand corner of the Start

Menu bar. The logon password must be reset so that the SQL Server is permitted to

start at boot. The following sub-steps must be executed to reset the SQL Server logon

information:

Select Start->Programs->Administrative Tools->Computer Management.

Double click on “Services and Applications”.

Wait for display on right window

Double click on the Services in left window

In the right-hand box all the services should be displayed

Locate  “MSSQL$JMPS_SQL_SERVER” service

Double Click on it to open Properties box

Click the “Log On” TAB to bring it forward

In the “This Account” box enter administrator Password and Confirm password 

(Note: Leave the account set to the domain account, it should be jmps\administrator)

Click the “OK” button

The Microsoft Management Console dialog box will open with the following message:

“The account %administrator%\Administrator has been granted the Log On As

A Service right.”

Click the “OK” 

Locate  “MSSQLServerADHelper” service

Double click on it to open  Properties box

Click the “Log On” TAB to bring it forward

Click the “This Account” button if its not selected

Enter administrator Password and Confirm password 

(Note: Leave the account set to the domain account, it should be jmps\administrator”

If it is not set to this value, use the Browse button to select administrator

On the MSSQLServerADHelper Properties dialog box click the “OK” button.

Locate the “SQLAgent$JMPS_SQL_SERVER” service

Double click on it to open the SQLAgent$JMPS_SQL_SERVER Properties box.

Click the “Log On” TAB to bring it forward

Enter administrator password in both boxes

(Note: Leave the account set to the domain account, it should be jmps\dministrator”).

Click the “OK” button.

Close the Computer Manager.

On the Start Menu Bar select Start->Shut Down(Restart

Click “OK” button to restart the system

After restart logon to the system and verify that the Service Control Manager

error does not appear

Verify that the SQL Server symbol present on the Start Menu bar has a green arrow, indication that the server is up and running.

INSTALLATION OF COE KERNEL PATCH P8 COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

NOTE : Add a shortcut on the Start Menu to the desktop for the COE Installer

Start(Right Click on DII installer (Select Create Shortcut

(OR browse to C:\h\COE\Comp\COEInstaller\bin\ and set a Desktop shortcut to the COE Installer (COEInstaller.exe)

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to C:\  

If not click the down-arrow button and select the C:\ partition as the install location

(the kernel patch must be placed on the same partition as the kernel)

Click the “OK” 

Assure COEInstaller title bar reflects new target as  C:\”.

On COEInstaller main menu select “File” and then “Select Source drive”

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder K2PX_WIN_4200P8 -  COE Kernel Patch Segment 

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

DII COE Kernel 4.2 Patch    Version 4.2.0.0P8” segment

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install” 

Wait until segment install process completes

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Win complete window “ install was successful” will display

Select OK

The COEInstaller dialog will then appear with the following message:

“In order for segment installation(s) to be complete the system must be rebooted. Do

you wish to reboot now?”

Click the “Yes” to reboot 

INSTALLATION OF WINDOWS 2000 PATCH COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to C:\  

If not click the down-arrow button and select the C:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as  C:\

On COEInstaller main menu select “File” and then “Select Source drive”

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder W2KPTH4610_021203 Windows 2000 Patch update segment

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

W2k Patch Update    version 4.6.1.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  (or install icon ( arrow))

Wait until segment install process completes

Since this involves applying Service Pack 2 to Windows 2000 system, it will take several minutes

Do not panic if the progress appears to stop at 97% for a long period of time

Wait until the process completes.

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Win complete window “ install was successful” will display

Select OK

The COEInstaller dialog will then appear with the following message:

“In order for segment installation(s) to be complete the system must be rebooted. Do

you wish to reboot now?”

Click the “Yes” to reboot 

After login – patch will continue to install

Logon as administrator

After logon – window will display following message:

Answer no to any prompts asking to reboot the computer

Select OK to continue with patch installation

When prompt to restart appears – select no

Select OK to Hotfix installer

Setup is complete window will appear 

Select OK to restart computer

Select NO to restart computer after next window

Select OK to next Hotfix installer

Setup is complete window will appear 

Select OK to restart computer

Install will complete and finally reboot automatically

INSTALLATION OF JAVA PLATFORM 2 COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder JAVA2_WIN_4700

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows: 

““Java Platform 2    version  4.7.0.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait until segment install process completes

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Win complete window “ install was successful” will display

Select OK

INSTALLATION OF COE UPDATE SYSTEM SECURITY LEVEL SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to C:\  

If not click the down-arrow button and select the C:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as C:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder UPDSTL_NTW2K_4600

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

COE Update System Security Level    version  4.6.0.0

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

LOCAL Security Level Manager window will appear

Set Classification  level to Secret

Leave Server Type to “Local”

Check “Allow Temporary Override”

Click on Apply

OK grays out

Close window

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

INSTALLATION OF COE SECURITY BANNER SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to C:\  

If not click the down-arrow button and select the C:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as C:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder SECBNR_NTW2K_4600

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

COE Security Banner      version  4.6.0.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Security banner should appear for a second during install

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Security banner should appear when complete

NOTE : after installation of security banner segment – occasionally a message will display:

At least one service or driver failed during startup –Check event viewer

Suspect this is caused by security banner service starting late.

Acknowledge and continue

INSTALLATION OF JMTK UTILITIES COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder JMTKbundle_WIN_4601

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

The Available Software window in main COEInstaller window will update to show:

“JMTK Analysis”, ,JMTK SDBM” ,JMTK Utilities segments

Only select the following segment to install:

JMTK Utilities segment    version 4.6.0.1   by clicking check box next to it

 (Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait until segment install process completes

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Installation of Microsoft Office 2000 Professional COE

Segment

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window expand COE 4.6 CD to display folders

Click on folder OFFICE_W2K_4600

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

Microsoft Office 2000 Pro       version  4.6.0.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Click on YES to prompt “ Do you want to continue”

Office segment will begin to install

Select OK to prompt to reboot – Software Installion will resume after login

Click OK to “install was successful window”

Click Yes to Reboot

After reboot – login as Administrator

Following message appears: 

Insert Microsoft Office CD in drive Click OK after CD light goes out

Insert Microsoft Office Pro Service Pack 1 CD into drive

Wait until CD-Rom light goes out before clicking OK

After clicking OK – IMPORTANT window appears briefly which states:

Do not click OK until MS Office installs

Respond NO to any prompts to restart

Follow directions

Input CD key for OFFICE  - select next

Accept license agreement  ( select next

Select customize

Change C to D in target path

Should be  D:\Program Files\Microsoft Office\

Select next

Click “Microsoft office” in upper window

Select “run all from my computer” 

Click Install Now 

Office will install for some time , wait for next prompt

Microsoft Office Setup window will display when complete

Click OK to “MS Office SR1 setup completed successfully” prompt

Acknowledge prompt to respond NO to any request to reboot
Click OK to this previous “IMPORTANT” window

Select YES to all prompts to updates

Click Yes to install SP-2

Numerous Update windows will appear during install of updates

Click OK to “update was applied successfully” window

Click Yes to all update windows

There will be numerous request for updates Select Yes to all

System will reboot when all updates are complete

Remove Office CD during reboot

INSTALLATION OF NETSCAPE WEB BROWSER COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder NSWEB_W2K_4700

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

Netscape Browser       version  4.7.0.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Netscape splash screen will display temporarily

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

INSTALLATION OF ADOBE ACROBAT READER COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder ACRORD_WIN4510

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

Adobe Acrobat Reader       version  4.5.1.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait for install to comlete

When completed, COEInstaller will display “Install was successful” 

Click the “OK”

Select NO to reboot now , will reboot after installation of Norton Antivirus 

INSTALLATION OF NORTON ANTIVIRUS COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes COE Installer caution Window

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder NAV_NT2WK_4530

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

Norton Antivirus       version  4.5.3.0

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Window with “Installing Norton Antivirus corporate edition  - please wait” will display

Wait for install to complete

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Select YES to reboot

Login into administrator account

After initial login , Netscape register screen will be displayed

Click OK to Alert window – could not find info.netscape.com

Select edit ( preferences (deselect “launch automatically at system start

Select OK ( File( exit Netscape register menu

INSTALLATION OF PEARL COE SEGMENT

Logon as administrator 

Use previous COE 4.6 Disk to install Pearl Segment:

T491  July 22 July 02

Segment on May 14 2003 disk is listed as Pearl 4.6??????

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes if COE Installer caution Window appears

In Browse for Folder window highlight COE46BaseW2k CD

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Locate segment Pearl   v1.0.0.4

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait for install to complete

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

INSTALLATION OF JAVA 1.4 (J2SE JRE 1.4 ) COE SEGMENT

Logon as administrator 

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes to COE Installer caution Window if appears

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder J2JRE_WIN_4700

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

J2SE JRE 1.4.1       version  4.7.0.0 

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait for install to complete

When completed, COEInstaller will display “Install was successful” 

Click the “OK”

Select YES to reboot now 

Remove COE CD during reboot

SET EVENT LOG FILES TO OVERWRITE

Perform the following on Application , Security , System DN Server event viewers

Right click My Computer (Select Manage ( expand Event Viewer

Right click on event log ( Application, Security , System,DNS Server) ( select properties

Select “overwrite as needed”

After all three done, exit Computer Management

INSTALL WINZIP

Install WINZIP CD

Select Start ( Run ( Browse 

Point to WINZIP exe file ( select OK to execute

Install in D drive

Select WINZIP Classic

Select Express Setup

Exit windows when complete

Remove WINZIP CD

GHOST IMAGE AFTER SCHEMA MODS
CREATE GHOST IMAGE WITH COE INSTALL  - ACTIVE DIRECTORY 

BEFORE SECURITY LOCKDOWNS APPLIED

Plug external Iomega Hard drive into power before inserting USB

Plug Iomega hard drive into USB port

Insert Ghost 2003 into CD Drive (Exit Ghost startup window if it comes up

Reboot Server to boot from Ghost CD in DOS mode

Start ( shutdown ( reboot ( OK

During end of boot up sequence – watch for following prompt

Attempting to boot from CD Rom

Press any key to boot from CD Rom
Press a key when prompted to boot from CD Rom

Boot options will display

Select option to boot with USB 1.1 drivers

At completion of DOS boot:

Iomega Quest driver version 8.5 should display

Drive letter should be listed as “D”

DOS prompt A:\>  should display

At  A:\>  prompt change drive letter to “C” as follows:

A:\> C:   ( hit return

C:\> should display

Change directory to “SUPPORT” by typing in as follows:

C:\> cd support   ( Hit return

C:\SUPPORT>    should display

Type in ghost to start Ghost image as follows:

C:\SUPPORT> ghost     ( hit return key
Select “local(partition(to image”

Select drive 1 ( OK ( part 1 and 2 ( OK

Select D:[GHOST] local drive in look in window

Double click serverL folder to open for Server Lite

Double click serverP folder to open for PicoServer

Type in CDADCOE in file name  ( C and D drive with COE) ( save

Select HIGH compression ( yes to proceed with image

When image complete ( exit Ghost ( ctrl-Alt-Del to reboot

Remove CD

SET SCHEMA TO BE MODIFIED BEFORE APPLYING SECURITY LOCKDOWNS

Security Lockdown segment will disallow setting option to modify Schema , will set option before applying security lockdowns

Install WIN2000 ADVANCED SERVER CD 

Navigate to Support/Tools/Setup.exe

RUN Setup.exe

Select custom install – change dir to D:

Install support tools

INSTALL ACTIVE DIRECTORY SCHEMA SNAP-IN

Control Panel - Ad/Remove programs 

Click Change or Remove Programs

On Windows 2000 Administration Tools – Select change - next 

Highlight install all Administrative Tools button

Select Next to begin installation

Click Finish - Close Control Panel when complete
ADD ACTIVE DIRECTORY SCHEMA
Select Start – Run – type in mmc-OK

On console menu – Select Add/Remove Snap-in

Select Add from Snap-in window

Double Click Active Directory Schema 

Click OK back to console window

Save console window

Select Console ( save as

Type name as “Schema” ( OK

Close all windows

REGISTER ACTIVE DIRECTORY SCHEMA

Select Start – Run – type in “cmd” – OK

Type CD WINNT\system32

Type “regsvr32 schmmgmt.dll” to register Schema

Observe message “ DlRegisterServer in schmmgmet.dll succeeded”

Exit window

SET OPTION TO MODIFY SCHEMA 

Select Start – Run

Type “schmmgmt.msc” ( OK

Right click Active Directory Schema – Select Operations Master

Select button “Schema my be modified on this Domain Controller”

Click OK

CREATE GROUPS AS GLOBAL GROUPS FOR COLLABORATION

Select Start(Settings(Control panel

Double Click Administrator Tools 

Double click Active Directory Users and Computers

Expand Users to display user/groups in right window

Add the Groups below using the following steps:

Right Click User (Select New ( Group

In New Object Group window


Input each group name in Group Name Window

Assure Default Global – Security Group Scope selected

Select OK

JmpsMissionPlanner  -  Global

JmpsAdministrator

JmpsSecurityAdministartor

JmpsDataBaseAdministrator

JmpsCollaboration

JmpsDowngradePrintedOutputClassification

Exit all windows when complete

Add groups to administrator account

Double click on administrator account

Add above groups as follows:

Select member of Tab

Select Add

Highlight all six JMPS groups

Select Add ( OK ( Apply

Verify all six JMPS groups in member off window

Close all windows

CREATE GHOST IMAGE WITH COE INSTALL  - ACTIVE DIRECTORY 

BEFORE SECURITY LOCKDOWNS APPLIED

Plug external Iomega Hard drive into power before inserting USB

Plug Iomega hard drive into USB port

Insert Ghost 2003 into CD Drive (Exit Ghost startup window if it comes up

Reboot Server to boot from Ghost CD in DOS mode

Start ( shutdown ( reboot ( OK

During end of boot up sequence – watch for following prompt

Attempting to boot from CD Rom

Press any key to boot from CD Rom
Press a key when prompted to boot from CD Rom

Boot options will display

Select option to boot with USB 1.1 drivers

At completion of DOS boot:

Iomega Quest driver version 8.5 should display

Drive letter should be listed as “D”

DOS prompt A:\>  should display

At  A:\>  prompt change drive letter to “C” as follows:

A:\> C:   ( hit return

C:\> should display

Change directory to “SUPPORT” by typing in as follows:

C:\> cd support   ( Hit return

C:\SUPPORT>    should display

Type in ghost to start Ghost image as follows:

C:\SUPPORT> ghost     ( hit return key
Select “local(partition(to image”

Select drive 1 ( OK ( part 1 and 2 ( OK

Select D:[GHOST] local drive in look in window

Double click serverL folder to open for Server Lite

Double click serverP folder to open for PicoServer

Type in CDADCOE in file name  ( C and D drive with COE) ( save

Select HIGH compression ( yes to proceed with image

When image complete ( exit Ghost ( ctrl-Alt-Del to reboot

Remove CD

Apply COE security lockdown segment W2CKET

Installing Security Lockdowns on the Domain Controller

Log in as the administrator

Use the COE Installer to install the W2KCET segment (MS Security Config Templates).

Place the CD containing the COE segments into the CD-ROM drive.

DoubleClick on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

On COEInstaller main menu select “File” and then “Select Source drive”

In Browse for Folder window  expand COE 4.6 CD to display folders

Click on folder W2CKET_WIN_4601

Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

MS Security Template                        v4.6.0.1

Select check box next to it

Select “Available Software” ( “Install”  or install icon ( arrow)

Wait for install to complete

When completed, COEInstaller will display “Install was successful” 

Click the “OK” 

Reboot the machine

Log in as the administrator

Start(Settings(control panel

Select Administrative Tools ( Domain Controller Security Policy

Right-click on Security Settings and select Import Policy

Select COE_W2KCET_4601_LANMANNT_Reapply.inf and click on Open

Right-click on Security Settings and select Reload

Expand Security Settings, Local Policies and click on Security Options

In the right windowpane double-click on Allow machine policy to automatically update during logon

Enable the policy, then click OK

Close the Domain Controller Security Policy window

You may get a message to Save Security Templates.  Click Yes if you get this dialog

Go to Administrative Tools and go to Domain Security Policy

Right-click on Security Settings and select Import Policy

Select COE_W2KCET_4601_Domain_Policy_Reapply.inf and click on Open

Right-click on Security Settings and select Reload

Close the Domain Security Policy window

NOTE: 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Partameters

Following key entry should be present:

Schema Update allowed                           REG_DWORD                0x00000001(1) 

This allows Schema to be modified

Reboot the machine

CORRECT SQL SERVER PASSWORD PROBLEM after Security template install

Select Start->Programs->Administrative Tools->Computer Management.

Double click on “Services and Applications”.

Wait for display on right window

Double click on the Services in left window

In the right-hand box all the services should be displayed

Locate  “MSSQL$JMPS_SQL_SERVER” service

Double Click on it to open Properties box

Click the “Log On” TAB to bring it forward

In the “This Account” box enter administrator Password and Confirm password 

(Note: Leave the account set to the domain account, it should be jmps\administrator)

Click the “OK” button

The Microsoft Management Console dialog box will open with the following message:

“The account %administrator%\Administrator has been granted the Log On As

A Service right.”

Click the “OK” 

Locate  “MSSQLServerADHelper” service

Double click on it to open  Properties box

Click the “Log On” TAB to bring it forward

Click the “This Account” button if its not selected

Enter administrator Password and Confirm password 

(Note: Leave the account set to the domain account, it should be jmps\administrator”

If it is not set to this value, use the Browse button to select administrator

On the MSSQLServerADHelper Properties dialog box click the “OK” button.

Locate the “SQLAgent$JMPS_SQL_SERVER” service

Double click on it to open the SQLAgent$JMPS_SQL_SERVER Properties box.

Click the “Log On” TAB to bring it forward

Enter administrator password in both boxes

(Note: Leave the account set to the domain account, it should be jmps\dministrator”).

Click the “OK” button.

Close the Computer Manager.

On the Start Menu Bar select Start->Shut Down(Restart

Click “OK” button to restart the system

After restart logon to the system and verify that the Service Control Manager error does not appear

Verify that the SQL Server symbol present on the Start Menu bar has a green arrow, indication that the server is up and running.

INSTALL JAVA DEVELOPMENT KIT-JDK 1.3.1_02  

Will copy JDK folder to E partition

Insert COE 4.6 disk described at start of procedure

Right click My Computer ( explore 

Expand COE 4.6 CD

Copy folder “JDK_1-3-02_Install” to E drive

On E drive expand JDK_1-3-1-02_Install folder 

Click on JDK_1-3-1-02_Install subfolder to Open  

Double click j2sdk-1-3-1-02-win to begin installation

At setup window Select NEXT  ( YES

Select Browse 

Change Drive to D (application)

Path should be D:\jdk1.3.1_02

Select “yes” to create new folder

Select next

Accept default Browsers

Accept default Components

Java Install will begin

JAVA Development Kit setup is now complete will display

Click FINISH

Close Explorer window

INSTALL  JC1, MISSION BINDERS AND MSDE  
INSTALLING JC1 

Insert JC1 CD containing JC1 install 

Select My Computer ( Explore (expand CD 

Double Click on JC1 install (i.e.  JC1-2500_05-12-03_JMPS_Data.zip)

WINZIP window will open

Select EXTRACT 

Assure all files selected

Click on Data(E) drive in right hand window

Click EXTRACT button

WINZIP should extract folders and files to E drive

When Complete – expand E drive – verify Install folder is displayed

ADD number of Build to Install folder name for future reference

BEGIN JMPS INSTALL

Navigate to Top folder that has JMPS Setup.exe file

NOTE: do not go down to far into subfolders – otherwise will execute Data setup by mistake

Double Click on setup.exe

Next 

JMPS-Combat1- setup screen will display

Accept license agreement ( NEXT

Select “Client” ( NEXT

Select “YES” apply security lockdown segments ( NEXT

Select “complete” for setup option ( NEXT

Click Install

Will install JMPS_Combat1

When Application is complete – Completing JMPS screen will display

Select Finish

Install JMPS Data

JMPS-Combat1- data Setup screen will display

Select NEXT

Select “complete” install ( NEXT ( INSTALL

This will begin the Data portion install

WinZip Self-Extractor Climatology.exe will execute for several minutes – wait for completion

Select “NO” do not reboot when MS SQL Desktop Engine window appears

JMPS install will complete

Click finish to complete install

Select YES to reboot

INSTALL MISSION BINDERS 

Logon as administrator 

Wait for COE-login to complete

Place the CD containing the COE segments into the CD-ROM drive.

Double Click on DII Installer

On COEInstaller main menu select “File” and then “Select Target drive” 

Assure target Set to D:\  

If not click the down-arrow button and select the D:\ partition as the install location

Click the “OK” 

Assure COEInstaller title bar reflects target as D:\

On COEInstaller main menu select “File” and then “Select Source drive”

Select Yes to COE Installer caution Window if appears

In Browse for Folder window expand COE 4.6 CD to display folders

Click on folder MissionBinderRepository_1.0.0.3
Select Ok

On COEInstaller main menu select “File” ( “Read Table of Contents” 

Assure main COEInstaller window shows:

Mission Binder v 1.0.0.3

Select check box next to it

(Turns dark blue).

Select “Available Software” ( “Install” or install icon (arrow)

Mission Binder Window appears

Select Next to display “Choose install folder” window

Change directory to D: drive for Program Folders install

Patch should be D:\Program Files\MissionBinder

Select Next to display “Choose folder to store MB data files” window

Select Choose

In “Browse for Folder” Window Navigate to E:\data\local
Click on local folder to set path

Select OK

Type “MissionBinder”  to end of path as follows:

E:\data\local\MissionBinder
Select NEXT ( Install

Wait for install to complete select Done

When completed, COEInstaller will display “Install was successful” 

Click the “OK”

Select YES to reboot now 

ATTACH MISSION BINDERS

JMPS WILL AUTOMATICALLY INSTALL MSDE and ATTACH all databases except Mission Binders. 

Must manually attach mission binders

Select START ( PROGRAMS (  JMPS ADMIN ( DBMaintenance

On MPS DataBase Connection Tool

Select browse “…” – navigate to the following directory

Select up arrow (yellow arrow) to toggle up to MissionBinder directory

Double click on MissionBinder folder

Double click on data folder

Click on MissionBinder.MDF file ( OPEN

Click Attach Database button

Observe “successfully attached following database: MissionBinder”

Select OK

COMPLETION OF SECURITY LOCKDOWN INSTALL

Log in as the administrator

Install JC1 using the Server and Security Lockdown options

Log in as the administrator

Go to Administrative Tools and go to Domain Controller Security Policy

Right-click on Security Settings and select Import Policy

Select JMPS.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select CoeJMPSBasicAuditPolicy.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select CoeJMPSSecurityPolicy.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select JMPS_files.inf and click on Open.

Right-click on Security Settings and select Reload.

Close the Domain Controller Security Policy window

Go to Administrative Tools and go to Domain Security Policy

Right-click on Security Settings and select Import Policy

Select JMPS.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select CoeJMPSBasicAuditPolicy.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select CoeJMPSSecurityPolicy.inf and click on Open.

Right-click on Security Settings and select Reload.

Right-click on Security Settings and select Import Policy.

Select JMPS_files.inf and click on Open.

Right-click on Security Settings and select Reload.

Close the Domain Security Policy window

Reboot the machine

SECURITY LOCKDOWN CHANGES ON THE DOMAIN CONTROLLER

Log in as the administrator

Start ( Control Panel (  Administrative Tools

Select Domain Controller Security Policy

Expand Security Settings, Event Log and click on Settings for Event Logs

Change each Retention method to As needed.  Confirm the dialog that appears to change the Retain settings

Change the Shut down the computer when the security audit log is full policy to Disabled

Expand Local Policies and click on User Rights Assignment

Double-click on Log on as service

Click Add ( Click Browse

Select the Administrators group and click on Add

Click OK ( Click OK ( Click OK

Double-click on Log on locally

Click Add ( Click Browse

Select the Authenticated Users group and click on Add

Click OK ( Click OK ( Click OK

Right-click on Security Settings and select Reload

Close the Domain Controller Security Policy window

Reboot the machine

Log in as the administrator

Go to Administrative Tools and go to Services

Double-click on Computer Browser

Change the Startup type to Automatic, then click Apply

Click on the Start button

Click OK

Close the Services window

MODIFY SCHEMA  

Install WIN2000 ADVANCED SERVER CD 

Navigate to Support/Tools/Setup.exe

RUN Setup.exe

Select custom install – change dir to D:

Install support tools

INSTALL ACTIVE DIRECTORY SCHEMA SNAP-IN

Control Panel - Ad/Remove programs 

Click Change or Remove Programs

On Windows 2000 Administration Tools – Select change - next 

Highlight install all Administrative Tools button

Select Next to begin installation

Click Finish - Close Control Panel when complete

ADD ACTIVE DIRECTORY SCHEMA
Select Start – Run – type in mmc-OK

On console menu – Select Add/Remove Snap-in

Select Add from Snap-in window

Double Click Active Directory Schema 

Click OK back to console window

Save console window

Select Console ( save as

Type name as “Schema” ( OK

Close all windows

ADD CUSTOM ATTRIBUTES TO SCHEMA 
REGISTER ACTIVE DIRECTORY SCHEMA

Select Start – Run – type in “cmd” – OK

Type CD WINNT\system32

Type “regsvr32 schmmgmt.dll” to register Schema

Observe message “ DlRegisterServer in schmmgmet.dll succeeded”

Exit window

RUN ACTIVE DIRECTORY SCHEMA SNAP-IN

Select Start – Run

Type “schmmgmt.msc” ( OK

Right click Active Directory Schema – Select Operations Master

Select button “Schema my be modified on this Domain Controller”

Click OK

ADD TWO CUSTOM ATTRIBUTES TO SCHEMA (P55)

RUN ACTIVE DIRECTORY SCHEMA SNAP-IN

Select Start – Run

Type “schmmgmt.msc” ( OK

On Schema Management Snap-in dialog

Right click on Attributes – Select New – Attribute

Acknowledge WARNING window – click continue

Create New Attribute dialog appears

Create two new attributes MDBName  MDBUpload

Enter values displayed on following figures

ENTER VALUES FOR THE 2 CUSTOM ATTRIBUTES 

PRE SETUP
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After server reboot

Login as administrator

Select Start – Run

Type “schmmgmt.msc” ( OK

Need to associate 2 new Attributes with Computer Class

Expand CLASSES column – right click on Computer Class – click Properties

On Computer Properties Dialog  click Attributes Tab

Click on Add button – select Schema Object Dialog shows up

On Select Schema Object Dialog , locate 1st new Attribute (MDBName) – click OK

Repeat previous steps for 2nd custom attribute (MDBUpload)

Observe two new attributes in Computer Properties Dialog

Click OK

Open Explorer Window 

Navigate to D:\Program Files\JMPS\data\

Assure that data directory is shared with permissions to everyone

Assure that configuration.mdb file is in data directory

Assure that a folder named Upload exist 

If not create one

Exit all windows

Reboot
After Reboot

Login as Administrator
POPULATE FIRST ATTRIBUTE
Click Start – Run 

Type in ADSIEdit.MSC

Observe ADSIEdit window

Expand Domain NC[jmpsenterprise]

Expand DC=jmps

Expand OU=Domain Controller

Right Click on jmpsenterprise (Select properties

Click on “Select a Property to View” drop down window

Locate 1st attribute MDBName

In Edit Attribute Field enter following value

\\servername\data\configuration.mdb
Click on Set Button ( OK to return to CN=jmpsenterprise  Window

POPULATE SECOND ATTRIBUTE

Right Click on jmpsenterprise (Select properties

Click on “Select a Property to View” drop down window

Locate 2nd attribute MDBUpload

In Edit Attribute Field enter following value

\\servername\data\Upload\
Click on Set Button to complete

Exit ADSIEdit window

CONFIGURE MACHINE FOR COM+

SET COM+ COMMUNICATION PROPERTIES  

CREATE JMPS UNIQUE WINDOWS USER 

SERVER – DOMAIN CONTROLLER 

Select Start(Control Panel

Navigate to Administrative Tools  - Active Directory Users and Computers

Right Click Users ( select new ( select user

Add user name “JMPS” to First Name window

Add login name “JMPS” to User login name window

Next

Enter administrator password with 1 appended

( COE will enforce password policies – add 1 at end of administrator password)

Deselect User must change password ( if selected)

Select password never expires

Remember password for COM+ applications

Click finish to return to Active Directory Users and Computers

Repeat above steps 1-8 for username “JMPSDOMAIN”

Click on Builtin folder – double click on administrators group

Click members Tab – Add button

Select JMPSDOMAIN user  - click Add

Click OK – Close Active Directory

SET DEFAULT COM+ AUTHENTICATION LEVEL 

Navigate to Administrative Tools - Component services – 

Expand Component Services Tree

Click on computers folder to open

Wait for component services to display in right window

Right click my computer – Select Default Properties 

Set default Authentication level - none

Click OK - do not close window

Do not reboot at this time

CONFIGURE JMPS COM+ APPLICATIONS  

Navigate to Administrative Tools - Component Services 

Open following folders: Component Services –Computers – My Computer - COM+ applications

Perform the steps listed below for appropriate configuration for each of three components

Data Change Notification

Event Subscription 

Remote Subscriber Proxy

Right click each component service - select properties – identity tab 

Select this user radio button to open user/password window

Click on browse 

In the lookin field select domain controller – (Server host name)

Select JMPSDOMAIN user on server domain and click OK

Enter password used during creation of Account ( System Password plus 1) 

Click Ok

Repeat for each of COM+ components above

Reboot

MODIFY JMPSPUBLISHER SERVICE TO RUN AS ADMIN USER

Required to connect to JMPS server 

Right Click on Computer and select manage

Expand the Services and Applications tree

Double Click on services in right window 

Services in the right window will display

Right Click on the JMPSPublisher service and select properties

Select the Log on Tab

Select the “This account” radio button

Browse to an administrator account

Select and hit OK

Input Administrator password

Click OK

Right click on the JMPSPublisher service and select restart

Exit Computer Management window

GPS ALMANAC UPDATE  

Selet Explorer window – 

Navigate to D:\Program Files\JMPS

Right click envelope folder

Select properties – advanced

Select encrypt contents to secure data

Select OK – apply – OK

SERVER ONLY – Or client accessing PTW server

INSTALL AND CONFIGURE FTP SERVER  

Create new folder on E:/ drive called ftproot




Click Start/Run 

Type in mmc return to start Management Console

Click Console – Add/Remove SnapIn 

Click Add button -  Select “Information Services Snap-In” – Click OK

Click on Local machine name to display Default FTP Site in right window



Right Click on Default FTP Site entry – select properties

On FTP site tab Change Description to “PTW FTP Site”

Limit to 10 connections

On security accounts tab – check allow “only anonymous connections”

On Home directory tab Change local path to E:\ftproot

Click read , write , log visits – click apply



Save console as JC1_install_cosole

SET POINTER TO PTW FOLDER RUN – type in regedit 

HKEY_LOCAL_MACHINE\SOFTWARE\JMPS\PTW

Assure FtpPushPath is set to e:\ftproot

SETUP ROAMING PROFILES 

Create a shared folder on E drive called “RoamingProfiles”

Select Admin Tools – Active Directory Users Groups

Double click administrator – Click on profile tab

In Profile Path field type : 

 \\jmps-sta12\RoamingProfiles\administrator

exit Active Directory - Admin Tools

COLLABORATION CONFIGURATION

Create a shared folder with the name “CollabShare” on the server

E:/Data/ CollabShare

Select “Permissions in the Collaboration Properties folder

Remove Everyone group

Select “Add” to add the following groups:

JmpsCollaboration

Change, Read

DOMAIN/Administrators

Change, Read

JmpsAdministrator

Change, Read

A file named collab.xml needs to be created and added to the aforementioned folder.  The collab.xml file is a text file that can be created through notepad.  The initial file contents are (case sensitive):

<Collaboration/>
An organizational unit named, “JMPS” needs to be added to the root level of Active Directory.  

Start( Control Panel ( Administrative Tools

Select Active Directory Users and Conputers

Right click on JMPSMUGU.COM

Select “new”

Select “organizational unit”

Type in JMPS in window ( OK to close window

To add the share point, do the following: 

Right click on JMPS organizational unit

Select “new”

Select “shared folder” 

In the name field enter, “CollabSessionList”

For the UNC path enter the following string:

\\jmpsenterprise\ CollabShare\Collab.xml

SETUP COLLABORATION ON EACH MACHINE
Log onto each machine with the (JmpsAdmin account) {note: had to use Administrator account in the JMPS Domain} and start JMPS.  When JMPS starts, select Options => Collaboration Settings from the JMPS main menu.  

Select “enabled” under Collaboration.  

Fill in the information to match the following dialog:

Pre-Approved User:

The pre-approved list allows a publisher to pre-admit users to a session.  Pre-approved users are those that are granted the Collaboration Privilege.  This setting controls the location that collaboration will check to identify users with this privilege.

If Active Directory is selected, the fully qualified distinguished name to the group in the Active Directory tree must be specified.

Select “Active Directory”

LDAP://CN=JmpsCollaboration, CN=Users, DC=JMPS, DC=smil,DC=mil

Session List:

The Session List is used by Collaboration to locate and store information about currently active sessions.  Note that selecting Active Directory requires entering the distinguished name to a share point in the Active Directory tree.

Select “Active Directory”

LDAP://CN=CollabSessionList, OU=JMPS, DC=jmps, DC=smil,DC=mil
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