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1. Overview

This document describes how to set up a test environment for the Joint Mission Planning System – Combat One (JC1) application.

JC1 is designed to run in a Common Operating Environment (COE), but JC1 can also run in a Non-COE environment.

2. JC1 Machine Environments

Here are possible environments that JC1 can be used in:

1. Client

a. A Client is a machine running JC1 that is connected to a network.

2. Walkaway

a. A Walkaway is a machine running JC1 that was previously or will be connected to a network, but is currently not connected to that network.

3. Standalone

a. A Standalone is a machine running JC1 that is never connected to a network.

4. JMPS Server

a. A JMPS Server is a machine running JC1 that is hosting its data on a domain.

5. Domain Controller

a. A Domain Controller is a machine that controls a domain.

b. A Domain Controller may run JC1 as a Client or a JMPS Server.

3. Minimum Configuration

(from JC1 Elaboration Use Cases document JC1-4897-1002)

This section defines the minimum configuration suite for JMPS Combat One.

To support Backup and Restore of Mission Binders and Standalone Export and Import the minimum configurations for each type of media storage to be used is as follows:

	Media Storage Type
	Minimum Configuration

	CD/RW
	24x10x40x, Access Speed 110ms, Transfer Speed 6.0 MB/sec

	Zip Disk Drive
	Internal Zip( 100MB ATAPI drive

	Tape Drives
	2 MB/sec data transfer rate (native)


To support Server, the minimum configuration is as follows:

	Feature
	Minimum Configuration

	Processor
	Single Intel Pentium IV 1.4 GHz Processor

	Level 2 Cache
	512 KB

	RAM
	1 GB, PC133-MHz SDRAM

	Network Interface Card
	PCI 10/100 MB/sec

	Hard Drive
	One 60 GB 7,200 RPM Drive

	OS
	Windows 2000 Advanced Server

	COE
	Version 4.6


To support all JC1 functionality, the minimum configuration is as follows:

	Feature
	Minimum Configuration

	Footprint
	Laptop or Desktop

	Processor
	Single Intel Pentium III 1.20 GHz Processor

	Level 2 Cache
	512 KB

	RAM
	512 MB, PC133-MHz SDRAM

	Network Interface Card
	10/100 MB/sec

	Hard Drive
	One 40 GB 7,200 RPM Drive

	Video Card
	32MB, 4x AGP, supports OpenGL

	OS
	Windows 2000 Professional, Windows 2000 Server, or Windows 2000 Advanced Server

	COE
	Version 4.6


4. Northrop Grumman Information Technology Test Lab Configurations

The Northrop Grumman Information Technology (NGIT) Test Labs use the following configurations, but many other configurations are possible:

1. Unclassified COE Standalone – A single machine that is never connected to a network

2. Two Unclassified COE Local Area Networks – A group of machines connected in a network and part of a domain

a. COE Domain Controller also acting as a JMPS data server

b. Laptop can be used in a Walkaway configuration

c. Network Attached Storage used as the Map Server

3. Two Unclassified COE Clients connected to the Internet – A single machine that is directly connected to a DSL line for Internet access

4. Classified COE Local Area Network

a. Non-COE Domain Controller

b. No JMPS Server

c. Laptop can be used in a Walkaway configuration

5. Unclassified COE Local Area Network for Development

a. COE Domain Controller also acting as a JMPS data server

b. Network Attached Storage used as the Map Server

See Table 1 for the hardware configurations of the machines used in the NGIT Unclassified Test Lab.  See Table 2 for the hardware configurations of the machines used in the NGIT Unclassified Development Lab.

See Table 3 for the hardware configurations of the machines used in the NGIT Classified Test Lab.

See Table 4, Table 5, Table 6, and Table 7 for the software configurations of the machines used in the NGIT Unclassified Test Lab and the NGIT Classified Test Lab.

See Table 4 and Table 7 for the software configurations of the machines used in the NGIT Unclassified Development Lab.

Table 1.  JC1 Unclassified Test Machine Hardware Configurations
	Machine Name
	Model
	CPU
	Memory
	HD
	Video Card
	CD Drive
	Other

	Base 1
	Gateway E-6000
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

Exabyte EXB-8700 8mm Tape Drive

Sony SDT-D11000 4mm Tape Drive

	Base 3
	Gateway E-6000
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

Texas Instruments PCI-1420 PCMCIA CardBus controller

HP DeskJet 990cxi Inkjet Printer

HP DesignJet 350C Plotter

	Base 4
	Gateway E-6000
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM

(16x DVD, 48x CD)
	Iomega Zip 250MB

	Base 5
	Gateway E-4600
	P4 1.8GHz
	512MB PC800 RDRAM
	40.0GB

13.7GB
	NVIDIA GeForce2 MX 200 32MB
	CD-ROM 48x
	Iomega Zip 250MB

	Mini-Me
	Micron Client Pro CS
	P2 450MHz
	256MB SDRAM
	20.5GB

13.0GB
	ATI Xpert128 Rage 128 Pro PCI 16MB
	DVD-ROM 

(16x DVD 48x CD)
	

	Dell Laptop
	Dell Inspiron 8200
	P4 2.0GHz
	1024MB PC2100 DDR SDRAM
	60.0GB
	NVIDIA GeForce4 440 Go 64MB
	DVD-ROM/CD-RW combo

(8x DVD, 24x10x24x)
	Iomega Zip 250MB

Texas Instruments PCI-4451 PCMCIA CardBus controller

	Performance Laptop
	Dell Latitude C800
	P3 1.0GHz
	256MB RAM
	20.0GB
	ATI Mobility M4 32MB
	DVD-ROM/CD-RW combo

(6x DVD, 4x4x24x)
	Texas Instruments PCI-4451 PCMCIA CardBus controller

	JMPS Server 1
	Gateway E-6000
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	JMPS Server 2
	Gateway E-4650
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

20.5GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM

(16x DVD, 48x CD)
	Iomega Zip 250MB

	Domain Controller / JMPS Server 3
	Generic
	Dual P3 1.266GHz
	2048MB RAM
	40.0GB

80.0GB
	ATI Rage XL PCI 8MB
	CD-ROM 52x
	HP LaserJet 2100

	Map Server
	Iomega NAS P435m
	P4 2.4GHz
	512MB PC266 DDR SDRAM ECC
	Six 82.3GB Drives
	N/A
	N/A
	Two Intel 10/100/1000Mbps NICs

Ultra160 SCSI interface

	Standalone 1
	Gateway E-6000
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce4 MX 440 128MB
	CD-RW 24x10x40x
	Iomega Zip 250MB

Texas Instruments PCI-1420 PCMCIA CardBus controller

Exabyte EXB-8700 8mm Tape Drive

Sony SDT-D11000 4mm Tape Drive

	Standalone 2
	Gateway E-4000
	P4 2.4GHz
	512MB PC266 DDR SDRAM
	40.0GB

41.2GB
	Intel 82845 G/GL 64MB
	DVD-ROM

(16x DVD, 48x CD)

CD-RW 40x12x40x
	

	DSL 1
	Gateway E-4650
	P4 2.4GHz
	512MB PC800 RDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	CD-RW 24x10x40x
	Iomega Zip 250MB

HP LaserJet 6MP

	DSL 2
	Gateway E-5200
	P3 600MHz
	256MB SDRAM
	20.5GB

6.5GB
	Diamond Viper II Z200 – S3 Savage 2000 32MB
	CD-ROM 48x
	Iomega Zip 250MB


	Client 1
	IBM NetVista 830741U
	P4 2.4GHz
	512MB RAM
	40.0GB

6.48GB
	NVIDIA GeForce FX 5200 128MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	Client 2
	IBM NetVista 830741U
	P4 2.4GHz
	512MB RAM
	40.0GB

41.2GB
	NVIDIA GeForce FX 5200 128MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	Client 3
	IBM NetVista 830741U
	P4 2.4GHz
	512MB RAM
	40.0GB

40.0GB
	NVIDIA GeForce FX 5200 128MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	Client 4
	IBM NetVista 830741U
	P4 2.4GHz
	512MB RAM
	40.0GB

41.2GB
	NVIDIA GeForce FX 5200 128MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	Gateway
	Gateway E5200-550
	P3 550MHz
	256MB SDRAM
	13.5 GB

76.9 GB
	NVIDIA GeForce2 MX 200 32MB
	CD-ROM 48x
	Tektronix Phaser 560 Color Printer

Iomega Zip 250MB

	Panasonic Laptop
	Panasonic Toughbook CF-71MY
	P3 600MHz
	128MB SDRAM
	12.0GB
	NeoMagic MagicGraph 256AV NM2200 2.5MB VRAM
	CD-ROM 24x
	Ricoh R/RL/RB/5C478(II), R5C522 PCMCIA controller

	JMPS Server 2
	IBM NetVista 830741U
	P4 2.4GHz
	512MB RAM
	40.0GB

20.5GB
	NVIDIA GeForce FX 5200 128MB
	DVD-ROM/CD-RW combo

(16x DVD, 32x10x40x)
	Iomega Zip 250MB

	Domain Controller / JMPS Server
	Generic
	Dual P3 1.266GHz
	2048MB RAM
	40.0GB

13.7GB
	ATI Rage XL PCI 8MB
	CD-ROM 52x
	HP LaserJet 2100

	Map Server
	Iomega NAS P435m
	P4 2.4GHz
	512MB PC266 DDR SDRAM ECC
	Six 82.3GB Drives
	N/A
	N/A
	Two Intel 10/100/1000Mbps NICs

Ultra160 SCSI interface


Table 2.  JC1 Unclassified Development Machine Hardware Configurations
	Machine Name
	Model
	CPU
	Memory
	HD
	Video Card
	CD Drive
	Other

	Station 1
	Gateway E-5200
	P3 600MHz
	256MB SDRAM
	20.5GB

41.2GB
	Diamond Viper II Z200 S3 Savage 2000 32MB
	CD-ROM (48x)
	Iomega Zip 250MB

	Station 2
	Gateway E-5200
	P3 550MHz
	256MB SDRAM
	20.5GB

41.2GB
	NVIDIA Riva TNT2/TNT2 Pro 32MB
	CD-ROM (40X)
	Iomega Zip 250MB

Exabyte EXB-8700 8mm Tape Drive

Sony SDT-D11000 4mm Tape Drive

	Station 3
	Dell Dimension 4100
	P3 733MHz
	256MB PC133 SDRAM
	20.5GB

13.6GB
	NVIDIA Riva TNT2 Model 64 32MB
	CD-ROM (40x)
	Iomega Zip 100MB (disabled)

	Station 4
	Dell Dimension 4100
	P3 733MHz
	256MB PC133 SDRAM
	20.4GB

13.7GB
	NVIDIA Riva TNT2 Model 64 32MB
	CD-ROM (48x)
	Iomega Zip 100MB (disabled)

	Station 5
	Gateway E-5200
	P3 550MHz
	256MB SDRAM
	13.7GB

13.7GB
	S3 Savage4 16MB
	CD-ROM (40x)
	Iomega Zip 250MB

	Domain Controller / JMPS Server
	Gateway E-3600
	P4 1.5GHz
	512MB SDRAM
	40.0GB

41.2GB
	NVIDIA GeForce2 MX 200 32MB
	DVD-ROM (disabled)

(16x DVD, 48x CD)

CD-RW 16x10x40
	Iomega Zip 250MB

	Map Server
	Iomega NAS P435m
	P4 1.8GHz
	512MB PC266 DDR SDRAM ECC
	Four 80.0GB Drives
	N/A
	N/A
	Two Intel 10/100/1000Mbps NICs

Ultra160 SCSI interface


Table 3.  JC1 Classified Test Machine Hardware Configurations
	Machine Name
	Model
	CPU
	Memory
	HD
	Video Card
	CD Drive
	Other

	Station 1
	Gateway E-4000
	P4 2.4GHz
	512MB PC266 DDR SDRAM
	40.0GB
	Intel 82845 G/GL 64MB
	DVD-ROM

(16x DVD, 48x CD)

CD-RW 40x12x40x
	

	Station 2
	Gateway E-4000
	P4 2.4GHz
	512MB PC266 DDR SDRAM
	40.0GB
	Intel 82845 G/GL 64MB
	DVD-ROM

(16x DVD, 48x CD)

CD-RW 40x12x40x
	

	Laptop
	Dell Inspiron 8200
	P4 1.6GHz
	512MB PC266 DDR SDRAM
	40.0GB
	NVIDIA GeForce2 Go 32MB
	DVD-ROM/CD-RW combo

(8x DVD, 8x8x24x)
	Texas Instruments PCI-4451 PCMCIA CardBus controller

	Domain Controller
	Compaq Proliant ML370 G2
	Dual P3 1.4GHz
	768MB PC133 SDRAM ECC
	18.2GB

70GB Raid5
	Integrated ATI Rage XL 8MB
	CD-ROM (40x)
	


Table 4.  JC1 COE Client and Standalone Software Configuration

	Software
	Version
	COE Segment?
	Segment Prefix

	Windows 2000 Professional
	2000 Pro
	No
	

	COE Kernel
	4.2.0.5
	Yes
	N/A

	COE Kernel 4.2 Patch 8
	4.2.0.0 P8
	Yes
	K42PXB

	W2K Patch Update
	4.6.0.0/SP3-128bit
	Yes
	W2KPTH

	Java Platform 2
	4.7.0.0
	Yes
	JAVA2

	JMTK Utilities Segment
	4.6.0.1
	Yes
	JMU

	COE Update System Security Level
	4.6.0.0
	Yes
	UPDTSL

	COE Security Banner
	4.6.0.0
	Yes
	SECBNR

	MS Security Config Templates
	4.6.0.1
	Yes
	W2KCET

	Norton Anti-Virus
	4.5.3.0
	Yes
	NAV

	MS Office 2000 Professional
	4.6.0.0
	Yes
	OFFICE

	PERL
	1.0.0.4/5.005_3
	Yes
	PERL

	Java Runtime Environment and Java Web Start
	4.7.0.0/1.41
	Yes
	J2SE JRE

	Netscape Web Browser
	4.7.0.0
	Yes
	NSWEB

	Adobe Acrobat Reader
	4.5.1.0
	Yes
	ACRORD

	JMPS-Framework Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	JMPS-Framework-Data Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	MS Message Queuing Services (MSMQ)
	N/A
	No
	

	Easy CD Creator with DirectCD (for machines with CD-writers)
	5 basic
	No
	

	Test Software Configuration

	MS SQL Query Analyzer
	8.00.194
	No
	

	PFPS
	3.2 Final
	No
	

	WinDiff
	5.0
	No
	

	WinZip
	7.0 SR-1
	No
	

	Development Software Configuration

	MS Visual Studio (for development machines)
	6.0
	No
	

	MSDN (for development machines)
	6.0a
	No
	

	Compuware DevPartner Studio (for dev machines)
	7.0
	No
	


Table 5.  JC1 COE Separate JMPS Server Software Configuration

	Software
	Version
	COE Segment?
	Segment Prefix

	Windows 2000 Advanced Server
	2000 Adv Srv
	No
	

	COE Kernel
	4.2.0.5
	Yes
	N/A

	COE Kernel 4.2 Patch 8
	4.2.0.0 P8
	Yes
	K42PXB

	W2K Patch Update
	4.6.0.0/SP3-128bit
	Yes
	W2KPTH

	Java Platform 2
	4.7.0.0
	Yes
	JAVA2

	JMTK Utilities Segment
	4.6.0.1
	Yes
	JMU

	COE Update System Security Level
	4.6.0.0
	Yes
	UPDTSL

	COE Security Banner
	4.6.0.0
	Yes
	SECBNR

	MS Security Config Templates
	4.6.0.1
	Yes
	W2KCET

	Norton Anti-Virus
	4.5.3.0
	Yes
	NAV

	MS Office 2000 Professional
	4.6.0.0
	Yes
	OFFICE

	PERL
	1.0.0.4/5.005_3
	Yes
	PERL

	MS SQL Server 2K Enterprise Edition
	4.4.0.1/2000
	Yes
	SQL2KE

	Java Runtime Environment and Java Web Start
	4.7.0.0/1.41
	Yes
	J2SE JRE

	Netscape Web Browser
	4.7.0.0
	Yes
	NSWEB

	Adobe Acrobat Reader
	4.5.1.0
	Yes
	ACRORD

	JMPS-Framework Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	JMPS-Framework-Data Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	MS Message Queuing Services (MSMQ)
	N/A
	No
	

	FTP Server
	N/A
	No
	

	Easy CD Creator with DirectCD (for machines with CD-writers)
	5 basic
	No
	

	Test Software Configuration

	MS SQL Query Analyzer
	8.00.194
	No
	

	PFPS
	3.2 Final
	No
	

	WinDiff
	5.0
	No
	

	WinZip
	7.0 SR-1
	No
	


Table 6.  JC1 Non-COE Separate Domain Controller Software Configuration
	Software
	Version

	Windows 2000 Advanced Server
	2000 Adv Srv

	Windows 2000 Service Pack 3
	SP3

	Microsoft Office 2000 Professional
	2000 Pro

	Active Directory
	N/A

	DNS Server
	N/A

	MS Message Queuing Services (MSMQ)
	N/A

	Easy CD Creator with DirectCD (for machines with CD-writers)
	5 basic

	Test Software Configuration

	WinDiff
	5.0

	WinZip
	7.0 SR-1


Table 7.  JC1 COE JMPS Server / Domain Controller Software Configuration

	Software
	Version
	COE Segment?
	Segment Prefix

	Windows 2000 Advanced Server
	2000 Adv Srv
	No
	

	COE Kernel
	4.2.0.5
	Yes
	N/A

	COE Kernel 4.2 Patch 8
	4.2.0.0 P8
	Yes
	K42PXB

	W2K Patch Update
	4.6.0.0/SP3-128bit
	Yes
	W2KPTH

	Java Platform 2
	4.7.0.0
	Yes
	JAVA2

	JMTK Utilities Segment
	4.6.0.1
	Yes
	JMU

	COE Update System Security Level
	4.6.0.0
	Yes
	UPDTSL

	COE Security Banner
	4.6.0.0
	Yes
	SECBNR

	MS Security Config Templates
	4.6.0.1
	Yes
	W2KCET

	Norton Anti-Virus
	4.5.3.0
	Yes
	NAV

	MS Office 2000 Professional
	4.6.0.0
	Yes
	OFFICE

	PERL
	1.0.0.4/5.005_3
	Yes
	PERL

	Java Runtime Environment and Java Web Start
	4.7.0.0/1.41
	Yes
	J2SE JRE

	MS SQL Server 2K Enterprise Edition
	4.4.0.1/2000
	Yes
	SQL2KE

	Netscape Web Browser
	4.7.0.0
	Yes
	NSWEB

	Adobe Acrobat Reader
	4.5.1.0
	Yes
	ACRORD

	JMPS-Framework Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	JMPS-Framework-Data Abbreviated Segment
	4.6.0.1
	Yes
	N/A

	Active Directory
	N/A
	No
	

	DNS Server
	N/A
	No
	

	MS Message Queuing Services (MSMQ)
	N/A
	No
	

	FTP Server
	N/A
	No
	

	Easy CD Creator with DirectCD (for machines with CD-writers)
	5 basic
	No
	

	Test Software Configuration

	MS SQL Query Analyzer
	8.00.194
	No
	

	PFPS
	3.2 Final
	No
	

	WinDiff
	5.0
	No
	

	WinZip
	7.0 SR-1
	No
	

	Development Software Configuration

	MS Visual Studio (for development machines)
	6.0
	No
	

	MSDN (for development machines)
	6.0a
	No
	

	Compuware DevPartner Studio (for dev machines)
	7.0
	No
	


5. JC1 Prerequisites

JC1 requires many prerequisites for it to be fully functional.  The prerequisites are different for COE machines than Non-COE machines.  NGIT uses Norton Ghost( to create images with those prerequisites included in them so that when we install new versions of JC1 we do not have to load all the prerequisites from scratch.  The COE Segments are installed using the COE Installer.  Detailed instructions are included in section 9.

5.1. COE-specific prerequisites:

1. Microsoft Windows 2000

a. Windows 2000 Professional for Standalone and Client

b. Windows 2000 Server or Advanced Server for JMPS Server and Domain Controller

c. Create 3 partitions (C = OS, D = Programs, E = Data) – Install Windows 2000 on C:\

i. Each partition must be NTFS

ii. Each partition size must be at least 4GB

d. Machine-specific drivers must be installed

e. Swap file should be moved to the E:\ partition – Swap file size recommended be at most 1024 MB

2. COE - COE Kernel

a. Install to C:\

b. Installs COE Java Runtime Environment as well

c. Enable APM Authentication

3. K2PX_WIN - COE Kernel Patch Segment - Target Drive is C:

4. W2KPTH – Windows 2000 Patch Update Segment - Target Drive is C:

5. JAVA2 – Java Platform 2 Segment - Target Drive is D:

6. UPDTSL – COE Update System Security Level Segment - Target Drive is C:

7. SECBNR – COE Security Banner Segment - Target Drive is C:

8. JMU – JMTK Utilities Segment - Target Drive is D:

9. OFFICE – Microsoft Office 2000 Professional Segment - Target Drive is D:

a. Requires Microsoft Office 2000 Professional CD

10. NAV – Norton AntiVirus Segment - Target Drive is D:

11. PERL – PERL Segment - Target Drive is D:

12. J2SE JRE – Java Runtime Environment Segment (includes Java Web Start) – Target Drive is D:

13. W2KCET – MS Security Config Templates Segment (Security Lockdowns) – Target Drive is C:

a. Installing this segment might take the machine off the domain.  You will need an administrator to put the machine back onto the domain.

b. Import appropriate policy file

i. WinNT for clients in Local Security Policy

ii. ServerNT for JMPS Servers in Local Security Policy

iii. LanmanNT for Domain Controllers in Domain Controller Security Policy

c. Go to the Domain Controller and import the Domain_Policy file in Domain Security Policy

d. Change Security Option, Allow machine policy to automatically update during logon, to be enabled

i. On Domain Controllers, do this in Domain Controller Security Policy

ii. On all others, do this in Local Security Policy

14. JMPS-Framework abbreviated segment – Target Drive is D:

15. JMPS-Framework-Data abbreviated segment – Target Drive is D:

16. SQL2KE – Microsoft SQL Server 2000 Enterprise Edition (required for JMPS Server) – Target Drive is D:

a. Install Microsoft SQL Server 2000 Enterprise Edition first

b. Name the DB server instance name “JMPS_SQL_SERVER”
17. NSWEB – Netscape Navigator Web Browser Segment – Target Drive is D:

18. ACRORD – Adobe Acrobat Reader Segment – Target Drive is D:

19. ONDOC – Online Docs (optional) – Target Drive is D:

20. JMPS MSI Install (not available yet) – Target Drive is D:

21. Security Lockdown changes (All the Security Lockdown changes are COE Deviations)

a. Change Domain Security Policy to not be defined for Log on as service

i. Uncheck the define checkbox

ii. You may need to restart the MS SQL Server service on all the machines in the domain.  You also might have to reenter the administrator username and password.

b. DisablePasswordChange registry key set to 1 (for Ghosting only)

i. HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services -> Netlogon -> Parameters

c. Computer Browser service started (for testing purposes only)

i. Enable service

ii. Set Startup type to Automatic

iii. Start service

d. Give System Full Control to Indexing Service, Internet Connection Sharing, Irmon, and NetMeeting Remote Desktop Sharing services on the Domain Controller (for Performance issues on COE Domain Controllers)

i. In Active Directory Users and Computers, Domain Controller Properties

ii. Edit Group Policy, Default Domain Controllers Policy

iii. Expand Computer Configuration, Windows Settings, Security Settings, System Services

iv. Add SYSTEM group and assign Full Control to the services

v. In Command prompt type “secedit /refreshpolicy machine_policy /enforce”

e. Import JMPS_COE_FIX.inf template to fix performance problem on Domain Controller

i. Get the JMPS_COE_FIX.inf template file from Ted Squilanti or Michael E. Chiang

ii. Copy the JMPS_COE_FIX.inf template file to C:\WINNT\security\templates\

iii. In the Domain Controller Security Policy import the JMPS_COE_FIX.inf template

iv. In the Command prompt type “secedit /refreshpolicy machine_policy /enforce”

f. Apply Task Scheduler and Event Viewer fix on Domain Controller

i. In Domain Security Policy -> Security Settings -> File System, delete %SystemRoot%\system32\mmc.exe and %SystemRoot%\Tasks\

ii. In Domain Controller Security Policy -> Security Settings -> File System

1. Delete any duplicate entries for %SystemRoot%\system32\mmc.exe and %SystemRoot%\Tasks\ (i.e. Make sure there is only one entry for mmc.exe and Tasks)

2. Change mmc.exe to give JmpsAdministrator, JmpsDataBaseAdministrator, JmpsMissionPlanner, and JmpsSecurityAdministrator Read and Execute permissions.

3. Change Tasks to give JmpsAdministrator Full Control permissions.

iii. In the Command prompt type “secedit /refreshpolicy machine_policy /enforce”

5.2. Non-COE-specific prerequisites:

1. Microsoft Windows 2000 with Service Pack 3

a. Windows 2000 Professional for Standalone and Clients

b. Windows 2000 Server or Advanced Server for Domain Controller and JMPS Server

c. Machine-specific drivers must be installed

2. Microsoft Office 2000 Professional with Service Release 2

3. ActivePerl

4. Joint Mapping Tool Kit Utilities (JMU)

5. Java Web Start

6. Web Browser with 128-bit encryption

7. Norton AntiVirus

8. Java Runtime Environment (JRE)

9. Adobe Acrobat Reader

10. Netscape Navigator

5.3. Common prerequisites:

1. Disable Automatic time adjustment for daylight savings so that Ghosting does not incorrectly change the time

2. Microsoft Message Queuing Services (MSMQ) – requires Windows 2000 CD

a. If Windows Components wizard displays

i. Select independent client

ii. Select Message Queuing will not access directory service

3. Active Directory on the Domain Controller – Do this before applying the Security Lockdowns
a. Install Active Directory

i. Install DNS Server

b. Create Location, MDBName, and MDBUpload schemas using schmmgmt tool

c. Use ADSIedit tool to set JMPS Server’s attribute settings

i. MDBName = \\(server name)\data\configuration.mdb

ii. MDBUpload = \\(server name)\data\Upload\

iii. Location = (description of location of server)

4. FTP Server for JMPS Server – requires Windows 2000 CD

a. Create “ftproot” folder on E: drive

b. Point FTP home directory to E:\ftproot

c. Make FTP home directory Read and Write accessible

d. Make sure Allow Anonymous Connections is enabled

5. Create “ftproot” folder on E: drive for all other JC1 machines as well

6. JMPS users, groups, and permissions are set up

a. Set up on Domain Controller if running on a domain

i. Set Groups as Security Group – Global

ii. For each user, enter the display name to be the same as the user name

b. Set up locally if running on Standalone or Walkaway

c. JMPS Groups – JmpsAdministrator, JmpsDataBaseAdministrator, JmpsSecurityAdministrator, JmpsMissionPlanner, JmpsDowngradePrintedOutputClassification, JmpsCollaboration

d. Uncheck the “User must change password at next logon” box (COE Deviation)

e. Check the “User cannot change password” box (COE Deviation)

f. Check the “Password never expires” box (COE Deviation)

7. The COM default authentication should be set to (None)

a. Component Services/Computers/My Computer/properties, Default Properties tab.

8. Roaming profiles set up for users running Server Walkaway (optional)

9. Prerequisites for running Collaboration

a. Shared PostOffice folder is created on the Data partition (E: drive) on the Domain Controller – for e-mail server using Microsoft Mail

b. Shared CollabShare folder is created on the Data partition (E: drive) on the Domain Controller

i. Read/Write access only to users in the JmpsCollaboration, JmpsAdministrator, and Administrators (domain) groups

c. Create collab.xml file in CollabShare folder.  File content:  <Collaboration/>

d. Create “collabadmin” domain user as a member of the following groups

i. JmpsAdministrator

ii. JmpsSecurityAdministrator

iii. JmpsMissionPlanner

iv. Administrators (local) for each machine

v. Administrators (domain)

e. Make sure DNS Server is installed on the Domain Controller

f. Configure DNS Server on the Domain Controller for Collaboration

g. Active Directory setup on the Domain Controller

i. “JMPS” Organization Unit created

ii. Share “CollabSessionList” - \\<Domain Controller name>\CollabShare\collab.xml

10. For machines that have a second hard drive, share that hard drive on the network as “SpareDrive”

11. Install Easy CD Creator and DirectCD for machines with CD-writers

12. If a Ghost image already exists, back it up to the SpareDrive partition

6. JC1 Install Overview

Install Overview:

1. If a machine is going to be a part of a domain, then it is highly recommended that the machine joins the domain before installing JC1

2. Install JC1 Program

a. For JMPS Server, select Server

b. For all others, select Client

c. Option to apply Security Lockdowns

3. Install JC1 Data

a. For JMPS Server, automatically shares <Programs Drive>:\Program Files\JMPS\data folder

b. For JMPS Server, automatically shares <Data Drive>:\data\local\JMPS\data folder and modifies configuration database to point data items to shared path.

c. Installs MSDE automatically if MS SQL Server is not already installed

i. Registers server

ii. Automatically attaches databases except Mission Binders

4. Install MissionBinderRepository

a. For COE machines, install as a COE segment

b. For Non-COE machines, install as an application

5. Attach MissionBinder database using DB Maintenance tool

6. Configure JMPSUpDataServer COM+ Application to use administrator account

7. Install JMPS-Framework and JMPS-Framework-Data COE Segments for COE machines

a. Relaxes Task Scheduler lockdown to allow JMPS groups to schedule tasks

b. Relaxes Event Viewer lockdown to allow JMPS groups to view the event logs

8. Install VBScript 5.6 Patch

a. D:\Program Files\JMPS\Setup\Scripts\scripten.exe

9. On JMPS Servers configure JmpsPublisher service to run using an administrator account

a. Set the service to start up Automatically

10. Set up e-mail notification for Server Walkaway errors

a. Modify AlertAdminEmailAddress key in HKEY_LOCAL_MACHINE\Software\JMPS to be a list of e-mail addresses you want errors to be sent to separated by semicolons

11. Apply additional Security Policies if necessary for COE machines

a. Import Domain Controller Security Policies on Domain Controller

i. JMPS.inf

ii. COEJMPSBasicAuditPolicy.inf

iii. COEJMPSSecurityAuditPolicy.inf

iv. JMPS_files.inf

b. Import Domain Security Policies on Domain Controller

i. JMPS.inf

ii. COEJMPSBasicAuditPolicy.inf

iii. COEJMPSSecurityAuditPolicy.inf

iv. JMPS_files.inf

c. Apply User Rights Assignments settings on Domain Controller

d. Apply DACL security settings

e. Apply MSDE security lockdowns

12. Configure Collaboration settings using “jmpsadmin” user if running Collaboration

13. Set up e-mail account for Collaboration

14. Register Security Stub for Non-COE machines

7. Optional Applications

Optional Applications to Install:

11. SQL Query Analyzer

12. PFPS

13. WinDiff

14. WinZip

15. Compuware DevPartner Studio (for Development)

16. MS Visual Studio (for Development)

17. MSDN (for Development)

8. COE Deviations

See Common Prerequisites items 6.d, 6.e, 6.f, and 21.

9. JC1 Test Environment Preparation Instructions

9.1. COE Client and Standalone Instructions

These instructions are derived from Point Mugu’s install procedure titled, INSTALL JC1 4.6 PT. MUGU V6.06, dated June 6, 2003, written by Joe Orosco.

9.1.1. Install Windows 2000 Professional – Requires Windows 2000 Professional CD

1. Insert the Windows 2000 Professional CD and restart the computer

2. When the message to hit any key to boot from CD appears, hit any key.  If you miss this message, then you need to restart the computer again.

3. Delete all the existing partitions

4. Create a Primary Partition (C drive) and format as NTFS

5. Set the partition size to be 4096 MB

6. Install Windows 2000 on this partition

7. Wait for the device installation to finish

8. For regional settings use the default settings and click Next

9. Enter “Associate” for the Name

10. Enter “Northrop Grumman IT” for the Organization

11. Enter the CD Key, then click Next

12. Enter the Computer Name – get this name from your Lab Manager

13. Enter the administrator password – get this from your Lab Manager

14. Set the time and date

15. For the Network Settings use the typical setting

16. Use the Workgroup default

17. Wait for the component installation to finish

18. Click Finish at the Completing the Windows 2000 setup screen

19. On the Network Identification Wizard welcome screen, click Next

20. Force logins by selecting “users must enter a user name and password”

21. Click Next

22. Click Finish at the Completing the network identification password screen

23. System will restart

9.1.2. Install Drivers – Requires Drivers CD

1. Log in as the administrator

2. Right-click on My Computer and select Properties

3. Select the Hardware tab

4. Click on Device Manager

5. Install all the drivers that you need.  Do not install any applications!

6. Restart the machine

7. Log in as the administrator

8. Right-click on the desktop and select Properties

9. Select the Settings tab

10. Set the display to at least 1024 x 768, True Color (24 bit).  For LCD screens the Native Resolution is recommended.

11. Click on Advanced

12. Select the Monitor tab

13. Set the refresh rate to be at least 75Hz for CRTs and 60Hz for LCDs

14. Click OK.  Confirm any dialogs that appear.

15. Close all the windows and restart the machine.

9.1.3. Change Date and Time Settings

1. Log in as the administrator

2. Double-click on the time in the system tray in the bottom-right corner

3. Set the date and time

4. Click on the Time Zone tab

5. Select your time zone

6. Uncheck the Automatically adjust clock for daylight saving changes (This will prevent incorrect time changes when restoring the Ghost image)

7. Click OK

9.1.4. Install MSMQ – Requires Windows 2000 Professional CD

1. Log in as the administrator

2. Make sure the Windows 2000 Professional CD is inserted

3. Uncheck show this screen at startup

4. Go to Start -> Settings -> Control Panel -> Add/Remove programs

5. Click on Add/Remove Windows Components

6. Check Message Queuing Services in the Windows Components Window

7. Make sure the Indexing Service is also checked

8. Click Next

9. If the Windows Components wizard displays, select Independent client and Message Queuing will not access a directory service

10. Click Finish when it is done installing

11. Close all the windows and remove the Windows 2000 CD

9.1.5. Create Programs (D:), Data (E:) partitions, and optionally the Ghost (G:) partition

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Select Disk Management

4. For any drive assigned to D, E, or G, right-click on the drive and select Change Drive Letter and Path

5. Click on Edit

6. Change the Drive letter to any unused letter that is not D, E, or G, then click OK

7. Click Yes on the warning dialog

8. Close the Change Drive Letter and Paths dialog

9. Right-click on unallocated space and select Create Partition

10. Click Next on the intro window

11. Select Primary Partition

12. Set the partition size for the D drive to be 4096 MB

13. Make sure the drive letter is set to D

14. Make sure the file system is set to NTFS

15. Set the volume label to be Programs

16. Click Next

17. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 9 through 17

18. When the format is complete the window will display Healthy

19. Right-click on unallocated space and select Create Partition

20. Click Next on the intro window

21. Select Primary Partition

22. If you are putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size minus 8192 MB.

23. If you are not putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size.

24. Make sure the drive letter is set to E

25. Make sure the file system is set to NTFS

26. Set the volume label to be Data

27. Click Next

28. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 19 through 28

29. When the format is complete the window will display Healthy

30. If you are putting a Ghost partition on the same hard drive, then right-click on unallocated space and select Create Partition

31. Click Next on the intro window

32. Select Primary Partition

33. Set the partition size for the G drive to be 8192 MB

34. Make sure the drive letter is set to G

35. Make sure the file system is set to FAT32

36. Set the volume label to be Ghost

37. Click Next

38. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 30 through 38

39. When the format is complete the window will display Healthy

40. Right-click on the C partition and select Properties

41. Type System in the Label field, then click OK

42. If you are putting a Ghost partition on a second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

43. Click Next on the intro window

44. Select Primary Partition

45. Set the partition size to be 8192 MB

46. Make sure the drive letter is set to G

47. Make sure the file system is set to FAT32

48. Set the volume label to be Ghost

49. Click Next

50. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 42 through 50

51. When the format is complete the window will display Healthy

52. If you want another partition on the second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

53. Click Next on the intro window

54. Select Primary Partition

55. Set the partition size to be the maximum remaining size

56. Set the drive letter to be any available drive letter

57. Make sure the file system is set to NTFS

58. Set the volume label to be SpareDrive

59. Click Next

60. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 52 through 60

61. When the format is complete the window will display Healthy

62. Close the Computer Management window

9.1.6. Move Swap File to Data (E:) partition

1. Right-click on My Computer and select Properties

2. Select the Advanced Tab

3. Click on Performance Options

4. Click on Change

5. For the C partition change the initial and maximum sizes to zero, then click on Set

6. Select the E partition

7. Enter a size that is twice the size of the physical memory on the machine for both the initial and maximum sizes, then click on Set.  If the swap file size is larger than 1024 MB, then it is recommended to change the initial and maximum sizes to 1024 MB.

8. Click OK

9. Click OK

10. Click OK

11. Restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “Win2KPro”.  See Appendix A for Ghosting instructions.

Note:  The following instructions are specific to installing COE 4.6.  The instructions will be different for other versions of COE.

9.1.7. Install COE Kernel – Requires COE Kernel Install CD

1. Log on as the administrator

2. Insert the CD containing the COE Kernel installer

3. Click on the Start menu and select Run

4. Click on the Browse button

5. On the Files of type field select All Files

6. Navigate to the COE Kernel installer called “kernel.msi” and double-click it

7. Click on the OK button to begin the installation

8. Click Next

9. On the COE Kernel Setup dialog click on the Browse button

10. In the Folder name field set the path to “C:\”, then click OK

11. Verify that the path has changed to C:\

12. Click Next

13. On the Ready to Install screen click Next

14. For the Secman password use “Security12$”, then click OK

15. For the Keyman password use “Security12$”, then click OK

16. On the dialog that asks if you want to Enable APM Authentication click on the Yes button.  (This dialog may be hidden behind the installation status window.)

17. Set the APM Authentication Key – get this from your Lab Manager

18. When the install is finished, click on the Finish button

19. Click Yes to restart the machine

All of the COE Segment installs require the COE Segments CD

9.1.8. Install COE Kernel Patch Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Click on the Start menu and while holding the Ctrl key, drag and drop the DII Installer onto the desktop

4. Double-click on DII Installer on the desktop

5. Enter the APM Authentication password, then click OK

6. Click on the File menu and select Select Target drive

7. Set the target to C:\, then click OK

8. Click on the File menu and select Select Source drive

9. Browse to the COE Kernel Patch Segment location (K42PX_4.2.0.0P8), then click OK

10. Click on the File menu and select Read Table of Contents

11. Check the COE Kernel 4.2 Patch Version 4.2.0.0P8 segment

12. Click on the Available Software menu and select Install

13. When the install is complete, click OK on the confirmation dialog

14. Click Yes to restart the machine

9.1.9. Install Windows 2000 Patch COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Windows 2000 Patch Segment location (W2KPTH), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the W2K Patch Update Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. A dialog will appear telling you to answer No to any prompts asking you to restart the machine

16. Click OK to continue the patch installation

17. Click No when the restart prompt appears

18. Click OK to run the hotfix installer

19. When the hotfix install is complete, click OK on the confirmation dialog

20. Click No when the restart prompt appears

21. The patch install will finish and restart the machine automatically

9.1.10. Install Java Platform 2 COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Platform 2 Segment location (JAVA2), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Java Platform 2 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.1.11. Install COE Update System Security Level Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Update System Security Level Segment location (UPDTSL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Update System Security Level Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. On the Security Level Manager dialog, leave the server type as Local

13. Set the classification to be the highest classification assigned to the machine

14. Check Allow Temporary Override

15. Click on OK

16. When the install is complete, click OK on the confirmation dialog

9.1.12. Install COE Security Banner Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Security Banner Segment location (SECBNR), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Security Banner Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.1.13. Install JMTK Utilities COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMTK Utilities Segment location (JMTK), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check only the JMTK Utilities Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.1.14. Install Microsoft Office 2000 Professional COE Segment – Requires Office 2K Pro CD

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Office 2000 Professional Segment location (OFFICE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Microsoft Office 2000 Pro Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. Click Yes on the confirmation dialog

13. Click OK on the restart warning dialog

14. When the install is complete, click OK on the confirmation dialog

15. Click Yes to restart the machine

16. Log back in as the administrator

17. Acknowledge the info window

18. Insert the Microsoft Office 2000 Professional CD

19. Click OK to start the install.

20. Another confirmation dialog will appear.  Do NOT click OK until the first installation is complete.

21. Follow the Microsoft Office install wizard

22. Input the CD key for Microsoft Office 2000 Professional, then click Next

23. Accept the license agreement, then click Next

24. Select Customize

25. Change the path to D:\Program Files\Microsoft Office\, then click Next

26. Click on the icon next to Microsoft Office in the upper window and select “Run all from my computer”

27. Click Install Now

28. When the install is complete, click OK on the confirmation dialog

29. Now click OK on the dialog that appeared in step 19

30. Now the installer will install all the updates.  Click No to any prompts to restart.  Click Yes to all prompts to update Office, and click OK when each update is complete.

31. The installer will automatically restart after all the updates are completed.  Remove the Microsoft Office 2000 Professional CD during the restart.

9.1.15. Install Norton Antivirus COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Norton Antivirus Segment location (NAV), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Norton Antivirus Version 4.5.3.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.1.16. Install Perl COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Perl Segment location (PERL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Perl Version 1.0.0.4 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.1.17. Install Java Runtime Environment COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Runtime Environment Segment location (J2JRE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the J2SE JRE 1.4.1 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.1.18. Install Netscape Web Browser COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Netscape Web Browser Segment location (NSWEB), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Netscape Browser Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Restart the machine

14. Log back in as the administrator

15. On the Netscape window click on the Edit menu and select Preferences

16. Uncheck “Launch automatically at system start”

17. Click OK

18. Close the Netscape window

9.1.19. Install Adobe Acrobat Reader COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Adobe Acrobat Reader Segment location (ACRORD), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Adobe Acrobat Reader Version 4.5.1.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “COE46”.  See Appendix A for Ghosting instructions.

9.1.20. Install MS Security Config Templates COE Segment (Security Lockdowns)

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Security Configuration Templates Segment location (W2KCET), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the MS Security Config Templates Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. Click on the Start menu, go to Settings, and select Control Panel

16. Double-click on Administrative Tools

17. Double-click on Local Security Policy

18. Right-click on Security Settings and select Import Policy

19. Select COE_W2KCET_4601_WinNT_Reapply.inf, then click Open

20. Right-click on Security Settings and select Reload

21. Expand Security Settings, Local Policies and click on Security Options

22. In the right windowpane double-click on Allow machine policy to automatically update during logon

23. Enable the policy, then click OK

24. Close the Local Security Policy window

25. Restart the computer

9.1.21. Change DisablePasswordChange Registry Key (COE Security Lockdown Deviation)

For Ghosting only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit”, then click OK

4. Expand My Computer, HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, Netlogon, and click on Parameters

5. Double-click on DisablePasswordChange

6. Enter 1 for the Value data, then click OK

7. Close the Registry Editor window

9.1.22. Start Computer Browser Service (COE Security Lockdown Deviation)

For testing purposes only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Services

5. Double-click on the Computer Browser service

6. Change the Startup type to Automatic, then click Apply

7. Click on the Start button

8. Click OK

9. Close the Services window

9.1.23. Create FTP Root folder for PTW

1. Log on as the administrator

2. Go to the E: drive

3. Create a folder named “ftproot”

9.1.24. Set COM Default Authentication Level to (None)

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. In the right windowpane double-click on Computers

6. In the right windowpane right-click on My Computer and select Properties

7. Select the Default Properties tab

8. Set the Default Authentication Level to (None)

9. Click OK

10. Close the confirmation dialog that appears

11. Close the Component Services window

12. Restart the machine

9.1.25. Create Local JMPS Users and Groups (Optional)

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Local Users and Groups

4. Click on Groups

5. Right-click on Groups and select New Group

6. Create the following groups

a. JmpsAdministrator

b. JmpsCollaboration

c. JmpsDataBaseAdministrator

d. JmpsDowngradePrintedOutputClassification

e. JmpsMissionPlanner

f. JmpsSecurityAdministrator

7. Click on the Close button

8. Click on Users

9. Right-click on Users and select New User

10. Create the users that you need

a. Make sure you fill in the Full name field

b. Uncheck User must change password at next logon (COE Deviation)

c. Check Password never expires (COE Deviation)

11. Click on Groups

12. Double-click on each group and add the appropriate users to each group

13. Close the Computer Management window

9.1.26. Configure IP Settings (For machines with IP addresses)

1. Get the IP settings from your Lab Manager

2. Log on as the administrator

3. Right-click on My Network Places and select Properties

4. Right-click on Local Area Connection and select Properties

5. Select Internet Protocol (TCP/IP) and click on the Properties button

6. Select Use the following IP address, and enter the IP settings for the machine

7. Select Use the following DNS server addresses, and enter the address of the DNS server

8. Click OK on the Internet Protocol (TCP/IP) Properties dialog

9. Click OK on the Local Area Connection Properties

10. Close the Network and Dial-up Connections window

9.1.27. Join the Domain (For domain clients) – Domain Controller must be set up first

This step is highly recommended if the machine is going to be on a domain!

1. Log on as the administrator

2. Right-click on My Computer and select Properties

3. Select the Network Identification tab

4. Click on Properties

5. In the Member of section select Domain

6. Type in the domain name that you are joining – Get this from your Lab Manager

7. Type in the domain administrator username and password – Only your Lab Manager should know this

8. Close the welcome message

9. Click OK

10. Click OK

11. Click Yes to restart the machine

9.1.28. Add Domain Users to Local Groups If Necessary (Optional) – DC must be set up first

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Local Users and Groups

4. Double-click on the group that you want to add a domain user to

5. Click on Add

6. In the Look in: field select the domain

7. Select the user(s) you want to add to this group, then click Add

8. Click OK

9. Click OK

10. Repeat steps 4 through 9 for all the groups you want to add domain users to

11. Close the Computer Management window

9.1.29. Install Roxio Easy CD Creator and DirectCD for Machines with CD-writers – Requires Easy CD Creator and DirectCD Install CD

1. Log in as the administrator

2. Insert the Roxio Easy CD Creator and DirectCD Install CD

3. Go to the CD drive and double-click on Setup.exe

4. Click Next on the welcome screen

5. Select Custom, then click Next

6. Click on the Change button

7. Change the path to D:\Program Files\Adaptec\Easy CD Creator 5\, then click OK

8. Click Next

9. Click Install

10. When the install is finished, click on the Finish button

11. Click Yes to restart the machine

12. Remove the Roxio Easy CD Creator and DirectCD install CD

9.1.30. Install WinZip (Optional)

1. Log in as the administrator

2. Insert the WinZip install CD

3. Click on the Start menu and select Run

4. Click on the Browse button

5. Navigate to the WinZip install file called “winzip.exe” and double-click it

6. Click on the OK button to begin the installation

7. Install to the D: partition

8. Select WinZip Classic

9. Select Express Setup

10. When the install is complete, close all the WinZip windows

11. Remove the WinZip install CD

9.1.31. Install SQL Query Analyzer (Optional) – Requires SQL Server 2000 CD

1. Log in as the administrator

2. Insert the install CD for any version of Microsoft SQL Server 2000

3. If the install window doesn’t automatically appear, then go to the CD drive and double-click on Setup.exe or autorun.exe

4. Click on SQL Server 2000 Components

5. Click on Install Database Server

6. Click Next on the welcome screen

7. Select Local Computer, then click Next

8. Select Create a new instance of SQL Server, or install Client Tools, then click Next

9. Enter “JMPS” in the Name field and “Northrop Grumman IT” in the Company field, then click Next

10. Click Yes to accept the agreement

11. Enter the CD Key, then click Next

12. Select Client Tools Only, then click Next

13. In the Components section select Management Tools

14. In the Sub-Components section uncheck Enterprise Manager, Profiler, DTC Client Support, and Conflict Viewer

15. In the Components section uncheck Client Connectivity, Books Online, Development Tools, and Code Samples

16. Click Next

17. Click Next

18. When the install is finished, click on the Finish button

19. Remove the Microsoft SQL Server 2000 CD

9.1.32. Install WinDiff (Optional) – Requires Windows 2000 Professional CD

1. Log in as the administrator

2. Insert the Windows 2000 Professional CD

3. Navigate to E:\Support\Tools\

4. Double-click on Setup.exe

5. Click Next

6. Enter “Associate” in the Name field and “Northrop Grumman IT” in the Organization field, then click Next

7. Select Custom, then click Next

8. Click on the Browse button

9. Change the Selected Path to D:\Program Files\Support Tools\, then click OK

10. Click Next

11. Click Next

12. When the install is finished, click on the Finish button

13. Remove the Windows 2000 Professional CD

9.1.33. Clear the Event Logs

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Event Viewer

4. Right-click on Application and select Clear all Events

5. Click No when it asks you if you want to save the log

6. Right-click on Security and select Clear all Events

7. Click No when it asks you if you want to save the log

8. Right-click on System and select Clear all Events

9. Click No when it asks you if you want to save the log

10. Close the Computer Management window

9.1.34. Defragment C:, D:, and E: Partitions (For Performance Tuning)

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Click on Disk Defragmenter

4. Select the E: partition, then click on the Defragment button

5. When the defragmentation is complete, close the confirmation dialog

6. Select the D: partition, then click on the Defragment button

7. When the defragmentation is complete, close the confirmation dialog

8. Select the C: partition, then click on the Defragment button

9. When the defragmentation is complete, close the confirmation dialog

10. Close the Computer Management window

It is recommended to make a Ghost image at this point.  Name the Ghost image “JC1Ready”.  See Appendix A for Ghosting instructions.

9.1.35. Install JC1 – Requires JC1 Install CD

1. Log on as the administrator

2. Insert the CD that contains the JC1 install files

3. Copy the CD contents to a temporary folder

4. If you have not run Microsoft Office on the machine before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

5. In the temporary folder go to the JC1 install directory (usually JC1 <build no>\JMPS, or JMPS), then double-click on setup

6. On the splash screen click Next

7. On the agreement screen select the “I accept the terms in the license agreement” option, then click Next

8. On the Client vs Server screen select Client, then click Next

9. On the COE Security Settings screen select Yes, then click Next

10. On the Setup Type screen select Custom, then click Next

11. On the Custom Setup screen make sure the Install to: field is “D:\Program Files\JMPS\”, then click Next

12. On the Ready to Install screen click Install

13. Wait for the installation to finish, then the wizard will go directly to the JC1 Data Install

14. On the splash screen click Next

15. On the Setup Type screen select Custom, then click Next

16. On the Custom Setup screen make sure the Install to: field is “E:\data\”, then click Next

17. On the Ready to Install screen click Install

18. Wait for the installation to finish.  The MSDE installer will automatically start

19. A digital signature message may appear several times during the MSDE install.  Click Yes on all of them

20. On the Setup Complete screen click Finish

21. Click Finish again

22. Click on Yes restart the machine

9.1.36. Install Mission Binders Repository – Requires MB Repository CD

1. Log on as the administrator

2. Insert the CD containing the Mission Binders Repository COE segment

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Mission Binders Repository Segment location (Mission Binders), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Mission Binders Version 1.0.0.7 segment

11. Click on the Available Software menu and select Install

12. On the Introduction screen click Next

13. On the Choose Install Folder screen make sure the folder path is “D:\Program Files\MissionBinder”, then click Next

14. On the Choose a Folder screen change the folder path to “E:\data\local\MissionBinder”, then click Next

15. On the Pre-Installation Summary screen click Install

16. Wait for the installation to finish, then on the Install Complete screen click Done

17. When the install is complete, click OK on the confirmation dialog

18. Click Yes to restart the machine

9.1.37. Attach MissionBinder Database

1. Log in as the administrator

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Click on the Browse button

4. Browse to “E:\data\local\MissionBinder\data\MissionBinder.MDF”

5. Click on Attach Database

6. Click OK on the confirmation dialog

7. Click on the Close button

9.1.38. Configure JMPS COM+ Application - JMPSUpDataServer

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. Expand Component Services, Computers, My Computers, and click on COM+ Applications

6. In the right windowpane right-click on JMPSUpDataServer and select Properties

7. Click on the Identity tab

8. Select the This user: radio button

9. Click on the Browse button

10. Select the local administrator

11. Enter the administrator password for the password fields

12. Click on the OK button

9.1.39. Install JMPS-Framework and JMPS-Framework-Data COE Segments – Requires CD with JMPS-Framework COE Segments (COE Security Lockdown Deviation)

Relaxes Task Scheduler lockdown to allow JMPS groups to schedule tasks and relaxes Event Viewer lockdown to allow JMPS groups to view the event logs.  If you want the domain users to have access to the task scheduler and event viewer, you must install these segments as a domain user.

1. If the machine is intended to be on the domain, then log in as a domain user that is also a local administrator.  Otherwise, log on as the administrator.

2. Insert the CD containing the JMPS-Framework COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMPS-Framework Segments location, then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the JMPS-Framework Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Check the JMPS-Framework-Data Version 4.6.0.1 segment

14. Click on the Available Software menu and select Install

15. When the install is complete, click OK on the confirmation dialog

9.1.40. Install VBScript 5.6 Patch for TOLD

1. Log on as the administrator

2. Go to D:\Program Files\JMPS\Setup\Scripts\

3. Double-click on scripten.exe

4. Click Yes on the confirmation dialog

5. Click Yes for the license agreement

6. Click OK on the confirmation dialog after the update is completed

7. Click Yes to restart the machine

9.1.41. Apply DACL Security Settings (Security Lockdowns)

1. See Appendix I – Apply DACL Security Settings
9.1.42. Apply MSDE Security Lockdowns (Security Lockdowns)

1. Log in as a domain JMPS Security Administrator if the machine is on a domain.  Otherwise log in as a local JMPS Security Administrator.

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Select the MSDE Security tab

4. Click on the Add button

5. If the machine is not on a domain, then skip to step 9
6. In the dropdown list select the appropriate domain name

7. Select the JmpsAdministrator, JmpsDataBaseAdministrator, JmpsMissionPlanner, and JmpsSecurityAdministrator groups, then click on the Add button

8. Click on the OK button

9. Select the BUILTIN\Users group, then click on the Remove button

10. Click on the Apply Security button

11. Close the JMPS Database Administration Tool

9.1.43. Set Up E-mail Notification for Server Walkaway Errors (Optional)

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit” then click on the OK button

4. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\JMPS\

5. In the right windowpane right-click on AlertAdminEmailAddress and select Modify

6. Enter the e-mail address of the user that you want the errors to be sent to.  You may enter multiple e-mail addresses by separating them with semicolons.  Click on the OK button

7. Close the Registry Editor

9.1.44. Set Event Log Files to Overwrite as Needed (Only if Security Lockdowns not applied)

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Expand the Event Viewer

4. For Application, Security, and System, right-click on the event log and select Properties

5. Select Overwrite as needed, then click OK

6. Close the Computer Management window

9.1.45. Running JC1

1. Log onto the machine

2. If you have not run Microsoft Office with the current user before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

3. Launch JMPS

4. A DAFIF expiration message may appear.  Click OK to acknowledge the message and continue to run JC1

9.1.46. Set Up Collaboration Using Active Directory (Optional) – DC must be set up first

1. Log on as a domain user that is a member of the following groups

a. Administrators (local)

b. JmpsAdministrator (domain)

c. JmpsSecurityAdministrator (domain)

d. JmpsMissionPlanner (domain)

2. Launch JC1

3. Click on the Options menu and select Collaboration Settings

4. In the Collaboration section check the Enabled checkbox

5. In the Pre-Approved Users section select Active Directory

6. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is “LDAP://CN=JmpsCollaboration, CN=Users”

b. The end of the string is determined by the full Domain name

i. For example, if the domain name is “Test.JC1.domain.com”, then the end of the string will be “, DC=Test, DC=JC1, DC=domain, DC=com”

c. So the entire string for the example above will be:              “LDAP://CN=JmpsCollaboration, CN=Users, DC=Test, DC=JC1, DC=domain, DC=com”

7. Click on the OK button

8. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 5 through 7

9. In the Session List section select Active Directory

10. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is determined by the Organizational Unit created on the Domain Controller

i. For example, if the Organizational Unit was named “JMPS” and the Shared Folder in it was named “CollabSessionList”, then the beginning of the string will be “LDAP://CN=CollabSessionList, OU=JMPS”

b. The end of the string is determined by the full Domain name.  Same as in step 6b

c. So the entire string for the example above will be:              “LDAP://CN=CollabSessionList, OU=JMPS, DC=Test, DC=JC1, DC=domain, DC=com”

11. Click on the OK button

12. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 9 through 11

13. Click on the OK button

9.2. COE Domain Controller and JMPS Server on the Same Machine Instructions

9.2.1. Install Windows 2000 Server or Advanced Server – Requires Windows 2000 Server or Advanced Server CD – TBD – Needs Dan Webb

1. TBD

9.2.2. Install Drivers – Requires Drivers CD

1. Right-click on My Computer and select Properties

2. Select the Hardware tab

3. Click on Device Manager

4. Install all the drivers that you need.  Do not install any applications!

5. Restart the machine

6. Log in as the administrator

7. Right-click on the desktop and select Properties

8. Select the Settings tab

9. Set the display to at least 1024 x 768, True Color (24 bit).  For LCD screens the Native Resolution is recommended.

10. Click on Advanced

11. Select the Monitor tab

12. Set the refresh rate to be at least 75Hz for CRTs and 60Hz for LCDs

13. Click OK.  Confirm any dialogs that appear.

14. Close all the windows and restart the machine.

9.2.3. Change Date and Time Settings

1. Log in as the administrator

2. Double-click on the time in the system tray in the bottom-right corner

3. Set the date and time

4. Click on the Time Zone tab

5. Select your time zone

6. Uncheck the Automatically adjust clock for daylight saving changes (This will prevent incorrect time changes when restoring the Ghost image)

7. Click OK

9.2.4. Install Active Directory – TBD – Needs Dan Webb

1. TBD

9.2.5. Install DNS Server – TBD – Needs Dan Webb

1. TBD

9.2.6. Configure IP Settings

1. Get the IP settings from your Lab Manager

2. Log on as the administrator

3. Right-click on My Network Places and select Properties

4. Right-click on Local Area Connection and select Properties

5. Select Internet Protocol (TCP/IP) and click on the Properties button

6. Select Use the following IP address, and enter the IP settings for the machine

7. Select Use the following DNS server addresses, and enter the address of the DNS server

8. Click OK on the Internet Protocol (TCP/IP) Properties dialog

9. Click OK on the Local Area Connection Properties

10. Close the Network and Dial-up Connections window

9.2.7. Install MSMQ – Requires Windows 2000 Server or Advanced Server CD – TBD – Needs Dan Webb

1. TBD

9.2.8. Install FTP Server – Requires Windows 2000 Server or Advanced Server CD – TBD – Needs Dan Webb

1. TBD

9.2.9. Set Up Active Directory schemas for Server Walkaway – Requires Windows 2000 Server or Advanced Server CD

1. Get a list of the machine names of all the JMPS Servers from your Lab Manager

2. Log in as the administrator

3. Insert the Windows 2000 Server or Advanced Server CD

4. Navigate to E:\Support\Tools\

5. Double-click on Setup.exe

6. Click Next

7. Enter “Associate” in the Name field and “Northrop Grumman IT” in the Organization field, then click Next

8. Select Custom, then click Next

9. Click on the Browse button

10. Change the Selected Path to D:\Program Files\Support Tools\, then click OK

11. Click Next

12. Click Next

13. When the install is finished, click on the Finish button

14. Remove the Windows 2000 Server or Advanced Server CD

15. Click on the Start menu and select Run

16. Type “schmmgmt.msc”, then click OK

17. Right-click on Active Directory Schema and select Operations Master

18. Check the checkbox that says “The Schema may be modified on this Domain Controller”

a. If this checkbox is disabled, then you must add a registry key

i. Click on the Start menu and select Run

ii. Type “regedit” then click OK

iii. Expand My Computer, HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, NTDS, and click on Parameters

iv. Right-click on Parameters, go to New, then select DWORD Value

v. Type in “Schema update allowed”

vi. Double-click on Schema update allowed, enter 1 for the value, then click OK

vii. Close the Registry Editor window

19. Expand Active Directory Schema

20. Right-click on Attributes, go to New, and select Attribute

21. Click Continue on the warning message

22. In the Create New Attribute window enter the following data:

a. Common name – “MDBName”

b. LDAP Display Name – “MDBName”

c. Unique X500 Object ID – “1.2.840.113556.1.8000.586.1.1”

d. Syntax – “Unicode String”

e. Leave the rest blank

f. Click OK

23. Right-click on Attributes, go to New, and select Attribute

24. Click Continue on the warning message

25. In the Create New Attribute window enter the following data:

a. Common name – “MDBUpload”

b. LDAP Display Name – “MDBUpload”

c. Unique X500 Object ID – “1.2.840.113556.1.8000.586.1.2”

d. Syntax – “Unicode String”

e. Leave the rest blank

f. Click OK

26. Close the Active Directory Schema window

27. Restart the machine

28. Log back in as the administrator

29. Click on the Start menu and select Run

30. Type “schmmgmt.msc”, then click OK

31. Expand Active Directory Schema and Classes

32. Right-click on the “computer” class and select Properties

33. On the Computer Properties dialog, click on the Attributes Tab

34. Click on the Add button

35. On the Select Schema Object dialog select MDBName, then click OK

36. Click on the Add button

37. On the Select Schema Object dialog select MDBUpload, then click OK

38. Click OK on the Computer Properties dialog

39. Restart the machine

40. Log back in as the administrator

41. Click on the Start menu, go to Programs, Windows 2000 Support Tools, Tools, and select ADSI Edit

42. Expand ADSI Edit, Domain NC [<domain controller name>], DC=<domain name>, CN=Computers

43. Expand OU=Domain Controllers

44. For each JMPS Server search in the Computers list and the Domain Controllers list for the JMPS Server name

a. When you find the JMPS Server, right-click on CN=<JMPS server name> and select Properties

b. For the “Select a property to view” field select MDBName

c. In the Edit Attribute field type in “\\<JMPS server name>\data\configuration.mdb”, then click on the Set button

d. For the “Select a property to view” field select MDBUpload

e. In the Edit Attribute field type in “\\<JMPS server name>\data\Upload.mdb”, then click on the Set button

f. For the “Select a property to view” field select location

g. In the Edit Attribute field type in some text that describes the location of the JMPS server, then click on the Set button

h. Click on the OK button

9.2.10. Install Microsoft SQL Server 2000 Enterprise Edition – Requires Microsoft SQL Server 2000 Enterprise Edition CD – TBD – Needs Dan Webb

1. TBD

9.2.11. Create Programs (D:), Data (E:) partitions, and optionally the Ghost (G:) partition

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Select Disk Management

4. For any drive assigned to D, E, or G, right-click on the drive and select Change Drive Letter and Path

5. Click on Edit

6. Change the Drive letter to any unused letter that is not D, E, or G, then click OK

7. Click Yes on the warning dialog

8. Close the Change Drive Letter and Paths dialog

9. Right-click on unallocated space and select Create Partition

10. Click Next on the intro window

11. Select Primary Partition

12. Set the partition size for the D drive to be 4096 MB

13. Make sure the drive letter is set to D

14. Make sure the file system is set to NTFS

15. Set the volume label to be Programs

16. Click Next

17. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 9 through 17

18. When the format is complete the window will display Healthy

19. Right-click on unallocated space and select Create Partition

20. Click Next on the intro window

21. Select Primary Partition

22. If you are putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size minus 8192 MB.

23. If you are not putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size.

24. Make sure the drive letter is set to E

25. Make sure the file system is set to NTFS

26. Set the volume label to be Data

27. Click Next

28. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 19 through 28

29. When the format is complete the window will display Healthy

30. If you are putting a Ghost partition on the same hard drive, then right-click on unallocated space and select Create Partition

31. Click Next on the intro window

32. Select Primary Partition

33. Set the partition size for the G drive to be 8192 MB

34. Make sure the drive letter is set to G

35. Make sure the file system is set to FAT32

36. Set the volume label to be Ghost

37. Click Next

38. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 30 through 38

39. When the format is complete the window will display Healthy

40. Right-click on the C partition and select Properties

41. Type System in the Label field, then click OK

42. If you are putting a Ghost partition on a second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

43. Click Next on the intro window

44. Select Primary Partition

45. Set the partition size to be 8192 MB

46. Make sure the drive letter is set to G

47. Make sure the file system is set to FAT32

48. Set the volume label to be Ghost

49. Click Next

50. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 42 through 50

51. When the format is complete the window will display Healthy

52. If you want another partition on the second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

53. Click Next on the intro window

54. Select Primary Partition

55. Set the partition size to be the maximum remaining size

56. Set the drive letter to be any available drive letter

57. Make sure the file system is set to NTFS

58. Set the volume label to be SpareDrive

59. Click Next

60. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 52 through 60

61. When the format is complete the window will display Healthy

62. Close the Computer Management window

9.2.12. Move Swap File to Data (E:) partition

1. Right-click on My Computer and select Properties

2. Select the Advanced Tab

3. Click on Performance Options

4. Click on Change

5. For the C partition change the initial and maximum sizes to zero, then click on Set

6. Select the E partition

7. Enter a size that is twice the size of the physical memory on the machine for both the initial and maximum sizes, then click on Set.  If the swap file size is larger than 1024 MB, then it is recommended to change the initial and maximum sizes to 1024 MB.

8. Click OK

9. Click OK

10. Click OK

11. Restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “Win2KSrv”.  See Appendix A for Ghosting instructions.

Note:  The following instructions are specific to installing COE 4.6.  The instructions will be different for other versions of COE.

9.2.13. Install COE Kernel – Requires COE Kernel Install CD

1. Log on as the administrator

2. Insert the CD containing the COE Kernel installer

3. Click on the Start menu and select Run

4. Click on the Browse button

5. On the Files of type field select All Files

6. Navigate to the COE Kernel installer called “kernel.msi” and double-click it

7. Click on the OK button to begin the installation

8. Click Next

9. On the COE Kernel Setup dialog click on the Browse button

10. In the Folder name field set the path to “C:\”, then click OK

11. Verify that the path has changed to C:\

12. Click Next

13. On the Ready to Install screen click Next

14. For the Secman password use “Security12$”, then click OK

15. For the Keyman password use “Security12$”, then click OK

16. On the dialog that asks if you want to Enable APM Authentication click on the Yes button.  (This dialog may be hidden behind the installation status window.)

17. Set the APM Authentication Key – get this from your Lab Manager

18. When the install is finished, click on the Finish button

19. Click Yes to restart the machine

9.2.14. Create New Secman and Keyman accounts on COE Domain Controller

1. See Appendix F – New Secman and Keyman User Accounts on a COE Domain Controller
All of the COE Segment installs require the COE Segments CD

9.2.15. Install COE Kernel Patch Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Click on the Start menu and while holding the Ctrl key, drag and drop the DII Installer onto the desktop

4. Double-click on DII Installer on the desktop

5. Enter the APM Authentication password, then click OK

6. Click on the File menu and select Select Target drive

7. Set the target to C:\, then click OK

8. Click on the File menu and select Select Source drive

9. Browse to the COE Kernel Patch Segment location (K42PX_4.2.0.0P8), then click OK

10. Click on the File menu and select Read Table of Contents

11. Check the COE Kernel 4.2 Patch Version 4.2.0.0P8 segment

12. Click on the Available Software menu and select Install

13. When the install is complete, click OK on the confirmation dialog

14. Click Yes to restart the machine

9.2.16. Install Windows 2000 Patch COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Windows 2000 Patch Segment location (W2KPTH), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the W2K Patch Update Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. A dialog will appear telling you to answer No to any prompts asking you to restart the machine

16. Click OK to continue the patch installation

17. Click No when the restart prompt appears

18. Click OK to run the hotfix installer

19. When the hotfix install is complete, click OK on the confirmation dialog

20. Click No when the restart prompt appears

21. The patch install will finish and restart the machine automatically

9.2.17. Install Java Platform 2 COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Platform 2 Segment location (JAVA2), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Java Platform 2 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.2.18. Install COE Update System Security Level Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Update System Security Level Segment location (UPDTSL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Update System Security Level Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. On the Security Level Manager dialog, leave the server type as Local

13. Set the classification to be the highest classification assigned to the machine

14. Check Allow Temporary Override

15. Click on OK

16. When the install is complete, click OK on the confirmation dialog

9.2.19. Install COE Security Banner Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Security Banner Segment location (SECBNR), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Security Banner Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.2.20. Install JMTK Utilities COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMTK Utilities Segment location (JMTK), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check only the JMTK Utilities Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.2.21. Install Microsoft Office 2000 Professional COE Segment – Requires Office 2K Pro CD

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Office 2000 Professional Segment location (OFFICE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Microsoft Office 2000 Pro Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. Click Yes on the confirmation dialog

13. Click OK on the restart warning dialog

14. When the install is complete, click OK on the confirmation dialog

15. Click Yes to restart the machine

16. Log back in as the administrator

17. Acknowledge the info window

18. Insert the Microsoft Office 2000 Professional CD

19. Click OK to start the install.

20. Another confirmation dialog will appear.  Do NOT click OK until the first installation is complete.

21. Follow the Microsoft Office install wizard

22. Input the CD key for Microsoft Office 2000 Professional, then click Next

23. Accept the license agreement, then click Next

24. Select Customize

25. Change the path to D:\Program Files\Microsoft Office\, then click Next

26. Click on the icon next to Microsoft Office in the upper window and select “Run all from my computer”

27. Click Install Now

28. When the install is complete, click OK on the confirmation dialog

29. Now click OK on the dialog that appeared in step 19

30. Now the installer will install all the updates.  Click No to any prompts to restart.  Click Yes to all prompts to update Office, and click OK when each update is complete.

31. The installer will automatically restart after all the updates are completed.  Remove the Microsoft Office 2000 Professional CD during the restart.

9.2.22. Install Norton Antivirus COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Norton Antivirus Segment location (NAV), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Norton Antivirus Version 4.5.3.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.2.23. Install Perl COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Perl Segment location (PERL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Perl Version 1.0.0.4 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.2.24. Install Java Runtime Environment COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Runtime Environment Segment location (J2JRE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the J2SE JRE 1.4.1 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.2.25. Install Microsoft SQL Server 2000 Enterprise Edition COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft SQL Server 2000 Enterprise Edition Segment location (SQL2KE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the SQL Server 2000 Enterprise Edition Version 4.4.0.1 segment

11. Click on the Available Software menu and select Install

12. Click OK on the SQL Server installation check message

13. When the install is complete, click OK on the confirmation dialog

9.2.26. Install Netscape Web Browser COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Netscape Web Browser Segment location (NSWEB), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Netscape Browser Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Restart the machine

14. Log back in as the administrator

15. On the Netscape window click on the Edit menu and select Preferences

16. Uncheck “Launch automatically at system start”

17. Click OK

18. Close the Netscape window

9.2.27. Install Adobe Acrobat Reader COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Adobe Acrobat Reader Segment location (ACRORD), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Adobe Acrobat Reader Version 4.5.1.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “COE46”.  See Appendix A for Ghosting instructions.

9.2.28. Install MS Security Config Templates COE Segment (Security Lockdowns)

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Security Configuration Templates Segment location (W2KCET), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the MS Security Config Templates Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. Click on the Start menu, go to Settings, and select Control Panel

16. Double-click on Administrative Tools

17. Double-click on Domain Controller Security Policy

18. Right-click on Security Settings and select Import Policy

19. Select COE_W2KCET_4601_LANMANNT_Reapply.inf, then click Open

20. Right-click on Security Settings and select Reload

21. Expand Security Settings, Local Policies and click on Security Options

22. In the right windowpane double-click on Allow machine policy to automatically update during logon

23. Enable the policy, then click OK

24. Close the Domain Controller Security Policy window

25. You may get a message to Save Security Templates.  Click Yes if you get this dialog

26. Go to Administrative Tools and double-click on Domain Security Policy

27. Right-click on Security Settings and select Import Policy

28. Select COE_W2KCET_4601_Domain_Policy_Reapply.inf, then click Open

29. Right-click on Security Settings and select Reload

30. Close the Domain Security Policy window

31. Restart the computer

9.2.29. Change DisablePasswordChange Registry Key (COE Security Lockdown Deviation)

For Ghosting only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit”, then click OK

4. Expand My Computer, HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, Netlogon, and click on Parameters

5. Double-click on DisablePasswordChange

6. Enter 1 for the Value data, then click OK

7. Close the Registry Editor window

9.2.30. Start Computer Browser Service (COE Security Lockdown Deviation)

For testing purposes only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Services

5. Double-click on the Computer Browser service

6. Change the Startup type to Automatic, then click Apply

7. Click on the Start button

8. Click OK

9. Close the Services window

9.2.31. Allow Administrator to Log on as Service (COE Security Lockdown Deviation)

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Domain Security Policy

5. Expand Security Settings, Local Policies, and click on User Rights Assignment

6. Double-click on Log on as service

7. Uncheck the define checkbox

8. Click OK

9. Right-click on Security Settings and select Reload

10. Close the Domain Security Policy window

11. Restart the machine

9.2.32. Restart Microsoft SQL Server Service (JMPS_SQL_SERVER)

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Services

5. Double-click on the MSSQL$JMPS_SQL_SERVER service

6. Select the Log On tab

7. Select This account and reenter the administrator username and password, then click OK

8. Right-click on the MSSQL$JMPS_SQL_SERVER service and select Restart

9. Close the Services window

9.2.33. Give System Full Control to Indexing Service, Internet Connection Sharing, Irmon, and NetMeeting Remote Desktop Sharing Services (COE Security Lockdown Deviation)

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Active Directory Users and Computers

5. Right-click on Domain Controllers and select Properties

6. Click on the Group Policy tab

7. Select the Default Domain Controllers Policy

8. Click on the Edit button

9. In the Group Policy window, expand Computer Configuration, Windows Settings, Security Settings, and select System Services

10. Double-click on Indexing Service

11. Click on the Edit Security button

12. Click on the Add button

13. Add the SYSTEM group and assign it Full Control

14. Click OK

15. Double-click on Internet Connection Sharing

16. Click on the Edit Security button

17. Click on the Add button

18. Add the SYSTEM group and assign it Full Control

19. Click OK

20. Double-click on the first Irmon

21. Click on the Edit Security button

22. Click on the Add button

23. Add the SYSTEM group and assign it Full Control

24. Click OK

25. Double-click on the second Irmon

26. Click on the Edit Security button

27. Click on the Add button

28. Add the SYSTEM group and assign it Full Control

29. Click OK

30. Double-click on NetMeeting Remote Desktop Sharing

31. Click on the Edit Security button

32. Click on the Add button

33. Add the SYSTEM group and assign it Full Control

34. Click OK

35. Close the Group Policy window

36. On the Domain Controller Properties window click OK

37. Close the Active Directory Users and Computers window

38. Click on the Start menu and select Run

39. Type in “cmd”, then click OK

40. Type “secedit /refreshpolicy machine_policy /enforce”, then press Enter

41. Type “exit”, then press Enter

9.2.34. Import JMPS_COE_FIX.inf Security Template File (COE Security Lockdown Deviation)

1. Obtain the JMPS_COE_FIX.inf template file from Ted Squilanti or Michael E. Chiang

2. Log in as the administrator

3. Copy the JMPS_COE_FIX.inf file to C:\WINNT\security\templates\

4. Click on the Start menu, go to Settings, and select Control Panel

5. Double-click on Administrative Tools

6. Double-click on Domain Controller Security Policy

7. Right-click on Security Settings and select Import Policy

8. Select JMPS_COE_FIX.inf and click on Open

9. Right-click on Security Settings and select Reload

10. Close the Domain Controller Security Policy window

11. Click on the Start menu and select Run

12. Type in “cmd”, then click OK

13. Type “secedit /refreshpolicy machine_policy /enforce”, then press Enter

14. Type ‘exit”, then press Enter

9.2.35. Apply Task Scheduler and Event Viewer Fix (COE Security Lockdown Deviation)

1. Log in as the administrator

2. Click on the Start menu, go to Settings, select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Domain Security Policy

5. Expand Security Settings, and click on File System

6. Delete any %SystemRoot%\system32\mmc.exe and %SystemRoot%\Tasks\ entries

7. Close the Domain Security Policy window

8. Double-click on Domain Controller Security Policy

9. Expand Security Settings, and click on File System

10. Delete any duplicate entries for %SystemRoot%\system32\mmc.exe and %SystemRoot%\Tasks\ (i.e. Make sure there is only one entry for mmc.exe and Tasks)

11. Double-click on %SystemRoot%\system32\mmc.exe

12. Click on the Edit Security button

13. Click on the Add button

14. Select the JmpsAdministrator, JmpsDataBaseAdministrator, JmpsMissionPlanner, and JmpsSecurityAdministrator groups, then click OK

15. Make sure the JMPS groups have the Read and Execute permissions

16. Click OK

17. Click OK

18. Double-click on %SystemRoot%\Tasks\

19. Click on the Edit Security button

20. Click on the Add button

21. Select the JmpsAdministrator group, then click OK

22. For the JmpsAdministrator group, check the Full Control checkbox

23. Click OK

24. Click OK

25. Close the Domain Controller Security Policy window

26. Click on the Start menu and select Run

27. Type in “cmd”, then click OK

28. Type “secedit /refreshpolicy machine_policy /enforce”, then press Enter

29. Type ‘exit”, then press Enter

9.2.36. Set COM Default Authentication Level to (None)

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. In the right windowpane double-click on Computers

6. In the right windowpane right-click on My Computer and select Properties

7. Select the Default Properties tab

8. Set the Default Authentication Level to (None)

9. Click OK

10. Close the confirmation dialog that appears

11. Close the Component Services window

12. Restart the machine

9.2.37. Set Up Prerequisites for Collaboration Using Active Directory – TBD – Needs Michael Chiang

1. TBD

9.2.38. Create Domain JMPS Users and Groups (Optional) – TBD – Needs Michael Chiang or Dan Webb

1. TBD

9.2.39. Set Up Roaming Profiles for Users Running Server Walkaway (Optional) – TBD – Needs Michael Chiang

1. TBD

9.2.40. Install Roxio Easy CD Creator and DirectCD for Machines with CD-writers – Requires Easy CD Creator and DirectCD Install CD

1. Log in as the administrator

2. Insert the Roxio Easy CD Creator and DirectCD Install CD

3. Go to the CD drive and double-click on Setup.exe

4. Click Next on the welcome screen

5. Select Custom, then click Next

6. Click on the Change button

7. Change the path to D:\Program Files\Adaptec\Easy CD Creator 5\, then click OK

8. Click Next

9. Click Install

10. When the install is finished, click on the Finish button

11. Click Yes to restart the machine

12. Remove the Roxio Easy CD Creator and DirectCD install CD

9.2.41. Install WinZip (Optional)

1. Log in as the administrator

2. Insert the WinZip install CD

3. Click on the Start menu and select Run

4. Click on the Browse button

5. Navigate to the WinZip install file called “winzip.exe” and double-click it

6. Click on the OK button to begin the installation

7. Install to the D: partition

8. Select WinZip Classic

9. Select Express Setup

10. When the install is complete, close all the WinZip windows

11. Remove the WinZip install CD

9.2.42. Install SQL Query Analyzer (Optional) – Requires SQL Server 2000 CD

1. Log in as the administrator

2. Insert the install CD for any version of Microsoft SQL Server 2000

3. If the install window doesn’t automatically appear, then go to the CD drive and double-click on Setup.exe or autorun.exe

4. Click on SQL Server 2000 Components

5. Click on Install Database Server

6. Click Next on the welcome screen

7. Select Local Computer, then click Next

8. Select Create a new instance of SQL Server, or install Client Tools, then click Next

9. Enter “JMPS” in the Name field and “Northrop Grumman IT” in the Company field, then click Next

10. Click Yes to accept the agreement

11. Enter the CD Key, then click Next

12. Select Client Tools Only, then click Next

13. In the Components section select Management Tools

14. In the Sub-Components section uncheck Enterprise Manager, Profiler, DTC Client Support, and Conflict Viewer

15. In the Components section uncheck Client Connectivity, Books Online, Development Tools, and Code Samples

16. Click Next

17. Click Next

18. When the install is finished, click on the Finish button

19. Remove the Microsoft SQL Server 2000 CD

9.2.43. Clear the Event Logs – TBD – Needs Michael Chiang

1. TBD

9.2.44. Defragment C:, D:, and E: Partitions (For Performance Tuning)

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Click on Disk Defragmenter

4. Select the E: partition, then click on the Defragment button

5. When the defragmentation is complete, close the confirmation dialog

6. Select the D: partition, then click on the Defragment button

7. When the defragmentation is complete, close the confirmation dialog

8. Select the C: partition, then click on the Defragment button

9. When the defragmentation is complete, close the confirmation dialog

10. Close the Computer Management window

It is recommended to make a Ghost image at this point.  Name the Ghost image “JC1Ready”.  See Appendix A for Ghosting instructions.

9.2.45. Install JC1 – Requires JC1 Install CD

1. Log on as the administrator

2. Insert the CD that contains the JC1 install files

3. Copy the CD contents to a temporary folder

4. If you have not run Microsoft Office on the machine before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

5. In the temporary folder go to the JC1 install directory (usually JC1 <build no>\JMPS, or JMPS), then double-click on setup

6. On the splash screen click Next

7. On the agreement screen select the “I accept the terms in the license agreement” option, then click Next

8. On the Client vs Server screen select Server, then click Next

9. On the COE Security Settings screen select Yes, then click Next

10. On the Setup Type screen select Custom, then click Next

11. On the Custom Setup screen make sure the Install to: field is “D:\Program Files\JMPS\”, then click Next

12. On the Ready to Install screen click Install

13. Wait for the installation to finish, then the wizard will go directly to the JC1 Data Install

14. On the splash screen click Next

15. On the Setup Type screen select Custom, then click Next

16. On the Custom Setup screen make sure the Install to: field is “E:\data\”, then click Next

17. On the Ready to Install screen click Install

18. Wait for the installation to finish.  A digital signature message may appear several times.  Click Yes on all of them

19. On the Setup Complete screen click Finish

20. Click Finish again

21. Click on Yes restart the machine

9.2.46. Install Mission Binders Repository – Requires MB Repository CD

1. Log on as the administrator

2. Insert the CD containing the Mission Binders Repository COE segment

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Mission Binders Repository Segment location (Mission Binders), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Mission Binders Version 1.0.0.7 segment

11. Click on the Available Software menu and select Install

12. On the Introduction screen click Next

13. On the Choose Install Folder screen make sure the folder path is “D:\Program Files\MissionBinder”, then click Next

14. On the Choose a Folder screen change the folder path to “E:\data\local\MissionBinder”, then click Next

15. On the Pre-Installation Summary screen click Install

16. Wait for the installation to finish, then on the Install Complete screen click Done

17. When the install is complete, click OK on the confirmation dialog

18. Click Yes to restart the machine

9.2.47. Attach MissionBinder Database

1. Log in as the administrator

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Click on the Browse button

4. Browse to “E:\data\local\MissionBinder\data\MissionBinder.MDF”

5. Click on Attach Database

6. Click OK on the confirmation dialog

7. Click on the Close button

9.2.48. Configure JMPS COM+ Application - JMPSUpDataServer

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. Expand Component Services, Computers, My Computers, and click on COM+ Applications

6. In the right windowpane right-click on JMPSUpDataServer and select Properties

7. Click on the Identity tab

8. Select the This user: radio button

9. Click on the Browse button

10. Select the local administrator

11. Enter the administrator password for the password fields

12. Click on the OK button

9.2.49. Install JMPS-Framework and JMPS-Framework-Data COE Segments – Requires CD with JMPS-Framework COE Segments (COE Security Lockdown Deviation)

Relaxes Task Scheduler lockdown to allow JMPS groups to schedule tasks and relaxes Event Viewer lockdown to allow JMPS groups to view the event logs

1. Log in as the administrator

2. Insert the CD containing the JMPS-Framework COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMPS-Framework Segments location, then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the JMPS-Framework Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Check the JMPS-Framework-Data Version 4.6.0.1 segment

14. Click on the Available Software menu and select Install

15. When the install is complete, click OK on the confirmation dialog

9.2.50. Install VBScript 5.6 Patch for TOLD

1. Log on as the administrator

2. Go to D:\Program Files\JMPS\Setup\Scripts\

3. Double-click on scripten.exe

4. Click Yes on the confirmation dialog

5. Click Yes for the license agreement

6. Click OK on the confirmation dialog after the update is completed

7. Click Yes to restart the machine

9.2.51. Server Walkaway Fix – Use the Administrator to Run JMPSPublisher Service

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. In the left windowpane, expand Services and Applications

4. In the left windowpane, click on Services

5. In the right windowpane, right-click on JMPSPublisher and select Properties

6. Change the Startup type to Automatic

7. Click on the Log On tab

8. Select “This account”

9. Browse to the “administrator” user

10. Enter the administrator password

11. Click on the OK button

12. In the right windowpane, right-click on JMPSPublisher and select Start

13. Close the Computer Management window

9.2.52. Apply Additional Security Lockdown Policies (Security Lockdowns)

1. Log in as the administrator

2. Click on the Start menu, go to Settings, select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Domain Controller Security Policy

5. Right-click on Security Settings and select Import Policy

6. Select “JMPS.inf” and click on Open

7. Right-click on Security Settings and select Reload

8. Right-click on Security Settings and select Import Policy

9. Select “COEJMPSBasicAuditPolicy.inf” and click on Open

10. Right-click on Security Settings and select Reload

11. Right-click on Security Settings and select Import Policy

12. Select “COEJMPSSecurityPolicy.inf” and click on Open

13. Right-click on Security Settings and select Reload

14. Right-click on Security Settings and select Import Policy

15. Select “JMPS_files.inf” and click on Open

16. Right-click on Security Settings and select Reload

17. Close the Domain Controller Security Policy window

18. Double-click on Domain Security Policy

19. Right-click on Security Settings and select Import Policy

20. Select “JMPS.inf” and click on Open

21. Right-click on Security Settings and select Reload

22. Right-click on Security Settings and select Import Policy

23. Select “COEJMPSBasicAuditPolicy.inf” and click on Open

24. Right-click on Security Settings and select Reload

25. Right-click on Security Settings and select Import Policy

26. Select “COEJMPSSecurityPolicy.inf” and click on Open

27. Right-click on Security Settings and select Reload

28. Right-click on Security Settings and select Import Policy

29. Select “JMPS_files.inf” and click on Open

30. Right-click on Security Settings and select Reload

31. Close the Domain Security Policy window

32. Close the Administrative Tools window

33. Restart the machine

9.2.53. Apply User Rights Assignments Settings and DACL Security Settings (Security Lockdowns)

1. See Appendix H – Apply User Rights Assignments Settings on Domain Controller and Appendix I – Apply DACL Security Settings
9.2.54. Apply MSDE Security Lockdowns (Security Lockdowns)

1. Log in as a domain JMPS Security Administrator

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Select the MSDE Security tab

4. Click on the Add button

5. In the dropdown list select the appropriate domain name

6. Select the JmpsAdministrator, JmpsDataBaseAdministrator, JmpsMissionPlanner, and JmpsSecurityAdministrator groups, then click on the Add button

7. Click on the OK button

8. Select the BUILTIN\Users group, then click on the Remove button

9. Click on the Apply Security button

10. Close the JMPS Database Administration Tool

9.2.55. Set Up E-mail Notification for Server Walkaway Errors (Optional)

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit” then click on the OK button

4. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\JMPS\

5. In the right windowpane right-click on AlertAdminEmailAddress and select Modify

6. Enter the e-mail address of the user that you want the errors to be sent to.  You may enter multiple e-mail addresses by separating them with semicolons.  Click on the OK button

7. Close the Registry Editor

9.2.56. Set Event Log Files to Overwrite as Needed (Only if Security Lockdowns not applied)

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Expand the Event Viewer

4. For Application, Security, and System, right-click on the event log and select Properties

5. Select Overwrite as needed, then click OK

6. Close the Computer Management window

9.2.57. Running JC1

1. Log onto the machine as an administrator

2. If you have not run Microsoft Office with the current user before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

3. Launch JMPS

4. A DAFIF expiration message may appear.  Click OK to acknowledge the message and continue to run JC1

9.2.58. Set Up Collaboration Using Active Directory (Optional)

1. Log on as a domain user that is a member of the following groups

a. Administrators (local)

b. JmpsAdministrator (domain)

c. JmpsSecurityAdministrator (domain)

d. JmpsMissionPlanner (domain)

2. Launch JC1

3. Click on the Options menu and select Collaboration Settings

4. In the Collaboration section check the Enabled checkbox

5. In the Pre-Approved Users section select Active Directory

6. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is “LDAP://CN=JmpsCollaboration, CN=Users”

b. The end of the string is determined by the full Domain name

i. For example, if the domain name is “Test.JC1.domain.com”, then the end of the string will be “, DC=Test, DC=JC1, DC=domain, DC=com”

c. So the entire string for the example above will be:              “LDAP://CN=JmpsCollaboration, CN=Users, DC=Test, DC=JC1, DC=domain, DC=com”

7. Click on the OK button

8. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 5 through 7

9. In the Session List section select Active Directory

10. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is determined by the Organizational Unit created on the Domain Controller

i. For example, if the Organizational Unit was named “JMPS” and the Shared Folder in it was named “CollabSessionList”, then the beginning of the string will be “LDAP://CN=CollabSessionList, OU=JMPS”

b. The end of the string is determined by the full Domain name.  Same as in step 6b

c. So the entire string for the example above will be:              “LDAP://CN=CollabSessionList, OU=JMPS, DC=Test, DC=JC1, DC=domain, DC=com”

11. Click on the OK button

12. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 9 through 11

13. Click on the OK button

9.3. COE Separate JMPS Server Instructions

9.3.1. Install Windows 2000 Server or Advanced Server – Requires Windows 2000 Server or Advanced Server CD – TBD – Needs Dan Webb

1. TBD

9.3.2. Install Drivers – Requires Drivers CD

1. Right-click on My Computer and select Properties

2. Select the Hardware tab

3. Click on Device Manager

4. Install all the drivers that you need.  Do not install any applications!

5. Restart the machine

6. Log in as the administrator

7. Right-click on the desktop and select Properties

8. Select the Settings tab

9. Set the display to at least 1024 x 768, True Color (24 bit).  For LCD screens the Native Resolution is recommended.

10. Click on Advanced

11. Select the Monitor tab

12. Set the refresh rate to be at least 75Hz for CRTs and 60Hz for LCDs

13. Click OK.  Confirm any dialogs that appear.

14. Close all the windows and restart the machine.

9.3.3. Change Date and Time Settings

1. Log in as the administrator

2. Double-click on the time in the system tray in the bottom-right corner

3. Set the date and time

4. Click on the Time Zone tab

5. Select your time zone

6. Uncheck the Automatically adjust clock for daylight saving changes (This will prevent incorrect time changes when restoring the Ghost image)

7. Click OK

9.3.4. Install MSMQ – Requires Windows 2000 Server or Advanced Server CD

1. Log in as the administrator

2. Make sure the Windows 2000 Server or Advanced Server CD is inserted

3. Uncheck show this screen at startup

4. Go to Start -> Settings -> Control Panel -> Add/Remove programs

5. Click on Add/Remove Windows Components

6. Check Message Queuing Services in the Windows Components Window

7. Make sure the Indexing Service is also checked

8. Click Next

9. If the Windows Components wizard displays, select Independent client and Message Queuing will not access a directory service

10. Click Finish when it is done installing

11. Close all the windows and remove the Windows 2000 CD

9.3.5. Install FTP Server – Requires Windows 2000 Server or Advanced Server CD – TBD – Needs Dan Webb

1. TBD

9.3.6. Install Microsoft SQL Server 2000 Enterprise Edition – Requires Microsoft SQL Server 2000 Enterprise Edition CD – TBD – Needs Dan Webb

1. TBD

9.3.7. Create Programs (D:), Data (E:) partitions, and optionally the Ghost (G:) partition

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Select Disk Management

4. For any drive assigned to D, E, or G, right-click on the drive and select Change Drive Letter and Path

5. Click on Edit

6. Change the Drive letter to any unused letter that is not D, E, or G, then click OK

7. Click Yes on the warning dialog

8. Close the Change Drive Letter and Paths dialog

9. Right-click on unallocated space and select Create Partition

10. Click Next on the intro window

11. Select Primary Partition

12. Set the partition size for the D drive to be 4096 MB

13. Make sure the drive letter is set to D

14. Make sure the file system is set to NTFS

15. Set the volume label to be Programs

16. Click Next

17. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 9 through 17

18. When the format is complete the window will display Healthy

19. Right-click on unallocated space and select Create Partition

20. Click Next on the intro window

21. Select Primary Partition

22. If you are putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size minus 8192 MB.

23. If you are not putting a Ghost partition on the same hard drive, then set the partition size for the E drive to be the maximum remaining size.

24. Make sure the drive letter is set to E

25. Make sure the file system is set to NTFS

26. Set the volume label to be Data

27. Click Next

28. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 19 through 28

29. When the format is complete the window will display Healthy

30. If you are putting a Ghost partition on the same hard drive, then right-click on unallocated space and select Create Partition

31. Click Next on the intro window

32. Select Primary Partition

33. Set the partition size for the G drive to be 8192 MB

34. Make sure the drive letter is set to G

35. Make sure the file system is set to FAT32

36. Set the volume label to be Ghost

37. Click Next

38. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 30 through 38

39. When the format is complete the window will display Healthy

40. Right-click on the C partition and select Properties

41. Type System in the Label field, then click OK

42. If you are putting a Ghost partition on a second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

43. Click Next on the intro window

44. Select Primary Partition

45. Set the partition size to be 8192 MB

46. Make sure the drive letter is set to G

47. Make sure the file system is set to FAT32

48. Set the volume label to be Ghost

49. Click Next

50. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 42 through 50

51. When the format is complete the window will display Healthy

52. If you want another partition on the second hard drive, then right-click on the unallocated space on the second hard drive and select Create Partition

53. Click Next on the intro window

54. Select Primary Partition

55. Set the partition size to be the maximum remaining size

56. Set the drive letter to be any available drive letter

57. Make sure the file system is set to NTFS

58. Set the volume label to be SpareDrive

59. Click Next

60. Click Finish to start the format – If an error message appears saying that the disk is busy, then delete the partition and recreate it using steps 52 through 60

61. When the format is complete the window will display Healthy

62. Close the Computer Management window

9.3.8. Move Swap File to Data (E:) partition

1. Right-click on My Computer and select Properties

2. Select the Advanced Tab

3. Click on Performance Options

4. Click on Change

5. For the C partition change the initial and maximum sizes to zero, then click on Set

6. Select the E partition

7. Enter a size that is twice the size of the physical memory on the machine for both the initial and maximum sizes, then click on Set.  If the swap file size is larger than 1024 MB, then it is recommended to change the initial and maximum sizes to 1024 MB.

8. Click OK

9. Click OK

10. Click OK

11. Restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “Win2KSrv”.  See Appendix A for Ghosting instructions.

Note:  The following instructions are specific to installing COE 4.6.  The instructions will be different for other versions of COE.

9.3.9. Install COE Kernel – Requires COE Kernel Install CD

1. Log on as the administrator

2. Insert the CD containing the COE Kernel installer

3. Click on the Start menu and select Run

4. Click on the Browse button

5. On the Files of type field select All Files

6. Navigate to the COE Kernel installer called “kernel.msi” and double-click it

7. Click on the OK button to begin the installation

8. Click Next

9. On the COE Kernel Setup dialog click on the Browse button

10. In the Folder name field set the path to “C:\”, then click OK

11. Verify that the path has changed to C:\

12. Click Next

13. On the Ready to Install screen click Next

14. For the Secman password use “Security12$”, then click OK

15. For the Keyman password use “Security12$”, then click OK

16. On the dialog that asks if you want to Enable APM Authentication click on the Yes button.  (This dialog may be hidden behind the installation status window.)

17. Set the APM Authentication Key – get this from your Lab Manager

18. When the install is finished, click on the Finish button

19. Click Yes to restart the machine

All of the COE Segment installs require the COE Segments CD

9.3.10. Install COE Kernel Patch Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Click on the Start menu and while holding the Ctrl key, drag and drop the DII Installer onto the desktop

4. Double-click on DII Installer on the desktop

5. Enter the APM Authentication password, then click OK

6. Click on the File menu and select Select Target drive

7. Set the target to C:\, then click OK

8. Click on the File menu and select Select Source drive

9. Browse to the COE Kernel Patch Segment location (K42PX_4.2.0.0P8), then click OK

10. Click on the File menu and select Read Table of Contents

11. Check the COE Kernel 4.2 Patch Version 4.2.0.0P8 segment

12. Click on the Available Software menu and select Install

13. When the install is complete, click OK on the confirmation dialog

14. Click Yes to restart the machine

9.3.11. Install Windows 2000 Patch COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Windows 2000 Patch Segment location (W2KPTH), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the W2K Patch Update Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. A dialog will appear telling you to answer No to any prompts asking you to restart the machine

16. Click OK to continue the patch installation

17. Click No when the restart prompt appears

18. Click OK to run the hotfix installer

19. When the hotfix install is complete, click OK on the confirmation dialog

20. Click No when the restart prompt appears

21. The patch install will finish and restart the machine automatically

9.3.12. Install Java Platform 2 COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Platform 2 Segment location (JAVA2), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Java Platform 2 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.3.13. Install COE Update System Security Level Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Update System Security Level Segment location (UPDTSL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Update System Security Level Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. On the Security Level Manager dialog, leave the server type as Local

13. Set the classification to be the highest classification assigned to the machine

14. Check Allow Temporary Override

15. Click on OK

16. When the install is complete, click OK on the confirmation dialog

9.3.14. Install COE Security Banner Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the COE Security Banner Segment location (SECBNR), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the COE Security Banner Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.3.15. Install JMTK Utilities COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMTK Utilities Segment location (JMTK), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check only the JMTK Utilities Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.3.16. Install Microsoft Office 2000 Professional COE Segment – Requires Office 2K Pro CD

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Office 2000 Professional Segment location (OFFICE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Microsoft Office 2000 Pro Version 4.6.0.0 segment

11. Click on the Available Software menu and select Install

12. Click Yes on the confirmation dialog

13. Click OK on the restart warning dialog

14. When the install is complete, click OK on the confirmation dialog

15. Click Yes to restart the machine

16. Log back in as the administrator

17. Acknowledge the info window

18. Insert the Microsoft Office 2000 Professional CD

19. Click OK to start the install.

20. Another confirmation dialog will appear.  Do NOT click OK until the first installation is complete.

21. Follow the Microsoft Office install wizard

22. Input the CD key for Microsoft Office 2000 Professional, then click Next

23. Accept the license agreement, then click Next

24. Select Customize

25. Change the path to D:\Program Files\Microsoft Office\, then click Next

26. Click on the icon next to Microsoft Office in the upper window and select “Run all from my computer”

27. Click Install Now

28. When the install is complete, click OK on the confirmation dialog

29. Now click OK on the dialog that appeared in step 19

30. Now the installer will install all the updates.  Click No to any prompts to restart.  Click Yes to all prompts to update Office, and click OK when each update is complete.

31. The installer will automatically restart after all the updates are completed.  Remove the Microsoft Office 2000 Professional CD during the restart.

9.3.17. Install Norton Antivirus COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Norton Antivirus Segment location (NAV), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Norton Antivirus Version 4.5.3.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.3.18. Install Perl COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Perl Segment location (PERL), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Perl Version 1.0.0.4 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

9.3.19. Install Java Runtime Environment COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Java Runtime Environment Segment location (J2JRE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the J2SE JRE 1.4.1 Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

9.3.20. Install Microsoft SQL Server 2000 Enterprise Edition COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft SQL Server 2000 Enterprise Edition Segment location (SQL2KE), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the SQL Server 2000 Enterprise Edition Version 4.4.0.1 segment

11. Click on the Available Software menu and select Install

12. Click OK on the SQL Server installation check message

13. When the install is complete, click OK on the confirmation dialog

9.3.21. Install Netscape Web Browser COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Netscape Web Browser Segment location (NSWEB), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Netscape Browser Version 4.7.0.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Restart the machine

14. Log back in as the administrator

15. On the Netscape window click on the Edit menu and select Preferences

16. Uncheck “Launch automatically at system start”

17. Click OK

18. Close the Netscape window

9.3.22. Install Adobe Acrobat Reader COE Segment

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Adobe Acrobat Reader Segment location (ACRORD), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Adobe Acrobat Reader Version 4.5.1.0 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

It is recommended to make a Ghost image at this point.  Name the Ghost image “COE46”.  See Appendix A for Ghosting instructions.

9.3.23. Install MS Security Config Templates COE Segment (Security Lockdowns)

1. Log on as the administrator

2. Insert the CD containing the COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to C:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Microsoft Security Configuration Templates Segment location (W2KCET), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the MS Security Config Templates Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Click Yes to restart the machine

14. Log back in as the administrator

15. Click on the Start menu, go to Settings, and select Control Panel

16. Double-click on Administrative Tools

17. Double-click on Local Security Policy

18. Right-click on Security Settings and select Import Policy

19. Select COE_W2KCET_4601_ServerNT_Reapply.inf, then click Open

20. Right-click on Security Settings and select Reload

21. Expand Security Settings, Local Policies and click on Security Options

22. In the right windowpane double-click on Allow machine policy to automatically update during logon

23. Enable the policy, then click OK

24. Close the Local Security Policy window

25. Restart the computer

9.3.24. Change DisablePasswordChange Registry Key (COE Security Lockdown Deviation)

For Ghosting only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit”, then click OK

4. Expand My Computer, HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, Netlogon, and click on Parameters

5. Double-click on DisablePasswordChange

6. Enter 1 for the Value data, then click OK

7. Close the Registry Editor window

9.3.25. Start Computer Browser Service (COE Security Lockdown Deviation)

For testing purposes only – no Waiver request

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Services

5. Double-click on the Computer Browser service

6. Change the Startup type to Automatic, then click Apply

7. Click on the Start button

8. Click OK

9. Close the Services window

9.3.26. Restart Microsoft SQL Server Service (JMPS_SQL_SERVER)

1. Make sure 9.2.31 - Allow Administrator to Log on as Service (COE Security Lockdown Deviation) is completed on the Domain Controller first.

2. Log in as the administrator

3. Click on the Start menu, go to Settings, and select Control Panel

4. Double-click on Administrative Tools

5. Double-click on Services

6. Double-click on the MSSQL$JMPS_SQL_SERVER service

7. Select the Log On tab

8. Select This account and reenter the administrator username and password, then click OK

9. Right-click on the MSSQL$JMPS_SQL_SERVER service and select Restart

10. Close the Services window

9.3.27. Set COM Default Authentication Level to (None)

1. Log on as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. In the right windowpane double-click on Computers

6. In the right windowpane right-click on My Computer and select Properties

7. Select the Default Properties tab

8. Set the Default Authentication Level to (None)

9. Click OK

10. Close the confirmation dialog that appears

11. Close the Component Services window

12. Restart the machine

9.3.28. Create Local JMPS Users and Groups (Optional)

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Local Users and Groups

4. Click on Groups

5. Right-click on Groups and select New Group

6. Create the following groups

a. JmpsAdministrator

b. JmpsCollaboration

c. JmpsDataBaseAdministrator

d. JmpsDowngradePrintedOutputClassification

e. JmpsMissionPlanner

f. JmpsSecurityAdministrator

7. Click on the Close button

8. Click on Users

9. Right-click on Users and select New User

10. Create the users that you need

a. Make sure you fill in the Full name field

b. Uncheck User must change password at next logon (COE Deviation)

c. Check Password never expires (COE Deviation)

11. Click on Groups

12. Double-click on each group and add the appropriate users to each group

13. Close the Computer Management window

9.3.29. Configure IP Settings (For machines with IP addresses)

1. Get the IP settings from your Lab Manager

2. Log on as the administrator

3. Right-click on My Network Places and select Properties

4. Right-click on Local Area Connection and select Properties

5. Select Internet Protocol (TCP/IP) and click on the Properties button

6. Select Use the following IP address, and enter the IP settings for the machine

7. Select Use the following DNS server addresses, and enter the address of the DNS server

8. Click OK on the Internet Protocol (TCP/IP) Properties dialog

9. Click OK on the Local Area Connection Properties

10. Close the Network and Dial-up Connections window

9.3.30. Join the Domain – Domain Controller must be set up first

This step is highly recommended if the machine is going to be on a domain!

1. Log on as the administrator

2. Right-click on My Computer and select Properties

3. Select the Network Identification tab

4. Click on Properties

5. In the Member of section select Domain

6. Type in the domain name that you are joining – Get this from your Lab Manager

7. Type in the domain administrator username and password – Only your Lab Manager should know this

8. Close the welcome message

9. Click OK

10. Click OK

11. Click Yes to restart the machine

9.3.31. Add Domain Users to Local Groups If Necessary (Optional) – DC must be set up first

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Local Users and Groups

4. Double-click on the group that you want to add a domain user to

5. Click on Add

6. In the Look in: field select the domain

7. Select the user(s) you want to add to this group, then click Add

8. Click OK

9. Click OK

10. Repeat steps 4 through 9 for all the groups you want to add domain users to

11. Close the Computer Management window

9.3.32. Install Roxio Easy CD Creator and DirectCD for Machines with CD-writers – Requires Easy CD Creator and DirectCD Install CD

1. Log in as the administrator

2. Insert the Roxio Easy CD Creator and DirectCD Install CD

3. Go to the CD drive and double-click on Setup.exe

4. Click Next on the welcome screen

5. Select Custom, then click Next

6. Click on the Change button

7. Change the path to D:\Program Files\Adaptec\Easy CD Creator 5\, then click OK

8. Click Next

9. Click Install

10. When the install is finished, click on the Finish button

11. Click Yes to restart the machine

12. Remove the Roxio Easy CD Creator and DirectCD install CD

9.3.33. Install WinZip (Optional) – Requires WinZip CD

1. Log in as the administrator

2. Insert the WinZip install CD

3. Click on the Start menu and select Run

4. Click on the Browse button

5. Navigate to the WinZip install file called “winzip.exe” and double-click it

6. Click on the OK button to begin the installation

7. Install to the D: partition

8. Select WinZip Classic

9. Select Express Setup

10. When the install is complete, close all the WinZip windows

11. Remove the WinZip install CD

9.3.34. Install WinDiff (Optional) – Requires Windows 2000 Server or Advanced Server CD

1. Log in as the administrator

2. Insert the Windows 2000 Server or Advanced Server CD

3. Navigate to E:\Support\Tools\

4. Double-click on Setup.exe

5. Click Next

6. Enter “Associate” in the Name field and “Northrop Grumman IT” in the Organization field, then click Next

7. Select Custom, then click Next

8. Click on the Browse button

9. Change the Selected Path to D:\Program Files\Support Tools\, then click OK

10. Click Next

11. Click Next

12. When the install is finished, click on the Finish button

13. Remove the Windows 2000 Server or Advanced Server CD

9.3.35. Clear the Event Logs

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Expand Event Viewer

4. Right-click on Application and select Clear all Events

5. Click No when it asks you if you want to save the log

6. Right-click on Security and select Clear all Events

7. Click No when it asks you if you want to save the log

8. Right-click on System and select Clear all Events

9. Click No when it asks you if you want to save the log

10. Close the Computer Management window

9.3.36. Defragment C:, D:, and E: Partitions (For Performance Tuning)

1. Log on as the administrator

2. Right-click on My Computer and select Manage

3. Click on Disk Defragmenter

4. Select the E: partition, then click on the Defragment button

5. When the defragmentation is complete, close the confirmation dialog

6. Select the D: partition, then click on the Defragment button

7. When the defragmentation is complete, close the confirmation dialog

8. Select the C: partition, then click on the Defragment button

9. When the defragmentation is complete, close the confirmation dialog

10. Close the Computer Management window

It is recommended to make a Ghost image at this point.  Name the Ghost image “JC1Ready”.  See Appendix A for Ghosting instructions.

9.3.37. Install JC1 – Requires JC1 Install CD

1. Log on as the administrator

2. Insert the CD that contains the JC1 install files

3. Copy the CD contents to a temporary folder

4. If you have not run Microsoft Office on the machine before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

5. In the temporary folder go to the JC1 install directory (usually JC1 <build no>\JMPS, or JMPS), then double-click on setup

6. On the splash screen click Next

7. On the agreement screen select the “I accept the terms in the license agreement” option, then click Next

8. On the Client vs Server screen select Server, then click Next

9. On the COE Security Settings screen select Yes, then click Next

10. On the Setup Type screen select Custom, then click Next

11. On the Custom Setup screen make sure the Install to: field is “D:\Program Files\JMPS\”, then click Next

12. On the Ready to Install screen click Install

13. Wait for the installation to finish, then the wizard will go directly to the JC1 Data Install

14. On the splash screen click Next

15. On the Setup Type screen select Custom, then click Next

16. On the Custom Setup screen make sure the Install to: field is “E:\data\”, then click Next

17. On the Ready to Install screen click Install

18. Wait for the installation to finish.  A digital signature message may appear several times.  Click Yes on all of them

19. On the Setup Complete screen click Finish

20. Click Finish again

21. Click on Yes restart the machine

9.3.38. Install Mission Binders Repository – Requires MB Repository CD

1. Log on as the administrator

2. Insert the CD containing the Mission Binders Repository COE segment

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the Mission Binders Repository Segment location (Mission Binders), then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the Mission Binders Version 1.0.0.7 segment

11. Click on the Available Software menu and select Install

12. On the Introduction screen click Next

13. On the Choose Install Folder screen make sure the folder path is “D:\Program Files\MissionBinder”, then click Next

14. On the Choose a Folder screen change the folder path to “E:\data\local\MissionBinder”, then click Next

15. On the Pre-Installation Summary screen click Install

16. Wait for the installation to finish, then on the Install Complete screen click Done

17. When the install is complete, click OK on the confirmation dialog

18. Click Yes to restart the machine

9.3.39. Attach MissionBinder Database

1. Log in as the administrator

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Click on the Browse button

4. Browse to “E:\data\local\MissionBinder\data\MissionBinder.MDF”

5. Click on Attach Database

6. Click OK on the confirmation dialog

7. Click on the Close button

9.3.40. Configure JMPS COM+ Application - JMPSUpDataServer

1. Log in as the administrator

2. Click on the Start menu, go to Settings, and select Control Panel

3. Double-click on Administrative Tools

4. Double-click on Component Services

5. Expand Component Services, Computers, My Computers, and click on COM+ Applications

6. In the right windowpane right-click on JMPSUpDataServer and select Properties

7. Click on the Identity tab

8. Select the This user: radio button

9. Click on the Browse button

10. Select the local administrator

11. Enter the administrator password for the password fields

12. Click on the OK button

9.3.41. Install JMPS-Framework and JMPS-Framework-Data COE Segments – Requires CD with JMPS-Framework COE Segments (COE Security Lockdown Deviation)

Relaxes Task Scheduler lockdown to allow JMPS groups to schedule tasks and relaxes Event Viewer lockdown to allow JMPS groups to view the event logs.  If you want the domain users to have access to the task scheduler and event viewer, you must install these segments as a domain user.

1. If the machine is intended to be on the domain, then log in as a domain user that is also a local administrator.  Otherwise, log in as the administrator.

2. Insert the CD containing the JMPS-Framework COE segments

3. Double-click on DII Installer on the desktop

4. Enter the APM Authentication password, then click OK

5. Click on the File menu and select Select Target drive

6. Set the target to D:\, then click OK

7. Click on the File menu and select Select Source drive

8. Browse to the JMPS-Framework Segments location, then click OK

9. Click on the File menu and select Read Table of Contents

10. Check the JMPS-Framework Version 4.6.0.1 segment

11. Click on the Available Software menu and select Install

12. When the install is complete, click OK on the confirmation dialog

13. Check the JMPS-Framework-Data Version 4.6.0.1 segment

14. Click on the Available Software menu and select Install

15. When the install is complete, click OK on the confirmation dialog

9.3.42. Install VBScript 5.6 Patch for TOLD

1. Log on as the administrator

2. Go to D:\Program Files\JMPS\Setup\Scripts\

3. Double-click on scripten.exe

4. Click Yes on the confirmation dialog

5. Click Yes for the license agreement

6. Click OK on the confirmation dialog after the update is completed

7. Click Yes to restart the machine

9.3.43. Server Walkaway Fix – Use the Administrator to Run JMPSPublisher Service

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. In the left windowpane, expand Services and Applications

4. In the left windowpane, click on Services

5. In the right windowpane, right-click on JMPSPublisher and select Properties

6. Change the Startup type to Automatic

7. Click on the Log On tab

8. Select “This account”

9. Browse to the local “administrator” user

10. Enter the local administrator password

11. Click on the OK button

12. In the right windowpane, right-click on JMPSPublisher and select Start

13. Close the Computer Management window

9.3.44. Apply DACL Security Settings (COE Security Lockdown Deviation)

1. See Appendix I – Apply DACL Security Settings
9.3.45. Apply MSDE Security Lockdowns (Security Lockdowns)

1. Log in as a domain JMPS Security Administrator

2. Click on the Start menu, go to Programs, JMPS Admin, and select DB Maintenance

3. Select the MSDE Security tab

4. Click on the Add button

5. In the dropdown list select the appropriate domain name

6. Select the JmpsAdministrator, JmpsDataBaseAdministrator, JmpsMissionPlanner, and JmpsSecurityAdministrator groups, then click on the Add button

7. Click on the OK button

8. Select the BUILTIN\Users group, then click on the Remove button

9. Click on the Apply Security button

10. Close the JMPS Database Administration Tool

9.3.46. Set Up Active Directory Schemas on the Domain Controller for Server Walkway (If not already set up)

1. See 9.2.9
9.3.47. Set Up E-mail Notification for Server Walkaway Errors (Optional)

1. Log on as the administrator

2. Click on the Start menu and select Run

3. Type in “regedit” then click on the OK button

4. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\JMPS\

5. In the right windowpane right-click on AlertAdminEmailAddress and select Modify

6. Enter the e-mail address of the user that you want the errors to be sent to.  You may enter multiple e-mail addresses by separating them with semicolons.  Click on the OK button

7. Close the Registry Editor

9.3.48. Set Event Log Files to Overwrite as Needed (Only if Security Lockdowns not applied)

1. Log in as the administrator

2. Right-click on My Computer and select Manage

3. Expand the Event Viewer

4. For Application, Security, and System, right-click on the event log and select Properties

5. Select Overwrite as needed, then click OK

6. Close the Computer Management window

9.3.49. Running JC1

1. Log onto the machine as an administrator

2. If you have not run Microsoft Office with the current user before, it is recommended that you do so.  Run an Office application such as Word.  You might need the Microsoft Office CD if it asks for it.

3. Launch JMPS

4. A DAFIF expiration message may appear.  Click OK to acknowledge the message and continue to run JC1

9.3.50. Set Up Collaboration Using Active Directory (Optional) – DC must be set up first

1. Log on as a domain user that is a member of the following groups

a. Administrators (local)

b. JmpsAdministrator (domain)

c. JmpsSecurityAdministrator (domain)

d. JmpsMissionPlanner (domain)

2. Launch JC1

3. Click on the Options menu and select Collaboration Settings

4. In the Collaboration section check the Enabled checkbox

5. In the Pre-Approved Users section select Active Directory

6. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is “LDAP://CN=JmpsCollaboration, CN=Users”

b. The end of the string is determined by the full Domain name

i. For example, if the domain name is “Test.JC1.domain.com”, then the end of the string will be “, DC=Test, DC=JC1, DC=domain, DC=com”

c. So the entire string for the example above will be:              “LDAP://CN=JmpsCollaboration, CN=Users, DC=Test, DC=JC1, DC=domain, DC=com”

7. Click on the OK button

8. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 5 through 7

9. In the Session List section select Active Directory

10. In the dialog that appears type in the appropriate LDAP string

a. The beginning of the string is determined by the Organizational Unit created on the Domain Controller

i. For example, if the Organizational Unit was named “JMPS” and the Shared Folder in it was named “CollabSessionList”, then the beginning of the string will be “LDAP://CN=CollabSessionList, OU=JMPS”

b. The end of the string is determined by the full Domain name.  Same as in step 6b

c. So the entire string for the example above will be:              “LDAP://CN=CollabSessionList, OU=JMPS, DC=Test, DC=JC1, DC=domain, DC=com”

11. Click on the OK button

12. Click on the Test button to make sure the settings are correct.  If not, then repeat steps 9 through 11

13. Click on the OK button

10. Appendix A – Using Norton Ghost(
Norton Ghost( allows you to capture an image of selected partitions of a hard drive or the entire hard drive.  We will use Norton Ghost( to capture an image of a clean configuration so that we can restore that image to get the machine back to a clean state.  This saves time by not having to reinstall everything from scratch.

We will discuss two ways to use Norton Ghost( to capture images.  The first way is to capture selected partitions and store the image onto another partition on the same hard drive.  The second way is to capture the entire hard drive and store the image onto a separate hard drive.  This is assuming a Ghost boot floppy has been already made.

10.1. Capturing selected partitions and storing the image onto another partition on the same hard drive

1. Insert the Norton Ghost( boot floppy and restart the machine

2. Select Local -> Partition -> To Image

3. Select the first Drive as the Source

4. Select Part 1, 2, and 3 as Source (to image C, D, and E partitions)

5. In the Look in field select the Ghost partition

6. Type in an appropriate name for the Ghost image

7. Use High compression

8. Select Yes to proceed with the Ghost image creation

9. When the Ghost image creation is complete, remove the floppy and restart the machine

10.2. Restoring the Ghost image of the selected partitions

1. Insert the Norton Ghost( boot floppy and restart the machine

2. Select Local -> Partition -> From Image

3. In the Look in field select the Ghost partition

4. Select the Ghost image you want to restore

5. Select the first Partition as the Source

6. Select the first Drive as the Destination Drive

7. Select the first Partition as the Destination Partition

8. Select Yes to proceed with the Ghost image restoration

9. When the Ghost image restoration is complete, select Continue

10. Repeat steps 2 through 9 for the rest of the partitions.  (Make sure the source and destination partitions match!)
11. After the last partition is restored, remove the floppy and restart the machine

10.3. Capturing the entire drive and storing the image onto a separate hard drive

1. Insert the Norton Ghost( boot floppy and restart the machine

2. Select Local -> Disk -> To Image

3. Select the first Drive as the Source

4. In the Look in field select the Ghost partition on the second drive

5. Type in an appropriate name for the Ghost image

6. Use High compression

7. Select Yes to proceed with the Ghost image creation

8. When the Ghost image creation is complete, remove the floppy and restart the machine

10.4. Restoring the Ghost image of the entire drive

1. Insert the Norton Ghost( boot floppy and restart the machine

2. Select Local -> Disk -> From Image

3. In the Look in field select the Ghost partition on the second drive

4. Select the Ghost image you want to restore

5. Select the first Drive as the Destination

6. If a Windows NT warning message appears, ignore it and select OK

7. Accept the defaults and select OK

8. Select Yes to proceed with the Ghost image restoration

9. When the Ghost image restoration is complete, remove the floppy and restart the machine

11. Appendix B – GPS Setup

11.1. Load Maps and Imagery

Suggest loading JOG 1:250K maps and/or CIB 10-5 for the trail location.

11.2. Power Management

Log on as an administrator.

It is suggested that GPS receiver be tested with the Power Options enabled and disabled.  Start with the Power Options being disabled, especially when using a laptop.

Prior to modifying the Power Opens record the current settings so they can be restored.

My Computer ( Control Panel ( Power Options ( Power Schemes tab
Set power schemes to "always on".  Laptop default is Portable/Laptop
	Default Settings for Portable/Laptop Power Scheme

	When compute is 
	Plugged in
	Running on Batteries

	Turn off Monitor
	Never
	Never

	Turn off Hard disks
	Never
	3 hours

	System Stand By
	Never
	Never


11.3. Display Setting

It is suggested that GPS receiver be tested with the Screen Saver enabled and disabled.  Start with the Screen Saver being disabled, especially when using a laptop.

My Computer ( Control Panel ( Display ( Screen Saver ( Wait xx minutes

11.4. Test Com Port Connection

Connect the device prior to testing the com port connection.

Com Port Settings

Start (Programs( Accessories ( Communications ( HyperTerminal

Enter Name [anyname] Select OK

Modify "Connect using" to use comX (where X is the com port number).  Select OK

Set Port Settings

For eTrex the port settings are

Bits Per Second  = 4800

Parity = None

Stop bits = 1

Flow control = None

Select OK

Com Port Input 

The HyperTerminal display will display the data that is received from the device connected to the com port.  Note:  can use HyperTerminal and JMPS at the same time.

The data received may be saved to a file if needed.

11.5. GPS Receiver Settings

Set time format to coincide with JMPS time format (i.e., 12 hours vs. 24 hours)   (12 hours) 
Set lat/lon units to match JMPS lat/lon preferences to make comparison easier     (hddd.mm.mmm)

Set Map Datum to match JMPS datum preferences to make comparison easier    ( WGS84)
Set interface settings (input/output format settings) to NEMA OUT (i.e., standard NMEA 0183 version 2.0 data

11.6. JMPS Settings

JMPS Preference and verify 

Session Preferences 

Lat/Lon                    (hdd.mm.mmm)

UTM Hemisphere    (North)

Datum                      (WGE)

GPS Trail

GPS Feed = NMEA 0183

Device = ComX (where X is the comport number)

Select GPS Tool

Select Connect/Disconnect to verify port settings and GPS connection

Select Settings and verify:

Set Port Settings

For eTrex the port settings are

Bits Per Second  = 4800

Parity = None

Stop bits = 1

Flow control = None

Select OK

11.7. Getting Started

Start the computer before connecting the receiver to the computer.

Start the GPS receiver and let it sync to the satellites before connecting it to the computer. 

Get the GPS receivers time and sync it with the computer.   You may have to change the time on the computer to match the receiver.   This is important to be able to see the updates in near real time.   If the computer lags in time the GPS receiver updates will lag by the same time difference.

Connect the Receiver to the COM port and start JMPS.   Start JMPS and the GPS Tool and setup the baud rate (4800) if it's different.  The defaults should be good.

Select connect on the tool bar and your receiving data. You see an info dialog comes up. You'll also see a sampling of data stream by on the screen.  The info dialog will automatically close after 20-30 messages.   This is OK.   To see the actual GPS position data click on the vehicle ICON on the map.  You will get a formatted Info dialog with your current position. 

11.8. Saving the GPS Trail

When you think you're done recording the GPS data.  Select to Disconnect (same icon you used to connect). 

Save the GPS Trail1.gpb  file and give it a unique name.    Note the GPS Trail software is still in a receive mode.   Close the file.

Disconnect the GPS receiver from you computer.   Make sure you have saved the file and closed the file before disconnecting the receiver.   

To play back the file you created open the file and you should be able to play it back.  

11.9. Overall Observations

Real easy to use.  If it's not working something is broken. 

Receiver needs to sync up before it will work properly with the computer. 

When recording the GPS trail it's fun to see your route as you drive or fly.   Scale into at least JOG 1:250K if you driving.  If you have CIB 10-5 imagery then you'll even have more fun.  

Most important check the machine clock time is in sync with the receiver.  You can get the time from the receiver by paging through to the menu screen.  

12. Appendix C – Laptop Power Options Properties
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13. Appendix D – Configuring Windows 2000 for File Transmission through STUs

Run Hyperterminal (Start/Program/Accessories/Communications/Hyperterminal) and when this is displayed, type a name for the connection (such as ToSTU2, or whatever).  Select OK to continue.
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Check the Connect using field and ensure it is set to COM1. Select OK to continue.
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Change the Bits per second to 4800 (this is what the STU is configured for), and ensure the other settings are as shown here. Select OK to continue.
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At the terminal window, select Call from the pull-down menu and Disconnect. 
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From the terminal window displayed above, select File from the pull-down menu and select Properties. Select the Settings tab and change Emulation to VT100 as shown. Then select the ASCII button.
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At the ASCII setup window, enable the top two options, Send line ends with line feeds and Echo typed characters locally as shown here. Select OK to continue.
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Select OK again at the properties window to return to the terminal windows. You are now ready to place the call from STU 1 to STU 2 and when voice connection is made, STU 1 operator should initiate going to security mode and then switching to Data in order to proceed with the file transmission test.

14. Appendix E – OIDs and What They Are

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netdir/ad/object_identifiers.asp
 

Object Identifiers (OIDs) are unique numeric values, issued by various "Issuing Authorities" to uniquely identify data elements, syntaxes, and various other parts of distributed applications. OIDs are found in OSI applications, X.500 Directories, SNMP, and other applications where uniqueness is important. OIDs are based on a tree structure, in which a superior issuing authority (such as the ISO) allocates a "branch" of the tree to a subauthority, who in turn can allocate subbranches.

  

Get an OID from Microsoft Corporation:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netdir/ad/obtaining_an_object_identifier_from_microsoft.asp
 

Object Identifiers (OIDs) can be obtained from, and registered with Microsoft by going to the following URL:

 

http://msdn.microsoft.com/certification/ad-registration.asp
 

Click on "please register now". On the Registration page, read the instructions, and then fill out the form for registering your OID. If you want Microsoft to generate the OID for you, simply leave blank that entry on the form.

 

No matter what source is used to get the OID, if you intend to extend the Active Directory schema and wish to apply for the Certified for Windows logo, you must register your OID with Microsoft. 

 

If a base OID is obtained, some care should be used in designing how the OIDs should be divided into categories, since these OIDs are contained in the prefix table and are part of the DC replication data. It is recommended that no more than two OID categories be created.

 

For example, if you were assigned the base OID of 1.2.840.113556.1.8000.586, you might create categories in the following manner:

 

a) For Application Attributes:

1.2.840.113556.1.8000.586.1.1
(for 1st custom attribute)

1.2.840.113556.1.8000.586.1.2
(for 2nd
custom attribute)

1.2.840.113556.1.8000.586.1.3
(for 3rd custom attribute)

and so on….




b) For Application Classes:

1.2.840.113556.1.8000.586.2.1
(for 1st custom class)

1.2.840.113556.1.8000.586.2.2
(for 2nd custom class)

1.2.840.113556.1.8000.586.2.3
(for 3rd custom class)

and so on…

Something you may want to consider, is to replicate these attributes in the Global Catalog, or to Index them. Both of these actions come at a cost, but improve the search performance for often accessed attributes. If you right click on the attribute you just created you will see these options made available to you.
15. Appendix F – New Secman and Keyman User Accounts on a COE Domain Controller

These instructions are derived from the document titled, Instructions for creating and configuring new secman and keyman user accounts on a COE enable Windows 2000 Domain Controller, dated April 22, 2003, written by Ted Squilanti.
Instructions for creating and configuring new secman and keyman user accounts on a COE enabled Windows 2000 Domain Controller

Overview

This instruction walks a user through the steps involved in creating and configuring new secman and keyman like user accounts on a COE enabled Windows 2000 Domain Controller.

During COE kernel installation, an attempt is made to create these two management user accounts locally (secman and keyman).  On a Windows 2000 domain Controller, the concept of a local machine isn’t the same as on a Windows 2000 Professional workstation and these accounts do not work as they should.

Effectively, what this procedure describes is the creation of two new accounts named secmandc and keymandc, which will take the place of the secman and keyman accounts respectively.  This is done due to the fact that the COE will not let us manipulate these original accounts enough, nor will it let us delete these accounts in order to make them useful.

The resulting instructions were gathered after numerous postings with the COE newsgroups, review of various COE documentation, and configuring a machine and working through the steps required. 

To create and configure new secman and keyman like accounts on a COE enabled Windows 2000 Domain Controller:

The appropriate folder needs to be shared and have its permissions modified in order for COE based account administration to work correctly.

As administrator, create a new secman-like account called secmandc.

As secmandc, assign the correct COE profile to itself in order to do allow it to do its secmandc duties.

As secmandc, create a new keyman-like account called keymandc.

As keymandc, assign the correct COE profile to itself in order to do allow it to do its keymandc duties.

This document is divided into the following sections:


Overview – An overview of the process and document.


Prerequisites – System and software requirements for this instruction.


Basic Instructions – High level instructions.


Detailed Instructions – More detailed instructions for selected steps.

Prerequisites

This instruction assumes that a Windows 2000 Server has already been created and configured as a Domain Controller.  For my testing and investigation, Windows 2000 Server was used.

This instruction also assumes that the workstation has had the COE kernel and kernel patch installed with the Account and Profile Manager (APM) enabled.  The investigation for this procedure was tested using the COE kernel version 4.2.0.5 and was tested three different times, once each for kernel patches P6, P7, and P8.  It worked identically on each patch.

High Level Instructions

Log in as Administrator.

Share and Configure the <SystemDrive>:\h\Users\Global folder

Create the secmandc user account to be used on the domain controller in place of the secman account.

Assign the "SSO Default" profile to the new secmandc user.

As the new secmandc user, create a keymandc account to be used on the domain controller in place of the keyman account

Assign the "AUTH Default" profile to the new keymandc user

Detailed Instructions

Share and Configure the <SystemDrive>:\h\Users\Global folder
In order for COE account management processing to work correctly, the <SystemDrive>:\h\Users\Global folder must be shared and Modify privilege must be given to authenticate users.

Table 4‑1 Share and Configure the <SystemDrive>:\h\Users\Global folder

	Step
	What You Do
	Installation Dialog

	1 
	Log on as Administrator.

Via the Windows Explorer, navigate to <SystemDrive>:\h\Users\Global and right mouse click on the "global" folder and select "sharing…" to bring up the "global Properties" dialog.
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	2 
	Select the "Share this folder" radio button.
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	3 
	Select the "Security" tab
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	4 
	Select "Authenticated Users"
	[image: image18.png]21|

global Properties

Generl| Shaing Secuity |

€0 adiristators UMPSICT\Adriistators)
T T— e |

€ CREATOR DWhER
€ svtem

Pemissions:

FullCanicl
Modty

Read b Execute
List Folder Corterts
Read

Wite

Advanced.

[~ Alow nheitable pemissions ffom parent to popagatetotis

e
= |






	5 
	Under Permissions, select the "Modify" checkbox and click OK.
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Create the secmandc user account

The secman user account is the one that is used to add, delete, and manage user accounts on a Account and Profile Manager (APM) enabled COE workstation.  Since this “locally created” account doesn’t work as needed on a Domain Controller, we will need to create a new account, which we will call secmandc, and configure it so that it can act just like the secman account should.

Table 4‑2 Create the secmandc user account
	Step
	What You Do
	Installation Dialog

	1 
	Via the Windows explorer, navigate to and double-click <SystemDrive>:\h\COE\Comp\Apm\bin\APM_Client.pl in order to launch the Account and Profile Manager client application.  If prompted, enter the APM authentication key and select the OK button to close the "Input" dialog.
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	2 
	The Account and Profile Manager Client application dialog should appear.
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	3 
	Select File->New Account. 

Select the "Identification" tab and set the fields as follows:

Login = secmandc, Password = some password,

Password Confirm = same password,

Full Name = Security Admin USER Account,

Manage As = domain,

Default Group = Domain Admins
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	4 
	Select the "Group" tab and add the user to the Domain Admins and Domain Users groups by double-clicking each group.
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	5 
	Select the "Profiles" tab and make the "SSO Default" profile available to the user by double-clicking it.
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	6 
	Select the "Hosts" tab and add the user to the domain controller (i.e. jmpsjc1) by double-clicking it.
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	7 
	Select the "Submit" button to create the new secmandc account.  If successful, the Status Summary dialog should be displayed with successful check marks as displayed here.

Select the Ok button to close the Status Summary dialog.  

Close the Account and Profile Manager client dialog by selecting the close (“X”) icon.

Logoff of the Administrator account.
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Assign the "SSO Default" profile to the new secmandc user

In order for the secmandc account to have the appropriate icons and/or menu items available on the desktop, the account must assign the “SSO Default” profile to itself.  Profiles are the mechanism through which the COE provides menu and icon access to its applications.

Table 4‑3 Assign the "SSO Default" profile to the new secmandc user

	Step
	What You Do
	Installation Dialog

	1 
	Logon as secmandc and, if required, change it’s password.

Dismiss the “COE Login Processing is Complete” dialog by selecting the OK button.

Select Start->Programs->COE Profile Selector to bring up the COE Profile Selector.
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	2 
	Assign the "SSO Default" profile to the user by double-clicking it.

Select the OK button to close the dialog.
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	3 
	If a "Profile Selector Results" dialog is displayed, select the "Done" button to close the dialog.

Log off secmandc.
	[image: image29.png]Profile Selector Results [=[00x]

Successiul

Nane

Failed

Nane

Dane Help







Create the keymandc user account

The keyman user account is the one used for key management on a COE workstation.  Since this “locally created” account doesn’t work as needed on a Domain Controller, we will need to create a new account, which we will call keymandc, and configure it so that it can act just like the keyman account should.

Table 4‑4 Create the keymandc user account

	Step
	What You Do
	Installation Dialog

	1 
	Log on as secmandc.

Select Start->Programs->DII Applications->SecAdm->APM Client to launch the Account and Profile Manager client application.  

If prompted, enter the APM authentication key and select the OK button to close the "Input" dialog.
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	2 
	The Account and Profile Manager Client application dialog should appear.
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	3 
	Select File->New Account. 

Select the "Identification" tab and set the fields as follows:

Login = keymandc, Password = some password,

Password Confirm = same password,

Full Name = Authentication Key Manager,

Manage As = domain,

Default Group = Domain Admins
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	4 
	Select the "Group" tab and add the user to the Domain Admins and Domain Users groups by double-clicking each group.
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	5 
	Select the "Profiles" tab and make the "SSO Default" profile available to the user by double-clicking it.
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	6 
	Select the "Hosts" tab and add the user to the domain controller (i.e. jmpsjc1) by double-clicking it.
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	7 
	Select the "Submit" button to create the new keymandc account.  If successful, the Status Summary dialog should be displayed with successful check-marks as displayed here.

Select the Ok button to close the Status Summary dialog.  

Close the Account and Profile Manager client dialog by selecting the close (“X”) icon.

Logoff of the secmandc account.
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Assign the "AUTH Default" profile to the new keymandc user

In order for the keymandc account to have the appropriate icons and/or menu items available on the desktop, the account must assign the “AUTH Default” profile to itself.  Profiles are the mechanism through which the COE provides menu and icon access to its applications.

Table 4‑5 Assign the "AUTH Default" profile to the new keymandc user

	Step
	What You Do
	Installation Dialog

	1 
	Logon as keymandc and, if required, change it’s password.

Dismiss the “COE Login Processing is Complete” dialog by selecting the OK button.

Select Start->Programs->COE Profile Selector to bring up the COE Profile Selector.
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	2 
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	3 
	If a "Profile Selector Results" dialog is displayed, select the "Done" button to close the dialog.

Log off keymandc.
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16. Appendix G – Setup JMPS Connection to GCCS-M/I3 DAL for Order of Battle Import

Perform the following to setup the JMPS connection to the GCCS-M/I3 DAL to import Order of Battle data:

· Gather the following information from the GCCS-M/I3 DAL System Administrator:  (At Pt. Mugu, contact Ancina Stevens or Paul Johns)
· DAL Domain Name, IP Address, Port Number, Username and Password

· Install Trusted Root Certificate on client machine (At Pt. Mugu, contact Ancina Stevens or Paul Johns. We are investigating how to install the certificate so that it is accessible by anybody that logs into the machine)
· Get Trusted Root Certificate from GCCS-M/I3 DAL System Administrator

· Install the certificate on the client machine

· Add the following inside of the $WINNT/system32/drivers/etc/hosts file

· appserver  IPAddress

· Replace “IPAddress” with the IP Address that was collected above

· Note: This is to get around a bug in GCCS-M/I3 DAL Build 10. This is not necessary in Build 11

· At Pt. Mugu and in our Class. Lab, you will also need to add an alias for the domain name that points to the China Lake IP Address.
· Set storage of DAL Username and Password on remote server machine (optional)

· Select Options ( Preferences ( Password Server (optional)

· Select a Username/Password Host (optional)

· Set the Order of Battle Import Preference

· Select Options ( Preferences ( Order of Battle Import

· Select “Connect to MIDB”

· Enter DAL Domain Name, Port Number, Username and Password

· Initiate Order of Battle Import

· Select File ( Import ( Order of Battle…

Trouble shooting JMPS connection to GCCS-M/I3 DAL:

· Determine if we can access DAL file via HTTPS

· Within address field of Internet Explorer, enter the following:

· https://DAL.domain.name.com/ishop/webservice/wsdl/SearchWebService.wsdl
· Replace “DAL.domain.name.com” with real DAL Domain Name

· If the wsdl file is not downloaded to the browser, then:

· Verify DAL Domain Name is correct

· Verify that connectivity to DAL machine is good

· Verify that Trusted Root Certificate was installed

· “appserver” alias was added to “hosts” file

· Determine if the DAL Username and Password are valid

· Within address field of Internet Explorer, enter the following:

· https://DAL.domain.name.com/ishop/
· Replace “DAL.domain.name.com” with real DAL Domain Name

· Within the Intel Shop page, click on Sign-In

· Within the Sign-In page:

· Enter the DAL User Name and Password

· Click the Sign-In button

· The DAL Username and Password is valid if you successfully get pass the Sign-In page

· Click on Sign-Out to log out of Intel Shop

17. Appendix H – Apply User Rights Assignments Settings on Domain Controller

These instructions are derived from the document titled, Manual Procedure, Setting up JMPS Domain User Rights Assignment Policy settings, dated August 01, 2003, written by Yie-Ming Shaw.

1. On the domain controller, Select Start>Programs>Administrative Tools>Domain Security Policy

2. Expand the explore tree Windows Settings>Security Settings>Local Policies>User Rights Assignment

3. Click on User Rights Assignment to display the policy settings on the right frame

4. Compare the displayed Policy Settings to the settings listed in Appendix A (Abstract from Table 3-7 of JMPS TFM * )

5. Double click on the policy setting that requires modification. The Local Security Policy Setting dialog is displayed

6. Click “Add” button and select the domain JMPS groups that need to be added in the Select Users or Groups dialog.  Remove any groups not specified in the table.  Remove all the groups for the Policies that are “Not assigned”

7. Click “OK” in the Select Users or Groups dialog

8. Click “OK” in the Local Security Policy Setting dialog 

9. Repeat Step 5 to 8 until all the required setting changes are implemented

10. Close the Domain Security Policy window

11. Restart the domain controller

* indicates that the right was retained from the COE security settings.

Appendix A – Table 3-7 User Rights Assignment Policy

	User Rights Policy
	Roles Requiring Right/Privilege

	Access this computer from the network
	Authenticated Users
Administrators

	Act as part of the operating system
	COE Admin

	Add workstations to domain
	Domain Administrator

	Back up files and directories
	JMPS Database Administrator
JMPS Administrator
JMPS Security Administrator

Administrators*

Backup Operators*

	Bypass traverse checking
	Authenticated Users*

	Change the system time
	Administrators*

JMPS Administrator

	Create a pagefile
	Administrators*

	Create a token object
	Not assigned

	Create permanent shared objects
	Not assigned

	Debug programs
	Administrators*

	Deny access to this computer from the network
	ANONYMOUS LOGON*

Guests*

	Deny logon as a batch job
	ANONYMOUS LOGON*

Guests*

	Deny logon as a service
	ANONYMOUS LOGON*

Guests*

	Deny logon locally
	ANONYMOUS LOGON*

Guests*

	Enable computer and user accounts to be trusted for delegation
	Not assigned

	Force shutdown from a remote system
	Administrators*

	Generate security audits
	Not assigned

	Increase quotas
	JMPS Administrator

JMPS Database Administrator

JMPS Mission Planner

JMPS Security Administrator

	Increase scheduling priority
	JMPS Administrator

JMPS Database Administrator

JMPS Mission Planner

JMPS Security Administrator

	Load and unload device drivers
	Administrators*

	Lock pages in memory
	Not assigned

	Log on as a batch job
	Not assigned

	Log on as a service
	Not assigned

	Log on locally
	Authenticated Users*

Administrators*

	Manage auditing and security log
	JMPS Security Administrator

Administrators*

	Modify firmware environment values
	Administrators*

	Profile single process
	Administrators*

	Profile system performance
	Administrators*

	Remove computer from docking station
	Authenticated Users*

Administrators*

	Replace a process level token
	Not assigned

	Restore files and directories
	Administrators*

Backup Operators*

JMPS Administrator
JMPS Database Administrator
JMPS Security Administrator

	Shut down the system
	Authenticated Users*

Administrators*

	Synchronize directory service data
	Not assigned

	Take ownership of files or other objects
	Administrators*


* Trusted Facility Manual (TFM) for the JMPS, JV1 and JC1. CDRL:A011, Appendix L
18. Appendix I – Apply DACL Security Settings

These instructions are derived from the document titled, Apply JC1 DACL (Discretionary Access Control List), dated August 01, 2003, written by Yie-Ming Shaw
Workstation, Standalone, & separate JMPS Server: 

The following procedures need to be performed in each workstation and server with JMPS required COE segments installed

1. If the machine is on a domain, then make sure the Domain Controller is set up first

2. Log in as a domain administrator if the machine is on a domain.  Otherwise log in as a local administrator

3. Go to D:\Program Files\JMPS\Setup\Security\

4. Double-click on JMPS_ApplyJmpsFileSecurity.bat

Domain Controller:

The following procedures will only be functional on the domain controller that is installed with JMPS required COE segments

1. Log in as a domain administrator on the domain controller

2. Select Start>Settings>Control Panel>Administrative Tools>Domain Security Policy

3. Expand Security Settings 

4. Double click on File System to display file/directory under control on the right panel

5. Select all the listed JMPS files/directories, right click and select delete to delete all the JMPS files/directories.  DO NOT delete any non-JMPS-related files or directories!
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6. Close the Domain Security Policy window

7. Select Start>Settings>Control Panel>Administrative Tools>Domain Controller Security Policy

8. Expand Security Settings 

9. Double click on File System to display file/directory under control on the right panel

10. Select all the listed JMPS files/directories, right click and select delete to delete all the JMPS files/directories (same directories in Step 5)

11. Skip to step 37 if you already have a template saved somewhere.

12. Select Start>Run and type “cmd” in the run command dialog 

13. In the command window, type copy c:\winnt\security\templates\JMPS_files.inf  c:\winnt\security\templates\JMPS_files_DACL.inf

14. Select Start>Run and type “mmc” in the run command dialog

15. [image: image1.wmf]Select Console>Add/Remove Snap-in 

16. Click “Add”button 

17. Select Security Templates and click the “Add” button

18. [image: image47.wmf]Click “Close” to close the “Add Standalone Snap-in” dialog

19. Click “OK” to close the “Add/Remove Snap-in” dialog

20. Browse the Security Templates tree inside the console to JMPS_files_DACL.inf
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21. Double-click d:\program files\jmps\data\AuditMonitor on the right frame 

22. Click “Edit Security” button to display the user groups permitted to the selected folder

23. Select “Authenticated Users”

24. Make note of the permissions assigned to Authenticated Users, then click “remove”

25. Click “Add” and add local and domain groups of JmpsSecurityAdministrator with the same permissions observed in step 24
[image: image42.png][Security for D:\Program Files\JMPS\data\Audit 2%

ety |
Name

€0 Admiristators WCTDEVWS2\Adriisatrs)

€5 CREATOR OWNER e
P L ps5ecuipAdmistator UCTDEV g

€0 JmpsSecuitybdminisirator (JC1DEVWS 2,

€ cvsTeEm

Permissions: Dery
Ful Control o
Moy o
Read and Execute o
List Folder Contents o
Read o
Wite [m]

e | e
Allow inheritable permissions from parent to propagate to this
= object

=





26. Double-click e:\data\local\jmps\data\AuditMonitor

27. Repeat steps 22 to 25
28. Double-click each remaining policy setting on the right frame

29. Click “Edit Security” button to display the user groups permitted to the selected folder

30. Select “Authenticated Users”

31. Make note of the permissions assigned to Authenticated Users, then click “remove”

32. Click “Add” and add domain groups of JmpsAdministrator, JmpsCollaboration, JmpsDowngradePrintedOutputClassification, JmpsDatabaseAdministrator, JmpsMissionPlanner, JmpsSecurityAdministrator with the same permissions observed in step 31
33. Repeat 28 to 32 until finished

34. Close the mmc Console 1 dialog

35. Select “Yes” to save Console 1

36. Select “Yes” to save the updated JMPS_files_DACL.inf template. This template file can be saved for later re-application of JMPS DACL set up.  It is recommended to copy the JMPS_files_DACL.inf template to a safe location.

37. If you have already saved the JMPS_files_DACL.inf template somewhere, make sure you copy this file to C:\winnt\security\templates

38. Select Start>Settings>Control Panel>Administrative Tools>Domain Controller Security Policy

39. Right click on Security Settings and select Import Policy
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40. Select JMPS_files_DACL.inf created

41. Close the domain controller Security Settings and close the Control Panel

42. Select “Yes” if you are asked to save the Security Templates
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43. Click on the Start menu and select Run

44. Type in “cmd”, then click OK

45. Type “secedit /refreshpolicy machine_policy /enforce”, then press Enter

46. Type “exit”, then press Enter

47. Wait for the policies to be propagated to all the domain clients.  Then restart the domain controller.

19. Appendix J – Test User Accounts

The following pages contain the test user accounts used in the NGIT Test Labs.

19.1. DSL Machine

The JC1 DSL machine has been configured with the following user accounts. Only local accounts (no domain accounts) exist.

Username
Password

localJA

b133m

JmpsAdministrator
localJDBA
x67!D0

JmpsDataBaseAdministrator
localJSA

%Cvu89

JmpsSecurityAdministrator

localJSAad
Jc1*test

JmpsSecurityAdministrator, Administrators

localJMP

O0Gn74

JmpsMissionPlanner
localJDPOC
ydaichi

JmpsDowngradePrintedOutputClassification, JmpsMissionPlanner

localJAJSAad
Jc1*test

JmpsAdministrator, JmpsSecurityAdministrator, Administrators

tester

B10tz*

JmpsMissionPlanner
testerad

Gr5)f$

JmpsMissionPlanner, JmpsDataBaseAdministrator, Administrators
administrator
3LZ1m#

Administrators

coeadmin
Security12$
Administrators – COE account used to install segments

secman

Security12$
COE account used to manage COE controlled accounts

keyman

Security12$
COE account

testall

Jc1*test

All JMPS roles
testallad

Jc1*test

All JMPS roles, Administrators

For security reasons, please turn off the DSL machine after you are done using it.

19.2. Standalone


[image: image45.wmf]Users

Member of

localJA

JmpsAdministrator

localJDBA

JmpsDataBaseAdministrator

localJSA

JmpsSecurityAdministrator

localJSAad

JmpsSecurityAdministrator, Administrators

localJMP

JmpsMissionPlanner

localJDPOC

JmpsDowngradePrintedOutputClassification, JmpsMissionPlanner

localJAJSAad

JmpsAdministrator, JmpsSecurityAdministrator, Administrators

collab1local

JmpsCollaboration

collab2local

JmpsCollaboration

<user>

JmpsMissionPlanner

<user>ad

JmpsDataBaseAdministrator, JmpsMissionPlanner, Administrators

testall

All JMPS roles

testallad

All JMPS roles, Administrators

administrator [password=Security12$]

Administrators (local system administrator)

coeadmin [password=Security12$]

Administrators (local system administrator) - COE account used to install segments

secman [password=Security12$]

COE account used to manage COE controlled accounts

keyman [password=Security12$]

COE account

Passwords are the same as the user names


All accounts below are in the local machine domain.  These are the “<user>” and “<user>ad” accounts mentioned above.

test1 

test1ad  
(assigned to Steve Allen)

test2 

test2ad  
(assigned to Michael E. Chiang)

test3 

test3ad  
(assigned to Lesley Matthews)

test4 

test4ad  
(assigned to Lucy Wallace)

test5 

test5ad  
(assigned to Lynn Diamond)

test6 

test6ad  
(assigned to Leoma Bastian)

test7 

test7ad  
(assigned to Jim Sra)

test8

test8ad  
(assigned to Yie-Ming Shaw)

test9 

test9ad  
(assigned to Greg Anderson)

test10

test10ad  
unassigned

19.3. JC1 Unclassified Test Lab, Unclassified Development Lab, and Classified Test Lab


[image: image46.wmf]Local users (Local machine domain)

Member of                                                                                 (Passwords are the same as the user names)

localJA

JmpsAdministrator (local)

localJDBA

JmpsDataBaseAdministrator (local)

localJSA

JmpsSecurityAdministrator (local)

localJSAad

JmpsSecurityAdministrator (local), Administrators (local)

localJMP

JmpsMissionPlanner (local)

localJDPOC

JmpsDowngradePrintedOutputClassification (local), JmpsMissionPlanner (local)

localJAJSAad

JmpsAdministrator (local), JmpsSecurityAdministrator (local), Administrators (local)

collab1local, collab2local

JmpsCollaboration (local)

localtestall

All JMPS roles (local)

localtestallad

All JMPS roles (local), Administrators (local)

administrator [password=Security12$]

Administrators (local system administrator with e-mail account)

coeadmin [password=Security12$]

Administrators (local system administrator) - local account used to install segments

secman (or secmandc) [password=Security12$]

local COE account used to manage COE controlled local accounts

keyman (or keymandc) [password=Security12$]

local COE account

Domain users

Member of                                                                                 (Passwords are the same as the user names)

domainJA

JmpsAdministrator (domain)

domainJDBA

JmpsDataBaseAdministrator (domain)

domainJSA

JmpsSecurityAdministrator (domain)

domainJSAad

Administrators (local), JmpsSecurityAdministrator (domain)

domainJMP

JmpsMissionPlanner (domain)

domainJDPOC

JmpsDowngradePrintedOutputClassification (domain), JmpsMissionPlanner (domain)

domainJAJSAad

JmpsAdministrator (domainl), JmpsSecurityAdministrator (domain), Administrators (local)

tester1, tester2, tester3 [password=tester]

JmpsCollaboration (domain), JmpsMissionPlanner (domain)

collabadmin

Administrators (local and domain), JmpsAdministrator (domain), JmpsSecurityAdministrator (domain),

JmpsMissionPlanner (domain)

<user>

JmpsMissionPlanner (domain)

<user>ad

JmpsDataBaseAdministrator (domain), JmpsMissionPlanner (domain), Administrators (local)

testall

All JMPS roles (domain)

testallad

All JMPS roles (domain), Administrators (local)

administrator [password=Security12$]

Administrators (domain system administrator)


All accounts below are in the domain.  These are the “<user>” and “<user>ad” accounts mentioned above.

test1 

test1ad

(assigned to Steve Allen)

test2 

test2ad

(assigned to Michael E Chiang)

test3 

test3ad

(assigned to Lesley Matthews)

test4 

test4ad

(assigned to Lucy Wallace)

test5 

test5ad

(assigned to Lynn Diamond)


test6 

test6ad

(assigned to Leoma Bastian)

test7 

test7ad

(assigned to Jim Sra)

test8

test8ad

(assigned to Yie-Ming Shaw)

test9 

test9ad

(assigned to Greg Anderson)

test10

test10ad
unassigned
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Sheet1

		Local users (Local machine domain)		Member of                                                                                 (Passwords are the same as the user names)

		localJA		JmpsAdministrator (local)

		localJDBA		JmpsDataBaseAdministrator (local)

		localJSA		JmpsSecurityAdministrator (local)

		localJSAad		JmpsSecurityAdministrator (local), Administrators (local)

		localJMP		JmpsMissionPlanner (local)

		localJDPOC		JmpsDowngradePrintedOutputClassification (local), JmpsMissionPlanner (local)

		localJAJSAad		JmpsAdministrator (local), JmpsSecurityAdministrator (local), Administrators (local)

		collab1local, collab2local		JmpsCollaboration (local)

		localtestall		All JMPS roles (local)

		localtestallad		All JMPS roles (local), Administrators (local)

		administrator [password=Security12$]		Administrators (local system administrator with e-mail account)

		coeadmin [password=Security12$]		Administrators (local system administrator) - local account used to install segments

		secman (or secmandc) [password=Security12$]		local COE account used to manage COE controlled local accounts

		keyman (or keymandc) [password=Security12$]		local COE account

		Domain users		Member of                                                                                 (Passwords are the same as the user names)

		domainJA		JmpsAdministrator (domain)

		domainJDBA		JmpsDataBaseAdministrator (domain)

		domainJSA		JmpsSecurityAdministrator (domain)

		domainJSAad		Administrators (local), JmpsSecurityAdministrator (domain)

		domainJMP		JmpsMissionPlanner (domain)

		domainJDPOC		JmpsDowngradePrintedOutputClassification (domain), JmpsMissionPlanner (domain)

		domainJAJSAad		JmpsAdministrator (domainl), JmpsSecurityAdministrator (domain), Administrators (local)

		tester1, tester2, tester3 [password=tester]		JmpsCollaboration (domain), JmpsMissionPlanner (domain)

		collabadmin		Administrators (local and domain), JmpsAdministrator (domain), JmpsSecurityAdministrator (domain),
JmpsMissionPlanner (domain)

		<user>		JmpsMissionPlanner (domain)

		<user>ad		JmpsDataBaseAdministrator (domain), JmpsMissionPlanner (domain), Administrators (local)

		testall		All JMPS roles (domain)

		testallad		All JMPS roles (domain), Administrators (local)

		administrator [password=Security12$]		Administrators (domain system administrator)





Sheet2

		





Sheet3

		






_1121254784.xls
Sheet1

		Passwords are the same as the user names

		Users		Member of

		localJA		JmpsAdministrator

		localJDBA		JmpsDataBaseAdministrator

		localJSA		JmpsSecurityAdministrator

		localJSAad		JmpsSecurityAdministrator, Administrators

		localJMP		JmpsMissionPlanner

		localJDPOC		JmpsDowngradePrintedOutputClassification, JmpsMissionPlanner

		localJAJSAad		JmpsAdministrator, JmpsSecurityAdministrator, Administrators

		collab1local		JmpsCollaboration

		collab2local		JmpsCollaboration

		<user>		JmpsMissionPlanner

		<user>ad		JmpsDataBaseAdministrator, JmpsMissionPlanner, Administrators

		testall		All JMPS roles

		testallad		All JMPS roles, Administrators

		administrator [password=Security12$]		Administrators (local system administrator)

		coeadmin [password=Security12$]		Administrators (local system administrator) - COE account used to install segments

		secman [password=Security12$]		COE account used to manage COE controlled accounts

		keyman [password=Security12$]		COE account
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